View Git repositories
branches with status:
Name Status Last Modified Last Commit
lp:~ubuntu-desktop/yelp/ubuntu bug Development 2016-07-01 08:45:57 UTC 19 hours ago
139. releasing package yelp version 3.20.1...

Author: Martin Pitt
Revision Date: 2016-07-01 08:45:57 UTC

releasing package yelp version 3.20.1-1ubuntu2

lp:~ubuntu-desktop/cheese/ubuntu bug Development 2016-07-01 08:35:35 UTC 19 hours ago
109. releasing package cheese version 3.20...

Author: Martin Pitt
Revision Date: 2016-07-01 08:35:35 UTC

releasing package cheese version 3.20.2-0ubuntu2

lp:~ubuntu-desktop/gnome-control-center/ubuntu bug Development 2016-07-01 06:38:22 UTC 21 hours ago
687. releasing package gnome-control-cente...

Author: Sebastien Bacher
Revision Date: 2016-07-01 06:38:22 UTC

releasing package gnome-control-center version 1:3.18.2-1ubuntu8

lp:~ubuntu-desktop/gtk/ubuntugtk3 bug Development 2016-06-29 15:22:43 UTC 2016-06-29
517. releasing package gtk+3.0 version 3.1...

Author: Sebastien Bacher
Revision Date: 2016-06-29 15:22:43 UTC

releasing package gtk+3.0 version 3.18.9-1ubuntu4

lp:ubuntu-make Development 2016-06-21 17:04:47 UTC 2016-06-21
958. Merge pull request #326 from LyzardKi...

Author: LyzardKing
Revision Date: 2016-06-21 17:04:47 UTC

Merge pull request #326 from LyzardKing/eclipse-fix-url

Fix eclipse download url

lp:~ubuntu-desktop/gnome-software/ubuntu-xenial Development 2016-06-17 10:58:58 UTC 2016-06-17
23. releasing package gnome-software vers...

Author: Iain Lane
Revision Date: 2016-06-17 10:58:49 UTC

releasing package gnome-software version 3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1~16.04.1

lp:~ubuntu-desktop/gnome-software/ubuntu bug Development 2016-06-17 09:08:32 UTC 2016-06-17
25. releasing package gnome-software vers...

Author: Iain Lane
Revision Date: 2016-06-17 09:08:32 UTC

releasing package gnome-software version 3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1

lp:~ubuntu-desktop/file-roller/ubuntu bug Development 2016-06-16 11:54:56 UTC 2016-06-16
178. releasing package file-roller version...

Author: Iain Lane
Revision Date: 2016-06-16 10:53:35 UTC

releasing package file-roller version 3.20.2-0ubuntu4

lp:~ubuntu-desktop/+junk/ghex-snap Development 2016-06-14 01:31:11 UTC 2016-06-14
3. Rename to ghex-udt so ghex can be use...

Author: Robert Ancell
Revision Date: 2016-06-14 01:31:11 UTC

Rename to ghex-udt so ghex can be used for the official package

lp:~ubuntu-desktop/+junk/gnome-logs-snap Development 2016-06-13 16:33:19 UTC 2016-06-13
1. gnome-log stable-git snaped

Author: Sebastien Bacher
Revision Date: 2016-06-13 16:30:10 UTC

gnome-log stable-git snaped

lp:~ubuntu-desktop/+junk/gucharmap-snap Development 2016-06-13 16:26:32 UTC 2016-06-13
1. gucharmap git snaped

Author: Sebastien Bacher
Revision Date: 2016-06-13 16:25:42 UTC

gucharmap git snaped

lp:~ubuntu-desktop/+junk/simple-scan-snap Development 2016-06-13 03:34:11 UTC 2016-06-13
1. Initial work

Author: Robert Ancell
Revision Date: 2016-06-13 03:33:47 UTC

Initial work

lp:~ubuntu-desktop/gnome-keyring/ubuntu bug Development 2016-06-10 16:07:33 UTC 2016-06-10
105. releasing package gnome-keyring versi...

Author: Iain Lane
Revision Date: 2016-06-10 16:07:33 UTC

releasing package gnome-keyring version 3.18.3-0ubuntu3

lp:~ubuntu-desktop/+junk/gnome-calendar-snap Development 2016-06-10 00:01:24 UTC 2016-06-10
1. Initial work

Author: Robert Ancell
Revision Date: 2016-06-10 00:00:56 UTC

Initial work

lp:~ubuntu-desktop/+junk/iagno-snap Development 2016-06-09 23:53:19 UTC 2016-06-09
1. Initial work

Author: Robert Ancell
Revision Date: 2016-06-09 23:53:05 UTC

Initial work

lp:~ubuntu-desktop/+junk/rhythmbox-snap Development 2016-06-09 23:43:06 UTC 2016-06-09
1. Initial work

Author: Robert Ancell
Revision Date: 2016-06-09 23:42:42 UTC

Initial work

lp:~ubuntu-desktop/+junk/gnome-maps-snap Development 2016-06-09 23:13:52 UTC 2016-06-09
1. Initial work

Author: Robert Ancell
Revision Date: 2016-06-09 23:13:18 UTC

Initial work

lp:~ubuntu-desktop/+junk/gnome-mahjongg-snap Development 2016-06-09 03:20:18 UTC 2016-06-09
1. It compiles...

Author: Robert Ancell
Revision Date: 2016-06-09 03:15:38 UTC

It compiles...

lp:~ubuntu-desktop/+junk/gnome-mines-snap Development 2016-06-09 03:19:37 UTC 2016-06-09
1. It compiles...

Author: Robert Ancell
Revision Date: 2016-06-09 03:19:06 UTC

It compiles...

lp:~ubuntu-desktop/+junk/gnome-calculator-snap Development 2016-06-07 14:52:34 UTC 2016-06-07
11. distribute the icon as recommended in...

Author: Sebastien Bacher
Revision Date: 2016-06-07 14:52:34 UTC

distribute the icon as recommended in current versions

lp:~ubuntu-desktop/lightdm-webkit-greeter/ubuntu bug Development 2016-06-01 19:48:08 UTC 2016-06-01
6. * debian/control: Build-depend on l...

Author: Michael Terry
Revision Date: 2016-06-01 19:47:56 UTC

* debian/control:
  Build-depend on libwebkitgtk-dev instead of libwebkit-dev,
  which has been a transitional package since Precise (LP: #1588037)
* debian/40-lightdm-webkit-greeter.conf:
  - Use [Seat:*] instead of deprecated [SeatDefaults]

lp:~ubuntu-desktop/evolution/ubuntu bug Development 2016-05-31 11:19:46 UTC 2016-05-31
397. releasing package evolution version 3...

Author: Iain Lane
Revision Date: 2016-05-31 11:19:46 UTC

releasing package evolution version 3.18.5.2-0ubuntu2

lp:ubuntu-desktop-versions Development 2016-05-31 01:23:40 UTC 2016-05-31
1566. Tag more xorg packages

Author: Robert Ancell
Revision Date: 2016-05-31 01:23:40 UTC

Tag more xorg packages

lp:~ubuntu-desktop/nautilus-sendto/ubuntu bug Development 2016-05-23 08:53:22 UTC 2016-05-23
44. releasing package nautilus-sendto ver...

Author: Sebastien Bacher
Revision Date: 2016-05-23 08:53:22 UTC

releasing package nautilus-sendto version 3.8.2-1ubuntu2

lp:~ubuntu-desktop/empathy/ubuntu bug Development 2016-05-23 02:37:19 UTC 2016-05-23
382. * Drop Revert-geoclue-2.0.patch and s...

Author: Robert Ancell
Revision Date: 2016-05-23 02:37:07 UTC

* Drop Revert-geoclue-2.0.patch and switch to geoclue-2.0 (LP: #1389336)
* Enable geoclue and map support now that empathy is in universe
* Drop 47_git_activate_with_platform_data.patch,
  git_correct_display_messages.patch and git_no_nautilus_sendto.patch:
  This has been merged upstream some times ago.
* Remove empathy-dbg package and rely on automatic dbgsym package

lp:~ubuntu-desktop/gnome-session/ubuntu-xenial bug Development 2016-05-13 08:26:13 UTC 2016-05-13
338. releasing package gnome-session versi...

Author: Iain Lane
Revision Date: 2016-05-13 08:14:27 UTC

releasing package gnome-session version 3.18.1.2-1ubuntu1.16.04.1

lp:~ubuntu-desktop/seahorse/ubuntu bug Development 2016-05-12 22:08:03 UTC 2016-05-12
77. * Merge with Debian, remaining Ubuntu...

Author: Robert Ancell
Revision Date: 2016-05-12 22:08:03 UTC

* Merge with Debian, remaining Ubuntu changes:
* debian/control:
  - Add build-depends on gnupg2 to allow building
  - Update Vcs-* field.
* debian/patches/use-stable-libsecret.patch:
  - Use the stable libsecret.
* debian/patches/use_valid_help_url:
  - Let help buttons point to valid documentation references.
* Bump gtk+ build-dependency to >= 3.16 (Closes: #808996)
* New upstream release.
* Bump Standards-Version to 3.9.8.

lp:~ubuntu-desktop/gnome-session/ubuntu bug Development 2016-05-12 13:44:21 UTC 2016-05-12
337. releasing package gnome-session versi...

Author: Iain Lane
Revision Date: 2016-05-12 13:44:21 UTC

releasing package gnome-session version 3.18.1.2-1ubuntu2

lp:~ubuntu-desktop/libgweather/ubuntu bug Development 2016-05-12 03:51:52 UTC 2016-05-12
72. * Merge with Debian, remaining Ubuntu...

Author: Robert Ancell
Revision Date: 2016-05-12 03:51:52 UTC

* Merge with Debian, remaining Ubuntu changes:
* debian/control.in:
  - Build-depend on dh-autoreconf
  - debian/control: Update Vcs-* field.
* debian/rules:
  - Use dh_autoreconf
  - Generate POT files on build

lp:~ubuntu-desktop/simple-scan/ubuntu bug Development 2016-05-11 21:50:02 UTC 2016-05-11
99. * New upstream release - Updated tr...

Author: Robert Ancell
Revision Date: 2016-05-11 21:50:02 UTC

* New upstream release
  - Updated translations

lp:~ubuntu-desktop/nautilus/ubuntu bug Development 2016-05-10 15:21:44 UTC 2016-05-10
511. * debian/patches/restore-traditional-...

Author: Iain Lane
Revision Date: 2016-05-10 15:21:44 UTC

* debian/patches/restore-traditional-menu-bar.patch:
  - update menubar visibility on GktSettings changes

lp:~ubuntu-desktop/gnome-terminal/ubuntu bug Development 2016-05-10 04:40:29 UTC 2016-05-10
176. * New upstream release * debian/contr...

Author: Robert Ancell
Revision Date: 2016-05-10 04:40:29 UTC

* New upstream release
* debian/control:
  - Bump build-depends on libgtk-3-dev, libvte-2.91-dev
  - Add build-depends on libpcre2-dev
* debian/rules:
  - Install compatibility version of gnome-terminal.desktop

lp:~ubuntu-desktop/libcanberra/ubuntu bug Development 2016-04-27 02:23:21 UTC 2016-04-27
154. * Merge from Debian unstable. Remain...

Author: Steve Langasek
Revision Date: 2016-04-27 02:23:21 UTC

* Merge from Debian unstable. Remaining changes:
  - Add Vcs-Bzr field
  - libcanberra0 depends on sound-theme-freedesktop
  - Build-depend on libx11-dev, and add libx11-dev to depends for
    libcanberra-gtk-dev and libcanberra-gtk3-dev
  - Build depend on libglib2.0-dev
  - Add support for unity-settings-daemon
  - Disable login sound by default
  - Show in Unity as well as GNOME
  - Hide from startup applications
  - gnome-session-canberra recommends libcanberra-pulse
* Dropped changes, included in Debian:
  - debian/patches/05_gtk_dont_assume_all_gdkdisplays_are_gdkx11displays.patch:
    Import patch from upstream, to fix crashes on non X11 Gdk backends
* Team upload.
* debian/libcanberra0.symbols,
  debian/libcanberra0.symbols.hurd-i386:
  + Drop hurd-i386 symbols file, instead use arch tags to mark a couple of
    symbols as not available on hurd.
* debian/patches/gtk_dont_assume_x11.patch: Don't assume all GdkDisplays are
  GdkX11Displays, fixing crashes when running Wayland. (Closes: #820944)
* debian/control, debian/compat: Bump debhelper compatibility to 9
* debian/control: Bump Standards-Version to 3.9.7 (no furter changes)
* Drop -dbg package and rely on automatically built -dbgsym ones
* debian/rules: Pass --as-needed to the linked and to dh_autoreconf to
  reduce the number of runtime dependencies

lp:~ubuntu-desktop/rhythmbox/ubuntu bug Development 2016-04-13 21:06:39 UTC 2016-04-13
264. releasing package rhythmbox version 3...

Author: Sebastien Bacher
Revision Date: 2016-04-13 21:06:39 UTC

releasing package rhythmbox version 3.3-1ubuntu7

lp:~ubuntu-desktop/gnome-user-share/ubuntu bug Development 2016-04-10 03:22:55 UTC 2016-04-10
21. releasing package gnome-user-share ve...

Author: Tim
Revision Date: 2016-04-10 03:16:42 UTC

releasing package gnome-user-share version 3.14.2-2ubuntu3

lp:~ubuntu-desktop/desktop-file-utils/ubuntu bug Development 2016-04-04 17:54:12 UTC 2016-04-04
67. releasing package desktop-file-utils ...

Author: Mario Limonciello
Revision Date: 2016-04-04 17:54:12 UTC

releasing package desktop-file-utils version 0.22-1ubuntu5

lp:~ubuntu-desktop/totem/ubuntu bug Development 2016-03-10 07:27:53 UTC 2016-03-10
242. * debian/patches/ubuntu-use-tradition...

Author: Robert Ancell
Revision Date: 2016-03-10 07:27:32 UTC

* debian/patches/ubuntu-use-traditional-titlebars.patch:
  - Fix usage of XDG_CURRENT_DESKTOP (LP: #1554878)

lp:~ubuntu-desktop/eog/ubuntu bug Development 2016-03-10 04:12:06 UTC 2016-03-10
182. * debian/patches/0001-EogWindow-Corre...

Author: Robert Ancell
Revision Date: 2016-03-10 04:11:46 UTC

* debian/patches/0001-EogWindow-Correctly-check-the-value-of-XDG_CURRENT_D.patch:
* debian/patches/0002-Show-traditional-title-bar-in-unity.patch:
  - Fix usage of XDG_CURRENT_DESKTOP (LP: #1554878)

lp:~ubuntu-desktop/evince/ubuntu bug Development 2016-03-08 09:10:15 UTC 2016-03-08
283. * debian/control: - Set breaks/repl...

Author: Robert Ancell
Revision Date: 2016-03-08 09:10:15 UTC

* debian/control:
  - Set breaks/replaces for .desktop file moves
* debian/evince.install:
* debian/evince-common.install:
  - Move .desktop files from -common to the main binary (LP: #1553156)
  - Remove reference to obsolete evince-gtk.desktop

lp:~ubuntu-desktop/gtk/ubuntu bug Development 2016-03-07 14:23:12 UTC 2016-03-07
252. releasing package gtk+2.0 version 2.2...

Author: Iain Lane
Revision Date: 2016-03-07 14:11:13 UTC

releasing package gtk+2.0 version 2.24.30-1ubuntu1

lp:~ubuntu-desktop/gedit/ubuntu bug(Linked to a blueprint) Development 2016-03-03 23:31:05 UTC 2016-03-03
203. * debian/patches/unity_no_csd.patch: ...

Author: Robert Ancell
Revision Date: 2016-03-03 23:31:05 UTC

* debian/patches/unity_no_csd.patch:
  - Update to correctly handle XDG_CURRENT_DESKTOP

lp:~ubuntu-desktop/deja-dup/ubuntu bug Development 2016-03-02 14:46:27 UTC 2016-03-02
50. * d/control.in, d/p/install-pygi.patc...

Author: Michael Terry
Revision Date: 2016-03-02 14:46:10 UTC

* d/control.in, d/p/install-pygi.patch:
  - Install deja-dup-backend-gvfs dynamically instead of python-gi,
    so we can keep samba-libs off the default image too.
    (LP: #1551989)

lp:~ubuntu-desktop/evolution-data-server/ubuntu bug Development 2016-02-23 12:06:00 UTC 2016-02-23
263. releasing package evolution-data-serv...

Author: Iain Lane
Revision Date: 2016-02-23 12:06:00 UTC

releasing package evolution-data-server version 3.18.5-1ubuntu1

lp:~ubuntu-desktop/vte/ubuntu-vte2.91 Development 2016-02-13 05:11:18 UTC 2016-02-13
121. releasing package vte2.91 version 0.4...

Author: Tim
Revision Date: 2016-02-13 05:11:18 UTC

releasing package vte2.91 version 0.42.4-1ubuntu1

lp:~ubuntu-desktop/+junk/ubuntu-settings bug Development 2016-02-09 07:23:10 UTC 2016-02-09
65. releasing package ubuntu-settings ver...

Author: Sebastien Bacher
Revision Date: 2016-02-09 07:23:10 UTC

releasing package ubuntu-settings version 15.10.7

lp:~ubuntu-desktop/brasero/ubuntu bug Development 2016-02-05 10:11:19 UTC 2016-02-05
168. brasero (3.12.1-1ubuntu2) xenial; urg...

Author: Matthias Klose
Revision Date: 2016-02-05 10:11:19 UTC

brasero (3.12.1-1ubuntu2) xenial; urgency=medium

  * Multiarchify the library packages. LP: #1508588.

 -- Matthias Klose <doko@ubuntu.com> Thu, 28 Jan 2016 15:52:38 +0100

lp:~ubuntu-desktop/gnome-bluetooth/ubuntu bug Development 2016-01-28 16:57:27 UTC 2016-01-28
109. gnome-bluetooth (3.18.2-1ubuntu2) xen...

Author: Matthias Klose
Revision Date: 2016-01-28 16:57:27 UTC

gnome-bluetooth (3.18.2-1ubuntu2) xenial; urgency=medium

  * Multiarchify the library packages.

 -- Matthias Klose <doko@ubuntu.com> Thu, 28 Jan 2016 17:52:16 +0100

lp:~ubuntu-desktop/gnome-menus/ubuntu bug(Linked to a blueprint) Development 2016-01-28 16:33:18 UTC 2016-01-28
148. gnome-menus (3.13.3-6ubuntu3) xenial;...

Author: Matthias Klose
Revision Date: 2016-01-28 16:33:18 UTC

gnome-menus (3.13.3-6ubuntu3) xenial; urgency=medium

  * Multiarchify the library packages.

 -- Matthias Klose <doko@ubuntu.com> Thu, 28 Jan 2016 17:12:29 +0100

gnome-menus (3.13.3-6ubuntu2) xenial; urgency=medium

  * debian/patches/ubuntu_gcc_translations.patch:
    - restore patch wrongly dropped in the previous merge, make the
      unity-control-center categories translatable (lp: #1515911)

 -- Sebastien Bacher <seb128@ubuntu.com> Tue, 17 Nov 2015 10:41:18 +0100

lp:~ubuntu-desktop/libgnome/ubuntu bug Development 2016-01-14 04:26:54 UTC 2016-01-14
32. * Merge from Debian unstable. Remain...

Author: Steve Langasek
Revision Date: 2016-01-14 04:26:54 UTC

* Merge from Debian unstable. Remaining changes:
  - debian/libgnome2-common.gconf-defaults:
    + changes to default configuration for Ubuntu, drop the keys for
      themes which are also set in the ubuntu-artwork defaults
  - debian/patches/08_dont_force_a11y_activation.patch:
    + don't force a11y activation
  - debian/patches/10_sounds_event_list.patch:
    + no sound event out of the login one for the default configuration
  - debian/control.in:
    + Build-depend on gnome-common
* Dropped changes, included in Debian:
  - gvfs Depends has been dropped.
  - Convert to multiarch
* debian/control.in:
  + Move to section oldlibs.
* Add missing build-dependency on gnome-common.
* Migrate to multiarch. Closes: #642415, #731295.
  + Bump build-dependencies.
  + Split libgnome2-0 into libgnome-2-0 (library, MA: same) and
    libgnome2-bin (binary, MA: foreign).
  + Make libgnome2-common MA: foreign and libgnome2-dev MA: same.
  + Keep libgnome2-0 arch: any and MA: same so that multi-arch
    packages can still depend on it.
  + Update installation paths.
  + Build-depend on MA version of libbonobo.
* Remove gnome:Version.
* 00_as-needed.patch: dropped, obsolete.
* 03_multiarch.patch: revert the logic, use /usr/lib as a fallback in
  search paths.

lp:~ubuntu-desktop/vino/ubuntu bug Development 2016-01-11 01:20:31 UTC 2016-01-11
100. releasing package vino version 3.8.1-...

Author: Tim
Revision Date: 2016-01-11 01:20:31 UTC

releasing package vino version 3.8.1-0ubuntu8

lp:~ubuntu-desktop/gnome-icon-theme/ubuntu bug Development 2016-01-08 18:11:32 UTC 2016-01-08
82. Merge the missing archive upload

Author: Iain Lane
Revision Date: 2016-01-08 18:11:32 UTC

Merge the missing archive upload

lp:~ubuntu-desktop/gnome-themes-standard/ubuntu bug Development 2015-12-29 11:21:08 UTC 2015-12-29
66. * Merge with Debian unstable, remaini...

Author: Dmitry Shachnev
Revision Date: 2015-12-29 11:21:08 UTC

* Merge with Debian unstable, remaining changes:
  - debian/control.in: Have gnome-themes-standard recommend
    ubuntu-mono | adwaita-icon-theme-full.
  - debian/control.in: Use Ubuntu Vcs link.
  - debian/patches/ubuntu_a11y_fallback.patch: Also have HighContrast
    inheirit from the Humanity icon theme.
* Drop gnome-icon-theme alternatives.

lp:~ubuntu-desktop/gnome-settings-daemon/ubuntu bug Development 2015-12-15 10:36:44 UTC 2015-12-15
497. releasing package gnome-settings-daem...

Author: Sebastien Bacher
Revision Date: 2015-12-15 10:36:44 UTC

releasing package gnome-settings-daemon version 3.18.2-0ubuntu3

lp:oneconf bug Development 2015-11-23 10:27:58 UTC 2015-11-23
279. merged lp:~barry/oneconf/lp1440375

Author: Daniel Holbach
Revision Date: 2015-11-23 10:27:58 UTC

merged lp:~barry/oneconf/lp1440375

lp:~ubuntu-desktop/shotwell/ubuntu bug Development 2015-10-28 16:12:10 UTC 2015-10-28
183. releasing package shotwell version 0....

Author: Sebastien Bacher
Revision Date: 2015-10-28 16:12:10 UTC

releasing package shotwell version 0.22.0-2ubuntu1

lp:~ubuntu-desktop/gtk/ubuntugtk3vivid bug Development 2015-09-08 08:56:53 UTC 2015-09-08
433. releasing package gtk+3.0 version 3.1...

Author: Iain Lane
Revision Date: 2015-08-24 15:26:12 UTC

releasing package gtk+3.0 version 3.14.15-0ubuntu1

lp:~ubuntu-desktop/totem-pl-parser/ubuntu bug Development 2015-08-03 09:12:34 UTC 2015-08-03
51. * New upstream release * Wrap depende...

Author: Daniel Holbach
Revision Date: 2015-08-03 09:12:34 UTC

* New upstream release
* Wrap dependencies and drop obsolete Conflicts and Replaces from
  pre-wheezy.
* Split the translations from libtotem-plparser18 into a separate
  libtotem-plparser-common package which is Architecture: all. Make
  libtotem-plparser18 depend on that package.
* Convert the package to multiarch.
* Bump debhelper compatility level to 9.
* Bump Standards-Version to 3.9.6.
* debian/control.in:
  + Let libtotem-plparser-dev depend on libquvi-dev, needed by the
    pkg-config file.
* Add debian/patches/totem-pl-parser-use-old-quvi.patch
  - reverts upstream commit 24970018abfcedcaa496
    "plparse: Port to libquvi 0.9"
    because we don't have this version in unstable yet.
* debian/rules: use autoreconf because of above patch
* Re-add libquvi build-dependency
* Add build-dependencies on dh-autoreconf and libgcrypt20-dev
* Run wrap-and-sort
* Make libquvi build-dependency >= 0.4.1-2.1~
  - this would avoid pulling in both lua 5.1 and 5.2 in same process
    (since totem crashes on startup if we do this) if libquvi had
    a "Build-Depends-Package" in its symbols file.... oh well.
* New upstream release.

lp:~ubuntu-desktop/gnome-vfs/ubuntu bug Development 2015-07-31 00:59:27 UTC 2015-07-31
33. * debian/control: - Depend on libgn...

Author: Robert Ancell
Revision Date: 2015-07-31 00:59:27 UTC

* debian/control:
  - Depend on libgnutls-dev instead of obsolete libgnutls28-dev

lp:~ubuntu-desktop/gnome-screensaver/ubuntu bug(Linked to a blueprint) Development 2015-07-20 14:05:44 UTC 2015-07-20
174. releasing package gnome-screensaver v...

Author: Iain Lane
Revision Date: 2015-07-20 14:05:44 UTC

releasing package gnome-screensaver version 3.6.1-7ubuntu1

lp:~ubuntu-desktop/inkscape/ubuntu bug Development 2015-07-06 08:19:56 UTC 2015-07-06
5. * Merge from Debian unstable (LP: #14...

Author: Daniel Holbach
Revision Date: 2015-07-06 08:19:48 UTC

* Merge from Debian unstable (LP: #1471394). Remaining changes:
  - debian/control:
    + build-depend on dh-translation to handle Ubuntu translation,
    + demote pstoedit from Recommends to Suggests (because it's in
      universe),
  - debian/rules:
    + add dh_translation to handle Ubuntu translation
* debian/control: dh-python b-dep added
* debian/README.source: file dropped (Closes: #696924)
* debian/patches/reproducible-build.patch: add to allow reproducible build.
* debian/rules: enable hardening.
* debian/control: Replace recommends on perlmagick (which is a transitional
  package) by libimage-magick-perl.
  Thanks to Martin Michlmayr <tbm@hp.com> for reporting (Closes: #789232)
* Upload to unstable
* debian/control: set DMM Team as Maintainer
* debian/gbp.conf: git-dch -> dch parameter fixed
* debian/control: add myself to Uploaders
* debian/control: update Vcs-* links to point
  the repo in the pkg-multimedia namespace
* No-change rebuild against new poppler
* Merge from Debian unstable (LP: #1416651). Remaining changes:
  - debian/control:
    + build-depend on dh-translation to handle Ubuntu translation,
    + demote pstoedit from Recommends to Suggests (because it's in
      universe),
  - debian/rules:
    + add dh_translation to handle Ubuntu translation
* debian/patches/0006_add_unity_quicklist_support.patch: dropped, accepted
  upstream.
* Cherry-pick commit from unstable suite
  - debian/control: build-dependencies updated [b4f5c6f]
    - librevenge-dev added
    - libwpd-dev (>= 0.9.0) dropped
    - libwpg-dev (>= 0.2.0) bumped to libwpg-dev (>= 0.3.0)
* debian/rules: override_dh_auto_test dropped (Closes: #776857)
* New upstream release
* New upstream pre-release
* New upstream pre-release
* debian/control: Uploader e-mail address updated
* debian/control: S-V bump 3.9.5 => 3.9.6 (no changes needed)
* New upstream pre-release
* New upstream pre-release
  - debian/control: poppler versioning dropped
  - debian/patches/: patchset updated
    - 0002-Fix_FTBFS_on_poppler-0.26.patch dropped (applied upstream)
* debian/control: libcdr-dev and libvisio-dev b-deps added (Closes: #751090)
* New upstream pre-release
  - debian/control: python-lxml b-dep added
  - debian/rules: dh_auto_test overridden for test purpose
  - debian/patches/: patchset refreshed against v0.91~pre0
    - 0001-Fix_Datamatrix_UI_issue.patch dropped (applied upstream)
    - 0002-Drop_PS_and_PDF_support_in_MimeType.patch => #0001
    - 0003-Fix_LP_-911146.patch dropped (applied upstream)
    - 0004-Fix_FTBFS_on_gcc-4.8.patch dropped (applied upstream)
    - 0005-Fix_FreeType_include.patch dropped (applied upstream)
    - 0006-Fix_FTBFS_on_poppler-0.26.patch updated and => #0002
* debian/control: b-dep bump to use poppler (>= 0.26)
* Merge from Debian unstable. Remaining changes:
  - debian/control:
    + build-depend on dh-translation to handle Ubuntu translation,
    + demote pstoedit from Recommends to Suggests (because it's in universe),
  - debian/patches/0006_add_unity_quicklist_support.patch: add.
  - debian/rules:
    + add dh_translation to handle Ubuntu translation
* debian/patches/: patchset updated
  - 0006-Update_to_new_libwpg.patch refreshed
  - 0007-Fix_API_mismatch.patch added (Closes: #754716)
    Thanks to Pino Toscano (pino) for the patch.
* New upstream pre-release
* No-change rebuild for new poppler
* Rebuild against libmagickcore-6.q16-2.
* Merge with Debian Unstable (LP: #1358863). Fixes several Ubuntu bugs:
  - Illustrator CS SVG won't load: namespace URIs in entities (LP: #166371)
  - inkscape crashed with SIGSEGV in
    sp_dtw_color_profile_event() (LP: #966441)
  - inkscape crashed with SIGSEGV (LP: #1051017)
  - inkscape crashed with SIGSEGV in Inkscape::Preferences::_getNode()
    (LP: #1163241)
  - save a copy reverts to save as (LP: #529843)
  - Extension to braille not working on Xubuntu 12.10 (LP: #1090865)
* Remaining changes:
  - debian/control:
    + Set Ubuntu Developer as maintainer,
    + build-depend on dh-translation to handle Ubuntu translation,
    + demote pstoedit from Recommends to Suggests (because it's in universe),
  - debian/patches/0006_add_unity_quicklist_support.patch: add.
  - debian/patches/series: update.
  - debian/rules:
    + add dh_translation to handle Ubuntu translation
* Drop debian/patches/librevenge.patch (superseded by
    debian/patches/0006-Update_to_new_libwpg.patch)
* debian/patches/: patchset updated
  - 0006-Update_to_new_libwpg.patch added (Closes: #753430)
    Thanks to Rene Engelhard (rene) for the patch.
* debian/control: build-dependencies updated
  - librevenge-dev added
  - libwpd-dev (>= 0.9.0) dropped
  - libwpg-dev (>= 0.2.0) bumped to libwpg-dev (>= 0.3.0)
* debian/: dh-autoreconf usage applied
* debian/rules: fix FTBFS on alpha (Closes: #738155)
* debian/patches/: patchset updated against v0.48.5
  - 0004-Fix_FTBFS_on_gcc-4.8.patch refreshed
  - 0005-Fix_FreeType_include.patch dropped (applied upstream)
  - 0006-Fix_FTBFS_on_poppler-0.26.patch dropped (applied upstream)
  - 0005-Fix_FTBFS_due_to_tests.patch added
* Imported Upstream version 0.48.5
* New upstream pre-release
  - debian/control: poppler versioning dropped
  - debian/patches/: patchset updated
    - 0002-Fix_FTBFS_on_poppler-0.26.patch dropped (applied upstream)
* debian/control: libcdr-dev and libvisio-dev b-deps added (Closes: #751090)
* New upstream pre-release
  - debian/control: python-lxml b-dep added
  - debian/rules: dh_auto_test overridden for test purpose
  - debian/patches/: patchset refreshed against v0.91~pre0
    - 0001-Fix_Datamatrix_UI_issue.patch dropped (applied upstream)
    - 0002-Drop_PS_and_PDF_support_in_MimeType.patch => #0001
    - 0003-Fix_LP_-911146.patch dropped (applied upstream)
    - 0004-Fix_FTBFS_on_gcc-4.8.patch dropped (applied upstream)
    - 0005-Fix_FreeType_include.patch dropped (applied upstream)
    - 0006-Fix_FTBFS_on_poppler-0.26.patch updated and => #0002
* debian/control: b-dep bump to use poppler (>= 0.26)
* Build with experimental patch against librevenge.
* Merge with Debian unstable. Remaining changes:
  - debian/control:
    + Set Ubuntu Developer as maintainer,
    + build-depend on dh-translation to handle Ubuntu translation,
    + demote pstoedit from Recommends to Suggests (because it's on universe),
  - debian/patches/0006_add_unity_quicklist_support.patch: add.
  - debian/patches/series: update.
  - debian/rules:
    + add dh_translation to handle Ubuntu translation,
    + add python2 to dh addon.
* debian/patches/: patchset updated
  - 0006-Fix_FTBFS_on_poppler-0.26.patch added
* debian/: python dependency fixed
* debian/control: b-dep bump liblcms1-dev => liblcms2-dev (Closes: #745533)
* 0007-Poppler-0.26-compatibility.patch: Take patch from bug #1315142 to fix
  compatibility with poppler 0.26.
* Rebuild for the new poppler soname
* Merge from Debian unstable (LP: #1225013). Remaining changes:
  - debian/control:
    + Set Ubuntu Developer as maintainer,
    + build-depend on dh-translation to handle Ubuntu translation,
    + build against liblcsm2 instead of liblcsm1,
    + demote pstoedit from Recommends to Suggests (because it's on universe),
    + add a ${python:Depends}.
  - debian/patches/0006_add_unity_quicklist_support.patch: add.
  - debian/patches/series: update.
  - debian/rules:
    + add dh_translation to handle Ubuntu translation,
    + add python2 to dh addon.
* Debian changes:
  - debian/control: make description more user-friendly (LP: #811634)
* debian/control: S-V bump 3.9.4 => 3.9.5 (no changes needed)
* debian/control: Uploader e-mail address updated
* debian/patches/: patchset updated
  - 0005-Fix_FreeType_include.patch added (Closes: #733118)
    Thanks to Adam Conrad for the patch.
* debian/control: fields update
  - Duplicate Homepage field removed
  - VCS-* fields repositioned
* debian/watch: path updated
* debian/: dh bump 7 => 9
* debian/source/format: 3.0 (quilt) file added
* debian/patches/: patchset re-worked using gbp-pq
  - patches re-worked using gbp-pq (authorships kept)
  - debian/control: quilt b-dep dropped
  - debian/rules: quilt usage dropped
* debian/gbp.conf: file added
* debian/control: autotools-dev b-dep added
* debian/rules: drastic simplification
* debian/control: S-V bump 3.8.3 => 3.9.4 (no changes needed)
* debian/control: python-lxml Suggests => Recommends (Closes: #389540)
* debian/control: python-numpy Suggests => Recommends (Closes: #440566)
* debian/control: libgnomevfs2-extra Suggests => Recommends
  (Closes: #602599)
* debian/control: skencil Suggests dropped.
  The package has been removed from unstable
  on 2010-09-03 and from testing on 2010-09-04. (Closes: #712192)
* debian/control: transfig added to Recommends (Closes: #601770)
* debian/control: python dropped from Suggests (Closes: #628009)
* debian/control: Package description updated.
  Thanks to Phil Bull <philbull@gmail.com> for the new description.
  (Closes: #635244) (LP: #811634)
* 05-freetype-include.patch: Use freetype upstream's recommended include.
* No change rebuild with the new poppler
* Rebuild to pick up new libgc package name
* Merge from Debian Unstable (LP: #1194855)
  - debian/control:
    + Ubuntu maintainers
    + Build against lcms2
    + promote libgnomevfs2-extra to recommends
    + Demote pstoedit to Suggests (universe package).
    + Suggest transfig to allow import of xfig files
    + Drop unnecessary python and skencil suggestions
  - Handle translation tasks for Ubuntu main:
    + debian/rules: Add dh_translations to binary-arch rule
    + debian/control: Build-Depends dh-translations
  - Drop debian/patches/bzr-fix-for-gcc48.patch: Superseded by
    04-Fix_FTBFS_on_gcc-4.8.patch
  - debian/patches/01_add_unity_quicklist_support.patch: add "New Drawing"
    to Unity quicklist
* Upload to unstable
* debian/control: added myself to Uploaders
* debian/patches/: patchset updated
  - 04-Fix_FTBFS_on_gcc-4.8.patch added (Closes: #701297)
* debian/patches/bzr-fix-for-gcc48.patch: fix build with gcc 4.8.
* Rebuild to pick up the new libgc1c3 dependency.
* Merge from Debian Experimental (LP: #1106182). Remaining changes:
  - debian/control:
    + Ubuntu maintainers
    + Build against lcms2 (LP: #885324)
    + Drop build-dependency on specific libwpd/libwpg version.
    + promote libgnomevfs2-extra to recommends (lp: #496223)
    + Demote pstoedit to Suggests (universe package).
    + Suggest transfig to allow import of xfig files (LP: #668300)
    + Drop unnecessary python and skencil suggestions (LP: #762541)
    + Promote python-lxml, python-numpy, python-uniconvertor to Recommends.
  - Handle translation tasks for Ubuntu main (LP: #726850):
    + debian/rules: Add dh_translations to binary-arch rule
    + debian/control: Build-Depends dh-translations
  - debian/patches/01_add_unity_quicklist_support.patch: add "New Drawing"
    to Unity quicklist (LP: #676886)
* Non-maintainer upload.
* New upstream release (Closes: #696181)
  - debian/patches/: patch #03 for CVE-2012-5656
    was merged upstream, so dropped our copy
  - libpng15 incompatibility fixed (Closes: #649975)
  - fixes compatibility with poppler 0.20.x (Closes: #679890)
* debian/changelog: old NMU changelog entry added (Closes: #564022)
* New upstream release (LP: #1091308). Fixes several Ubuntu bugs:
  - Inkscape crashed with SIGSEGV in getObject() (LP: #941317)
  - Inkscape crashed with SIGSEGV in
    Inkscape::Extension::Implementation::Script::effect() (LP: #944077)
  - Inkscape crashed with SIGSEGV in
    Inkscape::Extension::Output::get_extension() (LP: #973174)
  - Overlay scrollbars causing input boxes to be small (LP: #946631)
* Drop 03_track_libpoppler25_abi_changes.patch: applied upstream
* Drop 04_track_libpoppler25_abi_changes_colorspace.patch: applied upstream
* Non-maintainer upload.
* Add Debian patch to fix relative filename vulnerability (Closes: #654341).
* Non-maintainer upload.
* Add Debian patch to fix vulnerability CVE-2012-5656 (Closes: #696485).
* Non-maintainer upload.
* Switch the libpng12-dev build dependency to libpng-dev (closes: #662378)
* Add the libpoppler-private-dev build dependency (closes: #660987)
* No change rebuild for poppler transition.
* No change rebuild for poppler transition.
* No change rebuild for libmagick transition
* No change rebuild for libpoppler26 (poppler 0.20.1-1ubuntu1)
* Follow ABI changes for libpoppler25 (poppler 0.20.0-0ubuntu1).
  (LP: #1005565)
* Merge from Debian Unstable (LP: #966221). Remaining changes:
  - debian/control:
    + Ubuntu maintainers
    + Build against lcms2 (LP: #885324)
    + Drop build-dependency on specific libwpd/libwpg version.
    + promote libgnomevfs2-extra to recommends (lp: #496223)
    + Demote pstoedit to Suggests (universe package).
    + Suggest transfig to allow import of xfig files (LP: #668300)
    + Drop unnecessary python and skencil suggestions (LP: #762541)
    + Promote python-lxml, python-numpy, python-uniconvertor to Recommends.
  - Handle translation tasks for Ubuntu main (LP: #726850):
    + debian/rules: Add dh_translations to binary-arch rule
    + debian/control: Build-Depends dh-translations
  - debian/patches/01_add_unity_quicklist_support.patch: add "New Drawing"
    to Unity quicklist (LP: #676886)
* [cb1a6e2] delete 01-libwpg0.2.dpatch since proper patch appied upstream
* [041bdd7] delete 02-add-shebangs-and-fix-permissions.dpatch (applied upstream)
* [518e31b] delete 03-add-missing-mimetypes.dpatch (applied upstream)
* [df995c3] add datamatrix patch from ubuntu (closes: #618835)
* [169ca97] Imported Upstream version 0.48.3.1, this handles the following
  debian bugs:
  - closes: #665560: inkscape: Including individual glib headers no longer supported
  - closes: #627637: JessyInk: Embedded Javascript Broken
  - closes: #559332: inkscape: Cairo rendering broken for "use" elements with
                               scaling or a viewBox
  - closes: #596836: clipart search spews messages in console
  - closes: #628035: inkscape: in the pdf export dialog a wrong pdf version is
                     reported
  - closes: #651196: French manpage has accents replaced by some garbage
  - closes: #633150: inkscape: New upstream version 0.48.3 is available
* [3f6e27a] use quilt instead of dpatch for patch handling
* [dd10775] Acknowledge NMU, inkscape doesn't register for handling of pdf
  and ps anymore (closes: #613752)
* upload sponsored by Guido Guenther <agx@debian.org>
  Thank you very much!
* promote libgnomevfs2-extra to recommends (lp: #496223)
* New upstream release (LP: #943984)
  - Fixes build errors with glibmm < 2.28
* Build against lcms2 (LP: #885324)
* New upstream release (LP: #933188). Fixes several Ubuntu bugs:
  - inkscape fails to build with glib 2.31 (LP: #898538)
  - ctrl c ctrl v of text in edit mode crashes inkscape (LP: #496793)
  - Completely replace lcms1 by lcms2 in Ubuntu (LP: #885324)
  - parameters ending with '\' causes python to bomb (LP: #168417)
  - Extensions with <check> tags fail to load (LP: #668895)
  - ESC doesn't cancel move when using the Node Tool (LP: #788560)
  - unable to edit attributes in Inkscape XML Editor (LP: #884368)
  - Some layers should be visible by default in Layers dialog (LP: #902054)
  - Path Effect List is hidden (LP: #909958)
  - Input Devices > Hardware > Tree of devices is hidden (LP: #910467)
  - Glyphs Font styles are hidden (LP: #911079)
  - Error messages from Extensions hidden (LP: #911079)
  - Messages dialog doesn't work (LP: #911123)
* Drop 02-add-shebangs-and-fix-permissions.dpatch: Applied upstream.
* Drop build-dependency on specific libwpd/libwpg version.
* No-change rebuild against libpoppler19.
* No-change rebuild to drop spurious libsfgcc1 dependency on armhf.
* No change rebuild for imagemagick4 transition
* New upstream release (LP: #807912). Fixes several Ubuntu bugs:
  - [SVG Font Editor] Crash when kerning an empty pair (LP: #706506)
  - Connector tool crash Inkscake (orthogonal mode) (LP: #771738)
  - Errors printed to console if openclipart search fails (LP: #638844)
  - pdf export with cairo 1.10 defaults to version PDF-1.5 (LP: #664335)
  - Cairo rendering broken for "use" elements when scaling or a viewBox
    (LP: #705345)
  - gimp_xcf.py crashed with TypeError in effect() (LP: #565296)
  - Enable build against libwpg-0.2 (LP: #778951)
  - Please add supported filetypes into MimeType line of inkscape.desktop
    (LP: #278307)
  - Inkscape fails to build with gcc 4.6 (LP: #707205)
* Drop 01-libwpg0.2.dpatch - Applied upstream
* Drop 03-add-missing-mimetypes.dpatch - Applied upstream
* Drop 04-fix-build-with-gcc4.6.dpatch - Applied upstream
* Drop 05-add-missing-includes.dpatch - Applied upstream
* Drop fix-fontforge-glyph-template.dpatch - Applied upstream
* Merge from Debian Unstable (LP: #791728). Remaining changes:
  - debian/control:
    + Ubuntu maintainers
    + Promote python-lxml, python-numpy, python-uniconvertor to Recommends.
    + Demote pstoedit to Suggests (universe package).
    + Suggest transfig to allow import of xfig files (LP: #668300)
    + Drop unnecessary python and skencil suggestions (LP: #762541)
  - Handle translation tasks for Ubuntu main (LP: #726850):
    + debian/rules: Add dh_translations to binary-arch rule
    + debian/control: Build-Depends dh-translations
  - debian/patches/01_add_unity_quicklist_support.patch: add "New Drawing"
    to Unity quicklist (LP: #676886)
  - debian/patches/fix-fontforge-glyph-template.dpatch: Cherry-pick
    patch from uptream trunk to fix layer structure in template (LP: #565296)
  - debian/patches/02-add-shebangs-and-fix-permissions.dpatch: No longer mark
    JavaScript extension files as standalone executables (LP: #602005):
    + share/extensions/*.js: Revert addition of shebangs
    + share/extensions/Makefile.am: Install *.js using _DATA rule rather
      than _SCRIPTS rule to avoid giving executable permission
* debian/patches/fix-datamatrix-ui.dpatch: Prevent invalid input in
  Datamatrix extension dialog (LP: #738108)
* Non-maintainer upload.
* Fix FTBFS with gcc 4.6 (Closes: #624770), Thanks to Alex Valavanis
  for the patch.
  - added 04-fix-build-with-gcc4.6.dpatch
* Fix build issues due to missing includes (Closes: #628226), patch
  taken from upstream.
  - added 05-add-missing-includes.dpatch
* debian/rules: No need to manually call intltool-update on build. This
  is now handled by dh_translations.
* debian/control: No longer suggest python and skencil. They do not
  offer any enhancement to Inkscape (LP: #762541)
* debian/control: Suggest transfig to allow import of xfig files
  (LP: #668300)
* debian/patches/02-add-shebangs-and-fix-permissions.dpatch:
  No longer mark JavaScript extension files as standalone executables
  (LP: #602005):
  - share/extensions/*.js: Revert addition of shebangs
  - share/extensions/Makefile.am: Install *.js using _DATA rule rather
    than _SCRIPTS rule to avoid giving executable permission
* debian/patches/fix-fontforge-glyph-template.dpatch: Cherry-pick
  patch from uptream trunk to fix layer structure in template (LP: #565296)
* debian/rules: Drop broken code to add translation domain to desktop files.
  Replace this with a call to dh_translations. Add dh-translations build
  dependency for this. Thanks to Alex Valavanis for pointing this out, and
  the original patch. (LP: #726850)
* debian/patches/04-fix-gcc4.6-ftbfs.dpatch: Fix build failure with gcc 4.6
  - Backport upstream patch (lp:inkscape:r10071)
  - Add <cstddef> inclusion to src/2geom/utils.h
* debian/patches/01_add_unity_quicklist_support.patch:
  - updated with latest specification
* Merge with Debian unstable (LP: #719648, LP: #278307). Remaining changes:
* debian/control:
  - Ubuntu maintainers
  - Promote python-lxml, python-numpy, python-uniconvertor to Recommends.
  - Demote pstoedit to Suggests (universe package).
* debian/rules:
  - Run intltool-update on build (Ubuntu-specific).
  - Add translation domain to .desktop files (Ubuntu-specific)
* debian/patches/01_add_unity_quicklist_support.patch:
  - add unity quicklist support for a new entry to inkscape (LP: #676886)
* upload to unstable (closes: #611626)
* [d364fdc] link against libwpg0.2/libwpd0.9 (closes: 604825)
  Thanks to Rene Engelhard <rene@debian.org> for his work and the patch!
* upload sponsored by Guido Guenther <agx@debian.org>
  Thank you very much!
* [f6250fa] Imported Upstream version 0.48.1
* [e5b9206] remove debian/patches/01-end-drag-fix.dpatch since applied
  upstream
* [2b6fb5b] add patch to fix shebang lines in extensions scripts
* [f38e3e1] drop dependency upon ttf-bitstream-vera (closes: #597503)
* [0a91fb1] binary depends on ${misc:Depends} as indicated by lintian
* [02b4953] depend on libmagick++-dev instead of libmagick++9-dev
* [ea095c3] Add supported mime types (closes: #596982)
* debian/patches/01_add_unity_quicklist_support.patch:
  - add unity quicklist support for a new entry to inkscape (LP: #676886)
* New upstream version (LP: #710619). Fixes several Ubuntu bugs:
  - Node editing causes segmentation fault (LP: #544599)
  - Cursor position markers are not cleared from rulers (LP: #627134)
  - Crashes when opening document properties (LP: #658055)
  - Export to XCF error with default template (LP: #485032)
  - Editing a connector in a transformed group returns it to original
    position (LP: #533897)
  - Ungrouping objects changes position of arrow lines (LP: #552289)
  - Will not save XCF file (LP: #642417)
  - XCF export fails when exporting from unsaved document (LP: #650890)
* Drop all patches: Applied upstream
* debian/rules: Disable chmod on debian/patches/* in clean rule (no patches used)
* debian/patches/0001-Fix-build-with-Poppler-0.15.1.dpatch: Backport
  upstream patch to fix Poppler build issues in Natty (LP: #676271)
* Bug-fix release (LP: #645888)
* Added 02-fix-binutils-gold-build-failure.dpatch (LP: #662979)
* debian/control: No longer suggest ttf-dejavu (LP: #643371)
* Merge with Debian unstable (LP: #628048, LP: #401567, LP: #456248,
  LP: #463602, LP: #591986)
* debian/control:
  - Ubuntu maintainers
  - Promote python-lxml, python-numpy, python-uniconvertor to Recommends.
  - Demote pstoedit to Suggests (universe package).
  - Suggests ttf-dejavu instead of ttf-bitstream-vera (LP: #513319)
* debian/rules:
  - Run intltool-update on build (Ubuntu-specific).
  - Add translation domain to .desktop files (Ubuntu-specific).
* debian/dirs:
  - Add usr/share/pixmaps. Allow inkscape.xpm installation
* drop 50-poppler-API.dpatch (now upstream)
* drop 51-paste-in-unwritable-directory.dpatch (now upstream)
* [cae07a3] New Upstream version 0.48.0
* [309c498] add patch to fix crash in node tool
* The highlights of this release are:
    - multipath editing
    - improved text tool: subscript, superscript, numerical input for text kerning, tracking and more
    - new Airbrush tool
    - LaTeX export with PDF/PS/EPS
    - JessyInk extension to create presentations
    - numerous bugfixes
* [56702cf] don't build-depend on libssl-dev (closes: #573338)
* [013b235] wrap lines in debian/control. patch by Benjamin Drung,
  many thanks to him (closes: #576357)
* [747d3d1] add README.source adopted from nagios to make lintian a
  bit happier
* [4df0df7] Remove all patches since they are applied upstream
* 51-paste-in-unwritable-directory.dpatch, debian/control: Allow paste
  from clipboard when in unwritable working directory (LP: #211607)
* debian/control: Replaced ttf-bitstream-vera suggestion with ttf-dejavu
  (LP: #513319).
* Merge from debian testing (LP: #533584, LP: #486425). Remaining changes:
  - debian/control:
    - drop libssl-dev, no longer needed (Closes: #573338).
    - promote python-lxml, python-numpy, python-uniconvertor to Recommends.
    - demote pstoedit to Suggests (universe package).
  - debian/rules:
    - Run intltool-update on build (Ubuntu-specific).
    - Add translation domain to .desktop files (Ubuntu-specific).
  - 50-poppler-API.patch, debian/control: poppler 0.12.2 changed the
    GfxColorSpace API (LP: #487038).
* Build depend on libaspell-dev, recommend aspell, add explanation to
  package description (closes: #562060)
* update debian/watch patch by Kees Cook, many thanks to him
  (closes: #562225)
* process DEB_BUILD_OPTIONS for "parallel=N" flag patch by Kees Cook,
  many thanks to him. (Closes: #562226)
* Add patch to update man-page (closes:#570494)
* remove old unneeded patches
* upload sponsored by Guido Guenther <agx@debian.org>
* Brown paper bag update: actually use the correct version of the
  source tree.
* Merge with Debian testing (LP: #498150). Remaining changes:
  - debian/control:
    - promote python-lxml, python-numpy, python-uniconvertor to Recommends.
    - demote pstoedit to Suggests (universe package).
    - drop libssl-dev, no longer needed (Debian bug 484527).
  - debian/rules:
    - Handle parallel builds via -j (Debian bug 562226).
    - Run intltool-update on build (Ubuntu-specific).
    - Add translation domain to .desktop files (Ubuntu-specific).
  - debian/watch:
    - Correctly handle "pre" versions (Debian bug 562225).
* 50-poppler-API.patch, debian/control: poppler 0.12.2 changed the
  GfxColorSpace API (LP: #487038).
* Imported Upstream version 0.47
* This is upstream version 0.47, I added the .0 because
  I forget the ~ in the -pre versions.
* add proper Vcs-fields to debian/control
* upload sponsored by Guido Guenther <agx@debian.org>
* Imported Upstream version 0.47pre4
* upload sponsored by Guido Guenther <agx@debian.org>
* fix installation of usr/share/application-
  registry/inkscape.applications
* upload sponsored by Guido Guenther <agx@debian.org>
* new upstream release (closes: #532277)
  Improvements and new features include:
  - code cleanups and refractoring
  - autosave feature, configurable via Inkscape preferences
  - new and enhanced tools, extensions and filters
  - new path effects
  - enhanced import and export features
  - improved svg support
  - many other improvements and new features. For a better and more
    comprehensive decription of enhancements see the online release notes at
    http://wiki.inkscape.org/wiki/index.php/Release_notes/0.47
* remove 04-only-use-valid-font-families-in-text-tool.dpatch
  since there is a better fix in the code now (closes: #496784)
* remove other patches which are no longer needed:
  - 01_mips.dpatch
  - 02-poppler-0.8.3.dpatch
  - 03-chinese-inkscape.dpatch
  - 05_fix_latex_patch.dpatch
  - 06_gcc-4.4.dpatch
  - 07_cdr2svg.dpatch
  - 08_skip-bad-utf-on-pdf-import.dpatch
  - 09_gtk-clist.dpatch
  - 10_belarussian.dpatch
  - 12_desktop.dpatch
  fix patch permissions in clean target
* upload sponsored by Guido Guenther <agx@debian.org>
* build-depend on libgsl0-dev
* small adations to debian/rules
* New upstream pre-release, bug-fixes only (LP: #432328).
* No-change rebuild against libmagick++2.
* New upstream release.
  - Don't constrain maximization on small resolution devices (pre0)
    (LP: #348842)
  - Fixes segfault on startup (pre0)
    (LP: #391149)

* New upstream release
* debian/control: Adding libgsl0 and removing version specifics on boost
* debian/watch: updated to run uupdate and mangle pre-release versions.
* Dropped patches that have been taken upstream:
  - 01_mips
  - 02-poppler-0.8.3
  - 03-chinese-inkscape
  - 05_fix_latex_patch
  - 06_gcc-4.4
  - 07_cdr2svg
  - 08_skip-bad-utf-on-pdf-import
  - 09_gtk-clist
  - 10_belarussian
  - 11_libpng
  - 12_desktop
  - 13_slider
  - 100_svg_import_improvements
  - 102_sp_pattern_painter_free
  - 103_bitmap_type_print
* Non-maintainer upload.
* 03-gtk-includes.dpatch: patch from Ubuntu to fix FTBFS caused by
  wrong GTK+ includes. Closes: #518633.

lp:~ubuntu-desktop/transmission/ubuntu bug Development 2015-07-06 07:34:12 UTC 2015-07-06
37. * Merge from Debian unstable (LP: #12...

Author: Daniel Holbach
Revision Date: 2015-07-06 07:34:05 UTC

* Merge from Debian unstable (LP: #1235535). Remaining changes:
  - debian/control:
    + Build-depend on libappindicator3-dev
  - debian/transmission-daemon.upstart: add upstart job
* Acknowledge NMUs: thanks to Boris Pek, Thomas Goirand, Markus Koschany;
  Closes: #737366, #718624, #754982, #757365, #718624, #734467
* [323b2ad] Set me as maintaner, Leo as uploader (with Leo's blessing)
* [3eecf54] removed Bugs field, as it was causing bugs to be sent to upstream;
  Closes: #740944
* [e5bd0af] drop gconf integration, no longer needed; Closes: #741069,
  #745936, #756823
* [0432bb4] bump Standards-Version to 3.9.6 (no changes needed)
* [fd2b694] transition to libsystemd-dev; Closes: #779760
* Merge from Debian unstable (LP: #1407241). Remaining changes:
  - debian/control:
    + Build-depend on libappindicator3-dev
  - debian/transmission-daemon.upstart: add upstart job
* Non-maintainer upload.
* transmission-daemon.postinst:
  - Change home directory of transmission-daemon to
    /var/lib/transmission-daemon from /home/debian-transmission.
    Thanks to Alex Peters for the report. (Closes: #734467)
  - Disable password authentication for debian-transmission user for
    improved security. Logins with e.g. SSH RSA keys are still possible.
  - Check existence of debian-transmission user with getent passwd
    debian-transmission instead of id.
* Add transmission-daemon.preinst:
  - Fix permissions in /var/lib/transmission-daemon and use
    /var/lib/transmission-daemon as the new home directory.
  - Move old configuration files to appropriate config directory
    /var/lib/transmission-daemon/.config/transmission-daemon.
    All together this ensures that transmission-daemon will not segfault
    when systemd is the default init system.
    Thanks to Andrei Popescu and Antoine Legonidec for the report and
    additional tests. (Closes: #718624)
* transmission-daemon.links:
  - Link settings.json from /etc/transmission-daemon/settings.json to
    /var/lib/transmission-daemon/.config/transmission-daemon.
  - Link /var/lib/transmission-daemon/.config/transmission-daemon to
    /var/lib/transmission-daemon/info due to compatibility reasons with
    the old sysv-rc init script settings.
* transmission-daemon.dirs:
  - Do not create /var/lib/transmission-daemon/info anymore.
* Merge from Debian unstable (LP: #1387100). Remaining changes:
  - debian/control:
    + Build-depend on libappindicator3-dev
  - debian/transmission-daemon.upstart: add upstart job
* Non-maintainer upload.
* New upstream release:
  - Fixes build with newer miniupnpc (Closes: #754982, #757365).
* Ran wrap-and-sort.
* Fix upstream service file (Closes: #718624).
* Refresh fix_freebsd_quota_include.patch.
* Minimum version of libminiupnpc-dev is now >= 1.9.
* Removed debian/gbp.conf which imposes bzip2 when upstream releases source
  using xz compression.
* SECURITY UPDATE: denial of service and possible code execution via
  overflow in tr_bitfieldEnsureNthBitAlloced
  - debian/patches/CVE-2014-4909.patch: properly handle bitfields in
    libtransmission/bitfield.c, handle invalid blocks in
    libtransmission/peer-msgs.c.
  - CVE-2014-4909
* Rebuild to solve a powerpc dependency problem.
* Rebuild against Qt 5.2.1
* Merge from Debian unstable (LP: #1282453). Remaining changes:
  - debian/control:
    + Build-depend on libappindicator3-dev
  - debian/transmission-daemon.upstart: add upstart job
* Non-maintainer upload.
* [36a95ac] bump policy to 3.9.5 (no changes)
* [6f54782] use systemd only on linux systems
  Thanks to Peter Green (Closes: 737366)
* [8e97c66] add build-dep on dh-autoreconf
* [210734a] debian/rules: use dh with autoreconf instead of autotools-dev
  - fix re-configuring with automake >= 1.14
  - fix FTBFS on kFreeBSD systems
* [14305bc] debian/changelog: fix lintian warning about wrong weekday
  (2013-09-15 is a Sunday)
* [b7972f5] debian/control: fix lintian notes vcs-field-not-canonical
* [539e32b] debian/transmission-daemon.init:
  fix lintian note init.d-script-missing-lsb-description
* [b10417b] debian/transmission-daemon.postinst: fix lintian error
  maintainer-script-should-not-use-adduser-system-without-home
* [09bac94] debian/control: fix lintian note
  capitalization-error-in-description GTK GTK+

lp:~ubuntu-desktop/gtk/ubuntugtk3vivid-overlay Development 2015-07-01 15:16:05 UTC 2015-07-01
432. releasing package gtk+3.0 version 3.1...

Author: Iain Lane
Revision Date: 2015-07-01 11:41:47 UTC

releasing package gtk+3.0 version 3.14.13-0ubuntu2

lp:~ubuntu-desktop/gconf/ubuntu bug Development 2015-06-11 01:51:18 UTC 2015-06-11
115. releasing package gconf version 3.2.6...

Author: Steve Langasek
Revision Date: 2015-06-11 01:51:18 UTC

releasing package gconf version 3.2.6-3ubuntu2

lp:~ubuntu-desktop/gnome-disk-utility/ubuntu bug Development 2015-06-10 04:52:03 UTC 2015-06-10
52. New upstream release

Author: Robert Ancell
Revision Date: 2015-06-10 04:52:03 UTC

New upstream release

lp:~ubuntu-desktop/gnome-system-monitor/ubuntu bug Development 2015-06-02 19:58:37 UTC 2015-06-02
66. * Merge from debian. Remaining change...

Author: Jackson Doak
Revision Date: 2015-06-02 19:58:37 UTC

* Merge from debian. Remaining changes:
  - Change appdata-tools b-dep to appstream-util
* New upstream release.
* Drop obsolete --disable-scrollkeeper configure switch.
* Build against libsystemd. (Closes: #779753)

lp:~ubuntu-desktop/gnome-contacts/ubuntu bug Development 2015-05-28 11:32:09 UTC 2015-05-28
25. releasing package gnome-contacts vers...

Author: Iain Lane
Revision Date: 2015-05-28 11:32:09 UTC

releasing package gnome-contacts version 3.14.2-0ubuntu1

lp:~ubuntu-desktop/gtk/ubuntugtk3trusty bug Development 2015-05-27 13:42:15 UTC 2015-05-27
163. releasing package eog version 3.16.2-1

Author: Sebastien Bacher
Revision Date: 2015-05-27 13:42:15 UTC

releasing package eog version 3.16.2-1

lp:session-migration bug Development 2015-05-07 08:29:44 UTC 2015-05-07
29. releasing package session-migration v...

Author: Sebastien Bacher
Revision Date: 2015-05-07 08:29:29 UTC

releasing package session-migration version 0.2.3

lp:~ubuntu-desktop/empathy/ubuntutrusty Development 2015-04-30 11:06:25 UTC 2015-04-30
369. releasing package empathy version 3.8...

Author: Iain Lane
Revision Date: 2015-04-30 11:06:25 UTC

releasing package empathy version 3.8.6-0ubuntu9.2

lp:~ubuntu-desktop/empathy/ubuntuutopic Development 2015-04-30 09:56:21 UTC 2015-04-30
371. releasing package empathy version 3.8...

Author: Iain Lane
Revision Date: 2015-04-30 09:56:21 UTC

releasing package empathy version 3.8.6-0ubuntu13.1

lp:~ubuntu-desktop/empathy/ubuntuvivid Development 2015-04-30 09:13:37 UTC 2015-04-30
377. releasing package empathy version 3.1...

Author: Iain Lane
Revision Date: 2015-04-30 09:13:37 UTC

releasing package empathy version 3.12.9-1ubuntu1.1

lp:~ubuntu-desktop/ubuntu-seeds/ubuntu-touch.vivid (Has a merge proposal) Development 2015-04-22 14:16:10 UTC 2015-04-22
292. remove duplicated comment

Author: Didier Roche
Revision Date: 2015-04-22 14:16:10 UTC

remove duplicated comment

lp:~ubuntu-desktop/gnome-codec-install/ubuntu bug Development 2015-03-16 08:27:50 UTC 2015-03-16
47. merged lp:~ari-tczew/gnome-codec-inst...

Author: Daniel Holbach
Revision Date: 2015-03-16 08:27:50 UTC

merged lp:~ari-tczew/gnome-codec-install/ubuntu

lp:~ubuntu-desktop/xscreensaver/ubuntu bug Development 2015-02-19 08:49:44 UTC 2015-02-19
33. * Merge from Debian unstable. (LP: #1...

Author: Daniel Holbach
Revision Date: 2015-02-19 08:49:38 UTC

* Merge from Debian unstable. (LP: #1406825) Remaining changes:
    + Breaks/Replaces: the old changes are not needed anymore, but the
      new changes the screensavers sets needs it.
    + Use /usr/share/backgrounds as image directory.
    + Add translation domain to .desktop files.
    + Add apport hook.
  - debian/xscreensaver.dirs:
      /usr/share/backgrounds and without it, it displays an error.
  - debian/patch/90_ubuntu-branding.patch: Use Ubuntu branding.
  - debian/patches/60_sequential_glslideshow.patch:
    + Allow going through images sequentially rather than just at random in
      the GLSlideshow hack.
  - debian/patches/91_replace-gdmflexiserver.patch:
    + Use dm-tool instead of gdmflexiserver for user-switching,
      the latter is no longer provided by lightdm.
* New upstream release 5.30
  - New hack, `winduprobot'.
  - Many improvements to `lament', including Leviathan.
  - Fixed the normals in `flyingtoasters': shading is correct now.
  - Dragging has inertia now.
  - Most hacks respond to mouse-clicks, double-taps and swipes as
    meaning "do something different now".
  - Reworked OpenGL fonts.
  - Various minor fixes.
* Bump Standards-Version to 3.9.6 (no changes needed)
* debian/copyright: hacks/kumppa uses X11 license
* New upstream release 5.29, changes since 5.26:
  - New hacks, `tessellimage' and `projectiveplane'.
  - Added support for pthreads, because Dave Odell is a madman.
  - Updated `webcollage' for recent changes.
  - X11: Don't assume Suspend = 0 implies "No DPMS".
  - Minor updates to `boxed' and `klein'.
  - Fixed possible crash in `apple2', `noseguy', `xmatrix', `shadebobs'.
  - Plugged some leaks.
  - Fixed some compilation problems and intermittent crashes.
  - Updated `webcollage' for recent changes.
* debian/patches/91_replace-gdmflexiserver.patch:
  - Use dm-tool instead of gdmflexiserver for user-switching,
    the latter is no longer provided by lightdm (LP: #1320560)
* debian/control: Fix typo in Repleaces on xscreensaver-data
  (LP: #1319433).
* Dropped Ubuntu changes:
  - Ubuntu delta to the screensavers sets.
  - Keep Debian Vcs-* links instead of the ~ubuntu-desktop team bzr
    repository: the Desktop team does not have interest any more.
  - The Ubuntu changes to the descriptions.
* Merge from Debian unstable. (LP: #1283459) Remaining changes:
  - debian/control:
    + Breaks/Replaces: the old changes are not needed anymore, but the
      new changes the screensavers sets needs it.
  - debian/rules:
    + Use /usr/share/backgrounds as image directory.
    + Add translation domain to .desktop files.
  - debian/source_xscreensaver.py:
    + Add apport hook.
  - debian/xscreensaver.dirs:
    + Install /usr/share/backgrounds. By default, settings search in
      /usr/share/backgrounds and without it, it displays an error.
  - debian/patch/90_ubuntu-branding.patch: Use Ubuntu branding.
* New upstream release 5.26, changes since 5.23:
  - Updated feed-loading for recent Flickr changes.
  - Updated `webcollage' for recent Google changes.
  - Added Instagram and Bing as `webcollage' image sources.
  - Updated to latest autoconf.
  - Bug fixes.
* Drop patch applied upstream:
  - debian/patches/12_upstream_use_cppflags.patch
* Bump Standards-Version to 3.9.5 (no changes needed)
* New upstream release 5.23 (Closes: #729311)
  - New hack, geodesic
  - More heuristics for using RSS feeds as image sources
  - Improved Wikipedia parser
  - Updated webcollage for recent Flickr changes
  - Added Android to bsod
  - Made quasicrystal work on weak graphics cards
  - Better compression on icons, plists and XML files
  - Reverted that DEACTIVATE change. Bad idea.
  - Phosphor now supports amber as well as green
* Dropped patches applied upstream:
  - 12_upstream_quasicrystal_texture_width.patch
  - 14_upstream_hexadrop_keyboard_exit.patch
  - 15_upstream_activate_faster_nontty.patch
* debian/patches/12_upstream_use_cppflags.patch:
  Make sure CPPFLAGS are used (fixes hardening warnings)
* debian/control: Update VCS fields (fixes Lintian warning)
* New upstream release 5.22 (Closes: #699833), changes since 5.15:
  - XInput devices now also ignore small mouse motions
  - Loading images via RSS feeds is much improved
  - Enlarged the texture image for lament
  - Made pipes be ridiculously less efficient, but spin
  - Added better mouse control to rubik, cube21, crackberg, and julia
  - Cosmetic improvements to queens and endgame
  - sonar can now ping local subnet on DHCP
  - Most savers now resize/rotate properly
  - New version of `fireworkx'
  - Minor fixes to `distort', `fontglide', `xmatrix'
  - New MacOS crash in `bsod'
  - New mode in `lcdscrub'
  - Gnome/KDE instructions updated in man page (Closes: #640640)
  - New --enable-pam-check-account-type option (Closes: #656766)
  - Fixed imageDirectory URL parsing. Closes: #714582 (LP: #1116006)
  - Use of AC_SYS_LARGEFILE fixes inode number overflow when accessing
    image files on cifs file systems (LP: #609451) Thanks Mamoru Tasaka!
  - New hacks: kaleidocycle, quasicrystal, unknownpleasures, hexadrop
  - Performance improvements for `interference'.
  - Fixed possible crashes in apple2, maze, pacman, polyominoes,
    fireworkx, engine (LP: #1196251)
  - Fix for `bumps' in 64 bit (LP: #103975)
  - Fixed "Shake to Randomize"; display name of saver.
  - Fixed rotation problems with `pacman', `decayscreen'.
  - Better dragging in `fluidballs'.
  - Ignore rotation in hacks that don't benefit from it.
  - Ignore DEACTIVATE messages when locked, instead of popping up the
    password dialog box.
  - Fix format string glitch in xscreensaver-text (LP: #781948)
    (thanks Emanuel Bronshtein)
* debian/patches: Split up 53_XScreenSaver.ad.in.patch into
  logically separated and better named patches
* debian/patches/57_grabDesktopImages_default_off.patch:
  Do not reveal desktop content by default (Closes: #679974)
* debian/patches/12_upstream_quasicrystal_texture_width.patch:
  Adjust texture width to graphics card/driver capability
* debian/patches/14_upstream_hexadrop_keyboard_exit.patch:
  Allow keyboard exit when run standalone (from upstream)
* debian/patches/15_upstream_activate_faster_nontty.patch:
  Activate faster when not from tty session (LP: #1229486)
* Bump Standards-Version to 3.9.4 (no changes needed)
* debian/rules: Drop unnecessary dh_testroot from clean target
  (thanks Julien Cristau)
* debian/rules: Include buildflags.mk for hardening options
* Stop xscreensaver in prerm instead of postrm (Closes: 681613)
  (thanks Filipus Klutiero)
* New xscreensaver daemon wrapper used by the example .desktop file
  to determine correct "New login" command.
* debian/copyright: Updated to comply with accepted standard
* debian/control: Make short descriptions more consistent
* debian/control: Migrate Conflicts: to Breaks:
* Merge from Debian unstable. Remaining changes:
* Removed Jose Luis Rivas as maintainer, now the sole maintainer
  is Tormod Volden.
* Add -s to gdmflexiserver invocation (Closes: #349000)
* xscreensaver-data depends on libwww-perl (LP: #971140)
* Bump Standards-Version to 3.9.3 (no changes needed)

lp:~ubuntu-desktop/gcalctool/ubuntu bug Development 2015-01-27 11:36:59 UTC 2015-01-27
116. releasing package gnome-calculator ve...

Author: Iain Lane
Revision Date: 2015-01-27 11:36:59 UTC

releasing package gnome-calculator version 1:3.14.1-0ubuntu2

lp:~ubuntu-desktop/aisleriot/ubuntu bug Development 2015-01-16 11:32:15 UTC 2015-01-16
14. Merge lp:~noskcaj/aisleriot/3.14.2

Author: Iain Lane
Revision Date: 2015-01-16 11:32:15 UTC

Merge lp:~noskcaj/aisleriot/3.14.2

lp:~ubuntu-desktop/librsvg/ubuntu bug Development 2014-12-17 09:21:18 UTC 2014-12-17
10. * New upstream release 2.40.6. - Fi...

Author: Daniel Holbach
Revision Date: 2014-12-17 09:21:11 UTC

* New upstream release 2.40.6.
  - Fix path data number parsing (LP: #370061)
* New upstream release.
* Bump Standards-Version to 3.9.6. No further changes.
* Install typelib files into multiarch paths.
* Mark gir and dev package as Multi-Arch: same.
* New upstream release.
* Update Homepage: URL.
* Cherry-pick upstream fix to handle compressed input in rsvg-convert.
  Closes: #760178
* New upstream release.
* Refresh patches.
* Bump Standards-Version to 3.9.5.
* New upstream bugfix releases
* New upstream release.
  - Fixes local resource access vulnerability. Closes: #724741
    CVE-2013-1881
* Refresh patches.
* GTK2 support has been removed upstream. Drop Build-Depends on
  libgtk2.0-dev, libgtk2.0-doc and the now obsolete --disable-gtk-theme
  configure switch.
* Bump Build-Depends on libgtk-3-dev to (>= 3.2.0).
* Bump Build-Depends on libpango1.0-dev to (>= 1.36.0) to get the
  thread-safe version.
* debian/control.in:
  - Use canonical URL for VCS-* fields
  - Update Homepage URL
  - Move source package to the "libs" Section
  - Remove duplicate Section, thanks to lintian
* Upload to unstable.
* Drop Build-Conflicts against valac-0.16 again. With valac-0.20 now being
  the default this is no longer necessary.
* Drop explicit Build-Depends on gir1.2-glib-2.0 and gir1.2-freedesktop.
  Those are pulled in by libgirepository1.0-dev.
* Bump Standards-Version to 3.9.4. No further changes.
* Team upload
* New upstream version (LP: #1038843)
* Use dh-autoreconf with --as-needed instead of patching ltmain.sh
  (from Ubuntu, thanks Iain Lane)
* Enable Vala bindings (based on Ubuntu changes, thanks to Robert Ancell)
  - Build-Conflicts: valac-0.16 because if both are installed, the
    default version 0.16 is selected, breaking our build

lp:~ubuntu-desktop/libgnomekbd/ubuntu bug Development 2014-12-08 09:12:46 UTC 2014-12-08
35. * Merge from Debian unstable. (LP: #1...

Author: Daniel Holbach
Revision Date: 2014-12-08 09:12:39 UTC

* Merge from Debian unstable. (LP: #1400150) Remaining changes:
  - debian/patches/02-Remove-redundent-key-label-information.patch:
    + Fix keys that display too much information.
  - debian/rules:
    + Update package names to match soname.
  - debian/watch:
    + Watch for unstable versions.
* Fix gkbd-capplet description. Closes: #691143.
* Update homepage
* New upstream release.
* Rename package libgnomekbd7 -> libgnomekbd8 for new SONAME
* Update debian/libgnomekbd8.symbols
* Add gnome-common to build-depends to properly regenerate configure
* Bump Standards-Version to 3.9.4
* debian/patches/02-Remove-redundent-key-label-information.patch:
  - Fix keys that display too much information LP: #1025508
* New upstream stable release
* New upstream release
* New upstream release
* debian/control:
  - Use standards version 3.9.3
  - Update package names to match soname
* debian/rules:
  - Update package names to match soname
* debian/libgnomekbd8.symbols:
  - Updated
* debian/watch:
  - Watch for unstable versions
* New upstream release.
* debian/gkbd-capplet.install: Drop *.ui files which do not exist any more.
* debian/libgnomekbd7.symbols: Dropped obsolete plugin symbols.
* New upstream development release.
* Change section of gir1.2-gkbd-3.0 to introspection.
* Remove old Provides which are no longer necessary.
* Remove old Conflicts/Replaces.
* Re-wrap dependencies.
* Bump (Build-)Depends on libxklavier-dev to (>= 5.2).
* Drop explicit Build-Depends on the gir1.2-* packages, they are pulled via
  the corresponding -dev packages.
* debian/watch: Switch to .bz2 tarball and fix regex so latest directory is
  correctly detected
* Upload to unstable.
* New upstream release.
  - Link against -lm for sincos. Closes: #640445
* debian/watch:
  - Switch to .xz tarballs.
* Bump debhelper compatibility level to 8.
  - Update Build-Depends on debhelper.
  - Strip debian/tmp/ from .install files.
* debian/control.in:
  - Set pkg-gnome-maintainers@lists.alioth.debian.org as Maintainer.
  - Bump Standards-Version to 3.9.2. No further changes.
* Make the -dev package depend on the gir package.
* New upstream release.
* debian/libgnomekbd7.symbols: Adjust .symbols file
* debian/libgnomekbd-common.install:
  - Install /usr/share/GConf/gsettings and /usr/share/libgnomekbd/icons
  - Add libatk1.0-dev (>= 1.32.0-2~) build-dep to be sure we have .gir file
* New upstream release.
* debian/control.in: fix libxklavier-dev dep libgnomekbd-dev
* debian/libgnomekbd7.symbols: update for changed symbols.
* New upstream release.
  + debian/libgnomekbd7.symbols: update for new and changed symbols.
  + debian/control.in: update build-depend on libxklavier.
* debian/control.in:
  - Rename gir1.2-gnomekbd-3.0 to gir1.2-gkbd-3.0, add C/R/P accordingly
  - Add Vcs-* fields
* debian/copyright: Fix copyright-with-old-dh-make-debian-copyright
  to please lintian
* debian/control.in:
  - Update for the new gtk+ package names.
* debian/control,debian/rules:
  + add gir1.2-gnomekbd-3.0
* debian/gir1.2-gnomekbd-3.0.install,libgnomekbd-dev.install
  + install gir and typelib
* debian/rules:
  + call dh_girepository
  + enable introspection support
* debian/control.in:
  + Improve the package description.
  + Drop obsolete dpkg-dev build dependency.
  + Don't use tabs for padding.
* debian/control.in,
  debian/rules:
  + Let CDBS call dh_girepository for us.
* New upstream release.
  + debian/patches/100_gdkwindow_patch.patch:
    - Removed, fixed upstream.
  + debian/control.in:
    - Bump libgtk3.0-dev requirement.
* debian/libgnomekbd7.symbols:
  + Add a symbols file.
* debian/rules:
  + Fail the build if the symbols file is outdated.
  + Always depend on the latest upstream version on the shlibs file.
+ debian/patches/100_gdkwindow_patch.patch:
  + Added. Fix build with gtk 2.91.6 (from git). Based on the ubuntu
    libgnomekbd package.
* debian/control.in: Bump build-depend on gtk to >= 2.91.6
* New upstream release.
  + Fixes build with latest gtk+3. Closes: 605896.
  + debian/patches/0001-Add-gio-to-the-required-pkg-config-modules.patch:
    - Removed, merged upstream.
  + debian/patches/01_requires_private.patch:
    - Updated.
* debian/rules: Add list-missing
* debian/libgnomekbd-common.install: Install schemas file
* (Closes: 606361) gnome-settings-daemon crashed with signal 5 in
* New upstream release
* debian/patches/10_null_style_crasher.patch
  + Removed, fixed upstream
* debian/patches/99_ltmain_as-needed.patch
  + Removed, use dh-autoreconf instead
* Bumped soname from 4 to 7
* debian/patches/0001-Add-gio-to-the-required-pkg-config-modules.patch
  + Added. Fix compilation with --as-needed
* 10_null_style_crasher.patch: stolen from upstream git. Fix a crasher
  when there is a font declared but no style. Closes: #589391.
* New upstream translation and bugfix release.
* Switch to 3.0 source format.
* 02_layout_crash.patch: dropped, merged upstream.

lp:~ubuntu-desktop/xchat-indicator/ubuntu bug Development 2014-11-12 17:22:57 UTC 2014-11-12
41. debian/patches/fix_toplevel_window.pa...

Author: Marc Deslauriers
Revision Date: 2014-11-12 17:22:57 UTC

debian/patches/fix_toplevel_window.patch: use accessor function
gtk_window_has_toplevel_focus() to be compatible with gtk3
xchat-gnome.

lp:~ubuntu-desktop/gimp/ubuntu bug Development 2014-11-12 13:26:16 UTC 2014-11-12
32. * Merge from Debian unstable. (LP: #1...

Author: Daniel Holbach
Revision Date: 2014-11-12 13:26:07 UTC

* Merge from Debian unstable. (LP: #1366560) Remaining changes:
  - debian/patches/02_help-message.patch,
    debian/patches/03_gimp.desktop.in.in.patch:
    + Update some strings for Ubuntu.
  - debian/rules:
    + Set gettext domain and update translation templates.
* Drop following patches, fixed upstream:
  - CVE-2013-1913.patch
  - CVE-2013-1978.patch
  - freetype-251.patch
* Imported Upstream version 2.8.14
  * Fixes segfault when removing tag from palette (Closes: #736625)
* Bump standards version to 3.9.6
* Fix missing backslash in debian/rules (Closes: #743596)
* Always build with lcms2 even if lcms1 is present (Closes: #743596)
* Enable parallel building (Closes: #750654)
* Add dh-autoreconf (Closes: #746713)
* Upgrade to lcms2 (Closes: #743596)
* Remove helpbrowser plugin; gimp will fall back to an external web
  browser if present (Closes: #639761)
* Imported Upstream version 2.8.10
* Build-depend on libtiff-dev instead of libtiff4-dev (Closes: #736006)
* debian/patches
  - add adjust_freetype_header.patch to fix FTBFS (Closes: #732010)
  - add CVE-2013-1913_and_gimp_CVE-2013-1978.patch to fix xwd security
    vulnerabilities CVE-2013-1913 and CVE-2013-1978
    (Closes: #731305)
* New upstream version
* debian/patches/lcms2.patch:
  - dropped, the new version has support for the new lcms
* debian/rules:
  - use --with-lcms=lcms2
* Build using lcms2.
* Build using dh-autoreconf.
* SECURITY UPDATE: denial of service and possible code execution via
  huge color maps in xwd plugin
  - debian/patches/CVE-2013-1913.patch: limit number of color map entries
    in plug-ins/common/file-xwd.c.
  - CVE-2013-1913
* SECURITY UPDATE: denial of service and possible code execution via
  large number of color map entries in xwd plugin
  - debian/patches/CVE-2013-1978.patch: validate number of color map
    entries in plug-ins/common/file-xwd.c
  - CVE-2013-1978
* debian/patches/freetype-251.patch: fix FTBFS with newer freetype.
* Synchronize with Debian (LP: #1207734). Remaining changes:
* Imported Upstream version 2.8.6
  - Fixes some single window closing behavior (Closes: #686345)
  - Fixes build error (Closes: #713674)
* Tighten dependency on gdk-pixbuf (Closes: #712616)
* Imported Upstream version 2.8.4
* xwd-corruption.patch:
  - Fix memory corruption bug when reading XWD files (Closes: #693977)
* Imported Upstream version 2.8.2
  - Fixes a security hole in the CEL plugin (Closes: #685397) (CVE-2012-3403)
  - Fixes a security hole in the GIF plugin (CVE-2012-3481)
  - Fixes link failures on on hurd-i386 (Closes: #677342)
  - Fixes incorrect window title after exporting (Closes: #673898)
* Don't overwrite LDFLAGS from dpkg-buildflags
* Use a shlibs.local file to force a dependency on libbabl >= 0.1.10.
  GIMP has an internal check for this version and will refuse to start
  otherwise, as it relies on some optimisations made to babl in
  0.1.8 → 0.1.10 (closes: #672247).
* Add Breaks/Replaces on old gimp-plugin-registry because of conflicting
  file-xmc plugin.
* New upstream stable release (closes: #644182, #671399).
  - “Create” menu item is now accessible via a mnemonic (closes: #610579).
  - fixes build error with GEGL 0.2 (closes: #671982).
* Massive update of Build-Depends, to ensure all new features are
  enabled (bzip2 compression, JPEG 2000, Ghostscript, PDF export, GUdev,
  X Mourse Cursor and others), as per configure.ac.
* Build depend on unversioned libpng-dev (closes: #662347).
* Don't pass --without-hal to configure, it's obsolete.
* Build-Depend on gnome-pkg-tools and include check-dist.mk.
* Update Vcs-* URLs.
* Remove duplicate Section fields.
* Remove gimp.preinst, it only handled upgrades from pre-lenny.
* Use an explicit "set -e" in other maint scripts, instead of using the
  shebang.
* Drop 01_debian_gimprc.patch, obsolete. The web-browser config option
  is now gone and by default gimp will open help internally.
* Rename fix_gimp4hurd.patch to 01_hurd_ftbfs.patch.
* Drop part of 01_hurd_ftbfs.patch which has been applied upstream, and
  add a patch header.
* Update watch file so it works for any new stable release directories.
* Rewrite copyright file in machine-readable format 1.0. The GIMP is now
  licensed under the (L)GPLv3+.
* Pass -- -V -c4 to dh_makeshlibs.
* Rename all .files files to .install, and stop calling dh_movefiles.
* Rename BUILDDIR to “builddir”, as “build” is now a real directory in
  the distribution.
* Add myself to Uploaders.
* Configure with --disable-static and stop distributing .a files.
* Update libgimp2.0.symbols.
* Build-Depend on GTK-2.0, GDK-Pixbuf and GLib -doc packages to ensure
  proper cross-reference links in generated gtk-doc API documentation.
* Bump Standards-Version to 3.9.3, with no further changes.
* Imported Upstream version 2.6.12
* Add ${misc:Depends} variables to packages that were missing it
* Call default versioned python binary instead of just /usr/bin/python
* Really add the patch this time (Closes: #651387)
* poppler0.18.patch: Port file-pdf plugin to poppler 0.18 API. Patch taken
  from Fedora via Ubuntu.
  (Closes: #651387)
* libpng_compile.patch:
    - Apply patch from upstream to fix compilation with libpng 1.5
      (Closes: #649972)
* Improve gimp package description (Closes: #178293, #588898)

lp:~ubuntu-desktop/gnome-media/ubuntu bug Development 2014-11-09 23:52:27 UTC 2014-11-09
82. Merge branch lp:~noskcaj/gnome-media/...

Author: Luke Yelavich
Revision Date: 2014-11-09 23:52:27 UTC

Merge branch lp:~noskcaj/gnome-media/merge

lp:~ubuntu-desktop/evolution-data-server/ubuntu-trusty bug Development 2014-10-17 10:29:32 UTC 2014-10-17
229. releasing package evolution-data-serv...

Author: Iain Lane
Revision Date: 2014-10-17 09:26:44 UTC

releasing package evolution-data-server version 3.10.4-0ubuntu1.4

lp:~ubuntu-desktop/gucharmap/ubuntu bug Development 2014-10-12 08:28:36 UTC 2014-10-12
56. * Use dh_autoreconf to update libtool...

Author: Daniel Holbach
Revision Date: 2014-10-12 08:28:36 UTC

* Use dh_autoreconf to update libtool.m4 for new ports, and build with
  --as-needed to obsolete debian/patches/99_ltmain_as-needed.patch. Thanks
  to Colin Watson in Ubuntu.
* New upstream release.
* New upstream development release.
  - include support for unicode 7.0 (Closes: #759233)
* Add build-dependency on appdata-tools for appdata file validation
* New upstream release.
* Bump valac build-dependency to a version with fixed Atk bindings.
  - valac (>= 0.24.0-2~) avoids FTFS, see #746049.
* Bump Standards-Version to 3.9.5
* New upstream release.
* Install appdata files in gucharmap package.
* Now that debian has a newer unicode-data:
  - Bump unicode-data build-dependency to >= 6.2 (Closes: #736623)
  - Drop debian/patches/revert-unicode-6.2.patch
* New upstream release
* Drop debian/patches/10_perl_5_18.patch, merged upstream.
* debian/control.in:
  - Update homepage
  - Don't build-depend on scrollkeeper
* Add debian/patches/revert-unicode-6.2.patch (Closes: #714297)
  Thanks to everyone working together in the bug report to find
  the solution to this problem!
* Change unicode-data build-dependency to be (<< 6.2)
  - We should drop this and the above patch once unicode-data is updated.
* debian/patches/10_perl_5_18.patch:
  + Fix FTBFS with perl 5.18. Thanks to Roderich Schupp. Closes: #710038.
* Team upload.
* New upstream release.
* Add build-dependency on autotools-dev to let CDBS take care of
  "outdated-autotools-helper-file".
* Bump Standards-Version to 3.9.4
* Update build-dependencies according to configure.ac changes:
  - Bump gobject-introspection from (>= 0.9.0) to (>= 1.0.0).
  - Bump libgtk-3-dev from (>= 3.0.0) to (>= 3.4.0).
  - Bump libglib2.0-dev from (>= 2.25.5) to (>= 2.32.0).
  - Add desktop-file-utils needed for desktop-file-validate
* Upstream switched from gnome-doc-utils to yelp-tools.
  - Update build-dependencies accordingly
  - Update debian/gucharmap.install for new help files path
* Refresh debian/patches/99_ltmain_as-needed.patch to apply.
* Update debian/libgucharmap-2-90-7.symbols:
  - added one symbol: gucharmap_get_resource@Base
* Enable vala bindings:
  - Add valac (>= 0.16) needed for vapigen.
  - Add configure option --enable-vala in debian/rules
  - Install vapi files in libgucharmap-2-90-dev
* Non-maintainer upload.
* Rebuild to use xz compression for all binaries, saving space on CD#1
  (Closes: #687297).
* debian/patches/unicode-source-generation.patch: compatibility with
  the unicode-data package.
* debian/rules, debian/clean, debian/control: build-depend on unicode-data
  and generate our unicode header files at package build time, to ensure
  that we actually can. Closes: #603405.
* Use a stamp file to avoid running gen-guch-unicode-tables.pl twice.
* Point Vcs-* to unstable branch.
* Drop explicit Build-Depends on gir1.2-pango-1.0 and gir1.2-gtk-3.0.
* Drop debian/patches/spelling_fixes.patch since we re-generate
  gucharmap/unicode-*.h during build, so patching the pre-generated file is
  pointless. This spelling fix needs to go into unicode-data. (See #677896)
* New upstream translation release.
* New upstream release.
* debian/watch: Track stable releases (again).
* debian/patches/00git_fix_pkg_config.patch: Removed, merged upstream.
* debian/libgucharmap-2-90-7.symbols: Add new symbols.

lp:~ubuntu-desktop/evince/313 bug(Has a merge proposal) Development 2014-09-10 14:34:40 UTC 2014-09-10
252. * debian/control: - drop libsm buil...

Author: Sebastien Bacher
Revision Date: 2014-09-10 14:34:40 UTC

* debian/control:
  - drop libsm build-depends, that has been deprecated upstream
  - build-depends on libgnome-desktop-3-dev
  - updated gtk requirement
* debian/rules:
  - disable libgnome support in the gtk build

lp:~ubuntu-desktop/pangomm/ubuntu bug Development 2014-09-01 10:27:00 UTC 2014-09-01
15. * Non-maintainer upload. * Use dh-aut...

Author: Daniel Holbach
Revision Date: 2014-09-01 10:27:00 UTC

* Non-maintainer upload.
* Use dh-autoreconf to fix FTBFS on ppc64el. Closes: #752179
* New upstream release.
* Bump required version of libglibmm-2.4-dev to (>= 2.36.0).
* Drop obsolete DM-Upload-Allowed field.
* Update Vcs-* URLs.
* Update debian/copyright, use final copyright-format 1.0 spec.
* Bump Standards-Version to 3.9.4. No further changes.
* Add Build-Depends on autotools-dev as lintian was complaining about
  outdated config.{guess,sub}.
* Drop obsolete Conflicts/Replaces.
* Convert to multiarch.
* Bump debhelper compatibility level to 9.
* New upstream release.
* debian/watch:
  - Track .xz tarballs.
* Bump debhelper compatibility level to 8.
  - Bump Standards-Version to 3.9.2. No further changes.
  - Set pkg-gnome-maintainers@lists.alioth.debian.org as Maintainer.
* Stop installing libtool .la files.
* debian/watch:
  + Fix RegEx to work again.
* New upstream release:
  - Ship convert_pangomm.m4 in tarballs.
  - Don't use obsolete autotools macros.
* debian/control.in,
  debian/rules:
  + Remove the chrpath hack, it's been fixed in libtool.
* New upstream release.
* New upstream bugfix release.
  + debian/control.in:
    + Add mm-common >= 0.9.5 as builddep as per configure.ac.
  + debian/rules:
    + Update SHVER to 2.27.1 due to new API.
* Convert to source format 3.0 (quilt)
  + debian/rules:
    + Drop simple-patchsys.mk.
  + debian/watch:
    + Track *.tar.bz2 instead of *.tar.gz
* debian/control.in:
  + Update Standards-Version to 3.9.1.

lp:~ubuntu-desktop/gtkmm/ubuntu bug Development 2014-09-01 07:44:14 UTC 2014-09-01
19. * Non-maintainer upload. * Use dh-aut...

Author: Daniel Holbach
Revision Date: 2014-09-01 07:44:14 UTC

* Non-maintainer upload.
* Use dh-autoreconf to fix FTBFS on ppc64el.
* New upstream release.
* New upstream release.
* Update watch file to track .xz tarballs. (Closes: #706507)
* Drop obsolete DM-Upload-Allowed field.
* Stop installing libtool .la files.
* Update Vcs-* URLs.
* Drop obsolete Conflicts/Replaces.
* Update Build-Depends and Depends of libgtkmm-2.4-dev.
* Update debian/copyright for the final copyright-format 1.0 spec.
* Bump debhelper compatibility level to 9.
* Convert to multiarch. (Closes: #651776)
* Bump Standards-Version to 3.9.4.
* Add Build-Depends on autotools-dev for up-to-date config.{guess,sub}.
* New upstream release.
  + Remove all patches. Fixed upstream.
  + Drop mm-common as build-dep. Not needed anymore.
* Refine package descriptions. (Closes: #624356)
* New upstream release.
  - Fixes incompatibility with GTK+ 2.24+. (Closes: #621063)
* debian/rules:
  Update SHVER to 1:2.24.0 because of new API.
* debian/control.in:
  - Bump build dependency on libgtk2.0-dev, libpangomm-1.4-dev
    and libatkmm-1.6-dev.
* debian/control.in:
  - Update Standards-Version to 3.9.2. No changes needed.
* debian/watch:
  - Track gtkmm 2.x instead of 3.
  - Track *.tar.bz2 instead of *.tar.gz.
* debian/README.Debian:
  - Add notes about atkmm split.
* debian/patches/{aclocal.m4.patch,configure.ac.patch,relibtoolize.patch}:
  - Fix building against glibmm 2.28.
* debian/control.in:
  - Build depends on mm-common >= 0.9.3.
  - Bump build dependency of libglibmm-2.4-dev to >= 2.27.93
* New upstream release (Closes: #606407)
* upstream no longer installs examples in /usr/share/gtkmm-2.4
  so install them into libgtkmm-2.4-doc package instead.
* debian/control.in:
  - Bump build dependency on libgtk2.0-dev.
  - Remove build dependency on chrpath.
* debian/rules:
  - Remove chrpath call, it's not needed anymore with newer libtools.
  - Don't compress the examples.
* debian/source/format,
  debian/rules:
  - Switch to source format 3.0 (quilt).
* New upstream bugfix release.

lp:~ubuntu-desktop/libdmapsharing/ubuntu bug Development 2014-08-25 10:04:01 UTC 2014-08-25
13. * New bugfix upstream release. * New ...

Author: Daniel Holbach
Revision Date: 2014-08-25 10:04:01 UTC

* New bugfix upstream release.
* New upstream release.
* New upstream bugfix release.
* Build using dh-autoreconf.
* New upstream release.
* Update symbols file.
* New upstream release.
* Update symbols file.
* New upstream release.
* debian/control.in:
  - Updated Vcs-Svn.
  - Bump Standards-Version to 3.9.4.
  - Updated build and '-dev' dependencies from libgstreamer0.10 to
    libgstreamer1.0 according to configure.ac.
* Remove duplicate Section fields.
* Bump to debhelper v9.
* Use the list-missing rule.
* Pass -c4 to dpkg-gensymbols.
* New upstream release.
* Bump Standards-Version to 3.9.3.
* New upstream release.
* New upstream release.
* New upstream version.
* debian/control.in:
  - Bumped Standards-Version to 3.9.2 (no change needed)
* debian/rules
  - Explicitly use the .tar.gz archive as upstream did not switch to .bz2 yet
* debian/control.in
  - Added homepage
* Bump debhelper compatibility level to 8.
  - Update Build-Depends on debhelper.
  - Strip debian/tmp/ from .install files.
* debian/control.in: Update Vcs-* fields.
* debian/libdmapsharing-3.0-2.symbols: Add symbols file for improved shlibs
  dependency tracking.
* Initial release. (Closes: #620060)

lp:~ubuntu-desktop/libgtop/ubuntu bug Development 2014-08-18 22:54:46 UTC 2014-08-18
15. * New upstream release - Increases ...

Author: Robert Ancell
Revision Date: 2014-08-18 22:54:46 UTC

* New upstream release
  - Increases maximum CPU limit (LP: #1210280)
* debian/control:
* debian/rules:
* debian/libgtop2-10.install
* debian/libgtop2-10.symbols
  - Update soname
* debian/patches/06_kfreebsd_sys_pipe.patch:
  - Applied upstream

lp:~ubuntu-desktop/gnome-control-center/precise Development 2014-08-06 23:24:59 UTC 2014-08-06
478. sound: fix potential memory corruptio...

Author: Madper Xie
Revision Date: 2014-07-07 09:57:30 UTC

sound: fix potential memory corruption (LP: #1236612)

lp:~ubuntu-desktop/evolution/ubuntu-trusty bug Development 2014-08-04 08:00:20 UTC 2014-08-04
352. releasing package evolution version 3...

Author: Iain Lane
Revision Date: 2014-08-04 08:00:20 UTC

releasing package evolution version 3.10.4-0ubuntu2

lp:~ubuntu-desktop/sane-backends/ubuntu bug Development 2014-06-20 14:14:38 UTC 2014-06-20
27. Update changelog

Author: Iain Lane
Revision Date: 2014-06-20 14:14:38 UTC

Update changelog

lp:~ubuntu-desktop/gnome-settings-daemon/trusty Development 2014-06-18 09:26:27 UTC 2014-06-18
472. releasing package gnome-settings-daem...

Author: Sebastien Bacher
Revision Date: 2014-06-18 09:26:27 UTC

releasing package gnome-settings-daemon version 3.8.6.1-0ubuntu11.2

lp:~ubuntu-desktop/zenity/ubuntu Development 2014-06-16 12:47:34 UTC 2014-06-16
3. * Update homepage * New upstream rele...

Author: Daniel Holbach
Revision Date: 2014-06-16 12:47:34 UTC

* Update homepage
* New upstream release. (Closes: #740361)
  - Return correct exit code when --timeout is used (Closes: #646304)
  - Do not return item twice when double clicking in a list (Closes: #717053)
  - Expand lists vertically (Closes: #739248)
* debian/control.in: Bump Standards-Version to 3.9.5 (no further changes)
* Drop d/p/01_dont_quit_zenity_when_stdin_ends.patch: This patch is changing
  the upstream behavior when using --listen flag (Closes: #612683)
* New upstream release.
* Bump Standards-Version to 3.9.4. No further changes.
* Refresh 01_dont_quit_zenity_when_stdin_ends.patch.
* Remove 02_fix_segfault_in_listview.patch, merged upstream.
* Switch Build-Depends on gnome-doc-utils to yelp-tools.
* The Mallard documentation system uses different paths then
  gnome-doc-utils. Update the zenity-common.install file accordingly.
* Mark zenity as Multi-Arch: foreign (thanks, Stéphane Graber).
* debian/patches/02_fix_segfault_in_listview.patch: Fix segfault when using
  --list option. Patch cherry-picked from upstream Git. Closes: #668292
* Set pkg-gnome-maintainers@lists.alioth.debian.org as Maintainer.
* New upstream release.
* Drop obsolete Breaks/Replaces.
* Watch for xz tarballs.
* Update Vcs-* URLs.
* Update debhelper to v9.
* Bump Standards-Version to 3.9.3, with no further changes.
* Drop omf dir, documentation is now in Mallard format.
* Drop Build-Depends on docbook-xml.
* Add --list-missing to DEB_DH_INSTALL_ARGS.
* New upstream release.
* Add Build-Depends on libwebkitgtk-3.0-dev (>= 1.4.0) for HTML support.
* debian/watch: Track .bz2 tarballs.
* debian/control.in: Bump Standards-Version to 3.9.2. No further changes.
* Upload to unstable.
* New upstream release.
* New upstream release.
* debian/control.in:
  + Update for the new gtk+ 3 package names.
* New upstream release.
  - Bump Build-dependencies
  - Drop libnotify-dev-gtk2.10 build-dependency
  - Add zenity-common package
  - Bump Standards-Version to 3.9.1 (no further changes)
  - Bump debhelper version
  - Use Breaks instead of Conflicts
  - Add Homepage field
  - Add Vcs-* field
* Switch to dpkg-source 3.0 (quilt) format
* debian/watch: Bump version to 3
* debian/zenity.install, zenity-common.install:
  - Move all arch independent files to zenity-common
* debian/rules: Remove unneeded stuff
* New upstream release.
* debian/control.in:
  - really don't B-D on scrollkeeper anymore.
* debian/patches/01_focus_windows.patch:
  - Removed, it's empty.
* debian/patches/01_dont_quit_zenity_when_stdin_ends.patch:
  - Don't quit zenity when listening on stdin and the stream ends.
    Closes: #506425.
* debian/rules:
  - Include simple-patchsys.mk.
* debian/control.in:
  - Standards-Version is 3.8.4, no changes needed.
  - Move Uploaders right after Maintainer.
  - Build depend on docbook-xml, needed to build the documentation.
* debian/docs:
  - Removed, NEWS and README are installed automatically.

lp:~ubuntu-desktop/gtk/312 Development 2014-06-10 10:00:11 UTC 2014-06-10
348. Remove broadway symbols, we don't ena...

Author: Iain Lane
Revision Date: 2014-06-10 10:00:11 UTC

Remove broadway symbols, we don't enable this backend in Ubuntu.

lp:~ubuntu-desktop/gnome-terminal/ubuntu-current Development 2014-05-07 10:27:46 UTC 2014-05-07
119. Update Vcs-Bzr to point to current br...

Author: Iain Lane
Revision Date: 2014-05-07 10:27:30 UTC

Update Vcs-Bzr to point to current branch (trunk is staging a new series)

lp:~ubuntu-desktop/gtk/gtk3precise Development 2014-03-26 12:32:35 UTC 2014-03-26
205. releasing package gtk+3.0 version 3.4...

Author: Sebastien Bacher
Revision Date: 2014-03-26 12:32:35 UTC

releasing package gtk+3.0 version 3.4.2-0ubuntu0.8

lp:~ubuntu-desktop/evolution-indicator/ubuntu bug Development 2014-02-17 14:49:46 UTC 2014-02-17
105. releasing package evolution-indicator...

Author: Sebastien Bacher
Revision Date: 2014-02-17 14:49:46 UTC

releasing package evolution-indicator version 0.2.20-0ubuntu15

lp:~ubuntu-desktop/gnome-settings-daemon/unity bug Development 2014-02-07 10:42:17 UTC 2014-02-07
4009. Update upstart script with xnox magic

Author: Robert Ancell
Revision Date: 2014-02-07 10:42:17 UTC

Update upstart script with xnox magic

lp:~ubuntu-desktop/unity-control-center/trunk Development 2014-01-31 10:50:22 UTC 2014-01-31
12698. releasing package unity-control-cente...

Author: Sebastien Bacher
Revision Date: 2014-01-31 10:50:22 UTC

releasing package unity-control-center version 14.04.1-0ubuntu4

lp:~ubuntu-desktop/gnome-system-tools/ubuntu bug Development 2014-01-31 07:10:27 UTC 2014-01-31
73. releasing package gnome-system-tools ...

Author: Martin Pitt
Revision Date: 2014-01-31 07:10:27 UTC

releasing package gnome-system-tools version 3.0.0-3ubuntu2

1100 of 319 results