lp:~ubuntu-desktop/gnome-desktop/ubuntu

Created by Sebastien Bacher on 2009-03-19 and last modified on 2018-07-24
Get this branch:
bzr branch lp:~ubuntu-desktop/gnome-desktop/ubuntu
Members of Ubuntu Desktop can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu Desktop
Project:
gnome-desktop
Status:
Development

Recent revisions

83. By Jeremy Bicha on 2017-09-14

releasing package gnome-desktop3 version 3.26.0-0ubuntu1

82. By Jeremy Bicha on 2017-09-14

New upstream release

81. By Iain Lane on 2017-09-04

releasing package gnome-desktop3 version 3.25.91.1-0ubuntu2

80. By Jeremy Bicha on 2016-09-11

releasing package gnome-desktop3 version 3.20.2-1ubuntu1

79. By Jeremy Bicha on 2016-05-14

* Resynchronize on Debian, remaining changes
  - debian/patches:
    + 04_compute_average_color.patch: Compute the avergage color in
      gnome-desktop itself, not in unity to fix some races (LP #963140)
    + tweak_color_computation.patch, Patch from Gord, no patch header,
      no bug link.
    + git_revert_draw_background.patch
    + ubuntu_language.patch, Ported relevant bits from g-c-c
      52_region_language.patch, as required for gnome 3.8 region panel
    + ubuntu_language_list_from_SUPPORTED.patch,
      adds api to get list of available languages from SUPPORTED file.
      To be used by gnome 3.8 region panel language installation.
    + gnomebg_hidpi_image.patch,
      gnome_bg_create_surface: always honor device scale, that fixes
      the wallpaper rendering in hidpi config under ubiquity (lp: #1382291)
  - debian/libgnome-desktop-3-12.symbols:
    + Add symbols included in Ubuntu patches
  - debian/control.in:
    + Mark gnome-desktop3-data Multi-Arch: foreign
* debian/rules: Pass --disable-date-in-gnome-version to the configure to
  make the build reproducible (Closes: #784318)
* New upstream release.
* Merge with Debian (LP: #1510813), Remaining changes:
  - debian/patches:
    + 04_compute_average_color.patch: Compute the avergage color in
      gnome-desktop itself, not in unity to fix some races (LP #963140)
    + tweak_color_computation.patch, Patch from Gord, no patch header,
      no bug link.
    + git_revert_draw_background.patch
    + ubuntu_language.patch, Ported relevant bits from g-c-c
      52_region_language.patch, as required for gnome 3.8 region panel
    + ubuntu_language_list_from_SUPPORTED.patch,
      adds api to get list of available languages from SUPPORTED file.
      To be used by gnome 3.8 region panel language installation.
    + gnomebg_hidpi_image.patch,
      gnome_bg_create_surface: always honor device scale, that fixes
      the wallpaper rendering in hidpi config under ubiquity (lp: #1382291)
  - debian/libgnome-desktop-3-12.symbols:
    + Add symbols included in Ubuntu patches
  - debian/control.in:
    + Mark gnome-desktop3-data Multi-Arch: foreign
* libgnome-desktop-3-12: Add Breaks: libgnome-desktop-3-10
  - Forces a full upgrade. This is to prevent applications linking to
    and using both at the same time (which leads to crashed). That
    happens in eg. gdm3 built against libgnome-desktop-3-10 when using
    gir1.2-gnomedesktop-3.0 3.18.0-1 (built against
    libgnome-desktop-3-12). (Closes: #801603)
* Upload to unstable.
* Drop debian/patches/git_update-swedish-translation.patch and
  debian/patches/auto_regenerated_sv_indexdocbook.patch, merged upstream.
* Bump Build-Depends on libglib2.0-dev to (>= 2.44.0) as per configure.ac.
* debian/rules, debian/libgnome-desktop-3-12.install:
  - fix soname-like numbers in pkg/path names to have gnome-rr-debug
    installed in expected libexec path, as spotted by Matteo F. Vescovi.
* Add debian/patches/git_update-swedish-translation.patch
  - from upstream git, fixes swedish GFDL translation.
    Thanks to Anders Jonsson.
* Add debian/patches/auto_regenerated_sv_indexdocbook.patch
  - this is the autogenerated result from the above patch,
    only added to please lintian. Should be dropped as soon as
    the above patch is part of the released tarball.
* The source is now clean, but lintian still complains about the
  patches.... add overrides in debian/source/lintian-overrides
  This file should also be dropped once the above patches are...
* New upstream release.
* New upstream release candidante.
* Rename libgnome-desktop-3-10 package to libgnome-desktop-3-12.
* Update libgnome-desktop-3-12.symbols
* debian/patches/ubuntu_language_list_from_SUPPORTED.patch: don't
  strip the territory code from languages returned by
  gnome_get_all_languages() (LP: #1479907)
* Merge with Debian (LP: #1468941), Remaining changes:
  - debian/patches:
    + 04_compute_average_color.patch: Compute the avergage color in
      gnome-desktop itself, not in unity to fix some races (LP #963140)
    + tweak_color_computation.patch, Patch from Gord, no patch header,
      no bug link.
    + git_revert_draw_background.patch
    + ubuntu_language.patch, Ported relevant bits from g-c-c
      52_region_language.patch, as required for gnome 3.8 region panel
    + ubuntu_language_list_from_SUPPORTED.patch,
      adds api to get list of available languages from SUPPORTED file.
      To be used by gnome 3.8 region panel language installation.
    + gnomebg_hidpi_image.patch,
      gnome_bg_create_surface: always honor device scale, that fixes
      the wallpaper rendering in hidpi config under ubiquity (lp: #1382291)
  - debian/libgnome-desktop-3-10.symbols:
    + Add symbols included in Ubuntu patches
  - debian/control.in:
    + Mark gnome-desktop3-data Multi-Arch: foreign
* debian/patches/ubuntu_language.patch:
  - Show possible locale modifier in formats list (LP: #1440275).
* Add missing trailing slash to DEB_CONFIGURE_EXTRA_FLAGS arguments.
* New upstream release.
* Remove debian/patches/realpath-PATH_MAX.patch, upstream dropped the
  libgsystem dependency.
* Drop obsolete Breaks/Replaces from pre-wheezy.
* Drop explicit Build-Depends on dpkg-dev, even the version from wheezy
  provides dpkg-vendor.
* Convert to multiarch. This includes moving the gnome-rr-debug tool into an
  architecture qualified path.
* Bump debhelper compatibility level to 9.
* Bump Standards-Version to 3.9.6.
* Update debian/copyright. Change shortname from 'MIT/X11 (BSD like)' to
  Expat to comply with the spec.
* debian/patches/ubuntu_language.patch:
  - Drop modification of collect_locales() in gnome-languages.c
    (LP: #1440275).
* debian/patches/gnomebg_hidpi_image.patch:
  - gnome_bg_create_surface: always honor device scale, that fixes
    the wallpaper rendering in hidpi config under ubiquity,
    thanks Lars Uebernickel (lp: #1382291)
* Merge with Debian, Remaining changes:
  - debian/patches:
    + 04_compute_average_color.patch: Compute the avergage color in
      gnome-desktop itself, not in unity to fix some races (LP #963140)
    + tweak_color_computation.patch, Patch from Gord, no patch header,
      no bug link.
    + git_revert_draw_background.patch
    + ubuntu_language.patch, Ported relevant bits from g-c-c
      52_region_language.patch, as required for gnome 3.8 region panel
    + ubuntu_language_list_from_SUPPORTED.patch,
      adds api to get list of available languages from SUPPORTED file.
      To be used by gnome 3.8 region panel language installation.
  - debian/libgnome-desktop-3-10.symbols:
    + Add symbols included in Ubuntu patches
  - debian/control.in:
    + Mark gnome-desktop3-data Multi-Arch: foreign
* debian/rules: Drop obsolete scrollkeeper configure flag
* New upstream release
* debian/watch: only search for stable releases.
* New upstream release.
* Upload to unstable.
* New upstream development release.
* debian/libgnome-desktop-3-10.symbols:
  Add new symbol gnome_wall_clock_string_for_datetime@Base 3.13.91
* New upstream release (LP: #1372346)
* Merge with Debian, Remaining changes:
  - debian/patches:
    + 04_compute_average_color.patch: Compute the avergage color in
      gnome-desktop itself, not in unity to fix some races (LP #963140)
    + tweak_color_computation.patch, Patch from Gord, no patch header,
      no bug link.
    + git_revert_draw_background.patch
    + ubuntu_language.patch, Ported relevant bits from g-c-c
      52_region_language.patch, as required for gnome 3.8 region panel
    + ubuntu_language_list_from_SUPPORTED.patch,
      adds api to get list of available languages from SUPPORTED file.
      To be used by gnome 3.8 region panel language installation.
  - debian/rules:
    + drop obsolete --disable-scrollkeeper configure flag
  - debian/libgnome-desktop-3-10.symbols:
    + Add symbols included in Ubuntu patches
  - debian/control.in:
    + Mark gnome-desktop3-data Multi-Arch: foreign
* Dropped changes:
  - 02_refuse_to_break_GL_compositors.patch:
    + xrandr code has moved into libunity-settings-daemon now
* Add debian/patches/realpath-PATH_MAX.patch (from upstream libgsystem)
  - avoids PATH_MAX to hopefully fix FTBFS on Hurd.
* New upstream release.
* Bump Standards-Version to 3.9.5
* Upload to unstable.
* Drop conflicts against libgnome-desktop-3-7 because it is not
  necessary: only leaf packages in G3.8 use gnome-desktop, including
  gnome-shell that does work with the new g-desktop library.
* New upstream bugfix release.
* New upstream release.
* New upstream release.
* Rename packages to match new soname.
* Drop build-dependency on libxkbfile-dev, not needed anymore.
* Update symbols file for new soname.
* Drop empty debian/patches/
* Break libgnome-desktop-3-8 for the same reason as libgnome-desktop-3-7.
* Make libgnome-desktop-3-8 break libgnome-desktop-3-7. Mixing both on one
  system is a recipe for disaster when using gnome-desktop via
  gobject-introspection.
* New upstream release
* Sync with Ubuntu, bumped soname
* Upload to unstable.
* Remove obsolete build dependency on gnome-doc-utils.
* New upstream release.
  - Prevent a crash with unknown language/country codes (Closes: #692453)
* debian/control.in: Bump Standards-Version to 3.9.4 (no further changes)
* debian/patches/backlight-property-name.patch:
  - Use the corrent backlight property name as specified in the XRANDR spec
    (LP: #947919)
* debian/patches/ignore_errors_with_primary_outputs.patch:
  - Ignore failures when setting the primary output (LP: 1224254).
* New upstream bugfix release
  - Initialize gettext before constructing a wall clock
  - Update pnp.ids from upstream hwdata
  - Fix crash when XRRSetCrtcConfig() fails
  - Prevent a crash with unknown language/country codes
  - Ensure strings from xkeyboard-config are UTF-8
  - Translation updates
* Remove obsolete build dependency on scrollkeeper.
* New upstream release.
* New upstream release
* debian/control.in:
  - Drop obsolete gnome-doc-utils and scrollkeeper build dependencies
* debian/patches/git_no_filename_warning.patch:
  - "gnome-bg: objects without a filename are not slideshows",
    that should fix the warnings that are displayed by the appareance
    capplet on start (which are due to solid color backgrounds)
* New upstream release
* Sync with Debian (LP: #1184812) Remaining changes:
  - debian/patches:
    + 04_compute_average_color.patch: Compute the avergage color in
      gnome-desktop itself, not in unity to fix some races (LP #963140)
    + tweak_color_computation.patch, Patch from Gord, no patch header,
      no bug link.
    + git_revert_draw_background.patch
    + ubuntu_language.patch, Ported relevant bits from g-c-c
      52_region_language.patch, as required for gnome 3.8 region panel
    + ubuntu_language_list_from_SUPPORTED.patch,
      adds api to get list of available languages from SUPPORTED file.
      To be used by gnome 3.8 region panel language installation.
  - debian/control.in:
    + Don't break gnome-shell << 3.7.90
    + Use source:Version for gnome-desktop3-data Depend
    + Add epoch to gnome-desktop3-data's Breaks/Replaces, as our old
      gnome-desktop source package introduced an epoch. This needs to be
      kept until after 14.04 LTS.
 - Install helper tools into a versioned directory (by overriding
   libexecdir). They could alternatively be installed in a separate package
* Dropped changes:
  - 02_refuse_to_break_GL_compositors.patch:
    + Doesn't appear to be needed any more
* debian/libgnome-desktop-3-7.symbols:
  + Add Build-Depends-Package.
* New upstream release.
* New upstream release.
* New upstream release.
* New upstream release
  - soname bump, update symbols
* debian/control.in:
  - Build-depend on libgl1-mesa-dev and iso-codes
  - Bump minimum glib
* debian/control.in:
  + Add missing replaces on libgnome-desktop-3-4.
  + gir1.2-gnomedesktop-3.0 breaks gnome-shell (<< 3.7.90),
    as it loads libgnome-desktop-3.so.7 while old gnome-shell
    loads the old SONAME, making shell explode.
* New upstream release.
  + debian/libgnome-desktop-3-7.symbols:
    - Updated for removed symbols.
* debian/control.in: Temporarily loosen the depend on the data package so the
  library can be parallel installed with the G3.4 version
* New upstream release
* Add missing epoch on libxrandr build-dependency.
* New upstream release (3.6.0.1)
* Soname bumped to 4
* Team upload.
* Add missing epoch on libxrandr build-dependency.
* debian/control.in:
  + Loosen libgnome-desktop-3-2 dependency on gnome-desktop3-data
    so that the former can be coinstalled with other sonames of
    the library. Closes: #704177.
* Add patch from upstream 3.5.3 to sync thumbnail location with GLib
  2.34+ (~/.cache/thumbnails instead of ~/.thumbnails), preventing
  infinite loops in which Nautilus will generate thumbnails of thumbnails.
  Closes: #708185.
  + Explicitly (build-)depend on GLib 2.34+ to make sure the system is
    consistent
  + Thumbnails are now in a well-known cache directory (Closes: #637049)
* New upstream release.
* Upload to unstable.
* New upstream translation release.
* New upstream release.
* debian/patches/01-clock_gettime.patch: Removed, merged upstream.
* Bump (Build-)Depends on libgtk-3-dev to (>= 3.3.6).
* Bump Build-Depends on libxrandr-dev to (>= 1.3).
* debian/libgnome-desktop-3-2.symbols: Add new symbols and remove
  gnome_rr_crtc_set_config. None of the reverse dependencies uses that
  function so this should be safe without a soname bump.
* Build system-wide help documents and install them in gnome-desktop3-data.
* Add the necessary Breaks/Replaces against gnome-desktop-data (<< 2.32.1-2)
  which previously shipped those files.
* Build gtk-doc API documentation.
* debian/patches/01-clock_gettime.patch: Link libgnome-desktop against librt
  for clock_gettime().
* Update debian/copyright using the machine-readable copyright format 1.0.
* Bump Standards-Version to 3.9.3.
* Set <email address hidden> as Maintainer.
* Upload to unstable.
* debian/control.in:
  - Tighten dependency on gnome-desktop3-data again.
  - Change section of gir1.2-gnomedesktop-3.0 to introspection.
* debian/control.in:
  - Loosen the dependency on gnome-desktop-data for now such that
    libgnome-desktop-3-2 is installable in parallel with
    libgnome-desktop-3-0
* New upstream release.
  - Link against -lm for sqrt. Closes: #640437
* debian/watch:
  - Update to version 3.
  - Track .xz tarballs.
* debian/control.in:
  - Use Section: libs for gir1.2-gnomedesktop-3.0.
  - Drop (Build-)Depends on libstartup-notification0-dev.
  - Add Build-Depends on libxext-dev.
  - Update Vcs-* URLs.
  - Bump Build-Depends on intltool to (>= 0.40.6).
* debian/rules:
  - List missing files.
  - Include utils.mk for list-missing.
  - Drop clean-la.mk since we don't install any .la files.
* debian/libgnome-desktop-3-dev.install:
  - Remove .a file, static libraries are no longer built by default.
* Update libgnome-desktop-3 library package for the SONAME bump 0 → 2.
* Upload to unstable.
* Bump debhelper compatibility level to 8.
* debian/watch: Switch to .bz2 tarballs.
* debian/{rules,control.in,libgnome-desktop-3-dev,
  gir1.2-gnomedesktop-3.0.install}:
  - enable introspection build and add required files
* New upstream version
* libgnome-desktop-3-0.symbols: add Build-Depends-Package to generate
  stricter build-deps
* New upstream version
* New upstream release.
* New upstream release.
* New upstream release.
* Add missing dependency on gnome-desktop3-data.
* debian/control.in: update dependency on gsettings-desktop-schemas.
* debian/rules: disable introspection support at the moment.
* debian/rules: use dpkg-vendor to set the distributor
* New upstream release.
* debian/control.in:
  - Update for the new gtk+ package names.
* New upstream release.
  + debian/control.in,
    debian/rules,
    debian/gnome-about.install:
    - gnome-about is gone, drop every reference to it.
  + debian/patches/00git_no_GDK_DRAWABLE.patch,
    debian/patches/00git_no_GDK_WINDOW_TYPE.patch,
    debian/patches/00git_no_gdk_x11_drawable_get_xid.patch:
    - Dropped, fixed upstream.
  + debian/libgnome-desktop-3-0.symbols:
    - Updated.
  + debian/control.in:
    - Depend / Build-Depend on gsettings-desktop-schemas(-dev) >= 0.1.4
      for org.gnome.desktop.thumbnailers.
    - Bump libgtk3.0-dev build dependency.
  + debian/rules,
    debian/gnome-desktop3-data.install:
    - gnome-version.xml is back. Install it and build with
      --with-gnome-distributor=Debian again.
* debian/control.in: updated the dpkg-dev build-depends
* debian/rules:
  - use dpkg-vendor to set the distributor
* Merge patches to build against new GTK+ from the ubuntu packaging
  (originally from git)
* Update debian build-depend to >= 2.91.6
* debian/control.in:
  - Let libgnome-desktop-3-dev depend on
    gsettings-desktop-schemas-dev.
* debian/rules:
  - Fail the build if the .symbols file is not updated.
* debian/libgnome-desktop-3-0.symbols:
  - Updated.
* New upstream version
* Rename the source for the GNOME3 version since they are abi incompatible
* debian/control.in:
  - build-depends on gsettings-desktop-schemas-dev
  - clean some old conflicts and replaces
  - depends on gsettings-desktop-schemas
  - don't build the gnome-about binary from this version
  - updated description
  - updated for the source and binaries renaming
  - updated the build-depends and depends
* Updated the .install for the new version
* debian/patches/99_ltmain_as-needed.patch:
  - refreshed
* debian/libgnome-desktop-3-0.symbols:
  - use a .symbols rather than shlibs
* debian/rules:
  - dropped shlibs update since .symbols are used
  - updated to the new library name
  - use quilt as a patch system
  - use --disable-gnome-about --disable-desktop-docs to avoid conflicting
    with the gtk2 version
* New upstream release

78. By Martin Pitt on 2012-05-03

releasing version 1:2.32.1-2ubuntu1

77. By Martin Pitt on 2012-05-03

merge with Debian unstable

76. By Matthias Klose on 2011-12-17

gnome-desktop (1:2.32.1-0ubuntu8) precise; urgency=low

  * Build using dh_python2

 -- Matthias Klose <email address hidden> Sat, 17 Dec 2011 15:50:02 +0000

75. By Loïc Minier on 2011-12-01

Release 1:2.32.1-0ubuntu7

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.

Subscribers