Created by Michael Vogt on 2009-01-07 and last modified on 2015-09-16
Get this branch:
bzr branch lp:~ubuntu-desktop/totem/ubuntu
Members of Ubuntu Desktop can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Ubuntu Desktop

Recent revisions

235. By Sebastien Bacher on 2015-09-16

releasing package totem version 3.16.4-0ubuntu1

234. By Sebastien Bacher on 2015-09-16

New upstream version

233. By Sebastien Bacher on 2015-07-21

releasing package totem version 3.16.2-1ubuntu3

232. By Sebastien Bacher on 2015-07-21

* debian/patches/0001-Add-a-traditional-menubar.patch:
  - updated POTFILES.in so menus are translatables (lp: #1476684)

231. By Iain Lane on 2015-07-07

releasing package totem version 3.16.2-1ubuntu2

230. By Iain Lane on 2015-07-07

* debian/patches/disable-thumbnail-caching: Drop, we have a fixed
  grilo-plugins now.
* debian/control{,.in}: Version the dep on grilo-plugins to >= the version
  which had a fixed grl-bookmarks.

229. By Iain Lane on 2015-07-07

Sync bzr with archive

228. By Robert Ancell on 2015-06-18

* New upstream release (LP: #1466252)
* Merge with Debian, remaining Ubuntu changes:
* debian/control.in:
  - Drop build-depends on libepc-ui-dev (in universe)
  - Drop libxtst-dev build-depends so that the (redundant) fake key presses
    for inhibiting the screensaver are disabled (LP: #1007438)
  - Build-depend on libzeitgeist-dev
  - Suggest rather than recommend gstreamer components in universe
  - Add totem-plugins-extra
  - Don't recommend gnome-settings-daemon from the plugins any more; it's not
    right to pull in desktop integration bits by default.
  - Switch gnome-icon-theme to adwaita-icon-theme, which is its successor.
  - Use ubuntu-desktop vcs
  - Use Python 3
  - Switch from appdata-tools to libappstream-glib-dev, appstream-util
  - Add build-dep on libicu-dev
* debian/rules:
  - Build with --fail-missing, to ensure we install everything.
    + Ignore libtotem.{,l}a since we delibrately don't install these.
  - Binary install override for totem-plugins-extra
  - Enable buildflags script
  - Use Python 3
  - Remove obsolete --disable-vegas-plugin
  - Enable GTK+ Doc
* debian/totem-common.install, debian/source_totem.py:
  - Install Ubuntu apport debugging hook
* debian/totem-plugins-extra.install:
  - Universe plugins split out of totem-plugins (currently only gromit)
* debian/totem-plugins.install:
  - Skip the plugins split to -extra and add the zeitgeist plugin
* debian/patches/0001-Add-a-traditional-menubar.patch:
  - Add a traditional menubar
* debian/patches/correct_desktop_mimetypes.patch:
  - Don't list the mimetypes after the unity lists
* debian/patches/91_quicklist_entries.patch:
  - Add static quicklist
* debian/patches/ubuntu-grilo-filesystem.patch:
  - Use grl-filesystem if tracker is not available
* debian/patches/ubuntu-use-traditional-titlebars.patch:
  - Use traditional titlebars on !GNOME
* debian/patches/0001-totem-open-location-Respect-gtk-dialogs-use-header-s.patch:
  - Respect gtk-dialogs-use-header setting
* debian/patches/0002-preferences-Respect-gtk-dialogs-use-header-setting.patch:
  - Respect gtk-dialogs-use-header setting
* debian/patches/0003-totem-movie-properties-Respect-gtk-dialogs-use-heade.patch:
  - Respect gtk-dialogs-use-header setting
* debian/patches/disable-thumbnail-caching:
  - Don't save bookmark thumbnails back to grilo, a bug there means that this
    duplicates the bookmark.
* Upload to unstable.
* New upstream release.
* Update build-dependencies according to configure.ac
  - Bump intltool to >= 0.50.1
  - Add libcairo2-dev (>= 1.14.0)
  - Switch from libclutter-gst-2.0-dev to libclutter-gst-3.0-dev
  - Bump libgrilo-0.2-dev to >= 0.2.12
  - Bump libgtk-3-dev to >= 3.16.0
* totem-plugins: stop installing chapters which has been removed upstream.
* totem: stop shipping /usr/lib/totem/totem
  - the bugreport script no longer installed by upstream.
* Drop obsolete debian/bug/control
* debian/control.in:
  + Switch gstreamer1.0-clutter dependency to gstreamer1.0-clutter-3.0.
  + Standards-Version is 3.9.6, no changes needed.
* Upload to experimental.

227. By Robert Ancell on 2015-06-14

* debian/control:
* debian/patches/python3.patch:
  - Re-add python-gi-dev build-dependency. It makes no difference to the build
    and makes the patch simpler.

226. By Robert Ancell on 2015-06-12

* debian/control:
  - Use Python 3 (LP: #1440377)
  - Drop unnecessary dependency on python-gi-dev
* debian/rules:
  - Use dh_python3
* debian/patches/python3.patch:
  - Update script to use Python 3

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.