View Bazaar branches
Get this repository:
git clone https://git.launchpad.net/ubuntu/+source/strongswan
Members of Ubuntu Server Dev import team can upload to this repository. Log in for directions.

Branches

Name Last Modified Last Commit
importer/debian/dsc 2019-10-13 04:46:06 UTC 2019-10-13
DSC file for 5.8.0-2

Author: Ubuntu Git Importer
Author Date: 2019-10-13 04:46:06 UTC

DSC file for 5.8.0-2

applied/debian/sid 2019-10-13 04:44:03 UTC 2019-10-13
Import patches-applied version 5.8.0-2 to applied/debian/sid

Author: Yves-Alexis Perez
Author Date: 2019-10-05 13:03:59 UTC

Import patches-applied version 5.8.0-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: ab1352b6c18e277c8cac7bd98dd9abbb801ff06d
Unapplied parent: 79c177919f26d5672c6463766799d2959e4f5223

New changelog entries:
  [ Christian Ehrhardt ]
  * d/control: Mention mgf1 plugin which is in libstrongswan now
  * Complete the disabling of libfast
  * Clean up d/strongswan-starter.postinst: section about runlevel changes
  * Clean up d/strongswan-starter.postinst: opportunistic encryption
  * Enable kernel-libipsec for use of strongswan in containers
  * d/control, d/libcharon-{extras,extauth}-plugins.install: Add
    extauth-plugins package (Recommends)
  * apparmor: d/usr.lib.ipsec.charon: sync notify rule from charon-systemd
  * apparmor: fix apparmor denies reading the own FDs (LP: 1786250)
  * apparmor: d/usr.sbin.charon-systemd: allow CLUSTERIP for ha plugin
    (LP: 1773956)
  * apparmor: d/usr.lib.ipsec.stroke: executables need to be able to read map
    and execute themselves
  * apparmor: d/usr.lib.ipsec.lookip: executables need to be able to read map
    and execute themselves
  * apparmor: d/usr.sbin.swanctl: add apparmor rule for af-alg plugin
    (LP: 1807962)
  * d/control: libtpmtss is actually packaged in libstrongswan-extra-plugins
  [ Ryan Harper ]
  * Remove code related to unused debconf managed config
  [ Yves-Alexis Perez ]
  * ship xfrmi only on Linux, fix FTBFS on kfreebsd
  * d/libcharon-extra-plugins.install: drop plugins disabled in Debian
  * d/control: update standards version to 4.4.1
  * d/strongswan-starter.templates: drop runlevel_changes
  * let dh_installinit handle update-rc.d calls
  * d/salsa-ci.yml: add a salsa pipeline config
  * d/rules: drop dbgsym migration
  * strongswan-starter: update line number in lintian override

debian/sid 2019-10-13 04:44:03 UTC 2019-10-13
Import patches-unapplied version 5.8.0-2 to debian/sid

Author: Yves-Alexis Perez
Author Date: 2019-10-05 13:03:59 UTC

Import patches-unapplied version 5.8.0-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 847fa18d97d70bdb38e522a2e6d7707d34e91df5

New changelog entries:
  [ Christian Ehrhardt ]
  * d/control: Mention mgf1 plugin which is in libstrongswan now
  * Complete the disabling of libfast
  * Clean up d/strongswan-starter.postinst: section about runlevel changes
  * Clean up d/strongswan-starter.postinst: opportunistic encryption
  * Enable kernel-libipsec for use of strongswan in containers
  * d/control, d/libcharon-{extras,extauth}-plugins.install: Add
    extauth-plugins package (Recommends)
  * apparmor: d/usr.lib.ipsec.charon: sync notify rule from charon-systemd
  * apparmor: fix apparmor denies reading the own FDs (LP: 1786250)
  * apparmor: d/usr.sbin.charon-systemd: allow CLUSTERIP for ha plugin
    (LP: 1773956)
  * apparmor: d/usr.lib.ipsec.stroke: executables need to be able to read map
    and execute themselves
  * apparmor: d/usr.lib.ipsec.lookip: executables need to be able to read map
    and execute themselves
  * apparmor: d/usr.sbin.swanctl: add apparmor rule for af-alg plugin
    (LP: 1807962)
  * d/control: libtpmtss is actually packaged in libstrongswan-extra-plugins
  [ Ryan Harper ]
  * Remove code related to unused debconf managed config
  [ Yves-Alexis Perez ]
  * ship xfrmi only on Linux, fix FTBFS on kfreebsd
  * d/libcharon-extra-plugins.install: drop plugins disabled in Debian
  * d/control: update standards version to 4.4.1
  * d/strongswan-starter.templates: drop runlevel_changes
  * let dh_installinit handle update-rc.d calls
  * d/salsa-ci.yml: add a salsa pipeline config
  * d/rules: drop dbgsym migration
  * strongswan-starter: update line number in lintian override

importer/ubuntu/dsc 2019-08-15 07:50:23 UTC 2019-08-15
DSC file for 5.7.2-1ubuntu3

Author: Ubuntu Git Importer
Author Date: 2019-08-15 07:50:23 UTC

DSC file for 5.7.2-1ubuntu3

ubuntu/eoan-proposed 2019-08-15 07:48:15 UTC 2019-08-15
Import patches-unapplied version 5.7.2-1ubuntu3 to ubuntu/eoan-proposed

Author: Christian Ehrhardt 
Author Date: 2019-08-15 07:34:34 UTC

Import patches-unapplied version 5.7.2-1ubuntu3 to ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: 9661b734ca98bc6348d80d62c6d45b90b289f341

New changelog entries:
  * No change rebuild for libmysqlclient21.

ubuntu/eoan-devel 2019-08-15 07:48:15 UTC 2019-08-15
Import patches-unapplied version 5.7.2-1ubuntu3 to ubuntu/eoan-proposed

Author: Christian Ehrhardt 
Author Date: 2019-08-15 07:34:34 UTC

Import patches-unapplied version 5.7.2-1ubuntu3 to ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: 9661b734ca98bc6348d80d62c6d45b90b289f341

New changelog entries:
  * No change rebuild for libmysqlclient21.

applied/ubuntu/devel 2019-08-15 07:48:15 UTC 2019-08-15
Import patches-applied version 5.7.2-1ubuntu3 to applied/ubuntu/eoan-proposed

Author: Christian Ehrhardt 
Author Date: 2019-08-15 07:34:34 UTC

Import patches-applied version 5.7.2-1ubuntu3 to applied/ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: a43130acccf64e928295a2a45390ae9e8d6eeb70
Unapplied parent: c1ba077c924487a5203651b6e9901949f086520b

New changelog entries:
  * No change rebuild for libmysqlclient21.

ubuntu/devel 2019-08-15 07:48:15 UTC 2019-08-15
Import patches-unapplied version 5.7.2-1ubuntu3 to ubuntu/eoan-proposed

Author: Christian Ehrhardt 
Author Date: 2019-08-15 07:34:34 UTC

Import patches-unapplied version 5.7.2-1ubuntu3 to ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: 9661b734ca98bc6348d80d62c6d45b90b289f341

New changelog entries:
  * No change rebuild for libmysqlclient21.

applied/ubuntu/eoan-proposed 2019-08-15 07:48:15 UTC 2019-08-15
Import patches-applied version 5.7.2-1ubuntu3 to applied/ubuntu/eoan-proposed

Author: Christian Ehrhardt 
Author Date: 2019-08-15 07:34:34 UTC

Import patches-applied version 5.7.2-1ubuntu3 to applied/ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: a43130acccf64e928295a2a45390ae9e8d6eeb70
Unapplied parent: c1ba077c924487a5203651b6e9901949f086520b

New changelog entries:
  * No change rebuild for libmysqlclient21.

applied/ubuntu/eoan-devel 2019-08-15 07:48:15 UTC 2019-08-15
Import patches-applied version 5.7.2-1ubuntu3 to applied/ubuntu/eoan-proposed

Author: Christian Ehrhardt 
Author Date: 2019-08-15 07:34:34 UTC

Import patches-applied version 5.7.2-1ubuntu3 to applied/ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: a43130acccf64e928295a2a45390ae9e8d6eeb70
Unapplied parent: c1ba077c924487a5203651b6e9901949f086520b

New changelog entries:
  * No change rebuild for libmysqlclient21.

ubuntu/eoan 2019-08-15 07:48:15 UTC 2019-08-15
Import patches-unapplied version 5.7.2-1ubuntu3 to ubuntu/eoan-proposed

Author: Christian Ehrhardt 
Author Date: 2019-08-15 07:34:34 UTC

Import patches-unapplied version 5.7.2-1ubuntu3 to ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: 9661b734ca98bc6348d80d62c6d45b90b289f341

New changelog entries:
  * No change rebuild for libmysqlclient21.

applied/ubuntu/eoan 2019-08-15 07:48:15 UTC 2019-08-15
Import patches-applied version 5.7.2-1ubuntu3 to applied/ubuntu/eoan-proposed

Author: Christian Ehrhardt 
Author Date: 2019-08-15 07:34:34 UTC

Import patches-applied version 5.7.2-1ubuntu3 to applied/ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: a43130acccf64e928295a2a45390ae9e8d6eeb70
Unapplied parent: c1ba077c924487a5203651b6e9901949f086520b

New changelog entries:
  * No change rebuild for libmysqlclient21.

debian/buster 2019-01-02 16:42:30 UTC 2019-01-02
Import patches-unapplied version 5.7.2-1 to debian/sid

Author: Yves-Alexis Perez
Author Date: 2019-01-02 12:02:11 UTC

Import patches-unapplied version 5.7.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: ea0122a943d87dc2bbf11e5e555d306d8f3a0047

New changelog entries:
  * d/control: remove Rene from Uploaders, thanks!
  * d/copyright: fix typos
  * d/watch: use HTTPS protocol
  * d/control: update standards version to 4.2.1
  * drop unused debconf template
  * use a clean export for upstream signing key
  * d/copyright update
  * New upstream version 5.7.2
  * d/copyright updated
  * d/control: update standards version to 4.3.0
  * d/libstrongswan.dirs: drop lintian overrides dir
  * d/u/signing-key.asc: strip signatures from upstream signing key
  * d/patches: import patches in gbp pq

applied/debian/buster 2019-01-02 16:42:30 UTC 2019-01-02
Import patches-applied version 5.7.2-1 to applied/debian/sid

Author: Yves-Alexis Perez
Author Date: 2019-01-02 12:02:11 UTC

Import patches-applied version 5.7.2-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 66850d1cb4b39e5f27a0cee18c070dfadb2ccbba
Unapplied parent: ccabca78ba879f40e0330bdde51b5e91ae6f2833

New changelog entries:
  * d/control: remove Rene from Uploaders, thanks!
  * d/copyright: fix typos
  * d/watch: use HTTPS protocol
  * d/control: update standards version to 4.2.1
  * drop unused debconf template
  * use a clean export for upstream signing key
  * d/copyright update
  * New upstream version 5.7.2
  * d/copyright updated
  * d/control: update standards version to 4.3.0
  * d/libstrongswan.dirs: drop lintian overrides dir
  * d/u/signing-key.asc: strip signatures from upstream signing key
  * d/patches: import patches in gbp pq

applied/ubuntu/bionic-updates 2018-12-18 17:28:22 UTC 2018-12-18
Import patches-applied version 5.6.2-1ubuntu2.4 to applied/ubuntu/bionic-prop...

Author: Christian Ehrhardt 
Author Date: 2018-12-12 14:52:43 UTC

Import patches-applied version 5.6.2-1ubuntu2.4 to applied/ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: b2b73ea64ade65275b5589a0ac162f43615bd63f
Unapplied parent: 492be9b586ecc1f4bac296af5f1a0420dc7ac339

New changelog entries:
  * fix stroke and lookip execution in containers (LP: #1780534). Binaries
    need to be able to read map and execute themselves
    - d/usr.lib.ipsec.lookip: add rmix to own binary
    - d/usr.lib.ipsec.stroke: add rmix to own binary
  * d/usr.lib.ipsec.charon: allow CLUSTERIP for ha plugin (LP: #1773956)

ubuntu/bionic-devel 2018-12-18 17:28:22 UTC 2018-12-18
Import patches-unapplied version 5.6.2-1ubuntu2.4 to ubuntu/bionic-proposed

Author: Christian Ehrhardt 
Author Date: 2018-12-12 14:52:43 UTC

Import patches-unapplied version 5.6.2-1ubuntu2.4 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Upload parent: 33bcd983dde05db15703dea10d46facd6cd5fe6c

ubuntu/bionic-proposed 2018-12-18 17:28:22 UTC 2018-12-18
Import patches-unapplied version 5.6.2-1ubuntu2.4 to ubuntu/bionic-proposed

Author: Christian Ehrhardt 
Author Date: 2018-12-12 14:52:43 UTC

Import patches-unapplied version 5.6.2-1ubuntu2.4 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Upload parent: 33bcd983dde05db15703dea10d46facd6cd5fe6c

ubuntu/bionic-updates 2018-12-18 17:28:22 UTC 2018-12-18
Import patches-unapplied version 5.6.2-1ubuntu2.4 to ubuntu/bionic-proposed

Author: Christian Ehrhardt 
Author Date: 2018-12-12 14:52:43 UTC

Import patches-unapplied version 5.6.2-1ubuntu2.4 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Upload parent: 33bcd983dde05db15703dea10d46facd6cd5fe6c

applied/ubuntu/bionic-devel 2018-12-18 17:28:22 UTC 2018-12-18
Import patches-applied version 5.6.2-1ubuntu2.4 to applied/ubuntu/bionic-prop...

Author: Christian Ehrhardt 
Author Date: 2018-12-12 14:52:43 UTC

Import patches-applied version 5.6.2-1ubuntu2.4 to applied/ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: b2b73ea64ade65275b5589a0ac162f43615bd63f
Unapplied parent: 492be9b586ecc1f4bac296af5f1a0420dc7ac339

New changelog entries:
  * fix stroke and lookip execution in containers (LP: #1780534). Binaries
    need to be able to read map and execute themselves
    - d/usr.lib.ipsec.lookip: add rmix to own binary
    - d/usr.lib.ipsec.stroke: add rmix to own binary
  * d/usr.lib.ipsec.charon: allow CLUSTERIP for ha plugin (LP: #1773956)

applied/ubuntu/bionic-proposed 2018-12-18 17:28:22 UTC 2018-12-18
Import patches-applied version 5.6.2-1ubuntu2.4 to applied/ubuntu/bionic-prop...

Author: Christian Ehrhardt 
Author Date: 2018-12-12 14:52:43 UTC

Import patches-applied version 5.6.2-1ubuntu2.4 to applied/ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: b2b73ea64ade65275b5589a0ac162f43615bd63f
Unapplied parent: 492be9b586ecc1f4bac296af5f1a0420dc7ac339

New changelog entries:
  * fix stroke and lookip execution in containers (LP: #1780534). Binaries
    need to be able to read map and execute themselves
    - d/usr.lib.ipsec.lookip: add rmix to own binary
    - d/usr.lib.ipsec.stroke: add rmix to own binary
  * d/usr.lib.ipsec.charon: allow CLUSTERIP for ha plugin (LP: #1773956)

ubuntu/cosmic-devel 2018-12-18 17:28:22 UTC 2018-12-18
Import patches-unapplied version 5.6.3-1ubuntu4.1 to ubuntu/cosmic-proposed

Author: Christian Ehrhardt 
Author Date: 2018-12-12 14:52:43 UTC

Import patches-unapplied version 5.6.3-1ubuntu4.1 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Upload parent: 0ad77f7522812222f2c4212b563ae866b37ab4e2

ubuntu/cosmic-updates 2018-12-18 17:28:22 UTC 2018-12-18
Import patches-unapplied version 5.6.3-1ubuntu4.1 to ubuntu/cosmic-proposed

Author: Christian Ehrhardt 
Author Date: 2018-12-12 14:52:43 UTC

Import patches-unapplied version 5.6.3-1ubuntu4.1 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Upload parent: 0ad77f7522812222f2c4212b563ae866b37ab4e2

ubuntu/cosmic-proposed 2018-12-18 17:28:22 UTC 2018-12-18
Import patches-unapplied version 5.6.3-1ubuntu4.1 to ubuntu/cosmic-proposed

Author: Christian Ehrhardt 
Author Date: 2018-12-12 14:52:43 UTC

Import patches-unapplied version 5.6.3-1ubuntu4.1 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Upload parent: 0ad77f7522812222f2c4212b563ae866b37ab4e2

applied/ubuntu/cosmic-devel 2018-12-18 17:28:22 UTC 2018-12-18
Import patches-applied version 5.6.3-1ubuntu4.1 to applied/ubuntu/cosmic-prop...

Author: Christian Ehrhardt 
Author Date: 2018-12-12 14:52:43 UTC

Import patches-applied version 5.6.3-1ubuntu4.1 to applied/ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: f1c2fd3b9f9eb8d0005dd9899768a9e2edd66a4b
Unapplied parent: b89de7568e3d5376887e6493b72764cae6ee3146

New changelog entries:
  * fix stroke and lookip execution in containers (LP: #1780534). Binaries
    need to be able to read map and execute themselves
    - d/usr.lib.ipsec.lookip: add rmix to own binary
    - d/usr.lib.ipsec.stroke: add rmix to own binary
  * d/usr.lib.ipsec.charon: allow CLUSTERIP for ha plugin (LP: #1773956)

applied/ubuntu/cosmic-proposed 2018-12-18 17:28:22 UTC 2018-12-18
Import patches-applied version 5.6.3-1ubuntu4.1 to applied/ubuntu/cosmic-prop...

Author: Christian Ehrhardt 
Author Date: 2018-12-12 14:52:43 UTC

Import patches-applied version 5.6.3-1ubuntu4.1 to applied/ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: f1c2fd3b9f9eb8d0005dd9899768a9e2edd66a4b
Unapplied parent: b89de7568e3d5376887e6493b72764cae6ee3146

New changelog entries:
  * fix stroke and lookip execution in containers (LP: #1780534). Binaries
    need to be able to read map and execute themselves
    - d/usr.lib.ipsec.lookip: add rmix to own binary
    - d/usr.lib.ipsec.stroke: add rmix to own binary
  * d/usr.lib.ipsec.charon: allow CLUSTERIP for ha plugin (LP: #1773956)

applied/ubuntu/cosmic-updates 2018-12-18 17:28:22 UTC 2018-12-18
Import patches-applied version 5.6.3-1ubuntu4.1 to applied/ubuntu/cosmic-prop...

Author: Christian Ehrhardt 
Author Date: 2018-12-12 14:52:43 UTC

Import patches-applied version 5.6.3-1ubuntu4.1 to applied/ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: f1c2fd3b9f9eb8d0005dd9899768a9e2edd66a4b
Unapplied parent: b89de7568e3d5376887e6493b72764cae6ee3146

New changelog entries:
  * fix stroke and lookip execution in containers (LP: #1780534). Binaries
    need to be able to read map and execute themselves
    - d/usr.lib.ipsec.lookip: add rmix to own binary
    - d/usr.lib.ipsec.stroke: add rmix to own binary
  * d/usr.lib.ipsec.charon: allow CLUSTERIP for ha plugin (LP: #1773956)

applied/ubuntu/disco-proposed 2018-12-12 13:13:13 UTC 2018-12-12
Import patches-applied version 5.7.1-1ubuntu2 to applied/ubuntu/disco-proposed

Author: Christian Ehrhardt 
Author Date: 2018-12-10 07:30:01 UTC

Import patches-applied version 5.7.1-1ubuntu2 to applied/ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 92bea58539101d75ec1edc8530da59a3d27262ea
Unapplied parent: 1e99e945705373ba2f67fd7cb1671c037226d1d2

New changelog entries:
  * d/usr.sbin.charon-systemd: fix rule for CLUSTERIP to match effective
    path (LP: #1773956)
  * d/usr.lib.ipsec.charon, d/usr.sbin.charon-systemd: resync apparmor
    profiles of both ways to start charon (LP: #1807664)
  * d/usr.sbin.swanctl: add apparmor rule for af-alg plugin (LP: #1807962)

applied/ubuntu/disco-devel 2018-12-12 13:13:13 UTC 2018-12-12
Import patches-applied version 5.7.1-1ubuntu2 to applied/ubuntu/disco-proposed

Author: Christian Ehrhardt 
Author Date: 2018-12-10 07:30:01 UTC

Import patches-applied version 5.7.1-1ubuntu2 to applied/ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 92bea58539101d75ec1edc8530da59a3d27262ea
Unapplied parent: 1e99e945705373ba2f67fd7cb1671c037226d1d2

New changelog entries:
  * d/usr.sbin.charon-systemd: fix rule for CLUSTERIP to match effective
    path (LP: #1773956)
  * d/usr.lib.ipsec.charon, d/usr.sbin.charon-systemd: resync apparmor
    profiles of both ways to start charon (LP: #1807664)
  * d/usr.sbin.swanctl: add apparmor rule for af-alg plugin (LP: #1807962)

ubuntu/disco-proposed 2018-12-12 13:13:13 UTC 2018-12-12
Import patches-unapplied version 5.7.1-1ubuntu2 to ubuntu/disco-proposed

Author: Christian Ehrhardt 
Author Date: 2018-12-10 07:30:01 UTC

Import patches-unapplied version 5.7.1-1ubuntu2 to ubuntu/disco-proposed

Imported using git-ubuntu import.

Upload parent: 891ab057597eb2f27dbc7328e009f8179a1f0465

ubuntu/disco-devel 2018-12-12 13:13:13 UTC 2018-12-12
Import patches-unapplied version 5.7.1-1ubuntu2 to ubuntu/disco-proposed

Author: Christian Ehrhardt 
Author Date: 2018-12-10 07:30:01 UTC

Import patches-unapplied version 5.7.1-1ubuntu2 to ubuntu/disco-proposed

Imported using git-ubuntu import.

Upload parent: 891ab057597eb2f27dbc7328e009f8179a1f0465

ubuntu/disco 2018-12-12 13:13:13 UTC 2018-12-12
Import patches-unapplied version 5.7.1-1ubuntu2 to ubuntu/disco-proposed

Author: Christian Ehrhardt 
Author Date: 2018-12-10 07:30:01 UTC

Import patches-unapplied version 5.7.1-1ubuntu2 to ubuntu/disco-proposed

Imported using git-ubuntu import.

Upload parent: 891ab057597eb2f27dbc7328e009f8179a1f0465

applied/ubuntu/disco 2018-12-12 13:13:13 UTC 2018-12-12
Import patches-applied version 5.7.1-1ubuntu2 to applied/ubuntu/disco-proposed

Author: Christian Ehrhardt 
Author Date: 2018-12-10 07:30:01 UTC

Import patches-applied version 5.7.1-1ubuntu2 to applied/ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 92bea58539101d75ec1edc8530da59a3d27262ea
Unapplied parent: 1e99e945705373ba2f67fd7cb1671c037226d1d2

New changelog entries:
  * d/usr.sbin.charon-systemd: fix rule for CLUSTERIP to match effective
    path (LP: #1773956)
  * d/usr.lib.ipsec.charon, d/usr.sbin.charon-systemd: resync apparmor
    profiles of both ways to start charon (LP: #1807664)
  * d/usr.sbin.swanctl: add apparmor rule for af-alg plugin (LP: #1807962)

applied/debian/stretch 2018-11-10 17:13:05 UTC 2018-11-10
Import patches-applied version 5.5.1-4+deb9u4 to applied/debian/stretch

Author: Yves-Alexis Perez
Author Date: 2018-10-01 20:51:38 UTC

Import patches-applied version 5.5.1-4+deb9u4 to applied/debian/stretch

Imported using git-ubuntu import.

Changelog parent: 44cbcb35be0982fc29ba107252de63908d9f75d8
Unapplied parent: 90091d2e3b1ec8ec3387de4d0e984a6a37404591

New changelog entries:
  * d/p/CVE-2018-17540_gmp-pkcs1-overflow added, fix an integer underflow and
    subsequent heap buffer overflow vulnerability in the gmp plugin triggered
    by crafted certificates with RSA keys with very small moduli
    (CVE-2018-17540)
  * d/p/CVE-2018-16151+CVE-2018-16152_gmp-pkcs1-verify added
    fix potential Bleichenbacher's low-exponent attack (CVE-2018-16151,
    CVE-2018-16152)

debian/stretch 2018-11-10 17:13:05 UTC 2018-11-10
Import patches-unapplied version 5.5.1-4+deb9u4 to debian/stretch

Author: Yves-Alexis Perez
Author Date: 2018-10-01 20:51:38 UTC

Import patches-unapplied version 5.5.1-4+deb9u4 to debian/stretch

Imported using git-ubuntu import.

Changelog parent: 9a096d1762afb0127530690a68f35f12bda40410

New changelog entries:
  * d/p/CVE-2018-17540_gmp-pkcs1-overflow added, fix an integer underflow and
    subsequent heap buffer overflow vulnerability in the gmp plugin triggered
    by crafted certificates with RSA keys with very small moduli
    (CVE-2018-17540)
  * d/p/CVE-2018-16151+CVE-2018-16152_gmp-pkcs1-verify added
    fix potential Bleichenbacher's low-exponent attack (CVE-2018-16151,
    CVE-2018-16152)

ubuntu/cosmic 2018-10-04 21:33:22 UTC 2018-10-04
Import patches-unapplied version 5.6.3-1ubuntu4 to ubuntu/cosmic-proposed

Author: Andreas Hasenack
Author Date: 2018-10-04 13:34:01 UTC

Import patches-unapplied version 5.6.3-1ubuntu4 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Upload parent: 0ce9edf7cce08faa724c504db93705fb6eb740c0

applied/ubuntu/cosmic 2018-10-04 21:33:22 UTC 2018-10-04
Import patches-applied version 5.6.3-1ubuntu4 to applied/ubuntu/cosmic-proposed

Author: Andreas Hasenack
Author Date: 2018-10-04 13:34:01 UTC

Import patches-applied version 5.6.3-1ubuntu4 to applied/ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: 7ea49e6e834a9ef78a760c92e6b6e18511deab0b
Unapplied parent: 70a405d790fffb89b9e2c0c8374e761b4e96c575

New changelog entries:
  * d/usr.lib.ipsec.charon: allow reading of own FDs (LP: #1786250)
    Thanks to Matt Callaghan.

ubuntu/bionic-security 2018-10-01 17:23:37 UTC 2018-10-01
Import patches-unapplied version 5.6.2-1ubuntu2.3 to ubuntu/bionic-security

Author: Marc Deslauriers
Author Date: 2018-09-26 18:36:02 UTC

Import patches-unapplied version 5.6.2-1ubuntu2.3 to ubuntu/bionic-security

Imported using git-ubuntu import.

Changelog parent: 449302eecc5b1fc26501c74506860e1752175245

New changelog entries:
  * SECURITY UPDATE: Insufficient input validation in gmp plugin
    - debian/patches/strongswan-4.4.0-5.7.0_gmp-pkcs1-overflow.patch: fix
      buffer overflow with very small RSA keys in
      src/libstrongswan/plugins/gmp/gmp_rsa_private_key.c.
    - CVE-2018-17540

ubuntu/trusty-security 2018-10-01 17:23:37 UTC 2018-10-01
Import patches-unapplied version 5.1.2-0ubuntu2.11 to ubuntu/trusty-security

Author: Marc Deslauriers
Author Date: 2018-09-26 18:38:31 UTC

Import patches-unapplied version 5.1.2-0ubuntu2.11 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 19620b93b2b0be50e7319a3ed15c8c83d2a0766d

New changelog entries:
  * SECURITY UPDATE: Insufficient input validation in gmp plugin
    - debian/patches/strongswan-4.4.0-5.7.0_gmp-pkcs1-overflow.patch: fix
      buffer overflow with very small RSA keys in
      src/libstrongswan/plugins/gmp/gmp_rsa_private_key.c.
    - CVE-2018-17540

ubuntu/trusty-updates 2018-10-01 17:23:37 UTC 2018-10-01
Import patches-unapplied version 5.1.2-0ubuntu2.11 to ubuntu/trusty-security

Author: Marc Deslauriers
Author Date: 2018-09-26 18:38:31 UTC

Import patches-unapplied version 5.1.2-0ubuntu2.11 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 19620b93b2b0be50e7319a3ed15c8c83d2a0766d

New changelog entries:
  * SECURITY UPDATE: Insufficient input validation in gmp plugin
    - debian/patches/strongswan-4.4.0-5.7.0_gmp-pkcs1-overflow.patch: fix
      buffer overflow with very small RSA keys in
      src/libstrongswan/plugins/gmp/gmp_rsa_private_key.c.
    - CVE-2018-17540

applied/ubuntu/trusty-security 2018-10-01 17:23:37 UTC 2018-10-01
Import patches-applied version 5.1.2-0ubuntu2.11 to applied/ubuntu/trusty-sec...

Author: Marc Deslauriers
Author Date: 2018-09-26 18:38:31 UTC

Import patches-applied version 5.1.2-0ubuntu2.11 to applied/ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 96293837530740adf8e282bbd865fc48e3bce245
Unapplied parent: 0302425b86fa02b082186bee84d4fca0bb9e9f6b

New changelog entries:
  * SECURITY UPDATE: Insufficient input validation in gmp plugin
    - debian/patches/strongswan-4.4.0-5.7.0_gmp-pkcs1-overflow.patch: fix
      buffer overflow with very small RSA keys in
      src/libstrongswan/plugins/gmp/gmp_rsa_private_key.c.
    - CVE-2018-17540

ubuntu/xenial-devel 2018-10-01 17:23:37 UTC 2018-10-01
Import patches-unapplied version 5.3.5-1ubuntu3.8 to ubuntu/xenial-security

Author: Marc Deslauriers
Author Date: 2018-09-26 18:38:03 UTC

Import patches-unapplied version 5.3.5-1ubuntu3.8 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 7d0ec72349b0a1ede16e7046b48b0cb1dd631933

New changelog entries:
  * SECURITY UPDATE: Insufficient input validation in gmp plugin
    - debian/patches/strongswan-4.4.0-5.7.0_gmp-pkcs1-overflow.patch: fix
      buffer overflow with very small RSA keys in
      src/libstrongswan/plugins/gmp/gmp_rsa_private_key.c.
    - CVE-2018-17540

applied/ubuntu/bionic-security 2018-10-01 17:23:37 UTC 2018-10-01
Import patches-applied version 5.6.2-1ubuntu2.3 to applied/ubuntu/bionic-secu...

Author: Marc Deslauriers
Author Date: 2018-09-26 18:36:02 UTC

Import patches-applied version 5.6.2-1ubuntu2.3 to applied/ubuntu/bionic-security

Imported using git-ubuntu import.

Changelog parent: 2896a3c6248d7ede971cd4eb7295d1fb8b082ca2
Unapplied parent: 000cb9d75f451ac33b463515781c31b75e79f157

New changelog entries:
  * SECURITY UPDATE: Insufficient input validation in gmp plugin
    - debian/patches/strongswan-4.4.0-5.7.0_gmp-pkcs1-overflow.patch: fix
      buffer overflow with very small RSA keys in
      src/libstrongswan/plugins/gmp/gmp_rsa_private_key.c.
    - CVE-2018-17540

ubuntu/xenial-security 2018-10-01 17:23:37 UTC 2018-10-01
Import patches-unapplied version 5.3.5-1ubuntu3.8 to ubuntu/xenial-security

Author: Marc Deslauriers
Author Date: 2018-09-26 18:38:03 UTC

Import patches-unapplied version 5.3.5-1ubuntu3.8 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 7d0ec72349b0a1ede16e7046b48b0cb1dd631933

New changelog entries:
  * SECURITY UPDATE: Insufficient input validation in gmp plugin
    - debian/patches/strongswan-4.4.0-5.7.0_gmp-pkcs1-overflow.patch: fix
      buffer overflow with very small RSA keys in
      src/libstrongswan/plugins/gmp/gmp_rsa_private_key.c.
    - CVE-2018-17540

ubuntu/xenial-updates 2018-10-01 17:23:37 UTC 2018-10-01
Import patches-unapplied version 5.3.5-1ubuntu3.8 to ubuntu/xenial-security

Author: Marc Deslauriers
Author Date: 2018-09-26 18:38:03 UTC

Import patches-unapplied version 5.3.5-1ubuntu3.8 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 7d0ec72349b0a1ede16e7046b48b0cb1dd631933

New changelog entries:
  * SECURITY UPDATE: Insufficient input validation in gmp plugin
    - debian/patches/strongswan-4.4.0-5.7.0_gmp-pkcs1-overflow.patch: fix
      buffer overflow with very small RSA keys in
      src/libstrongswan/plugins/gmp/gmp_rsa_private_key.c.
    - CVE-2018-17540

applied/ubuntu/trusty-devel 2018-10-01 17:23:37 UTC 2018-10-01
Import patches-applied version 5.1.2-0ubuntu2.11 to applied/ubuntu/trusty-sec...

Author: Marc Deslauriers
Author Date: 2018-09-26 18:38:31 UTC

Import patches-applied version 5.1.2-0ubuntu2.11 to applied/ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 96293837530740adf8e282bbd865fc48e3bce245
Unapplied parent: 0302425b86fa02b082186bee84d4fca0bb9e9f6b

New changelog entries:
  * SECURITY UPDATE: Insufficient input validation in gmp plugin
    - debian/patches/strongswan-4.4.0-5.7.0_gmp-pkcs1-overflow.patch: fix
      buffer overflow with very small RSA keys in
      src/libstrongswan/plugins/gmp/gmp_rsa_private_key.c.
    - CVE-2018-17540

applied/ubuntu/xenial-updates 2018-10-01 17:23:37 UTC 2018-10-01
Import patches-applied version 5.3.5-1ubuntu3.8 to applied/ubuntu/xenial-secu...

Author: Marc Deslauriers
Author Date: 2018-09-26 18:38:03 UTC

Import patches-applied version 5.3.5-1ubuntu3.8 to applied/ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: a7f7a4fa949acc9ecc8e3b52514d98d9e7452cc9
Unapplied parent: 0dda85fb868d21f06663a92409c2db246f67aa26

New changelog entries:
  * SECURITY UPDATE: Insufficient input validation in gmp plugin
    - debian/patches/strongswan-4.4.0-5.7.0_gmp-pkcs1-overflow.patch: fix
      buffer overflow with very small RSA keys in
      src/libstrongswan/plugins/gmp/gmp_rsa_private_key.c.
    - CVE-2018-17540

applied/ubuntu/xenial-security 2018-10-01 17:23:37 UTC 2018-10-01
Import patches-applied version 5.3.5-1ubuntu3.8 to applied/ubuntu/xenial-secu...

Author: Marc Deslauriers
Author Date: 2018-09-26 18:38:03 UTC

Import patches-applied version 5.3.5-1ubuntu3.8 to applied/ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: a7f7a4fa949acc9ecc8e3b52514d98d9e7452cc9
Unapplied parent: 0dda85fb868d21f06663a92409c2db246f67aa26

New changelog entries:
  * SECURITY UPDATE: Insufficient input validation in gmp plugin
    - debian/patches/strongswan-4.4.0-5.7.0_gmp-pkcs1-overflow.patch: fix
      buffer overflow with very small RSA keys in
      src/libstrongswan/plugins/gmp/gmp_rsa_private_key.c.
    - CVE-2018-17540

applied/ubuntu/xenial-devel 2018-10-01 17:23:37 UTC 2018-10-01
Import patches-applied version 5.3.5-1ubuntu3.8 to applied/ubuntu/xenial-secu...

Author: Marc Deslauriers
Author Date: 2018-09-26 18:38:03 UTC

Import patches-applied version 5.3.5-1ubuntu3.8 to applied/ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: a7f7a4fa949acc9ecc8e3b52514d98d9e7452cc9
Unapplied parent: 0dda85fb868d21f06663a92409c2db246f67aa26

New changelog entries:
  * SECURITY UPDATE: Insufficient input validation in gmp plugin
    - debian/patches/strongswan-4.4.0-5.7.0_gmp-pkcs1-overflow.patch: fix
      buffer overflow with very small RSA keys in
      src/libstrongswan/plugins/gmp/gmp_rsa_private_key.c.
    - CVE-2018-17540

applied/ubuntu/trusty-updates 2018-10-01 17:23:37 UTC 2018-10-01
Import patches-applied version 5.1.2-0ubuntu2.11 to applied/ubuntu/trusty-sec...

Author: Marc Deslauriers
Author Date: 2018-09-26 18:38:31 UTC

Import patches-applied version 5.1.2-0ubuntu2.11 to applied/ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 96293837530740adf8e282bbd865fc48e3bce245
Unapplied parent: 0302425b86fa02b082186bee84d4fca0bb9e9f6b

New changelog entries:
  * SECURITY UPDATE: Insufficient input validation in gmp plugin
    - debian/patches/strongswan-4.4.0-5.7.0_gmp-pkcs1-overflow.patch: fix
      buffer overflow with very small RSA keys in
      src/libstrongswan/plugins/gmp/gmp_rsa_private_key.c.
    - CVE-2018-17540

ubuntu/trusty-devel 2018-10-01 17:23:37 UTC 2018-10-01
Import patches-unapplied version 5.1.2-0ubuntu2.11 to ubuntu/trusty-security

Author: Marc Deslauriers
Author Date: 2018-09-26 18:38:31 UTC

Import patches-unapplied version 5.1.2-0ubuntu2.11 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 19620b93b2b0be50e7319a3ed15c8c83d2a0766d

New changelog entries:
  * SECURITY UPDATE: Insufficient input validation in gmp plugin
    - debian/patches/strongswan-4.4.0-5.7.0_gmp-pkcs1-overflow.patch: fix
      buffer overflow with very small RSA keys in
      src/libstrongswan/plugins/gmp/gmp_rsa_private_key.c.
    - CVE-2018-17540

debian/jessie 2018-06-23 17:28:57 UTC 2018-06-23
Import patches-unapplied version 5.2.1-6+deb8u6 to debian/jessie

Author: Yves-Alexis Perez
Author Date: 2018-06-14 08:13:44 UTC

Import patches-unapplied version 5.2.1-6+deb8u6 to debian/jessie

Imported using git-ubuntu import.

Changelog parent: 09016c358a7691eba36828c7c44c7d981ebfeede

New changelog entries:
  * d/p/CVE-2018-10811.patch added, fix missing initialization of a variable
    in IKEv2 key derivation (CVE-2018-10811)
  * d/p/CVE-2018-5388 added, fix insufficient validation in the stroke plugin
    (CVE-2018-5388)

applied/debian/jessie 2018-06-23 17:28:57 UTC 2018-06-23
Import patches-applied version 5.2.1-6+deb8u6 to applied/debian/jessie

Author: Yves-Alexis Perez
Author Date: 2018-06-14 08:13:44 UTC

Import patches-applied version 5.2.1-6+deb8u6 to applied/debian/jessie

Imported using git-ubuntu import.

Changelog parent: 5459b315d6df1ec22d32f1ab77d956b20650fa39
Unapplied parent: 9450b550a018c3975778787e636f40db38dc44e0

New changelog entries:
  * d/p/CVE-2018-10811.patch added, fix missing initialization of a variable
    in IKEv2 key derivation (CVE-2018-10811)
  * d/p/CVE-2018-5388 added, fix insufficient validation in the stroke plugin
    (CVE-2018-5388)

applied/ubuntu/bionic 2018-03-20 13:28:49 UTC 2018-03-20
Import patches-applied version 5.6.2-1ubuntu2 to applied/ubuntu/bionic-proposed

Author: Christian Ehrhardt 
Author Date: 2018-03-20 06:37:29 UTC

Import patches-applied version 5.6.2-1ubuntu2 to applied/ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: e95361e96cf174c6f12dc5162426d03b851a3e51
Unapplied parent: 706e6495b7d195284acda10d6b0c481cdbec71e4

New changelog entries:
  * d/control: fix dependencies of strongswan-libcharon due to the move
    the updown plugin.

ubuntu/bionic 2018-03-20 13:28:49 UTC 2018-03-20
Import patches-unapplied version 5.6.2-1ubuntu2 to ubuntu/bionic-proposed

Author: Christian Ehrhardt 
Author Date: 2018-03-20 06:37:29 UTC

Import patches-unapplied version 5.6.2-1ubuntu2 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: 3d8d2d60843a5c3fb14650169c40fd8a792d7368

New changelog entries:
  * d/control: fix dependencies of strongswan-libcharon due to the move
    the updown plugin.

importer/ubuntu/pristine-tar 2018-03-19 14:44:20 UTC 2018-03-19
pristine-tar data for strongswan_5.6.2.orig.tar.bz2

Author: Ubuntu Git Importer
Author Date: 2018-03-19 14:44:20 UTC

pristine-tar data for strongswan_5.6.2.orig.tar.bz2

ubuntu/trusty-proposed 2018-03-15 18:44:54 UTC 2018-03-15
Import patches-unapplied version 5.1.2-0ubuntu2.8 to ubuntu/trusty-proposed

Author: Trent Lloyd
Author Date: 2018-03-14 06:50:05 UTC

Import patches-unapplied version 5.1.2-0ubuntu2.8 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 184b61c0a38c32cb661bb4f230866c5d9c48906a

New changelog entries:
  * d/control: Add Conflicts from strongswan-starter to openswan to
    avoid file conflict on upgrade. (LP: #1755693)

applied/ubuntu/trusty-proposed 2018-03-15 18:44:54 UTC 2018-03-15
Import patches-applied version 5.1.2-0ubuntu2.8 to applied/ubuntu/trusty-prop...

Author: Trent Lloyd
Author Date: 2018-03-14 06:50:05 UTC

Import patches-applied version 5.1.2-0ubuntu2.8 to applied/ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 92269a0e4fb55d66e541791203f2b1d08290d9ab
Unapplied parent: 70362f5e5ec3fcd2b3a62d47545560ed0540771e

New changelog entries:
  * d/control: Add Conflicts from strongswan-starter to openswan to
    avoid file conflict on upgrade. (LP: #1755693)

importer/debian/pristine-tar 2018-03-08 06:19:19 UTC 2018-03-08
pristine-tar data for strongswan_5.6.2.orig.tar.bz2

Author: Ubuntu Git Importer
Author Date: 2018-03-08 06:19:19 UTC

pristine-tar data for strongswan_5.6.2.orig.tar.bz2

applied/ubuntu/xenial-proposed 2017-12-20 00:58:16 UTC 2017-12-20
Import patches-applied version 5.3.5-1ubuntu3.5 to applied/ubuntu/xenial-prop...

Author: Christian Ehrhardt 
Author Date: 2017-12-18 10:22:24 UTC

Import patches-applied version 5.3.5-1ubuntu3.5 to applied/ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: b275802f5ebc6042e6e1e518e2da6aee1e521a06
Unapplied parent: 59c33b7529e4e0172c0490eafa4ee2140c875386

New changelog entries:
  * d/p/ikev1-First-do-PSK-lookups-lp1734207.patch ensure evaluation
    with resolvable hostnames selects the right PSK (LP: #1734207).

applied/ubuntu/zesty-updates 2017-12-20 00:58:16 UTC 2017-12-20
Import patches-applied version 5.5.1-1ubuntu3.3 to applied/ubuntu/zesty-proposed

Author: Christian Ehrhardt 
Author Date: 2017-12-18 10:13:53 UTC

Import patches-applied version 5.5.1-1ubuntu3.3 to applied/ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 0fd6d1f7d62cea4641802ef2af5bf0c0ad89b188
Unapplied parent: 6fe14ebc4c0789b2eada1f64e8ba68be03773ee8

New changelog entries:
  * d/p/ikev1-First-do-PSK-lookups-lp1734207.patch ensure evaluation
    with resolvable hostnames selects the right PSK (LP: #1734207).

applied/ubuntu/zesty-proposed 2017-12-20 00:58:16 UTC 2017-12-20
Import patches-applied version 5.5.1-1ubuntu3.3 to applied/ubuntu/zesty-proposed

Author: Christian Ehrhardt 
Author Date: 2017-12-18 10:13:53 UTC

Import patches-applied version 5.5.1-1ubuntu3.3 to applied/ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 0fd6d1f7d62cea4641802ef2af5bf0c0ad89b188
Unapplied parent: 6fe14ebc4c0789b2eada1f64e8ba68be03773ee8

New changelog entries:
  * d/p/ikev1-First-do-PSK-lookups-lp1734207.patch ensure evaluation
    with resolvable hostnames selects the right PSK (LP: #1734207).

ubuntu/zesty-devel 2017-12-20 00:58:16 UTC 2017-12-20
Import patches-unapplied version 5.5.1-1ubuntu3.3 to ubuntu/zesty-proposed

Author: Christian Ehrhardt 
Author Date: 2017-12-18 10:13:53 UTC

Import patches-unapplied version 5.5.1-1ubuntu3.3 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 9e5acf37e3326013690dc5c0723fe6953c255e5f
Upload parent: 6904f20fec3f3462df14ebd004e8983c69933990

New changelog entries:
  * d/p/ikev1-First-do-PSK-lookups-lp1734207.patch ensure evaluation
    with resolvable hostnames selects the right PSK (LP: #1734207).

ubuntu/zesty-proposed 2017-12-20 00:58:16 UTC 2017-12-20
Import patches-unapplied version 5.5.1-1ubuntu3.3 to ubuntu/zesty-proposed

Author: Christian Ehrhardt 
Author Date: 2017-12-18 10:13:53 UTC

Import patches-unapplied version 5.5.1-1ubuntu3.3 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 9e5acf37e3326013690dc5c0723fe6953c255e5f
Upload parent: 6904f20fec3f3462df14ebd004e8983c69933990

New changelog entries:
  * d/p/ikev1-First-do-PSK-lookups-lp1734207.patch ensure evaluation
    with resolvable hostnames selects the right PSK (LP: #1734207).

applied/ubuntu/zesty-devel 2017-12-20 00:58:16 UTC 2017-12-20
Import patches-applied version 5.5.1-1ubuntu3.3 to applied/ubuntu/zesty-proposed

Author: Christian Ehrhardt 
Author Date: 2017-12-18 10:13:53 UTC

Import patches-applied version 5.5.1-1ubuntu3.3 to applied/ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 0fd6d1f7d62cea4641802ef2af5bf0c0ad89b188
Unapplied parent: 6fe14ebc4c0789b2eada1f64e8ba68be03773ee8

New changelog entries:
  * d/p/ikev1-First-do-PSK-lookups-lp1734207.patch ensure evaluation
    with resolvable hostnames selects the right PSK (LP: #1734207).

ubuntu/xenial-proposed 2017-12-20 00:58:16 UTC 2017-12-20
Import patches-unapplied version 5.3.5-1ubuntu3.5 to ubuntu/xenial-proposed

Author: Christian Ehrhardt 
Author Date: 2017-12-18 10:22:24 UTC

Import patches-unapplied version 5.3.5-1ubuntu3.5 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 951e5485026256afb8d41f75f212e6512d537146

New changelog entries:
  * d/p/ikev1-First-do-PSK-lookups-lp1734207.patch ensure evaluation
    with resolvable hostnames selects the right PSK (LP: #1734207).

ubuntu/zesty-updates 2017-12-20 00:58:16 UTC 2017-12-20
Import patches-unapplied version 5.5.1-1ubuntu3.3 to ubuntu/zesty-proposed

Author: Christian Ehrhardt 
Author Date: 2017-12-18 10:13:53 UTC

Import patches-unapplied version 5.5.1-1ubuntu3.3 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 9e5acf37e3326013690dc5c0723fe6953c255e5f
Upload parent: 6904f20fec3f3462df14ebd004e8983c69933990

New changelog entries:
  * d/p/ikev1-First-do-PSK-lookups-lp1734207.patch ensure evaluation
    with resolvable hostnames selects the right PSK (LP: #1734207).

applied/ubuntu/artful-proposed 2017-12-20 00:43:16 UTC 2017-12-20
Import patches-applied version 5.5.1-4ubuntu2.2 to applied/ubuntu/artful-prop...

Author: Christian Ehrhardt 
Author Date: 2017-12-18 10:05:57 UTC

Import patches-applied version 5.5.1-4ubuntu2.2 to applied/ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 32e328369f081a05e41b45736ecf91825f737d5f
Unapplied parent: 404fc75e0c7e193c4a13d07154ab9dc8659e7b2d

New changelog entries:
  * d/p/ikev1-First-do-PSK-lookups-lp1734207.patch ensure evaluation
    with resolvable hostnames selects the right PSK (LP: #1734207).

ubuntu/artful-proposed 2017-12-20 00:43:16 UTC 2017-12-20
Import patches-unapplied version 5.5.1-4ubuntu2.2 to ubuntu/artful-proposed

Author: Christian Ehrhardt 
Author Date: 2017-12-18 10:05:57 UTC

Import patches-unapplied version 5.5.1-4ubuntu2.2 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: f68200f1312886b8764f0c110c872a28b05829f1
Upload parent: 2a7a26050e3c4dc72db498be8933768122987342

New changelog entries:
  * d/p/ikev1-First-do-PSK-lookups-lp1734207.patch ensure evaluation
    with resolvable hostnames selects the right PSK (LP: #1734207).

ubuntu/artful-devel 2017-12-20 00:43:16 UTC 2017-12-20
Import patches-unapplied version 5.5.1-4ubuntu2.2 to ubuntu/artful-proposed

Author: Christian Ehrhardt 
Author Date: 2017-12-18 10:05:57 UTC

Import patches-unapplied version 5.5.1-4ubuntu2.2 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: f68200f1312886b8764f0c110c872a28b05829f1
Upload parent: 2a7a26050e3c4dc72db498be8933768122987342

New changelog entries:
  * d/p/ikev1-First-do-PSK-lookups-lp1734207.patch ensure evaluation
    with resolvable hostnames selects the right PSK (LP: #1734207).

applied/ubuntu/artful-devel 2017-12-20 00:43:16 UTC 2017-12-20
Import patches-applied version 5.5.1-4ubuntu2.2 to applied/ubuntu/artful-prop...

Author: Christian Ehrhardt 
Author Date: 2017-12-18 10:05:57 UTC

Import patches-applied version 5.5.1-4ubuntu2.2 to applied/ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 32e328369f081a05e41b45736ecf91825f737d5f
Unapplied parent: 404fc75e0c7e193c4a13d07154ab9dc8659e7b2d

New changelog entries:
  * d/p/ikev1-First-do-PSK-lookups-lp1734207.patch ensure evaluation
    with resolvable hostnames selects the right PSK (LP: #1734207).

applied/ubuntu/artful-updates 2017-12-20 00:43:16 UTC 2017-12-20
Import patches-applied version 5.5.1-4ubuntu2.2 to applied/ubuntu/artful-prop...

Author: Christian Ehrhardt 
Author Date: 2017-12-18 10:05:57 UTC

Import patches-applied version 5.5.1-4ubuntu2.2 to applied/ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 32e328369f081a05e41b45736ecf91825f737d5f
Unapplied parent: 404fc75e0c7e193c4a13d07154ab9dc8659e7b2d

New changelog entries:
  * d/p/ikev1-First-do-PSK-lookups-lp1734207.patch ensure evaluation
    with resolvable hostnames selects the right PSK (LP: #1734207).

ubuntu/artful-updates 2017-12-20 00:43:16 UTC 2017-12-20
Import patches-unapplied version 5.5.1-4ubuntu2.2 to ubuntu/artful-proposed

Author: Christian Ehrhardt 
Author Date: 2017-12-18 10:05:57 UTC

Import patches-unapplied version 5.5.1-4ubuntu2.2 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: f68200f1312886b8764f0c110c872a28b05829f1
Upload parent: 2a7a26050e3c4dc72db498be8933768122987342

New changelog entries:
  * d/p/ikev1-First-do-PSK-lookups-lp1734207.patch ensure evaluation
    with resolvable hostnames selects the right PSK (LP: #1734207).

ubuntu/zesty-security 2017-08-21 12:28:15 UTC 2017-08-21
Import patches-unapplied version 5.5.1-1ubuntu3.2 to ubuntu/zesty-security

Author: Leonidas S. Barbosa
Author Date: 2017-08-15 18:00:33 UTC

Import patches-unapplied version 5.5.1-1ubuntu3.2 to ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: db71c23f282186229edfad23622be2daba164cb5

New changelog entries:
  * SECURITY UPDATE: Fix RSA signature verification
    - debian/patches/CVE-2017-11185.patch: does some
      verifications in order to avoid null-point dereference
      in src/libstrongswan/gmp/gmp_rsa_public_key.c
    - CVE-2017-11185

applied/ubuntu/zesty-security 2017-08-21 12:28:15 UTC 2017-08-21
Import patches-applied version 5.5.1-1ubuntu3.2 to applied/ubuntu/zesty-security

Author: Leonidas S. Barbosa
Author Date: 2017-08-15 18:00:33 UTC

Import patches-applied version 5.5.1-1ubuntu3.2 to applied/ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: af64cf1eb68751750ca96079b215c36428db7519
Unapplied parent: c9f26c526054a3088717fea0c90ae597368abd85

New changelog entries:
  * SECURITY UPDATE: Fix RSA signature verification
    - debian/patches/CVE-2017-11185.patch: does some
      verifications in order to avoid null-point dereference
      in src/libstrongswan/gmp/gmp_rsa_public_key.c
    - CVE-2017-11185

applied/ubuntu/artful 2017-08-16 19:43:30 UTC 2017-08-16
Import patches-applied version 5.5.1-4ubuntu2 to applied/ubuntu/artful-proposed

Author: Leonidas S. Barbosa
Author Date: 2017-08-15 17:49:49 UTC

Import patches-applied version 5.5.1-4ubuntu2 to applied/ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 3087e9099e7d553610eb52575ca36d9548e40b26
Unapplied parent: 6a388ea85be3ab9ae884c85fe9b23341edabcb8b

New changelog entries:
  * SECURITY UPDATE: Fix RSA signature verification
    - debian/patches/CVE-2017-11185.patch: does some
      verifications in order to avoid null-point dereference
      in src/libstrongswan/gmp/gmp_rsa_public_key.c
    - CVE-2017-11185

ubuntu/artful 2017-08-16 19:43:30 UTC 2017-08-16
Import patches-unapplied version 5.5.1-4ubuntu2 to ubuntu/artful-proposed

Author: Leonidas S. Barbosa
Author Date: 2017-08-15 17:49:49 UTC

Import patches-unapplied version 5.5.1-4ubuntu2 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 8c1a07607cfebb2e19e83dcb252942fb2669f3e5

New changelog entries:
  * SECURITY UPDATE: Fix RSA signature verification
    - debian/patches/CVE-2017-11185.patch: does some
      verifications in order to avoid null-point dereference
      in src/libstrongswan/gmp/gmp_rsa_public_key.c
    - CVE-2017-11185

applied/ubuntu/yakkety-security 2017-05-30 13:08:21 UTC 2017-05-30
Import patches-applied version 5.3.5-1ubuntu4.3 to applied/ubuntu/yakkety-sec...

Author: Marc Deslauriers
Author Date: 2017-05-24 18:58:16 UTC

Import patches-applied version 5.3.5-1ubuntu4.3 to applied/ubuntu/yakkety-security

Imported using git-ubuntu import.

Changelog parent: ee5fd53fe6974b6548a242a33fca647a934c96bc
Unapplied parent: 7d6ee361fc65357b8cdfbe771ad719a829e7cd52

New changelog entries:
  * SECURITY UPDATE: Insufficient Input Validation in gmp Plugin
    - debian/patches/CVE-2017-9022.patch: make sure the modulus is odd and
      the exponent not zero in
      src/libstrongswan/plugins/gmp/gmp_rsa_public_key.c.
    - CVE-2017-9022
  * SECURITY UPDATE: Incorrect Handling of CHOICE types in ASN.1 parser and
    x509 plugin
    - debian/patches/CVE-2017-9023.patch: fix CHOICE parsing in
      src/libstrongswan/asn1/asn1_parser.*,
      src/libstrongswan/plugins/x509/x509_cert.c.
    - CVE-2017-9023

ubuntu/yakkety-updates 2017-05-30 13:08:21 UTC 2017-05-30
Import patches-unapplied version 5.3.5-1ubuntu4.3 to ubuntu/yakkety-security

Author: Marc Deslauriers
Author Date: 2017-05-24 18:58:16 UTC

Import patches-unapplied version 5.3.5-1ubuntu4.3 to ubuntu/yakkety-security

Imported using git-ubuntu import.

Changelog parent: e89205f58082e3fcaee7573b6d63ef3f9cec2561

New changelog entries:
  * SECURITY UPDATE: Insufficient Input Validation in gmp Plugin
    - debian/patches/CVE-2017-9022.patch: make sure the modulus is odd and
      the exponent not zero in
      src/libstrongswan/plugins/gmp/gmp_rsa_public_key.c.
    - CVE-2017-9022
  * SECURITY UPDATE: Incorrect Handling of CHOICE types in ASN.1 parser and
    x509 plugin
    - debian/patches/CVE-2017-9023.patch: fix CHOICE parsing in
      src/libstrongswan/asn1/asn1_parser.*,
      src/libstrongswan/plugins/x509/x509_cert.c.
    - CVE-2017-9023

ubuntu/yakkety-security 2017-05-30 13:08:21 UTC 2017-05-30
Import patches-unapplied version 5.3.5-1ubuntu4.3 to ubuntu/yakkety-security

Author: Marc Deslauriers
Author Date: 2017-05-24 18:58:16 UTC

Import patches-unapplied version 5.3.5-1ubuntu4.3 to ubuntu/yakkety-security

Imported using git-ubuntu import.

Changelog parent: e89205f58082e3fcaee7573b6d63ef3f9cec2561

New changelog entries:
  * SECURITY UPDATE: Insufficient Input Validation in gmp Plugin
    - debian/patches/CVE-2017-9022.patch: make sure the modulus is odd and
      the exponent not zero in
      src/libstrongswan/plugins/gmp/gmp_rsa_public_key.c.
    - CVE-2017-9022
  * SECURITY UPDATE: Incorrect Handling of CHOICE types in ASN.1 parser and
    x509 plugin
    - debian/patches/CVE-2017-9023.patch: fix CHOICE parsing in
      src/libstrongswan/asn1/asn1_parser.*,
      src/libstrongswan/plugins/x509/x509_cert.c.
    - CVE-2017-9023

ubuntu/yakkety-devel 2017-05-30 13:08:21 UTC 2017-05-30
Import patches-unapplied version 5.3.5-1ubuntu4.3 to ubuntu/yakkety-security

Author: Marc Deslauriers
Author Date: 2017-05-24 18:58:16 UTC

Import patches-unapplied version 5.3.5-1ubuntu4.3 to ubuntu/yakkety-security

Imported using git-ubuntu import.

Changelog parent: e89205f58082e3fcaee7573b6d63ef3f9cec2561

New changelog entries:
  * SECURITY UPDATE: Insufficient Input Validation in gmp Plugin
    - debian/patches/CVE-2017-9022.patch: make sure the modulus is odd and
      the exponent not zero in
      src/libstrongswan/plugins/gmp/gmp_rsa_public_key.c.
    - CVE-2017-9022
  * SECURITY UPDATE: Incorrect Handling of CHOICE types in ASN.1 parser and
    x509 plugin
    - debian/patches/CVE-2017-9023.patch: fix CHOICE parsing in
      src/libstrongswan/asn1/asn1_parser.*,
      src/libstrongswan/plugins/x509/x509_cert.c.
    - CVE-2017-9023

applied/ubuntu/yakkety-updates 2017-05-30 13:08:21 UTC 2017-05-30
Import patches-applied version 5.3.5-1ubuntu4.3 to applied/ubuntu/yakkety-sec...

Author: Marc Deslauriers
Author Date: 2017-05-24 18:58:16 UTC

Import patches-applied version 5.3.5-1ubuntu4.3 to applied/ubuntu/yakkety-security

Imported using git-ubuntu import.

Changelog parent: ee5fd53fe6974b6548a242a33fca647a934c96bc
Unapplied parent: 7d6ee361fc65357b8cdfbe771ad719a829e7cd52

New changelog entries:
  * SECURITY UPDATE: Insufficient Input Validation in gmp Plugin
    - debian/patches/CVE-2017-9022.patch: make sure the modulus is odd and
      the exponent not zero in
      src/libstrongswan/plugins/gmp/gmp_rsa_public_key.c.
    - CVE-2017-9022
  * SECURITY UPDATE: Incorrect Handling of CHOICE types in ASN.1 parser and
    x509 plugin
    - debian/patches/CVE-2017-9023.patch: fix CHOICE parsing in
      src/libstrongswan/asn1/asn1_parser.*,
      src/libstrongswan/plugins/x509/x509_cert.c.
    - CVE-2017-9023

applied/ubuntu/yakkety-devel 2017-05-30 13:08:21 UTC 2017-05-30
Import patches-applied version 5.3.5-1ubuntu4.3 to applied/ubuntu/yakkety-sec...

Author: Marc Deslauriers
Author Date: 2017-05-24 18:58:16 UTC

Import patches-applied version 5.3.5-1ubuntu4.3 to applied/ubuntu/yakkety-security

Imported using git-ubuntu import.

Changelog parent: ee5fd53fe6974b6548a242a33fca647a934c96bc
Unapplied parent: 7d6ee361fc65357b8cdfbe771ad719a829e7cd52

New changelog entries:
  * SECURITY UPDATE: Insufficient Input Validation in gmp Plugin
    - debian/patches/CVE-2017-9022.patch: make sure the modulus is odd and
      the exponent not zero in
      src/libstrongswan/plugins/gmp/gmp_rsa_public_key.c.
    - CVE-2017-9022
  * SECURITY UPDATE: Incorrect Handling of CHOICE types in ASN.1 parser and
    x509 plugin
    - debian/patches/CVE-2017-9023.patch: fix CHOICE parsing in
      src/libstrongswan/asn1/asn1_parser.*,
      src/libstrongswan/plugins/x509/x509_cert.c.
    - CVE-2017-9023

debian/experimental 2017-05-19 16:10:55 UTC 2017-05-19
Import patches-unapplied version 5.5.2-1 to debian/experimental

Author: Yves-Alexis Perez
Author Date: 2017-05-19 09:32:00 UTC

Import patches-unapplied version 5.5.2-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: a799d59abcf619d9257673691f12ce95abef72f2

New changelog entries:
  * New upstream release.
  * debian/patches/03_systemd-service refreshed.
  * debian/libcharon-extra-plugins.install:
    - include curve25519 plugin.
  * debian/libstrongswan-extra-plugins.install:
    - install libtpmtss library.

applied/debian/experimental 2017-05-19 16:10:55 UTC 2017-05-19
Import patches-applied version 5.5.2-1 to applied/debian/experimental

Author: Yves-Alexis Perez
Author Date: 2017-05-19 09:32:00 UTC

Import patches-applied version 5.5.2-1 to applied/debian/experimental

Imported using git-ubuntu import.

Changelog parent: 294025857d11715260051984507ed855b2f1d577
Unapplied parent: 3643afaf0621020188bb5edaaa7d2604a6528da0

New changelog entries:
  * New upstream release.
  * debian/patches/03_systemd-service refreshed.
  * debian/libcharon-extra-plugins.install:
    - include curve25519 plugin.
  * debian/libstrongswan-extra-plugins.install:
    - install libtpmtss library.

ubuntu/yakkety-proposed 2017-05-15 15:23:14 UTC 2017-05-15
Import patches-unapplied version 5.3.5-1ubuntu4.2 to ubuntu/yakkety-proposed

Author: Christian Ehrhardt 
Author Date: 2017-05-15 05:48:30 UTC

Import patches-unapplied version 5.3.5-1ubuntu4.2 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: c4ce0c1d4340348ab63cc7db836869eb902e92ed

New changelog entries:
  * d/p/ikev2-Only-add-NAT-D-notifies-to-DPDs-as-initiator.patch: fix issue
    related to DPD vs iOS10 (LP: #1687711)

applied/ubuntu/yakkety-proposed 2017-05-15 15:23:14 UTC 2017-05-15
Import patches-applied version 5.3.5-1ubuntu4.2 to applied/ubuntu/yakkety-pro...

Author: Christian Ehrhardt 
Author Date: 2017-05-15 05:48:30 UTC

Import patches-applied version 5.3.5-1ubuntu4.2 to applied/ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: b6d5f5c72a9dc3d3019e99066e3ec3c191dfdf84
Unapplied parent: acd9cf52d272a83a4c0b17702005cd8e99151da7

New changelog entries:
  * d/p/ikev2-Only-add-NAT-D-notifies-to-DPDs-as-initiator.patch: fix issue
    related to DPD vs iOS10 (LP: #1687711)

applied/ubuntu/zesty 2017-04-10 09:18:14 UTC 2017-04-10
Import patches-applied version 5.5.1-1ubuntu3 to applied/ubuntu/zesty-proposed

Author: Gianfranco Costamagna
Author Date: 2017-04-10 08:56:49 UTC

Import patches-applied version 5.5.1-1ubuntu3 to applied/ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: ae6a8ce672606dd820cb17b3276d968e16b93148
Unapplied parent: 3a5916e284fc3dd193564d922ca85f0bb083c87d

New changelog entries:
  * Rebuild against new libldns2.

ubuntu/zesty 2017-04-10 09:18:14 UTC 2017-04-10
Import patches-unapplied version 5.5.1-1ubuntu3 to ubuntu/zesty-proposed

Author: Gianfranco Costamagna
Author Date: 2017-04-10 08:56:49 UTC

Import patches-unapplied version 5.5.1-1ubuntu3 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: b33412b7913cc93873792c2e27d992ba6845159e

New changelog entries:
  * Rebuild against new libldns2.

applied/ubuntu/yakkety 2016-04-29 18:04:21 UTC 2016-04-29
Import patches-applied version 5.3.5-1ubuntu4 to applied/ubuntu/yakkety-proposed

Author: Graham Inggs
Author Date: 2016-04-29 17:04:22 UTC

Import patches-applied version 5.3.5-1ubuntu4 to applied/ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: c8277374675e0d7c97d12aa8bd473311a11a631b
Unapplied parent: 6653ffc64796ef2369ff7f6e3f9adaf31d2afabd

New changelog entries:
  * Build-depend on libjson-c-dev instead of libjson0-dev.
  * Rebuild against libjson-c3.

ubuntu/yakkety 2016-04-29 18:04:21 UTC 2016-04-29
Import patches-unapplied version 5.3.5-1ubuntu4 to ubuntu/yakkety-proposed

Author: Graham Inggs
Author Date: 2016-04-29 17:04:22 UTC

Import patches-unapplied version 5.3.5-1ubuntu4 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: fb571670781cdb7e09d4735cab824a86ae2d23f1

New changelog entries:
  * Build-depend on libjson-c-dev instead of libjson0-dev.
  * Rebuild against libjson-c3.

applied/ubuntu/xenial 2016-04-05 13:34:21 UTC 2016-04-05
Import patches-applied version 5.3.5-1ubuntu3 to applied/ubuntu/xenial-proposed

Author: Robie Basak
Author Date: 2016-04-05 13:02:48 UTC

Import patches-applied version 5.3.5-1ubuntu3 to applied/ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: db45500ae17a065d6c313c71f0bd3ec87e7d845c
Unapplied parent: 5556ea4ccdc1718890f87b3aaa8ce9f6bb143cb2

New changelog entries:
  * Rebuild against libmysqlclient20.

ubuntu/xenial 2016-04-05 13:34:21 UTC 2016-04-05
Import patches-unapplied version 5.3.5-1ubuntu3 to ubuntu/xenial-proposed

Author: Robie Basak
Author Date: 2016-04-05 13:02:48 UTC

Import patches-unapplied version 5.3.5-1ubuntu3 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 78452afc45057c5b1fa4c0ce9040ed60889a1486

New changelog entries:
  * Rebuild against libmysqlclient20.

applied/debian/wheezy 2016-04-02 23:43:42 UTC 2016-04-02
Import patches-applied version 4.5.2-1.5+deb7u8 to applied/debian/wheezy

Author: Yves-Alexis Perez
Author Date: 2015-11-16 11:26:13 UTC

Import patches-applied version 4.5.2-1.5+deb7u8 to applied/debian/wheezy

Imported using git-ubuntu import.

Changelog parent: c36838992bcee52e42ee97313bedd08db93d6c24
Unapplied parent: 7a534dd8a63f81c399d2bf11cb60f548e1368318

New changelog entries:
  * debian/patches:
    - CVE-2015-8023_eap_mschapv2_state added, fix authentication bypass when
    using EAP MSCHAPv2.

debian/wheezy 2016-04-02 23:43:42 UTC 2016-04-02
Import patches-unapplied version 4.5.2-1.5+deb7u8 to debian/wheezy

Author: Yves-Alexis Perez
Author Date: 2015-11-16 11:26:13 UTC

Import patches-unapplied version 4.5.2-1.5+deb7u8 to debian/wheezy

Imported using git-ubuntu import.

Changelog parent: bcbdb3f0b30d9f7ed3b7da4523799b2ef276d9fe

New changelog entries:
  * debian/patches:
    - CVE-2015-8023_eap_mschapv2_state added, fix authentication bypass when
    using EAP MSCHAPv2.

ubuntu/vivid-updates 2015-11-16 18:24:35 UTC 2015-11-16
Import patches-unapplied version 5.1.2-0ubuntu5.3 to ubuntu/vivid-security

Author: Marc Deslauriers
Author Date: 2015-11-11 12:59:37 UTC

Import patches-unapplied version 5.1.2-0ubuntu5.3 to ubuntu/vivid-security

Imported using git-ubuntu import.

Changelog parent: c73c799c96b4eb5ebe74270d433299009c64f212

New changelog entries:
  * SECURITY UPDATE: authentication bypass in eap-mschapv2 plugin
    - debian/patches/CVE-2015-8023.patch: only succeed authentication if
      MSK was established in
      src/libcharon/plugins/eap_mschapv2/eap_mschapv2.c.
    - CVE-2015-8023

ubuntu/vivid-security 2015-11-16 18:24:35 UTC 2015-11-16
Import patches-unapplied version 5.1.2-0ubuntu5.3 to ubuntu/vivid-security

Author: Marc Deslauriers
Author Date: 2015-11-11 12:59:37 UTC

Import patches-unapplied version 5.1.2-0ubuntu5.3 to ubuntu/vivid-security

Imported using git-ubuntu import.

Changelog parent: c73c799c96b4eb5ebe74270d433299009c64f212

New changelog entries:
  * SECURITY UPDATE: authentication bypass in eap-mschapv2 plugin
    - debian/patches/CVE-2015-8023.patch: only succeed authentication if
      MSK was established in
      src/libcharon/plugins/eap_mschapv2/eap_mschapv2.c.
    - CVE-2015-8023

ubuntu/vivid-devel 2015-11-16 18:24:35 UTC 2015-11-16
Import patches-unapplied version 5.1.2-0ubuntu5.3 to ubuntu/vivid-security

Author: Marc Deslauriers
Author Date: 2015-11-11 12:59:37 UTC

Import patches-unapplied version 5.1.2-0ubuntu5.3 to ubuntu/vivid-security

Imported using git-ubuntu import.

Changelog parent: c73c799c96b4eb5ebe74270d433299009c64f212

New changelog entries:
  * SECURITY UPDATE: authentication bypass in eap-mschapv2 plugin
    - debian/patches/CVE-2015-8023.patch: only succeed authentication if
      MSK was established in
      src/libcharon/plugins/eap_mschapv2/eap_mschapv2.c.
    - CVE-2015-8023

ubuntu/wily-security 2015-11-16 18:24:35 UTC 2015-11-16
Import patches-unapplied version 5.1.2-0ubuntu6.2 to ubuntu/wily-security

Author: Marc Deslauriers
Author Date: 2015-11-16 15:10:31 UTC

Import patches-unapplied version 5.1.2-0ubuntu6.2 to ubuntu/wily-security

Imported using git-ubuntu import.

Changelog parent: bde83fea5dd2f12d62f3e09164a7f7c4985bbfe8

New changelog entries:
  * SECURITY UPDATE: authentication bypass in eap-mschapv2 plugin
    - debian/patches/CVE-2015-8023.patch: only succeed authentication if
      MSK was established in
      src/libcharon/plugins/eap_mschapv2/eap_mschapv2.c.
    - CVE-2015-8023
  * debian/patches/disable_ntru_test.patch: disable test causing FTBFS
    until regression is properly investigated.

applied/ubuntu/wily-updates 2015-11-16 18:24:35 UTC 2015-11-16
Import patches-applied version 5.1.2-0ubuntu6.2 to applied/ubuntu/wily-security

Author: Marc Deslauriers
Author Date: 2015-11-16 15:10:31 UTC

Import patches-applied version 5.1.2-0ubuntu6.2 to applied/ubuntu/wily-security

Imported using git-ubuntu import.

Changelog parent: f291bc1d80c205206d8d52befa1e3002ff775099
Unapplied parent: ee24e709edef1be92cc6d669e1e3e75d18b39f94

New changelog entries:
  * SECURITY UPDATE: authentication bypass in eap-mschapv2 plugin
    - debian/patches/CVE-2015-8023.patch: only succeed authentication if
      MSK was established in
      src/libcharon/plugins/eap_mschapv2/eap_mschapv2.c.
    - CVE-2015-8023
  * debian/patches/disable_ntru_test.patch: disable test causing FTBFS
    until regression is properly investigated.

applied/ubuntu/wily-security 2015-11-16 18:24:35 UTC 2015-11-16
Import patches-applied version 5.1.2-0ubuntu6.2 to applied/ubuntu/wily-security

Author: Marc Deslauriers
Author Date: 2015-11-16 15:10:31 UTC

Import patches-applied version 5.1.2-0ubuntu6.2 to applied/ubuntu/wily-security

Imported using git-ubuntu import.

Changelog parent: f291bc1d80c205206d8d52befa1e3002ff775099
Unapplied parent: ee24e709edef1be92cc6d669e1e3e75d18b39f94

New changelog entries:
  * SECURITY UPDATE: authentication bypass in eap-mschapv2 plugin
    - debian/patches/CVE-2015-8023.patch: only succeed authentication if
      MSK was established in
      src/libcharon/plugins/eap_mschapv2/eap_mschapv2.c.
    - CVE-2015-8023
  * debian/patches/disable_ntru_test.patch: disable test causing FTBFS
    until regression is properly investigated.

1100 of 192 results
You can't create new repositories for strongswan in Ubuntu.