lp:~ubuntu-desktop/totem-pl-parser/ubuntu

Created by Michael Vogt on 2009-01-07 and last modified on 2015-08-03
Get this branch:
bzr branch lp:~ubuntu-desktop/totem-pl-parser/ubuntu
Members of Ubuntu Desktop can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu Desktop
Project:
totem-pl-parser
Status:
Development

Recent revisions

51. By Daniel Holbach on 2015-08-03

* New upstream release
* Wrap dependencies and drop obsolete Conflicts and Replaces from
  pre-wheezy.
* Split the translations from libtotem-plparser18 into a separate
  libtotem-plparser-common package which is Architecture: all. Make
  libtotem-plparser18 depend on that package.
* Convert the package to multiarch.
* Bump debhelper compatility level to 9.
* Bump Standards-Version to 3.9.6.
* debian/control.in:
  + Let libtotem-plparser-dev depend on libquvi-dev, needed by the
    pkg-config file.
* Add debian/patches/totem-pl-parser-use-old-quvi.patch
  - reverts upstream commit 24970018abfcedcaa496
    "plparse: Port to libquvi 0.9"
    because we don't have this version in unstable yet.
* debian/rules: use autoreconf because of above patch
* Re-add libquvi build-dependency
* Add build-dependencies on dh-autoreconf and libgcrypt20-dev
* Run wrap-and-sort
* Make libquvi build-dependency >= 0.4.1-2.1~
  - this would avoid pulling in both lua 5.1 and 5.2 in same process
    (since totem crashes on startup if we do this) if libquvi had
    a "Build-Depends-Package" in its symbols file.... oh well.
* New upstream release.

50. By Daniel Holbach on 2014-05-13

* Merge from Debian unstable. Remaining changes:
  - debian/patches/ppc64el.diff:
    + Patch m4/libtool.m4 and libtool.m4 for ppc64el.
* New upstream release.
* Upload to unstable.
* New upstream release.
* Patch m4/libtool.m4 and libtool.m4 for ppc64el.
* New upstream release.
* Update build-dependencies according to configure.ac:
  - Bump libsoup-gnome2.4-dev to >= 2.43.0
  - Bump libarchive-dev to >= 3.0
  - Drop libquvi-dev (new quvi has incompatible license)
* Rename package for new SONAME (17->18)
* Update debian/libtotem-plparser18.symbols
* Remove libquvi-dev dependency from libtotem-plparser-dev, the library no
  longer links against libquvi.
* Add replaces on libtotem-plparser17 for the translations
* New upstream release.
* Upload to unstable.
* The dependency on newer glib versions has been removed by not using
  g_clear_pointer(). Lower the Build-Depends accordingly.
* Bump Standards-Version to 3.9.4. No further changes.
* New upstream release.
* Team upload
* New upstream bug fix release
  - build-depend on GLib 2.34, for g_clear_pointer()
* New upstream release.
* New upstream bug fix release.
* Drop explicit Build-Depends on gir1.2-glib-2.0 and bump Build-Depends on
  libgirepository1.0-dev accordingly.
* New upstream release.
* Don't bother setting a shlibs version and just use -V since we have a
  symbols file.
* Build gtk-doc documentation.
* Update Vcs-* URLs.
* Bump Standards-Version to 3.9.3.
* Switch to gmime 2.6.
* New upstream release.
* debian/patches/01-libquvi-0.4.patch: Removed, merged upstream.
* debian/control.in: Bump (Build-)Depends on libglib2.0-dev to (>= 2.31.0).
* debian/watch: Track .xz tarballs.
* Bump debhelper compatibility level to 8.
  - Strip debian/tmp/ from .install files.
  - Bump Build-Depends on debhelper.
* Change section of gir1.2-totem-plparser-1.0 to introspection.
* Rely on cdbs to call dh_girepository instead of calling it explicitly.
  Bump Build-Depends on cdbs accordingly.
* debian/patches/01-libquvi-0.4.patch:
  - Make totem-pl-parser build against libquvi 0.4. Patch is backwards
    compatible with libquvi 0.2. Thanks Ansgar Burchardt for the patch.
    Closes: #651637
* debian/watch: Look for bzip2 tarballs.
* New upstream release:
  - Fix parsing of remote RSS feeds
  - Add support for M4U/MXU playlists
* debian/control.in: Add libarchive-dev dependency to libtotem-plparser-dev
  as well.
* New upstream release.
  - debian/control.in: Bump libquvi-dev build dep and add libarchive-dev
    build dep as per configure.in.
* debian/control.in: Add Vcs-* fields.
* debian/watch: Fix syntax to actually catch current version.
* debian/control.in: Bump Standards-Version to 3.9.2 (no changes necessary).
* Team upload.
* Upload to unstable to fix pkg-config breakage mistakenly introduced by
  2.32.4-1. Closes: #622214
* Team upload.
* Add libquvi-dev to the dependencies of libtotem-pl-parser-dev.
* Team upload.
* Make the -dev package depend on the gir package.
* New upstream release 2.32.4.
* Drop an unneeded section field (duplication the source entry).
* New upstream release.
  + debian/control.in:
    - Updated build dependencies.
  + debian/libtotem-plparser17.symbols:
    - Updated for the new symbols.
* New upstream release.
* Update to the new gir policy:
  - Rename gir1.0-totem-plparser-1.0 to gir1.2-totem-plparser-1.0.
  - Bump the gobject-introspection build dependency.
  - Build depend on gir1.2 packages.
* debian/control.in:
  - Remove unneeded libgtk2.0-dev and gir-repository-dev build
    dependencies.
* debian/rules,
  debian/source/format:
  - Switch to source format 3.0 (quilt).
* debian/libtotem-plparser17.symbols:
  - Added.

49. By Sebastien Bacher on 2010-11-09

releasing version 2.32.1-0ubuntu1

48. By Sebastien Bacher on 2010-10-15

releasing version 2.32.0-0ubuntu1

47. By Sebastien Bacher on 2010-10-15

New upstream version

46. By Sebastien Bacher on 2010-10-15

releasing version 2.30.3-1ubuntu1

45. By Sebastien Bacher on 2010-08-10

releasing version 2.30.2-1build1

44. By Sebastien Bacher on 2010-08-10

releasing version 2.30.2-1

43. By Sebastien Bacher on 2010-04-14

releasing version 2.30.0git201000413-0ubuntu1

42. By Sebastien Bacher on 2010-04-08

releasing version 2.30.0-2ubuntu1

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.

Subscribers