lp:ubuntu/karmic/mplayer

Created by James Westby on 2009-08-19 and last modified on 2009-10-19
Get this branch:
bzr branch lp:ubuntu/karmic/mplayer
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Development

Recent revisions

60. By Reinhard Tartler on 2009-10-15

make sure that patches are applied for non-i386 builds as well.
Fixes: LP: #390398, #448603, #448595, #441566, #440346

59. By Reinhard Tartler on 2009-10-08

[ Julien Lavergne ]
* Renable xvid support by removing --disable-xvid in debian/rules.

[ Reinhard Tartler ]
* Also enable mp3lame support (at least for now) LP: #386449
* don't override the mplayer built-in defaults for the vo module LP: #446040
* verified that mennuc's screensaver patch is enabled and works in the default
  configuration. LP: #439787

58. By Reinhard Tartler on 2009-10-03

* build depend on nvidia-185-libvdpau-dev only on i386 and amd64
* add ubuntu specific configuration file. LP: #276957, #440343

57. By Reinhard Tartler on 2009-09-28

* remove 41_use_fontconfig_by_default.patch, doesn't apply
* enable VDPAU on i386 and amd64 (LP: #437039)

56. By Reinhard Tartler on 2009-09-24

[ Andres Mejia ]
* Enable VDPAU support by including vdpau headers in deb packaging.

[ Reinhard Tartler ]
* sort build dependencies alphabetically
* avoid using tabs - prefer space instead
* reenable 22disable-xscreensaver.patch. The patch does work, but you
  need to have the mouse cursor INSIDE the window
* don't build-depend on libmad, the internal mp3lib library is superiour
  for most cases these days, according to upstream. LP: #111025, #163382
* add clarifications to the libgsm license.
* install the TOOLS/midentify.sh script LP: #333828

55. By StefanPotyra on 2009-08-28

No-change rebuild to pick up new ffmpeg shlibs file.

54. By Reinhard Tartler on 2009-06-18

* remove 22disable-xscreensaver.patch. Patch is not working properly
  anyways and actually potentially dangerous because it is faking input
  activity.
* enable fontconfig by default.

53. By Reinhard Tartler on 2009-06-15

[ Reinhard Tartler ]
* add additional build dependencies that are available in
  ubuntu/multiverse LP: #386449
* prefer auto-detection and lavc variants of many codecs in debian/rules
* install .desktop and .xpm file in the mplayer package

[ Siegfried Gevatter ]
* improve desktop file to conform (more) to the freedesktop file
  specification LP: #386505

52. By Reinhard Tartler on 2009-06-08

Bump epoch in debian/control as well, so that the Replaces field has
any effect in ubuntu

51. By Reinhard Tartler on 2009-06-06

* Switch to debian packaging for the mplayer package
* New upstream release, LP: #336697, #260918, #246675, #243453, #74282
* Fixes security issues: CVE-2008-5616, LP: #308939
* many flv fixes LP: #73271, #347021
* Build and install mencoder
* Bump epoch

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/lucid/mplayer
This branch contains Public information 
Everyone can see this information.

Subscribers