Code review comment for lp:~martin-lp/hipl/hipl_exp_backoff

Revision history for this message
David Martin (martin-lp) wrote :

Hi,

On Thu, Mar 8, 2012 at 7:00 PM, Diego Biurrun <email address hidden> wrote:
> review approve
>
> On Wed, Mar 07, 2012 at 06:05:28PM +0000, David Martin wrote:
>> David Martin has proposed merging lp:~martin-lp/hipl/hipl_exp_backoff into lp:hipl.
>
> No real comments from me, looks sane overall. If this is well-tested,
> I trust you it will be fine.

Tested it on the N900, netbook and VMs. Did not have a look at the
more exotic HIPL scenarios with shotgunning or relays and what other
stuff there is though. Fingers crossed those will be fine I guess.

>> --- hipd/maintenance.c 2012-02-15 17:37:10 +0000
>> +++ hipd/maintenance.c 2012-03-07 18:04:31 +0000
>> @@ -87,6 +86,31 @@
>> static struct hip_ll *maintenance_functions;
>>
>> /**
>> + * Update the retransmission backoff of the given retransmission.
>> + * The backoff will simply be doubled and in case the maximum is exceeded the
>> + * retransmissions are disabled.
>
> in case the maximum is exceeded retransmissions are

Fixed in revision 6304.

>> +static void update_retrans_backoff(struct hip_msg_retrans *const retrans)
>> +{
>> + retrans->current_backoff = retrans->current_backoff << 1;
>> + if (retrans->current_backoff > HIP_RETRANSMIT_BACKOFF_MAX) {
>> + HIP_DEBUG("Maximum retransmission backoff reached. Stopping"
>> + " retransmission.\n");
>
> retransmissionS I think.

I had the plural before but decided to change it. Directly quoted from
the commit log:

> "Stopping retransmissions." sounds like no more retransmissions will be
> sent at all but it only refers to this specific one. "Stopping "
> retransmission." makes it more clear.

« Back to merge proposal