Name Status Last Modified Last Commit
lp:ubuntu/vivid-security/ffmpeg bug 2 Mature 2015-08-07 23:03:01 UTC 2015-08-07
62. Import new upstream bugfix release 2....

Author: Andreas Cadhalpun
Revision Date: 2015-07-31 15:50:07 UTC

Import new upstream bugfix release 2.5.8. (LP: #1480311)

lp:ubuntu/wily/ffmpeg 1 Development 2015-08-07 10:20:45 UTC 2015-08-07
34. No-change rebuild for opencv library ...

Author: Matthias Klose
Revision Date: 2015-08-07 11:43:18 UTC

No-change rebuild for opencv library renames.

lp:ubuntu/wily-proposed/ffmpeg 1 Development 2015-08-07 10:20:45 UTC 2015-08-07
34. No-change rebuild for opencv library ...

Author: Matthias Klose
Revision Date: 2015-08-07 11:43:18 UTC

No-change rebuild for opencv library renames.

lp:ubuntu/vivid-updates/ffmpeg 2 Mature 2015-07-31 15:50:07 UTC 2015-07-31
62. Import new upstream bugfix release 2....

Author: Andreas Cadhalpun
Revision Date: 2015-07-31 15:50:07 UTC

Import new upstream bugfix release 2.5.8. (LP: #1480311)

lp:ubuntu/vivid/ffmpeg 2 Mature 2015-02-14 23:14:52 UTC 2015-02-14
59. * Import new upstream bugfix release ...

Author: Andreas Cadhalpun
Revision Date: 2015-02-14 23:14:52 UTC

* Import new upstream bugfix release 2.5.4.
* Drop configure-enable-vsx-together-with-altivec-for-ppc64el.patch
  included upstream.
* Add patches making the build binary reproducible.
* Stop using faketime.
* Correctly handle noopt in DEB_BUILD_OPTIONS.
* Disable assembler optimizations on ppc64el, as they don't work yet.
* Disable assembler optimizations on mips64(el), as they don't work yet.
  Thanks to James Cowgill. (Closes: #776649)
* Fix dep5-copyright-license-name-not-unique lintian warnings.

lp:ubuntu/vivid-proposed/ffmpeg 1 Development 2015-02-14 23:14:52 UTC 2015-02-14
25. * Import new upstream bugfix release ...

Author: Andreas Cadhalpun
Revision Date: 2015-02-14 23:14:52 UTC

* Import new upstream bugfix release 2.5.4.
* Drop configure-enable-vsx-together-with-altivec-for-ppc64el.patch
  included upstream.
* Add patches making the build binary reproducible.
* Stop using faketime.
* Correctly handle noopt in DEB_BUILD_OPTIONS.
* Disable assembler optimizations on ppc64el, as they don't work yet.
* Disable assembler optimizations on mips64(el), as they don't work yet.
  Thanks to James Cowgill. (Closes: #776649)
* Fix dep5-copyright-license-name-not-unique lintian warnings.

lp:ubuntu/utopic/ffmpeg 2 Mature 2014-04-24 11:15:59 UTC 2014-04-24
55. releasing version 4:0.6.1-5ubuntu2

Author: Dustin Kirkland 
Revision Date: 2011-03-14 15:21:23 UTC

releasing version 4:0.6.1-5ubuntu2

lp:ubuntu/trusty/ffmpeg 2 Mature 2013-10-19 22:05:21 UTC 2013-10-19
55. releasing version 4:0.6.1-5ubuntu2

Author: Dustin Kirkland 
Revision Date: 2011-03-14 15:21:23 UTC

releasing version 4:0.6.1-5ubuntu2

lp:ubuntu/saucy/ffmpeg 2 Mature 2013-04-25 16:23:59 UTC 2013-04-25
55. releasing version 4:0.6.1-5ubuntu2

Author: Dustin Kirkland 
Revision Date: 2011-03-14 15:21:23 UTC

releasing version 4:0.6.1-5ubuntu2

lp:ubuntu/lucid-updates/ffmpeg bug 2 Mature 2013-01-28 14:41:24 UTC 2013-01-28
48. * SECURITY UPDATE: unspecified securi...

Author: Marc Deslauriers
Revision Date: 2013-01-24 13:48:47 UTC

* SECURITY UPDATE: unspecified security issue in vp56.c (LP: #1104019)
  - debian/patches/CVE-2012-2783.patch: release frames on error in
    libavcodec/vp56.c.
  - CVE-2012-2783
* SECURITY UPDATE: double free vulnerability in mpeg_decode_frame
  - debian/patches/CVE-2012-2803.patch: do not decode extradata more than
    once in libavcodec/mpeg12.c.
  - CVE-2012-2803

lp:ubuntu/lucid-security/ffmpeg bug 2 Mature 2013-01-28 14:41:20 UTC 2013-01-28
48. * SECURITY UPDATE: unspecified securi...

Author: Marc Deslauriers
Revision Date: 2013-01-24 13:48:47 UTC

* SECURITY UPDATE: unspecified security issue in vp56.c (LP: #1104019)
  - debian/patches/CVE-2012-2783.patch: release frames on error in
    libavcodec/vp56.c.
  - CVE-2012-2783
* SECURITY UPDATE: double free vulnerability in mpeg_decode_frame
  - debian/patches/CVE-2012-2803.patch: do not decode extradata more than
    once in libavcodec/mpeg12.c.
  - CVE-2012-2803

lp:ubuntu/raring/ffmpeg 2 Mature 2012-10-19 17:02:26 UTC 2012-10-19
55. releasing version 4:0.6.1-5ubuntu2

Author: Dustin Kirkland 
Revision Date: 2011-03-14 15:21:23 UTC

releasing version 4:0.6.1-5ubuntu2

lp:ubuntu/quantal/ffmpeg 2 Mature 2012-04-26 18:22:09 UTC 2012-04-26
55. releasing version 4:0.6.1-5ubuntu2

Author: Dustin Kirkland 
Revision Date: 2011-03-14 15:21:23 UTC

releasing version 4:0.6.1-5ubuntu2

lp:ubuntu/maverick-security/ffmpeg bug 2 Mature 2011-12-21 10:46:50 UTC 2011-12-21
54. * SECURITY UPDATE: denial of service ...

Author: Marc Deslauriers
Revision Date: 2011-12-21 10:46:50 UTC

* SECURITY UPDATE: denial of service and possible code execution via
  malformed Matroska file
  - debian/patches/CVE-2011-3504.patch: verify memory allocation failures
    in libavformat/matroskadec.c.
  - CVE-2011-3504
* SECURITY UPDATE: denial of service and possible code execution via
  malformed file containing QDM2 stream
  - debian/patches/CVE-2011-4351.patch: check boundaries in
    libavcodec/qdm2.c.
  - CVE-2011-4351
* SECURITY UPDATE: denial of service and possible code execution via
  malformed file containing VP3 stream
  - debian/patches/CVE-2011-4352.patch: check coefficient index in
    libavcodec/vp3.c.
  - CVE-2011-4352
* SECURITY UPDATE: denial of service and possible code execution via
  malformed file containing VP5 or VP6 streams
  - debian/patches/CVE-2011-4353.patch: check indexes in libavcodec/vp5.c
    and libavcodec/vp6.c.
  - CVE-2011-4353
* SECURITY UPDATE: denial of service and possible code execution via
  malformed VMD file
  - debian/patches/CVE-2011-4364.patch: properly check lengths in
    libavcodec/vmdav.c.
  - CVE-2011-4364
* SECURITY UPDATE: denial of service and possible code execution via
  malformed file containing svq1 stream
  - debian/patches/CVE-2011-4579.patch: set dimensions after they have
    changed in libavcodec/svq1dec.c.
  - CVE-2011-4579

lp:ubuntu/maverick-updates/ffmpeg 2 Mature 2011-12-21 10:46:50 UTC 2011-12-21
54. * SECURITY UPDATE: denial of service ...

Author: Marc Deslauriers
Revision Date: 2011-12-21 10:46:50 UTC

* SECURITY UPDATE: denial of service and possible code execution via
  malformed Matroska file
  - debian/patches/CVE-2011-3504.patch: verify memory allocation failures
    in libavformat/matroskadec.c.
  - CVE-2011-3504
* SECURITY UPDATE: denial of service and possible code execution via
  malformed file containing QDM2 stream
  - debian/patches/CVE-2011-4351.patch: check boundaries in
    libavcodec/qdm2.c.
  - CVE-2011-4351
* SECURITY UPDATE: denial of service and possible code execution via
  malformed file containing VP3 stream
  - debian/patches/CVE-2011-4352.patch: check coefficient index in
    libavcodec/vp3.c.
  - CVE-2011-4352
* SECURITY UPDATE: denial of service and possible code execution via
  malformed file containing VP5 or VP6 streams
  - debian/patches/CVE-2011-4353.patch: check indexes in libavcodec/vp5.c
    and libavcodec/vp6.c.
  - CVE-2011-4353
* SECURITY UPDATE: denial of service and possible code execution via
  malformed VMD file
  - debian/patches/CVE-2011-4364.patch: properly check lengths in
    libavcodec/vmdav.c.
  - CVE-2011-4364
* SECURITY UPDATE: denial of service and possible code execution via
  malformed file containing svq1 stream
  - debian/patches/CVE-2011-4579.patch: set dimensions after they have
    changed in libavcodec/svq1dec.c.
  - CVE-2011-4579

lp:ubuntu/precise/ffmpeg 2 Mature 2011-10-13 18:31:02 UTC 2011-10-13
55. releasing version 4:0.6.1-5ubuntu2

Author: Dustin Kirkland 
Revision Date: 2011-03-14 15:21:23 UTC

releasing version 4:0.6.1-5ubuntu2

lp:ubuntu/oneiric/ffmpeg 2 Mature 2011-04-28 19:57:49 UTC 2011-04-28
55. releasing version 4:0.6.1-5ubuntu2

Author: Dustin Kirkland 
Revision Date: 2011-03-14 15:21:23 UTC

releasing version 4:0.6.1-5ubuntu2

lp:ubuntu/karmic-security/ffmpeg bug 2 Mature 2011-04-04 17:41:14 UTC 2011-04-04
40. * SECURITY UPDATE: arbitrary code exe...

Author: Marc Deslauriers
Revision Date: 2011-03-31 13:39:29 UTC

* SECURITY UPDATE: arbitrary code execution via crafted flic file
  - debian/patches/CVE-2010-3429.patch: add checks to
    libavcodec/flicvideo.c.
  - CVE-2010-3429
* SECURITY UPDATE: arbitrary code execution via crafted wmv file
  (LP: #690169)
  - debian/patches/CVE-2010-3908.patch: properly calculate size in
    libavcodec/utils.c.
  - CVE-2010-3908
* SECURITY UPDATE: denial of service via crafted .ogg file
  - debian/patches/CVE-2010-4704.patch: validate codebook in
    libavcodec/vorbis_dec.c.
  - CVE-2010-4704
* SECURITY UPDATE: denial of service and possible code execution via
  crafted WebM file
  - debian/patches/CVE-2011-0480.patch: check rangebits in
    libavcodec/vorbis_dec.c.
  - CVE-2011-0480
* SECURITY UPDATE: arbitrary code execution via crafted RealMedia file
  (LP: #690169)
  - debian/patches/CVE-2011-0722.patch: set dimensions in
    libavcodec/rv34.c.
  - CVE-2011-0722
* SECURITY UPDATE: denial of service and possible code execution via
  crafted VC1 file (LP: #690169)
  - debian/patches/CVE-2011-0723.patch: fix invalid reads in
    libavcodec/vc1dec.c.
  - CVE-2011-0723

lp:ubuntu/hardy-security/ffmpeg bug 2 Mature 2011-04-04 17:37:15 UTC 2011-04-04
23. * SECURITY UPDATE: arbitrary code exe...

Author: Marc Deslauriers
Revision Date: 2011-03-31 13:54:41 UTC

* SECURITY UPDATE: arbitrary code execution via crafted flic file
  - debian/patches/CVE-2010-3429.patch: add checks to
    libavcodec/flicvideo.c.
  - CVE-2010-3429
* SECURITY UPDATE: arbitrary code execution via crafted wmv file
  (LP: #690169)
  - debian/patches/CVE-2010-3908.patch: properly calculate size in
    libavcodec/utils.c.
  - CVE-2010-3908
* SECURITY UPDATE: denial of service via crafted .ogg file
  - debian/patches/CVE-2010-4704.patch: validate codebook in
    libavcodec/vorbis.c.
  - CVE-2010-4704
* SECURITY UPDATE: denial of service and possible code execution via
  crafted WebM file
  - debian/patches/CVE-2011-0480.patch: check rangebits in
    libavcodec/vorbis.c.
  - CVE-2011-0480
* SECURITY UPDATE: denial of service and possible code execution via
  crafted VC1 file (LP: #690169)
  - debian/patches/CVE-2011-0723.patch: fix invalid reads in
    libavcodec/vc1dec.c.
  - CVE-2011-0723

lp:ubuntu/hardy-updates/ffmpeg 2 Mature 2011-03-31 13:54:41 UTC 2011-03-31
23. * SECURITY UPDATE: arbitrary code exe...

Author: Marc Deslauriers
Revision Date: 2011-03-31 13:54:41 UTC

* SECURITY UPDATE: arbitrary code execution via crafted flic file
  - debian/patches/CVE-2010-3429.patch: add checks to
    libavcodec/flicvideo.c.
  - CVE-2010-3429
* SECURITY UPDATE: arbitrary code execution via crafted wmv file
  (LP: #690169)
  - debian/patches/CVE-2010-3908.patch: properly calculate size in
    libavcodec/utils.c.
  - CVE-2010-3908
* SECURITY UPDATE: denial of service via crafted .ogg file
  - debian/patches/CVE-2010-4704.patch: validate codebook in
    libavcodec/vorbis.c.
  - CVE-2010-4704
* SECURITY UPDATE: denial of service and possible code execution via
  crafted WebM file
  - debian/patches/CVE-2011-0480.patch: check rangebits in
    libavcodec/vorbis.c.
  - CVE-2011-0480
* SECURITY UPDATE: denial of service and possible code execution via
  crafted VC1 file (LP: #690169)
  - debian/patches/CVE-2011-0723.patch: fix invalid reads in
    libavcodec/vc1dec.c.
  - CVE-2011-0723

lp:ubuntu/karmic-updates/ffmpeg 2 Mature 2011-03-31 13:39:29 UTC 2011-03-31
40. * SECURITY UPDATE: arbitrary code exe...

Author: Marc Deslauriers
Revision Date: 2011-03-31 13:39:29 UTC

* SECURITY UPDATE: arbitrary code execution via crafted flic file
  - debian/patches/CVE-2010-3429.patch: add checks to
    libavcodec/flicvideo.c.
  - CVE-2010-3429
* SECURITY UPDATE: arbitrary code execution via crafted wmv file
  (LP: #690169)
  - debian/patches/CVE-2010-3908.patch: properly calculate size in
    libavcodec/utils.c.
  - CVE-2010-3908
* SECURITY UPDATE: denial of service via crafted .ogg file
  - debian/patches/CVE-2010-4704.patch: validate codebook in
    libavcodec/vorbis_dec.c.
  - CVE-2010-4704
* SECURITY UPDATE: denial of service and possible code execution via
  crafted WebM file
  - debian/patches/CVE-2011-0480.patch: check rangebits in
    libavcodec/vorbis_dec.c.
  - CVE-2011-0480
* SECURITY UPDATE: arbitrary code execution via crafted RealMedia file
  (LP: #690169)
  - debian/patches/CVE-2011-0722.patch: set dimensions in
    libavcodec/rv34.c.
  - CVE-2011-0722
* SECURITY UPDATE: denial of service and possible code execution via
  crafted VC1 file (LP: #690169)
  - debian/patches/CVE-2011-0723.patch: fix invalid reads in
    libavcodec/vc1dec.c.
  - CVE-2011-0723

lp:ubuntu/natty/ffmpeg bug 2 Mature 2011-03-14 15:21:23 UTC 2011-03-14
55. releasing version 4:0.6.1-5ubuntu2

Author: Dustin Kirkland 
Revision Date: 2011-03-14 15:21:23 UTC

releasing version 4:0.6.1-5ubuntu2

lp:~gal-fourier/ubuntu/natty/ffmpeg/bug-734331 bug(Has a merge proposal) 1 Development 2011-03-14 11:48:20 UTC 2011-03-14
58. * Replace cp with tar to avoid an err...

Author: Gal Shalif
Revision Date: 2011-03-14 11:48:20 UTC

* Replace cp with tar to avoid an error of "/bin/cp: Argument list too long" on the ARM platform (running under a QEMU chroot environment) (LP: #734331)
  - Restore a "Doxygen" file that excidentaly got into the changeset of the bug

lp:ubuntu/maverick/ffmpeg bug 2 Mature 2010-10-05 23:22:20 UTC 2010-10-05
51. fix dependency on libswscale-extra-0,...

Author: Reinhard Tartler
Revision Date: 2010-10-05 21:25:53 UTC

fix dependency on libswscale-extra-0, LP: #637895

lp:ubuntu/lucid/ffmpeg 1 Development 2010-03-04 10:34:37 UTC 2010-03-04
42. * merge from debian. remaining change...

Author: Reinhard Tartler
Revision Date: 2010-03-04 10:34:37 UTC

* merge from debian. remaining changes:
  - don't disable encoders
  - don't build against libfaad, libdirac and libopenjpeg (all in universe)

lp:ubuntu/karmic/ffmpeg bug 1 Development 2009-11-03 18:35:38 UTC 2009-11-03
37. [ Reinhard Tartler ] * Make arguments...

Author: Loïc Minier
Revision Date: 2009-10-13 23:56:04 UTC

[ Reinhard Tartler ]
* Make arguments of av_set_pts_info() unsigned.
* update debian/changelog
* use patch for issue1245 from git.ffmpeg.org
* Support constant-quant encoding for libtheora, LP: #356322
* increase swscale compile time width (VOF/VOFW), LP: #443264

[ Loïc Minier ]
* Update config for karmic's armel toolchain.
* Enable neon flavour; LP: #383240.
* Update NEON confflags to assume v7 and VFP.
* Add backported NEON patches from ffmpeg trunk; see debian/patches/neon/.
* Pass proper --cpu and --extra-flags on armel.
* Pass -fPIC -DPIC to neon pass.

lp:ubuntu/jaunty/ffmpeg 2 Mature 2009-11-03 18:13:18 UTC 2009-11-03
29. merge from ubuntu.jaunty branch

Author: Reinhard Tartler
Revision Date: 2009-03-21 14:30:03 UTC

merge from ubuntu.jaunty branch

lp:ubuntu/intrepid/ffmpeg 2 Mature 2009-11-03 18:12:21 UTC 2009-11-03
22. Compile against libfaac-dev, libxvidc...

Author: Lionel Le Folgoc
Revision Date: 2008-10-18 20:32:44 UTC

Compile against libfaac-dev, libxvidcore-dev | libxvidcore4-dev for aac
encoding and xvid support. (LP: #285540)

lp:ubuntu/hardy/ffmpeg 2 Mature 2009-11-03 18:10:47 UTC 2009-11-03
17. * added qt-faststart (LP: #200996) ...

Author: Stephan Ruegamer
Revision Date: 2008-03-11 11:52:21 UTC

* added qt-faststart (LP: #200996)
  reorders the components of an H.264 MPEG4 video file to enable progressive
  download playback of certain H.264 videos in the Flash Player browser plugin.
* debian/rules:
  - build: $(MAKE) qt-faststart
  - install: cp this to debian/tmp/usr/bin/
* debian/ffmpeg.install:
  - added usr/bin/qt-faststart

lp:ubuntu/gutsy/ffmpeg 1 Development 2009-11-03 18:09:50 UTC 2009-11-03
14. make ffmpeg-config not add -ldts and ...

Author: Reinhard Tartler
Revision Date: 2007-06-03 18:21:33 UTC

make ffmpeg-config not add -ldts and -la52 to LDFLAGS. fixes FTBFS in
unrelated packages.

lp:ubuntu/feisty/ffmpeg 1 Development 2009-11-03 18:08:24 UTC 2009-11-03
9. * Have ffmpeg link against the PIC ve...

Author: John Dong
Revision Date: 2007-01-25 12:38:17 UTC

* Have ffmpeg link against the PIC version of x264. Fixes FTBFS on amd64.
  * Does not affect Ubuntu, only applicable when DEB_BUILD_OPTIONS=risky

lp:ubuntu/edgy/ffmpeg 1 Development 2009-11-03 18:07:50 UTC 2009-11-03
6. * Sync with Debian + Added epoch again

Author: Sebastian Dröge
Revision Date: 2006-09-20 00:32:47 UTC

* Sync with Debian
  + Added epoch again

lp:ubuntu/dapper/ffmpeg 2 Mature 2009-11-03 18:06:46 UTC 2009-11-03
2. * Sync with Debian: + Compile with ...

Author: Sebastian Dröge
Revision Date: 2005-11-24 10:40:37 UTC

* Sync with Debian:
  + Compile with -fomit-frame-pointer for x86 to gain a new register in
    some situations... Fixes FTBFS on x86... ugly architecture
  + Add -DRUNTIME_CPUDETECT to CFLAGS to enable runtime CPU feature detection.
    This let ffmpeg work on G3 powerpc for example
  + Re-add epoch

lp:ubuntu/breezy/ffmpeg 1 Development 2009-11-03 18:06:08 UTC 2009-11-03
2. * New upstream (needed for fixed upst...

Author: Daniel T Chen
Revision Date: 2005-09-28 20:21:08 UTC

* New upstream (needed for fixed upstream vlc).
* Readd epoch.

lp:ubuntu/hoary/ffmpeg 1 Development 2009-11-03 18:05:20 UTC 2009-11-03
2. Sync with debian, no source change ot...

Author: LaMont Jones
Revision Date: 2005-02-04 18:04:28 UTC

Sync with debian, no source change other than epoch to override others...

lp:ubuntu/warty/ffmpeg 1 Development 2009-11-03 18:04:44 UTC 2009-11-03
2. Package dsputil.h in the -dev package.

Author: Christian Marillat
Revision Date: 2004-09-12 09:25:16 UTC

Package dsputil.h in the -dev package.

lp:ubuntu/hardy-proposed/ffmpeg bug 2 Mature 2009-07-25 11:24:16 UTC 2009-07-25
19. * SECURITY UPDATE: denial of service ...

Author: Marc Deslauriers
Revision Date: 2009-03-13 13:04:19 UTC

* SECURITY UPDATE: denial of service via a malformed Ogg Media (OGM) file
  - debian/patches/100_security_CVE-2008-4610.diff: properly check return
    codes in libavcodec/vp3.c.
  - CVE-2008-4610
* SECURITY UPDATE: buffer overflow caused by an incorrect DCA_MAX_FRAME_SIZE
  value
  - debian/patches/101_security_CVE-2008-4867.diff: set DCA_MAX_FRAME_SIZE to
    a correct value in libavcodec/dca.c.
  - CVE-2008-4867
* SECURITY UPDATE: arbitrary code execution via a malformed 4X movie file
  (LP: #323620)
  - debian/patches/102_security_CVE-2009-0385.diff: validate current_track
    value in libavformat/4xm.c.
  - CVE-2009-0385

lp:ubuntu/gutsy-security/ffmpeg bug 1 Development 2009-07-25 11:24:07 UTC 2009-07-25
16. * SECURITY UPDATE: denial of service ...

Author: Marc Deslauriers
Revision Date: 2009-03-13 13:20:07 UTC

* SECURITY UPDATE: denial of service via a malformed Ogg Media (OGM) file
  - debian/patches/100_security_CVE-2008-4610.diff: properly check return
    codes in libavcodec/vp3.c.
  - CVE-2008-4610
* SECURITY UPDATE: buffer overflow caused by an incorrect DCA_MAX_FRAME_SIZE
  value
  - debian/patches/101_security_CVE-2008-4867.diff: set DCA_MAX_FRAME_SIZE to
    a correct value in libavcodec/dca.c.
  - CVE-2008-4867
* SECURITY UPDATE: arbitrary code execution via a malformed 4X movie file
  (LP: #323620)
  - debian/patches/102_security_CVE-2009-0385.diff: validate current_track
    value in libavformat/4xm.c.
  - CVE-2009-0385

lp:ubuntu/gutsy-updates/ffmpeg 1 Development 2009-07-25 11:22:24 UTC 2009-07-25
16. * SECURITY UPDATE: denial of service ...

Author: Marc Deslauriers
Revision Date: 2009-03-13 13:20:07 UTC

* SECURITY UPDATE: denial of service via a malformed Ogg Media (OGM) file
  - debian/patches/100_security_CVE-2008-4610.diff: properly check return
    codes in libavcodec/vp3.c.
  - CVE-2008-4610
* SECURITY UPDATE: buffer overflow caused by an incorrect DCA_MAX_FRAME_SIZE
  value
  - debian/patches/101_security_CVE-2008-4867.diff: set DCA_MAX_FRAME_SIZE to
    a correct value in libavcodec/dca.c.
  - CVE-2008-4867
* SECURITY UPDATE: arbitrary code execution via a malformed 4X movie file
  (LP: #323620)
  - debian/patches/102_security_CVE-2009-0385.diff: validate current_track
    value in libavformat/4xm.c.
  - CVE-2009-0385

lp:ubuntu/feisty-updates/ffmpeg 1 Development 2009-07-25 11:21:45 UTC 2009-07-25
10. * SECURITY UPDATE: crash from crafted...

Author: Kees Cook
Revision Date: 2008-07-23 13:28:45 UTC

* SECURITY UPDATE: crash from crafted STR file.
* Add debian/patches/400_str_file_crash.diff: backported upstream fixes.
* References
  CVE-2008-3162

lp:ubuntu/feisty-security/ffmpeg 1 Development 2009-07-25 11:21:37 UTC 2009-07-25
10. * SECURITY UPDATE: crash from crafted...

Author: Kees Cook
Revision Date: 2008-07-23 13:28:45 UTC

* SECURITY UPDATE: crash from crafted STR file.
* Add debian/patches/400_str_file_crash.diff: backported upstream fixes.
* References
  CVE-2008-3162

lp:ubuntu/dapper-updates/ffmpeg 2 Mature 2009-07-25 11:21:10 UTC 2009-07-25
4. * SECURITY UPDATE: crash from crafted...

Author: Kees Cook
Revision Date: 2008-07-23 13:28:45 UTC

* SECURITY UPDATE: crash from crafted STR file, heap overflow in PNG.
* libavcodec/utils.c: fixes from upstream, thanks to Debian (CVE-2005-4048).
* libavformat/psxstr.c: backported fixes from upstream (CVE-2008-3162).

lp:ubuntu/dapper-security/ffmpeg 2 Mature 2009-07-25 11:20:59 UTC 2009-07-25
4. * SECURITY UPDATE: crash from crafted...

Author: Kees Cook
Revision Date: 2008-07-23 13:28:45 UTC

* SECURITY UPDATE: crash from crafted STR file, heap overflow in PNG.
* libavcodec/utils.c: fixes from upstream, thanks to Debian (CVE-2005-4048).
* libavformat/psxstr.c: backported fixes from upstream (CVE-2008-3162).

lp:ubuntu/breezy-security/ffmpeg 1 Development 2009-07-25 11:20:35 UTC 2009-07-25
3. * SECURITY UPDATE: Fix arbitrary code...

Author: Kees Cook
Revision Date: 2006-09-29 21:31:30 UTC

* SECURITY UPDATE: Fix arbitrary code execution in multiple buffer
  overflows.
* libavcodec/{4mc,alac,shorten,snow,dtsdec,vorbis}.c, libavformat/rm.c:
  Backported CVS changes to check for buffer overflow conditions.
* References
  - CVE-2006-4800
  - http://bugs.gentoo.org/show_bug.cgi?id=133520

lp:ubuntu/hoary-security/ffmpeg 1 Development 2009-07-25 11:20:12 UTC 2009-07-25
4. * SECURITY UPDATE: Fix arbitrary code...

Author: Kees Cook
Revision Date: 2006-09-29 21:40:58 UTC

* SECURITY UPDATE: Fix arbitrary code execution in multiple buffer
  overflows.
* libavcodec/{4mc,snow,dtsdec}.c, libavformat/rm.c: Backported CVS
  changes to check for buffer overflow conditions.
* References
  - CVE-2006-4800
  - http://bugs.gentoo.org/show_bug.cgi?id=133520

145 of 45 results