lp:ubuntu/karmic/ffmpeg

Created by James Westby on 2009-07-25 and last modified on 2009-11-03
Get this branch:
bzr branch lp:ubuntu/karmic/ffmpeg
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Development

Recent revisions

37. By Loïc Minier on 2009-10-13

[ Reinhard Tartler ]
* Make arguments of av_set_pts_info() unsigned.
* update debian/changelog
* use patch for issue1245 from git.ffmpeg.org
* Support constant-quant encoding for libtheora, LP: #356322
* increase swscale compile time width (VOF/VOFW), LP: #443264

[ Loïc Minier ]
* Update config for karmic's armel toolchain.
* Enable neon flavour; LP: #383240.
* Update NEON confflags to assume v7 and VFP.
* Add backported NEON patches from ffmpeg trunk; see debian/patches/neon/.
* Pass proper --cpu and --extra-flags on armel.
* Pass -fPIC -DPIC to neon pass.

36. By Reinhard Tartler on 2009-08-26

* merge from debian. Remaining changes:
  - disabled output decoders: faad, openjpeg, dirac (all not in main)
  - build arm vfp variant
  - don't build depend on yasm.
* fix dependencies on -extra packages: LP: #418705, #416348
* no need to remove mpeg encoders in the ubuntu package, unless we hear
  otherwise from some patent owner. This brings back the mpeg2video
  encoder is available. cf. formats.txt.gz LP: #416585

35. By Reinhard Tartler on 2009-08-25

update the dependencies of the -dev packages for the
unstripped -> extra renaming

34. By Reinhard Tartler on 2009-08-25

really drop libopenjpeg from build depends.

33. By Reinhard Tartler on 2009-08-15

* merge from debian. Remaining changes:
  - don't build-depend on libfaad-dev, disabling faad decoder.
  - build arm vfp variant
  - don't build libopenjpeg support (not in main)
* change shlibs file to make applications depend on the -extra- packages.
* don't build depend on yasm.

32. By Reinhard Tartler on 2009-07-25

* don't build against faac in any case, it is deemed non-free
* update debian/changelog
* enable libopenjpeg support for the multiverse package

31. By Reinhard Tartler on 2009-07-24

* brown paperbag upload
* add missing comma in build depends

30. By Reinhard Tartler on 2009-07-24

* prepare new upload
* update gbp.conf
* move gbp.conf to debian/
* regroup build dependencies to minimize the diff

29. By Reinhard Tartler on 2009-03-21

merge from ubuntu.jaunty branch

28. By Reinhard Tartler on 2009-03-13

merge from ubuntu.jaunty branch

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/lucid/ffmpeg
This branch contains Public information 
Everyone can see this information.

Subscribers