Code review comment for lp:~widelands-dev/widelands/cmakepolicy

Toni Förster (stonerl) wrote :

@kaputtnik I know.

The warning you get, can't be resolved be simply setting cmake_policy to 3.10 or newer (as I naively thought). Doing so would result in using the new GLVND-libs (which is desired), but apparently widelands currently can't be compiled using these libraries. See the linking errors in your second post.

Getting this fixed means. Get widelands to compile with the GLVND-libs and then set the policy to version 3.10.

The intention for this change was to get the builds for 14.04 running (the ones GunChleoc mentioned later on). By doing so I broke Travis and Appveyor builds, because most cmake-versions there don't support a version range. But just a fixed max version (which is totally fine). A by-product would have been fixing your warning as well, but for reasons I described above this is sadly not as simple as I hoped.

« Back to merge proposal