Mir

Code review comment for lp:~vanvugt/mir/mir-display-config-header

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

There is a clean path forward. I thought it was obvious but let me explain:

1. Land this branch to make the file name consistent with the "new" API.

2. Add a new function (so it's not an API break) that wraps the remaining inconsistent function Alan mentioned, but using the correct naming convention:

MirDisplayConfig* mir_connection_get_display_config(MirConnection* connection)
{
    return mir_connection_create_display_configuration(connection);
}

3. Now we have consistently _display_config functions operating on MirDisplayConfig. We can deprecate the rest when we want.

« Back to merge proposal