Code review comment for lp:~vanvugt/compiz/fix-1081425

Revision history for this message
Sam Spilsbury (smspillaz) wrote :

23 + // Scaling factors to be applied to attrib later in glDrawTexture
24 + opacity = 1.0f;

Might be best to rename that to opacityScaleFactor

123 + private:
124 + float opacity;

Yeah definitely rename it, having a member called "opacity" really runs the risk of it being shadowed later.

74 + GLWindowPaintAttrib a (attrib);

wAttrib is the convention (though this is glDraw/Texture/ so maybe tAttrib?)

In any case "a" is far too undescriptive for a variable of function-scope.

Probably better to refresh the patch - we can just ignore the noise it creates. Its better to know if the tests continue passing, since that's what we care about.

« Back to merge proposal