Code review comment for lp:~unity-team/unity/fixes-2011-04-04

Revision history for this message
Tim Penhey (thumper) wrote :

On Fri, 08 Apr 2011 01:42:07 you wrote:
> +bool
> +PlaceFactoryFile::DoSortThemMister (Place *aa, Place *bb)
> +{
> +#define FIRST "/com/canonical/unity/applicationsplace"
> +#define SECOND "/com/canonical/unity/filesplace"
> +

For the love of clean code, what is wrong with:

  static const char* const apps_place =
"/com/canonical/unity/applicationsplace";
  static const char* const files_place = "/com/canonical/unity/filesplace";

#defines are brutal hammers that just aren't needed in places like this.

« Back to merge proposal