lp:~ubuntu-dev/ubuntu/lucid/devscripts/lucid-201002101908

Created by James Westby on 2010-02-10 and last modified on 2010-02-10
Get this branch:
bzr branch lp:~ubuntu-dev/ubuntu/lucid/devscripts/lucid-201002101908
Members of Ubuntu Development Team can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu Development Team
Status:
Development

Recent revisions

83. By Thierry Carrez on 2010-01-19

Restore changes to scripts/debchange.pl erroneously dropped in the
2.10.55ubuntu1 merge, thereby fixing the --distributor option.
(LP: #509441)

82. By أحمد المحمودي (Ahmed El-Mahmoudy) on 2010-01-06

[ ﺄﺤﻣﺩ ﺎﻠﻤﺤﻣﻭﺪﻳ (Ahmed El-Mahmoudy) ]
* Resynchronise with Debian (LP: #500968). Remaining changes:
  - Drop universe packages from Recommends to Suggests:
    + libcrypt-ssleay-perl: only needed for a corner case (uscan on SSL
      download sites), wasn't installed by default in previous releases
      either, and seems quite dead upstream
    + libsoap-lite-perl: only needed for one less common command ("select")
      for bts, which isn't useful for Ubuntu itself, and pulls in a lot of
      other universe Perl libraries
    + debian-{keyring,maintainers}: not useful enough in Ubuntu
    + equivs: too much of a hack to install by default
    + libyaml-syck-perl: transition-check is fairly Debian-specific
  - scripts/debchange.pl:
    + Adjust --security template for Ubuntu.
    + Add -U/--upstream flag that forces original "just increment
      the end" behaviour; Ubuntu is upstream for some pieces of software.
    + Add --distributor= to override lsb_release output.
    + Default to "lucid" as distribution.
    + Add "ubuntu1" to version string for new versions, with tweaks for
      special cases.
    + Add -R/--rebuild flag for Ubuntu's no-change rebuilds.
    + Don't use the last distribution in debian/changelog when doing
      "dch -r" on Ubuntu. "Just because it was last uploaded to jaunty
      doesn't mean that's the right thing to do now." Thanks to Colin
      Watson. (LP: #429288)
  - scripts/debsign.{sh,1}: Implement DEBSIGN_ALWAYS_RESIGN variable to skip
    the "Would you like to use the current signature?" question. (Debian
    #447955)
  - scripts/debuild.pl: Enforce Ubuntu merge policy.
  - scripts/dscverify.pl: Add Ubuntu keyrings.
  - scripts/rmadison.pl: Change default URL parameter to ubuntu.
  - scripts/uupdate.{sh,1}: Use -0ubuntu1 default revision on Ubuntu.
  - Add test/debchange.pl, test/Makefile: debchange test suite; call it
    during build in debian/rules. Also add lsb-release build dependency for
    this, so that debchange uses Ubuntu mode.

[ Daniel Holbach ]
* Update merge to 2.10.61 instead of 2.10.59.

81. By James Westby on 2009-12-19

Added lucid to the list of recognised distros printed out when the distro
is not recognised (LP: #498325).

80. By Steve Langasek on 2009-11-09

Make lucid the default target.

79. By Reinhard Tartler on 2009-11-04

* Resynchronise with Debian. Remaining changes:
  - Drop universe packages from Recommends to Suggests:
    + libcrypt-ssleay-perl: only needed for a corner case (uscan on SSL
      download sites), wasn't installed by default in previous releases
      either, and seems quite dead upstream
    + libsoap-lite-perl: only needed for one less common command ("select")
      for bts, which isn't useful for Ubuntu itself, and pulls in a lot of
      other universe Perl libraries
    + debian-{keyring,maintainers}: not useful enough in Ubuntu
    + equivs: too much of a hack to install by default
    + libyaml-syck-perl: transition-check is fairly Debian-specific
  - scripts/debchange.pl:
    + Adjust --security template for Ubuntu.
    + Add -U/--upstream flag that forces original "just increment
      the end" behaviour; Ubuntu is upstream for some pieces of software.
    + Add --distributor= to override lsb_release output.
    + Default to "karmic" as distribution.
    + Add "ubuntu1" to version string for new versions, with tweaks for
      special cases.
    + Add -R/--rebuild flag for Ubuntu's no-change rebuilds.
    + Don't use the last distribution in debian/changelog when doing
      "dch -r" on Ubuntu. "Just because it was last uploaded to jaunty
      doesn't mean that's the right thing to do now." Thanks to Colin
      Watson. (LP: #429288)
  - scripts/debsign.{sh,1}: Implement DEBSIGN_ALWAYS_RESIGN variable to skip
    the "Would you like to use the current signature?" question. (Debian
    #447955)
  - scripts/debuild.pl: Enforce Ubuntu merge policy.
  - scripts/dscverify.pl: Add Ubuntu keyrings.
  - scripts/rmadison.pl: Change default URL parameter to ubuntu.
  - scripts/uupdate.{sh,1}: Use -0ubuntu1 default revision on Ubuntu.
  - Add test/debchange.pl, test/Makefile: debchange test suite; call it
    during build in debian/rules. Also add lsb-release build dependency for
    this, so that debchange uses Ubuntu mode.

78. By Jamie Strandboge on 2009-10-08

* SECURITY UPDATE: fix handling of mangle rules in watch files to
  not execute them as Perl code
  - patch adapted from r1984, r1992 and r2006 of Debian svn
  - CVE-2009-2946

77. By James Westby on 2009-09-14

debchange: Don't use the last distribution in debian/changelog
when doing "dch -r" on Ubuntu. "Just because it was last uploaded to
jaunty doesn't mean that's the right thing to do now." Thanks
to Colin Watson. (LP: #429288)

76. By أحمد المحمودي (Ahmed El-Mahmoudy) on 2009-08-16

[ أحمد المحمودي (Ahmed El-Mahmoudy) ]
* Resynchronise with Debian. Remaining changes: (LP: #511269)
  - rmadison: Change default URL parameter to ubuntu.
  - scripts/debchange.pl:
    + Adjust --security template for Ubuntu.
    + Add -U/--upstream flag that forces original "just increment
      the end" behaviour; Ubuntu is upstream for some pieces of software.
    + Add --distributor= to override lsb_release output.
    + Default to "karmic" as distribution.
    + Add "ubuntu1" to version string for new versions, with tweaks for
      special cases.
    + Add -R/--rebuild flag for Ubuntu's no-change rebuilds.
  - Add test/debchange.pl, test/Makefile: debchange test suite; call it
    during build in debian/rules. Also add lsb-release build dependency for
    this, so that debchange uses Ubuntu mode.
  - scripts/debuild.pl: Enforce Ubuntu merge policy.
  - scripts/debsign.{sh,1}: Implement DEBSIGN_ALWAYS_RESIGN variable to skip
    the "Would you like to use the current signature?" question. (Debian
    #447955)
  - scripts/uupdate.{sh,1}: Use -0ubuntu1 default revision on Ubuntu.
  - scripts/dscverify.pl: Add Ubuntu keyrings.
  - Drop universe packages from Recommends to Suggests:
    + libcrypt-ssleay-perl: only needed for a corner case (uscan on SSL
      download sites), wasn't installed by default in previous releases
      either, and seems quite dead upstream
    + libsoap-lite-perl: only needed for one less common command ("select")
      for bts, which isn't useful for Ubuntu itself, and pulls in a lot of
      other universe Perl libraries
    + debian-{keyring,maintainers}: not useful enough in Ubuntu
    + equivs: too much of a hack to install by default
    + libyaml-syck-perl: transition-check is fairly Debian-specific

[ James Westby ]
* Revert to use Vcs-* rather than XS-Vcs-*.

75. By Colin Watson on 2009-07-15

[ Marian Sigler ]
Update rmadison's Ubuntu URL to cope with people.ubuntu.com ->
people.canonical.com; invoke curl in such a way as to follow redirects
by default (LP: #399891).

74. By Colin Watson on 2009-04-27

* Resynchronise with Debian. Remaining changes:
  - rmadison: Change default URL parameter to ubuntu.
  - scripts/debchange.pl:
    + Adjust --security template for Ubuntu.
    + Add -U/--upstream flag that forces original "just increment
      the end" behaviour; Ubuntu is upstream for some pieces of software.
    + Add --distributor= to override lsb_release output.
    + Add "karmic" as valid release name.
    + Default to "karmic" as distribution.
    + Add "ubuntu1" to version string for new versions, with tweaks for
      special cases.
    + Add -R/--rebuild flag for Ubuntu's no-change rebuilds.
  - Add test/debchange.pl, test/Makefile: debchange test suite; call it
    during build in debian/rules. Also add lsb-release build dependency for
    this, so that debchange uses Ubuntu mode.
  - scripts/debuild.pl: Enforce Ubuntu merge policy.
  - scripts/debsign.{sh,1}: Implement DEBSIGN_ALWAYS_RESIGN variable to skip
    the "Would you like to use the current signature?" question. (Debian
    #447955)
  - scripts/uupdate.{sh,1}: Use -0ubuntu1 default revision on Ubuntu.
  - scripts/dscverify.pl: Add Ubuntu keyrings.
  - scripts/debcommit.pl: Re-enable --fixes integration for launchpad
    bugs, as the code is present in our dpkg-dev.
  - Drop universe packages from Recommends to Suggests:
    + libcrypt-ssleay-perl: only needed for a corner case (uscan on SSL
      download sites), wasn't installed by default in previous releases
      either, and seems quite dead upstream
    + libsoap-lite-perl: only needed for one less common command ("select")
      for bts, which isn't useful for Ubuntu itself, and pulls in a lot of
      other universe Perl libraries
    + debian-{keyring,maintainers}: not useful enough in Ubuntu
    + equivs: too much of a hack to install by default
    + libyaml-syck-perl: transition-check is fairly Debian-specific
* scripts/debcommit.pl: Handle new location of find_launchpad_closes
  function in dpkg 1.15.0 (Debian #525823).

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/lucid/devscripts
This branch contains Public information 
Everyone can see this information.

Subscribers