lp:ubuntu/trusty-proposed/gst-plugins-bad1.0

Created by Ubuntu Package Importer on 2013-11-15 and last modified on 2014-04-27
Get this branch:
bzr branch lp:ubuntu/trusty-proposed/gst-plugins-bad1.0
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Development

Recent revisions

40. By Iain Lane on 2014-03-03

Split videoparsers and faad out into their own packages.

39. By Adam Conrad on 2014-02-22

* Merge with Debian unstable for random bugfixes; remaining changes:
  + Stop installing camerabin2 basecamerabin jpegformat - plugins which have
  moved to -good.
  + Provide gstreamer-plugins-bad-1.0.pc with Requires on
    gstreamer-plugins-good-1.0 - the package we've moved the referenced
    library to. This maintains compatibility with upstream software and
    other distributions.
  + debian/patches/adding-mirsink-and-android-media-over-hybris-support.patch:
    - Adding mirsink and Android media over hybris support, for hardware
      accelerated decode using libstagefright and the hybris compat layer.
  + debian/control.in:
    - Making the hybris plugin as part of a separated package, and i386 and
      armhf only (can only work with android compatible archs)
  + debian/build-deps.in:
    - Adding mirsink/android decoder specific build dependencies for i386 and
      armhf (libplatform-api1-dev and libmedia-dev)
* debian/patches/bump_opencv_dep_version.patch: Dropped, no longer needed.

38. By Ricardo Salveti on 2014-02-16

bump_opencv_dep_version.patch: bumping opencv as we're now building against
opencv 2.4.8

37. By Ricardo Salveti on 2014-02-16

* Refreshing adding-mirsink-and-android-media-over-hybris-support.patch:
  - Make the fill buffer compatible with Android 4.2 as well as 4.4+
  - Add the divx variant for mpeg4 video
  - Adding color formats used by Exynos 5 (Nexus 10)

36. By Iain Lane on 2014-01-20

No-change rebuild for libwebp transition

35. By Iain Lane on 2014-01-10

* Merge from Debian unstable. Remaining changes:
  + Stop installing camerabin2 basecamerabin jpegformat - plugins which have
  moved to -good.
  + Provide gstreamer-plugins-bad-1.0.pc with Requires on
    gstreamer-plugins-good-1.0 - the package we've moved the referenced
    library to. This maintains compatibility with upstream software and
    other distributions.
  + debian/patches/adding-mirsink-and-android-media-over-hybris-support.patch:
    - Adding mirsink and Android media over hybris support, for hardware
      accelerated decode using libstagefright and the hybris compat layer.
  + debian/control.in:
    - Making the hybris plugin as part of a separated package, and i386 and
      armhf only (can only work with android compatible archs)
  + debian/build-deps.in:
    - Adding mirsink/android decoder specific build dependencies for i386 and
      armhf (libplatform-api1-dev and libmedia-dev)

34. By Ricardo Salveti on 2013-12-23

* Refreshing adding-mirsink-and-android-media-over-hybris-support.patch:
  - Improved the CAPS for mirsink to use a cleaner method of constructing
    the caps, plus increased the formats it supports.
  - Adding a small delay to make sure we have the window id when doing
    hardware rendering
  - Fixing crash on EOS (LP: #1234506, LP: #1236599)
* debian/build-deps.*:
  - Bumping dep version requirement for libmedia

33. By Iain Lane on 2013-11-15

* Merge from Debian unstable. Remaining changes:
  + Stop installing camerabin2 basecamerabin jpegformat - plugins which have
  moved to -good.
  + Provide gstreamer-plugins-bad-1.0.pc with Requires on
    gstreamer-plugins-good-1.0 - the package we've moved the referenced
    library to. This maintains compatibility with upstream software and
    other distributions.
  + debian/patches/adding-mirsink-and-android-media-over-hybris-support.patch:
    - Adding mirsink and Android media over hybris support, for hardware
      accelerated decode using libstagefright and the hybris compat layer.
  + debian/control.in:
    - Making the hybris plugin as part of a separated package, and i386 and
      armhf only (can only work with android compatible archs)
  + debian/build-deps.in:
    - Adding mirsink/android decoder specific build dependencies for i386 and
      armhf (libplatform-api1-dev and libmedia-dev)

32. By Ricardo Salveti on 2013-10-14

* Refreshing adding-mirsink-and-android-media-over-hybris-support.patch:
  - Improving texture_id sync handling when using mirsink
  - Extending mirsink caps (was just supporting NV12)
  - Disabling google software codecs (needed until we have software
    rendering support in mirsink)
* debian/build-deps.*:
  - Bumping dep version requirement for libmedia

31. By Ricardo Salveti on 2013-10-14

* Refreshing adding-mirsink-and-android-media-over-hybris-support.patch:
  - Increasing timeout before waiting for a valid texture id

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/trusty/gst-plugins-bad1.0
This branch contains Public information 
Everyone can see this information.

Subscribers