lp:ubuntu/precise-security/wpasupplicant

Created by Ubuntu Package Importer on 2014-10-14 and last modified on 2015-06-15
Get this branch:
bzr branch lp:ubuntu/precise-security/wpasupplicant
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

20. By Marc Deslauriers on 2015-06-15

* SECURITY UPDATE: denial of service via AP mode WMM Action frame
  - debian/patches/CVE-2015-4142.patch: check length in src/ap/wmm.c.
  - CVE-2015-4142

19. By Marc Deslauriers on 2014-10-10

* SECURITY UPDATE: arbitrary command execution via unsanitized string
  passed to action scripts by wpa_cli
  - debian/patches/CVE-2014-3686.patch: added os_exec() helper to
    src/utils/os.h, src/utils/os_unix.c, src/utils/os_win32.c,
    use instead of system() in wpa_supplicant/wpa_cli.c.
  - CVE-2014-3686

18. By Mathieu Trudel-Lapierre on 2012-03-16

debian/wpasupplicant.postinst: don't fail package configuration if the
sendsig omission files can't be migrated from /lib/init/rw to /run.
Thanks to Anthony Fok for the patch. (LP: #935678)

17. By Mathieu Trudel-Lapierre on 2012-02-16

debian/patches/dbus-activation-cmdline.patch: have wpasupplicant create
a pid file in /run/sendsigs.omit.d when activated by DBus. (LP: #869635)

16. By Stefan Lippers-Hollmann <email address hidden> on 2011-12-19

* add "hostap: Allow linking with libnl-3" from Ben Greear
  <email address hidden> to allow building against libnl3 3.2.
* raise versioned build-dependency to (>= 3.2.3-2~), we need
  libnl-genl-3-200-udeb and expect it in /lib/.
* switch build dependency from libnl3-dev to libnl-3-dev && libnl-genl-3-dev
  accordingly.
* symlink /usr/share/doc/wpasupplicant/ to /usr/share/doc/wpa_supplicant,
  which is referred to from upstream documentation (Closes: #537375,
  #616120).
* enable BGSCAN_SIMPLE (Closes: #650834).
* add "For MS-CHAP, convert the password from UTF-8 to UCS-2" from
  Evan Broder <email address hidden>, accepted upstream into hostap-1.git
  (Closes: #649202).

15. By Mathieu Trudel-Lapierre on 2011-12-20

Release 0.7.3-6 from Debian's pkg-wpa SVN to Ubuntu Precise as
0.7.3-5ubuntu1. Leaving 0.7.3-6 as UNRELEASED for now.

14. By Stefan Lippers-Hollmann <email address hidden> on 2011-10-14

* restrict wpasupplicant-udeb to linux-any, until a udeb for libpcap0.8 gets
  available for kfreebsd-any (Closes: #644823).
* build-depend on libncurses5-dev explicitly, as it is no longer pulled in
  indirectly.

13. By Stefan Lippers-Hollmann <email address hidden> on 2011-09-26

[ Kel Modderman ]
* Support /run/sendsigs.omit.d/ (Closes: #633040):
  - depend on initscripts (>= 2.88dsf-13.3)
  - create new omission pid files in /run/sendsigs.omit.d/ unconditionally
  - migrate existing omission pid files from /lib/init/rw/ to
    /run/sendsigs.omit.d/
* ACK NMU (Closes: #610931)
  - add wpasupplicant-udeb
  - build against libnl3
* Improve integration of the udeb addition with existing debian/rules:
  - build the required binary in the build target in similar way to standard
    package build
  - install binary manually in dh_auto_install override rather than
    wpasupplicant-udeb.install to handle renaming of binary
  - sync udeb CFLAGS with the standard build
  - allow potential for non-linux udebs, add a kfreebsd udeb configuration
    snippet
* Filter the numerous hyphen-used-as-minus-sign informational messages
  from lintian output.
* Add preferred options to debian/source/local-options to assist with quilt
  patch management.
* Add patch for wpa_gui-qt4 which displays scan results signal strength in
  dBm with bar indicator. (Closes: #630681)

[ Stefan Lippers-Hollmann ]
* make wpasupplicant-udeb arch=any, an initial kfreebsd udeb config is now
  provided as well.
* use Package-Type instead of XC-Package-Type for wpasupplicant-udeb,
  dpkg-dev >1.15.7 is available in squeeze.
* add a dependency on ${misc:Depends} for the udeb package as well.
* adapt debian/copyright to recent changes (r174) in DEP-5 and use the new
  anonscm URL.
* don't use /run/sendsigs.omit.d/ if it hasn't already been created by
  mountkernfs.sh (e.g. when using systemd), thanks to Michael Biebl.

12. By Gaudenz Steinlin on 2011-07-30

* Non-maintainer upload with the agreement of Kel Modderman.

[ Stefan Lippers-Hollmann ]
* bump standards version to 3.9.2, no changes necessary.

[ Gaudenz Steinlin ]
* Add wpasupplicant-udeb for debian-installer. Thanks to
  Mathew Palmer for providing the initial patch. (Closes: #610931)
* Build against libnl3

11. By Kel Modderman <email address hidden> on 2011-04-17

* Restore code which loop waits for wpa_supplicant generated PID and
  UNIX socket on the filesystem before proceeeding with execution of
  ifupdown script. (Closes: #622757, #622589)
* On DISCONNECTED event using wpa-roam, do not immediately issue
  reassociation command. (Closes: #622821)
* Enable CONFIG_IEEE80211W in build configuration. (Closes: #622587)

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/utopic/wpasupplicant
This branch contains Public information 
Everyone can see this information.

Subscribers