View Bazaar branches
Get this repository:
git clone https://git.launchpad.net/ubuntu/+source/wpasupplicant
Members of Ubuntu Server Dev import team can upload to this repository. Log in for directions.

Branches

Name Last Modified Last Commit
importer/ubuntu/dsc 2018-03-09 00:56:29 UTC 2018-03-09
DSC file for 0.7.3-6ubuntu2.4

Author: Ubuntu Git Importer
Author Date: 2018-03-09 00:56:29 UTC

DSC file for 0.7.3-6ubuntu2.4

importer/ubuntu/pristine-tar 2018-03-09 00:53:43 UTC 2018-03-09
pristine-tar data for wpasupplicant_0.7.3.orig.tar.gz

Author: Ubuntu Git Importer
Author Date: 2018-03-09 00:53:43 UTC

pristine-tar data for wpasupplicant_0.7.3.orig.tar.gz

importer/debian/dsc 2018-03-09 00:42:43 UTC 2018-03-09
DSC file for 0.7.3-6

Author: Ubuntu Git Importer
Author Date: 2018-03-09 00:42:43 UTC

DSC file for 0.7.3-6

importer/debian/pristine-tar 2018-03-09 00:41:36 UTC 2018-03-09
pristine-tar data for wpasupplicant_0.7.3.orig.tar.gz

Author: Ubuntu Git Importer
Author Date: 2018-03-09 00:41:36 UTC

pristine-tar data for wpasupplicant_0.7.3.orig.tar.gz

ubuntu/precise-updates 2015-06-16 17:14:32 UTC 2015-06-16
Import patches-unapplied version 0.7.3-6ubuntu2.4 to ubuntu/precise-security

Author: Marc Deslauriers
Author Date: 2015-06-15 14:35:48 UTC

Import patches-unapplied version 0.7.3-6ubuntu2.4 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 2a20b63f39ceb184af2f913840c378e198667302

New changelog entries:
  * SECURITY UPDATE: denial of service via AP mode WMM Action frame
    - debian/patches/CVE-2015-4142.patch: check length in src/ap/wmm.c.
    - CVE-2015-4142

ubuntu/precise-security 2015-06-16 17:14:32 UTC 2015-06-16
Import patches-unapplied version 0.7.3-6ubuntu2.4 to ubuntu/precise-security

Author: Marc Deslauriers
Author Date: 2015-06-15 14:35:48 UTC

Import patches-unapplied version 0.7.3-6ubuntu2.4 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 2a20b63f39ceb184af2f913840c378e198667302

New changelog entries:
  * SECURITY UPDATE: denial of service via AP mode WMM Action frame
    - debian/patches/CVE-2015-4142.patch: check length in src/ap/wmm.c.
    - CVE-2015-4142

ubuntu/precise-devel 2015-06-16 17:14:32 UTC 2015-06-16
Import patches-unapplied version 0.7.3-6ubuntu2.4 to ubuntu/precise-security

Author: Marc Deslauriers
Author Date: 2015-06-15 14:35:48 UTC

Import patches-unapplied version 0.7.3-6ubuntu2.4 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 2a20b63f39ceb184af2f913840c378e198667302

New changelog entries:
  * SECURITY UPDATE: denial of service via AP mode WMM Action frame
    - debian/patches/CVE-2015-4142.patch: check length in src/ap/wmm.c.
    - CVE-2015-4142

applied/ubuntu/precise-security 2015-06-16 17:14:32 UTC 2015-06-16
Import patches-applied version 0.7.3-6ubuntu2.4 to applied/ubuntu/precise-sec...

Author: Marc Deslauriers
Author Date: 2015-06-15 14:35:48 UTC

Import patches-applied version 0.7.3-6ubuntu2.4 to applied/ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 261883f8708f852c6dce835015d151b4577e5720
Unapplied parent: e329144f97a4a1dd5bff6f6a2595cc957a59631f

New changelog entries:
  * SECURITY UPDATE: denial of service via AP mode WMM Action frame
    - debian/patches/CVE-2015-4142.patch: check length in src/ap/wmm.c.
    - CVE-2015-4142

applied/ubuntu/precise-devel 2015-06-16 17:14:32 UTC 2015-06-16
Import patches-applied version 0.7.3-6ubuntu2.4 to applied/ubuntu/precise-sec...

Author: Marc Deslauriers
Author Date: 2015-06-15 14:35:48 UTC

Import patches-applied version 0.7.3-6ubuntu2.4 to applied/ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 261883f8708f852c6dce835015d151b4577e5720
Unapplied parent: e329144f97a4a1dd5bff6f6a2595cc957a59631f

New changelog entries:
  * SECURITY UPDATE: denial of service via AP mode WMM Action frame
    - debian/patches/CVE-2015-4142.patch: check length in src/ap/wmm.c.
    - CVE-2015-4142

applied/ubuntu/precise-updates 2015-06-16 17:14:32 UTC 2015-06-16
Import patches-applied version 0.7.3-6ubuntu2.4 to applied/ubuntu/precise-sec...

Author: Marc Deslauriers
Author Date: 2015-06-15 14:35:48 UTC

Import patches-applied version 0.7.3-6ubuntu2.4 to applied/ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 261883f8708f852c6dce835015d151b4577e5720
Unapplied parent: e329144f97a4a1dd5bff6f6a2595cc957a59631f

New changelog entries:
  * SECURITY UPDATE: denial of service via AP mode WMM Action frame
    - debian/patches/CVE-2015-4142.patch: check length in src/ap/wmm.c.
    - CVE-2015-4142

ubuntu/lucid-updates 2014-10-14 17:46:21 UTC 2014-10-14
Import patches-unapplied version 0.6.9-3ubuntu3.2 to ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2014-10-10 13:27:24 UTC

Import patches-unapplied version 0.6.9-3ubuntu3.2 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: b0e7e9183de3d5cf001fadb2d2ab709ec7205a17

New changelog entries:
  * SECURITY UPDATE: arbitrary command execution via unsanitized string
    passed to action scripts by wpa_cli
    - debian/patches/CVE-2014-3686.patch: added os_exec() helper to
      src/utils/os.h, src/utils/os_unix.c, src/utils/os_win32.c,
      use instead of system() in wpa_supplicant/wpa_cli.c.
    - CVE-2014-3686

ubuntu/lucid-devel 2014-10-14 17:46:21 UTC 2014-10-14
Import patches-unapplied version 0.6.9-3ubuntu3.2 to ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2014-10-10 13:27:24 UTC

Import patches-unapplied version 0.6.9-3ubuntu3.2 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: b0e7e9183de3d5cf001fadb2d2ab709ec7205a17

New changelog entries:
  * SECURITY UPDATE: arbitrary command execution via unsanitized string
    passed to action scripts by wpa_cli
    - debian/patches/CVE-2014-3686.patch: added os_exec() helper to
      src/utils/os.h, src/utils/os_unix.c, src/utils/os_win32.c,
      use instead of system() in wpa_supplicant/wpa_cli.c.
    - CVE-2014-3686

applied/ubuntu/lucid-updates 2014-10-14 17:46:21 UTC 2014-10-14
Import patches-applied version 0.6.9-3ubuntu3.2 to applied/ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2014-10-10 13:27:24 UTC

Import patches-applied version 0.6.9-3ubuntu3.2 to applied/ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: 2a5fd53f7befec55e97e3a2adcfa1bf919397004
Unapplied parent: 37b5d31c7714ad10c9a587776a18de7b0e582c61

New changelog entries:
  * SECURITY UPDATE: arbitrary command execution via unsanitized string
    passed to action scripts by wpa_cli
    - debian/patches/CVE-2014-3686.patch: added os_exec() helper to
      src/utils/os.h, src/utils/os_unix.c, src/utils/os_win32.c,
      use instead of system() in wpa_supplicant/wpa_cli.c.
    - CVE-2014-3686

applied/ubuntu/lucid-security 2014-10-14 17:46:21 UTC 2014-10-14
Import patches-applied version 0.6.9-3ubuntu3.2 to applied/ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2014-10-10 13:27:24 UTC

Import patches-applied version 0.6.9-3ubuntu3.2 to applied/ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: 2a5fd53f7befec55e97e3a2adcfa1bf919397004
Unapplied parent: 37b5d31c7714ad10c9a587776a18de7b0e582c61

New changelog entries:
  * SECURITY UPDATE: arbitrary command execution via unsanitized string
    passed to action scripts by wpa_cli
    - debian/patches/CVE-2014-3686.patch: added os_exec() helper to
      src/utils/os.h, src/utils/os_unix.c, src/utils/os_win32.c,
      use instead of system() in wpa_supplicant/wpa_cli.c.
    - CVE-2014-3686

applied/ubuntu/lucid-devel 2014-10-14 17:46:21 UTC 2014-10-14
Import patches-applied version 0.6.9-3ubuntu3.2 to applied/ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2014-10-10 13:27:24 UTC

Import patches-applied version 0.6.9-3ubuntu3.2 to applied/ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: 2a5fd53f7befec55e97e3a2adcfa1bf919397004
Unapplied parent: 37b5d31c7714ad10c9a587776a18de7b0e582c61

New changelog entries:
  * SECURITY UPDATE: arbitrary command execution via unsanitized string
    passed to action scripts by wpa_cli
    - debian/patches/CVE-2014-3686.patch: added os_exec() helper to
      src/utils/os.h, src/utils/os_unix.c, src/utils/os_win32.c,
      use instead of system() in wpa_supplicant/wpa_cli.c.
    - CVE-2014-3686

ubuntu/lucid-security 2014-10-14 17:46:21 UTC 2014-10-14
Import patches-unapplied version 0.6.9-3ubuntu3.2 to ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2014-10-10 13:27:24 UTC

Import patches-unapplied version 0.6.9-3ubuntu3.2 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: b0e7e9183de3d5cf001fadb2d2ab709ec7205a17

New changelog entries:
  * SECURITY UPDATE: arbitrary command execution via unsanitized string
    passed to action scripts by wpa_cli
    - debian/patches/CVE-2014-3686.patch: added os_exec() helper to
      src/utils/os.h, src/utils/os_unix.c, src/utils/os_win32.c,
      use instead of system() in wpa_supplicant/wpa_cli.c.
    - CVE-2014-3686

applied/ubuntu/precise-proposed 2013-07-08 15:48:22 UTC 2013-07-08
Import patches-applied version 0.7.3-6ubuntu2.2 to applied/ubuntu/precise-pro...

Author: Mathieu Trudel-Lapierre
Author Date: 2013-06-12 19:57:50 UTC

Import patches-applied version 0.7.3-6ubuntu2.2 to applied/ubuntu/precise-proposed

Imported using git-ubuntu import.

Changelog parent: 6d46efaaa03802780d78b3cf9aad8101ec74b267
Unapplied parent: 9821b084b73aeb0ce04eb215cbd112470bae20df

New changelog entries:
  * Multiple patches to reduce the number of disconnections for WPA Enterprise
    roaming and Opportunistic Key Caching. (LP: #1187524)
  * In debian/patches:
    0001-sme-fix-retry-after-auth-assoc-timeout-failure.patch,
    0002-sme-optimize-recovery-from-common-load-balancing-mechanisms.patch,
    0003-sme-blacklist-bss-on-first-failure-if-only-a-*.patch,
    0004-sme-extend-load-balancing-optimization-in-bss-blacklisting.patch,
    0005-sme-optimize-recovery-from-association-command-failures.patch,
    0006-sme-add-timers-for-authentication-and-association.patch,
    0007-sme-nl80211-set-cipher-suites.patch:
    Cherry-pick patches fixing SME (Session Management Entity) for the nl80211
    driver, which works as a basis for the OKC patches.
  * In debian/patches:
    0001-pmkokc-Set-portValid-TRUE-on-association-for-driver-based-4.patch,
    0002-pmkokc-Clear-WPA-and-EAPOL-state-machine-config-pointer-on-.patch,
    0003-pmkokc-Clear-driver-PMKSA-cache-entry-on-PMKSA-cache-expira.patch,
    0004-pmkokc-Flush-PMKSA-cache-entries-and-invalidate-EAP-state-o.patch,
    0005-pmkokc-Fix-proactive_key_caching-configuration-to-WPA-code.patch,
    0006-pmkokc-RSN-Add-a-debug-message-when-considing-addition-of-O.patch,
    0007-pmkokc-Clear-OKC-based-PMKSA-caching-entries-if-PMK-is-chan.patch,
    0008-pmkokc-Move-wpa_sm_remove_pmkid-call-to-PMKSA-cache-entry-f.patch,
    0009-pmkokc-Use-PMKSA-cache-entries-with-only-a-single-network-c.patch,
    0010-pmkokc-PMKSA-Do-not-evict-active-cache-entry-when-adding-ne.patch,
    0011-pmkokc-PMKSA-Set-cur_pmksa-pointer-during-initial-associati.patch,
    0012-pmkokc-PMKSA-make-deauthentication-due-to-cache-entry-remov.patch,
    0013-pmkokc-PMKSA-update-current-cache-entry-due-to-association-.patch:
    Cherry-pick patches to properly do OKC (Opportunistic Key Caching) which
    helps maintaining connectivity on networks secured with WPA Enterprise,
    especially on nl80211-based drivers -- these patches require SME, and add
    or fix key caching and handling of the cache entries.
  * debian/patches/force-enable-okc.patch: force Opportunistic Key Caching to
    be enabled.
  * debian/patches/less-aggressive-roaming.patch: use less aggressive roaming
    settings to avoid switching to another AP unnecessarily, when the actual
    signal level difference is small.
  * debian/patches/wpa_supplicant-dbus-null-error.patch: Don't send NULL to
    dbus_message_new_error().
  * debian/patches/0001-nl80211-Fix-UNSPEC-signal-quality-reporting.patch: fix
    marking qual as invalid rather than signal level.
  * debian/patches/wpa_supplicant-squelch-driver-disconnect-spam.patch: recover
    cleanly from streams of disconnect messages (like on iwl3945).
  * debian/patches/wpa_supplicant-assoc-timeout.patch: increase association
    timeouts.

ubuntu/precise-proposed 2013-07-08 15:48:22 UTC 2013-07-08
Import patches-unapplied version 0.7.3-6ubuntu2.2 to ubuntu/precise-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2013-06-12 19:57:50 UTC

Import patches-unapplied version 0.7.3-6ubuntu2.2 to ubuntu/precise-proposed

Imported using git-ubuntu import.

Changelog parent: a71054f96c98c8c28d12140e6bc745f090f5ea60

New changelog entries:
  * Multiple patches to reduce the number of disconnections for WPA Enterprise
    roaming and Opportunistic Key Caching. (LP: #1187524)
  * In debian/patches:
    0001-sme-fix-retry-after-auth-assoc-timeout-failure.patch,
    0002-sme-optimize-recovery-from-common-load-balancing-mechanisms.patch,
    0003-sme-blacklist-bss-on-first-failure-if-only-a-*.patch,
    0004-sme-extend-load-balancing-optimization-in-bss-blacklisting.patch,
    0005-sme-optimize-recovery-from-association-command-failures.patch,
    0006-sme-add-timers-for-authentication-and-association.patch,
    0007-sme-nl80211-set-cipher-suites.patch:
    Cherry-pick patches fixing SME (Session Management Entity) for the nl80211
    driver, which works as a basis for the OKC patches.
  * In debian/patches:
    0001-pmkokc-Set-portValid-TRUE-on-association-for-driver-based-4.patch,
    0002-pmkokc-Clear-WPA-and-EAPOL-state-machine-config-pointer-on-.patch,
    0003-pmkokc-Clear-driver-PMKSA-cache-entry-on-PMKSA-cache-expira.patch,
    0004-pmkokc-Flush-PMKSA-cache-entries-and-invalidate-EAP-state-o.patch,
    0005-pmkokc-Fix-proactive_key_caching-configuration-to-WPA-code.patch,
    0006-pmkokc-RSN-Add-a-debug-message-when-considing-addition-of-O.patch,
    0007-pmkokc-Clear-OKC-based-PMKSA-caching-entries-if-PMK-is-chan.patch,
    0008-pmkokc-Move-wpa_sm_remove_pmkid-call-to-PMKSA-cache-entry-f.patch,
    0009-pmkokc-Use-PMKSA-cache-entries-with-only-a-single-network-c.patch,
    0010-pmkokc-PMKSA-Do-not-evict-active-cache-entry-when-adding-ne.patch,
    0011-pmkokc-PMKSA-Set-cur_pmksa-pointer-during-initial-associati.patch,
    0012-pmkokc-PMKSA-make-deauthentication-due-to-cache-entry-remov.patch,
    0013-pmkokc-PMKSA-update-current-cache-entry-due-to-association-.patch:
    Cherry-pick patches to properly do OKC (Opportunistic Key Caching) which
    helps maintaining connectivity on networks secured with WPA Enterprise,
    especially on nl80211-based drivers -- these patches require SME, and add
    or fix key caching and handling of the cache entries.
  * debian/patches/force-enable-okc.patch: force Opportunistic Key Caching to
    be enabled.
  * debian/patches/less-aggressive-roaming.patch: use less aggressive roaming
    settings to avoid switching to another AP unnecessarily, when the actual
    signal level difference is small.
  * debian/patches/wpa_supplicant-dbus-null-error.patch: Don't send NULL to
    dbus_message_new_error().
  * debian/patches/0001-nl80211-Fix-UNSPEC-signal-quality-reporting.patch: fix
    marking qual as invalid rather than signal level.
  * debian/patches/wpa_supplicant-squelch-driver-disconnect-spam.patch: recover
    cleanly from streams of disconnect messages (like on iwl3945).
  * debian/patches/wpa_supplicant-assoc-timeout.patch: increase association
    timeouts.

applied/ubuntu/devel 2012-03-16 14:03:36 UTC 2012-03-16
Import patches-applied version 0.7.3-6ubuntu2 to applied/ubuntu/precise

Author: Mathieu Trudel-Lapierre
Author Date: 2012-03-16 13:55:12 UTC

Import patches-applied version 0.7.3-6ubuntu2 to applied/ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 978fdfd35a79d142e53168e4e29cdaf86c870ff4
Unapplied parent: a579cb29ca1320fae2e2a5c331c50fc14961fe26

New changelog entries:
  * debian/wpasupplicant.postinst: don't fail package configuration if the
    sendsig omission files can't be migrated from /lib/init/rw to /run.
    Thanks to Anthony Fok for the patch. (LP: #935678)

ubuntu/quantal 2012-03-16 14:03:36 UTC 2012-03-16
Import patches-unapplied version 0.7.3-6ubuntu2 to ubuntu/precise

Author: Mathieu Trudel-Lapierre
Author Date: 2012-03-16 13:55:12 UTC

Import patches-unapplied version 0.7.3-6ubuntu2 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 982e1ed3353b3df9bd23cbc3293398f3b56617d4

New changelog entries:
  * debian/wpasupplicant.postinst: don't fail package configuration if the
    sendsig omission files can't be migrated from /lib/init/rw to /run.
    Thanks to Anthony Fok for the patch. (LP: #935678)

ubuntu/precise 2012-03-16 14:03:36 UTC 2012-03-16
Import patches-unapplied version 0.7.3-6ubuntu2 to ubuntu/precise

Author: Mathieu Trudel-Lapierre
Author Date: 2012-03-16 13:55:12 UTC

Import patches-unapplied version 0.7.3-6ubuntu2 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 982e1ed3353b3df9bd23cbc3293398f3b56617d4

New changelog entries:
  * debian/wpasupplicant.postinst: don't fail package configuration if the
    sendsig omission files can't be migrated from /lib/init/rw to /run.
    Thanks to Anthony Fok for the patch. (LP: #935678)

ubuntu/devel 2012-03-16 14:03:36 UTC 2012-03-16
Import patches-unapplied version 0.7.3-6ubuntu2 to ubuntu/precise

Author: Mathieu Trudel-Lapierre
Author Date: 2012-03-16 13:55:12 UTC

Import patches-unapplied version 0.7.3-6ubuntu2 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 982e1ed3353b3df9bd23cbc3293398f3b56617d4

New changelog entries:
  * debian/wpasupplicant.postinst: don't fail package configuration if the
    sendsig omission files can't be migrated from /lib/init/rw to /run.
    Thanks to Anthony Fok for the patch. (LP: #935678)

ubuntu/quantal-devel 2012-03-16 14:03:36 UTC 2012-03-16
Import patches-unapplied version 0.7.3-6ubuntu2 to ubuntu/precise

Author: Mathieu Trudel-Lapierre
Author Date: 2012-03-16 13:55:12 UTC

Import patches-unapplied version 0.7.3-6ubuntu2 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 982e1ed3353b3df9bd23cbc3293398f3b56617d4

New changelog entries:
  * debian/wpasupplicant.postinst: don't fail package configuration if the
    sendsig omission files can't be migrated from /lib/init/rw to /run.
    Thanks to Anthony Fok for the patch. (LP: #935678)

applied/ubuntu/precise 2012-03-16 14:03:36 UTC 2012-03-16
Import patches-applied version 0.7.3-6ubuntu2 to applied/ubuntu/precise

Author: Mathieu Trudel-Lapierre
Author Date: 2012-03-16 13:55:12 UTC

Import patches-applied version 0.7.3-6ubuntu2 to applied/ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 978fdfd35a79d142e53168e4e29cdaf86c870ff4
Unapplied parent: a579cb29ca1320fae2e2a5c331c50fc14961fe26

New changelog entries:
  * debian/wpasupplicant.postinst: don't fail package configuration if the
    sendsig omission files can't be migrated from /lib/init/rw to /run.
    Thanks to Anthony Fok for the patch. (LP: #935678)

applied/ubuntu/quantal 2012-03-16 14:03:36 UTC 2012-03-16
Import patches-applied version 0.7.3-6ubuntu2 to applied/ubuntu/precise

Author: Mathieu Trudel-Lapierre
Author Date: 2012-03-16 13:55:12 UTC

Import patches-applied version 0.7.3-6ubuntu2 to applied/ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 978fdfd35a79d142e53168e4e29cdaf86c870ff4
Unapplied parent: a579cb29ca1320fae2e2a5c331c50fc14961fe26

New changelog entries:
  * debian/wpasupplicant.postinst: don't fail package configuration if the
    sendsig omission files can't be migrated from /lib/init/rw to /run.
    Thanks to Anthony Fok for the patch. (LP: #935678)

applied/ubuntu/quantal-devel 2012-03-16 14:03:36 UTC 2012-03-16
Import patches-applied version 0.7.3-6ubuntu2 to applied/ubuntu/precise

Author: Mathieu Trudel-Lapierre
Author Date: 2012-03-16 13:55:12 UTC

Import patches-applied version 0.7.3-6ubuntu2 to applied/ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 978fdfd35a79d142e53168e4e29cdaf86c870ff4
Unapplied parent: a579cb29ca1320fae2e2a5c331c50fc14961fe26

New changelog entries:
  * debian/wpasupplicant.postinst: don't fail package configuration if the
    sendsig omission files can't be migrated from /lib/init/rw to /run.
    Thanks to Anthony Fok for the patch. (LP: #935678)

applied/ubuntu/lucid-proposed 2012-03-05 16:46:26 UTC 2012-03-05
Import patches-applied version 0.6.9-3ubuntu3.1 to applied/ubuntu/lucid-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2012-01-06 16:49:41 UTC

Import patches-applied version 0.6.9-3ubuntu3.1 to applied/ubuntu/lucid-proposed

Imported using git-ubuntu import.

Changelog parent: 6c4b15f5650d5f54ba56cfaf2e97478e7dbc0642
Unapplied parent: b0e7e9183de3d5cf001fadb2d2ab709ec7205a17

New changelog entries:
  * debian/patches/git_dbus_smartcard_eapol_d719934.patch: cherry-pick a patch
    from Git to correctly re-initialize pointers in the WPA state machine to
    avoid crashing when smartcard parameters change over DBUS (LP: #528087)

ubuntu/lucid-proposed 2012-03-05 16:46:26 UTC 2012-03-05
Import patches-unapplied version 0.6.9-3ubuntu3.1 to ubuntu/lucid-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2012-01-06 16:49:41 UTC

Import patches-unapplied version 0.6.9-3ubuntu3.1 to ubuntu/lucid-proposed

Imported using git-ubuntu import.

Changelog parent: 25aeb493016085db72e8104d8e3530c409c7d765

New changelog entries:
  * debian/patches/git_dbus_smartcard_eapol_d719934.patch: cherry-pick a patch
    from Git to correctly re-initialize pointers in the WPA state machine to
    avoid crashing when smartcard parameters change over DBUS (LP: #528087)

applied/debian/wheezy 2012-01-05 03:30:02 UTC 2012-01-05
Import patches-applied version 0.7.3-6 to applied/debian/sid

Author: Stefan Lippers-Hollmann
Author Date: 2011-12-19 22:31:20 UTC

Import patches-applied version 0.7.3-6 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 29704852956d9847049e5bc19d8199ef4359e31e
Unapplied parent: d332e795b1216ddba3c68c0da9c445dc7731c4fa

New changelog entries:
  * add "hostap: Allow linking with libnl-3" from Ben Greear
    <greearb@candelatech.com> to allow building against libnl3 3.2.
  * raise versioned build-dependency to (>= 3.2.3-2~), we need
    libnl-genl-3-200-udeb and expect it in /lib/.
  * switch build dependency from libnl3-dev to libnl-3-dev && libnl-genl-3-dev
    accordingly.
  * symlink /usr/share/doc/wpasupplicant/ to /usr/share/doc/wpa_supplicant,
    which is referred to from upstream documentation (Closes: #537375,
    #616120).
  * enable BGSCAN_SIMPLE (Closes: #650834).
  * add "For MS-CHAP, convert the password from UTF-8 to UCS-2" from
    Evan Broder <ebroder@mokafive.com>, accepted upstream into hostap-1.git
    (Closes: #649202).

debian/wheezy 2012-01-05 03:30:02 UTC 2012-01-05
Import patches-unapplied version 0.7.3-6 to debian/sid

Author: Stefan Lippers-Hollmann
Author Date: 2011-12-19 22:31:20 UTC

Import patches-unapplied version 0.7.3-6 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 5f5fa8031eedc82ac9e897c2c88bf3a5007a4c49

New changelog entries:
  * add "hostap: Allow linking with libnl-3" from Ben Greear
    <greearb@candelatech.com> to allow building against libnl3 3.2.
  * raise versioned build-dependency to (>= 3.2.3-2~), we need
    libnl-genl-3-200-udeb and expect it in /lib/.
  * switch build dependency from libnl3-dev to libnl-3-dev && libnl-genl-3-dev
    accordingly.
  * symlink /usr/share/doc/wpasupplicant/ to /usr/share/doc/wpa_supplicant,
    which is referred to from upstream documentation (Closes: #537375,
    #616120).
  * enable BGSCAN_SIMPLE (Closes: #650834).
  * add "For MS-CHAP, convert the password from UTF-8 to UCS-2" from
    Evan Broder <ebroder@mokafive.com>, accepted upstream into hostap-1.git
    (Closes: #649202).

debian/sid 2012-01-05 03:30:02 UTC 2012-01-05
Import patches-unapplied version 0.7.3-6 to debian/sid

Author: Stefan Lippers-Hollmann
Author Date: 2011-12-19 22:31:20 UTC

Import patches-unapplied version 0.7.3-6 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 5f5fa8031eedc82ac9e897c2c88bf3a5007a4c49

New changelog entries:
  * add "hostap: Allow linking with libnl-3" from Ben Greear
    <greearb@candelatech.com> to allow building against libnl3 3.2.
  * raise versioned build-dependency to (>= 3.2.3-2~), we need
    libnl-genl-3-200-udeb and expect it in /lib/.
  * switch build dependency from libnl3-dev to libnl-3-dev && libnl-genl-3-dev
    accordingly.
  * symlink /usr/share/doc/wpasupplicant/ to /usr/share/doc/wpa_supplicant,
    which is referred to from upstream documentation (Closes: #537375,
    #616120).
  * enable BGSCAN_SIMPLE (Closes: #650834).
  * add "For MS-CHAP, convert the password from UTF-8 to UCS-2" from
    Evan Broder <ebroder@mokafive.com>, accepted upstream into hostap-1.git
    (Closes: #649202).

applied/debian/sid 2012-01-05 03:30:02 UTC 2012-01-05
Import patches-applied version 0.7.3-6 to applied/debian/sid

Author: Stefan Lippers-Hollmann
Author Date: 2011-12-19 22:31:20 UTC

Import patches-applied version 0.7.3-6 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 29704852956d9847049e5bc19d8199ef4359e31e
Unapplied parent: d332e795b1216ddba3c68c0da9c445dc7731c4fa

New changelog entries:
  * add "hostap: Allow linking with libnl-3" from Ben Greear
    <greearb@candelatech.com> to allow building against libnl3 3.2.
  * raise versioned build-dependency to (>= 3.2.3-2~), we need
    libnl-genl-3-200-udeb and expect it in /lib/.
  * switch build dependency from libnl3-dev to libnl-3-dev && libnl-genl-3-dev
    accordingly.
  * symlink /usr/share/doc/wpasupplicant/ to /usr/share/doc/wpa_supplicant,
    which is referred to from upstream documentation (Closes: #537375,
    #616120).
  * enable BGSCAN_SIMPLE (Closes: #650834).
  * add "For MS-CHAP, convert the password from UTF-8 to UCS-2" from
    Evan Broder <ebroder@mokafive.com>, accepted upstream into hostap-1.git
    (Closes: #649202).

applied/ubuntu/oneiric-devel 2011-07-30 12:10:31 UTC 2011-07-30
Import patches-applied version 0.7.3-3.1 to applied/debian/sid

Author: Gaudenz Steinlin
Author Date: 2011-07-30 12:10:31 UTC

Import patches-applied version 0.7.3-3.1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: c7cf2147582d9305b920ce65df5b2cf532363eac
Unapplied parent: 1ad477a103e4c84d6980d6f3a20c6f2438803a18

New changelog entries:
  * Non-maintainer upload with the agreement of Kel Modderman.

  [ Stefan Lippers-Hollmann ]
  * bump standards version to 3.9.2, no changes necessary.
  [ Gaudenz Steinlin ]
  * Add wpasupplicant-udeb for debian-installer. Thanks to
    Mathew Palmer for providing the initial patch. (Closes: #610931)
  * Build against libnl3

ubuntu/oneiric 2011-07-30 12:10:31 UTC 2011-07-30
Import patches-unapplied version 0.7.3-3.1 to debian/sid

Author: Gaudenz Steinlin
Author Date: 2011-07-30 12:10:31 UTC

Import patches-unapplied version 0.7.3-3.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c25dc7e0f32efd619c59b81620be64d3a53296a5

New changelog entries:
  * Non-maintainer upload with the agreement of Kel Modderman.

  [ Stefan Lippers-Hollmann ]
  * bump standards version to 3.9.2, no changes necessary.
  [ Gaudenz Steinlin ]
  * Add wpasupplicant-udeb for debian-installer. Thanks to
    Mathew Palmer for providing the initial patch. (Closes: #610931)
  * Build against libnl3

applied/ubuntu/oneiric 2011-07-30 12:10:31 UTC 2011-07-30
Import patches-applied version 0.7.3-3.1 to applied/debian/sid

Author: Gaudenz Steinlin
Author Date: 2011-07-30 12:10:31 UTC

Import patches-applied version 0.7.3-3.1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: c7cf2147582d9305b920ce65df5b2cf532363eac
Unapplied parent: 1ad477a103e4c84d6980d6f3a20c6f2438803a18

New changelog entries:
  * Non-maintainer upload with the agreement of Kel Modderman.

  [ Stefan Lippers-Hollmann ]
  * bump standards version to 3.9.2, no changes necessary.
  [ Gaudenz Steinlin ]
  * Add wpasupplicant-udeb for debian-installer. Thanks to
    Mathew Palmer for providing the initial patch. (Closes: #610931)
  * Build against libnl3

ubuntu/oneiric-devel 2011-07-30 12:10:31 UTC 2011-07-30
Import patches-unapplied version 0.7.3-3.1 to debian/sid

Author: Gaudenz Steinlin
Author Date: 2011-07-30 12:10:31 UTC

Import patches-unapplied version 0.7.3-3.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c25dc7e0f32efd619c59b81620be64d3a53296a5

New changelog entries:
  * Non-maintainer upload with the agreement of Kel Modderman.

  [ Stefan Lippers-Hollmann ]
  * bump standards version to 3.9.2, no changes necessary.
  [ Gaudenz Steinlin ]
  * Add wpasupplicant-udeb for debian-installer. Thanks to
    Mathew Palmer for providing the initial patch. (Closes: #610931)
  * Build against libnl3

debian/experimental 2011-03-09 21:27:06 UTC 2011-03-09
Import patches-unapplied version 0.7.3-1 to debian/experimental

Author: Kel Modderman
Author Date: 2011-03-08 12:02:17 UTC

Import patches-unapplied version 0.7.3-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: a7a605992f307a32fa19528bd17cc4c911bbf344

New changelog entries:
  [ Kel Modderman ]
  * ACK NMU (Closes: #582917) and integrate changelog.
  * New upstream release (Closes: #591371).
    - nl80211 driver interface doesn't use WEXT compat layer
      (Closes: #570688)
  * Adjust debian/watch for 0.7.X series of upstream.
  * Drop patches applied upstream:
    - 11_syslog.patch
    - 18_wpa_gui_wps_ap_avail_annoyance.patch
    - 20_wpa_msg_ctrl_wps.patch
    - 21_kfreebsd.patch
    - 30_cfg80211_association_optimisation.patch
  * Refresh patch series and merge with new upstream.
  * Change build configuration:
    - remove all comments from our config
    - enable new D-Bus interface
    - disable experimental feature CONFIG_EAP_PSK
    - enable CONFIG_AP, which allows hostapd-like functionality
  * Install D-Bus service activation file for new interface.
  * Set default driver type to nl80211,wext in ifupdown glue.
  * Remove duplicate handling of wpa-mode in ifupdown/functions.sh.
  * Add support for scan_freq and freq_list in ifupdown/functions.sh.
  * Install pm-utils action script to notify wpa_supplicant of susepnd
    and resume events.
  * Remove pm-utils stuff from debian/ifupdown/action_wpa.sh.
  * Remove sleep loops which wait for creation of interface specific
    control sockets, these are now created before the process is
    backgrounded (http://w1.fi/bugz/show_bug.cgi?id=283).
  * After a disconnected event, attempt to reassociate to a network
    when using wpa-roam.
  * Add statement to debian/copyright about our choice to distribute
    this software under BSD license and link with openssl.
  * Override lintian in the case of possible-gpl-code-linked-with-
    openssl.
  * Establish control interface when D-Bus activated wpa_supplicant
    daemon starts. (Closes: #606051)
  * Update all patches with DEP-3 compliant header information.
  * Cherry pick upstream commit which fixes up emission of change events
    over D-bus. (Closes: #617199)
  * Add patch to load libpcsclite1 via dlopen(), making pcsc support
    optional. (Closes: #612842, #612715, #583671, #531592)
  * Set build config option CONFIG_PCSC=dyn to use above mentioned feature.
  * Add patch to wpa_gui to use KDE's KNotify when running under KDE.
    (Closes: #582793)
  * Adjust versioned debhelper build-depends to (>> 8).
  * Use architecture wildcards in debian/control.
  * Adjust wpagui versioned dependency on wpasupplicant to >= 0.7.3 to
    make sure all new UI features are supported.
  [ Stefan Lippers-Hollmann ]
  * Add myself to uploaders.
  * Bump policy version to 3.9.1:
    - Include full text of the employed BSD license variant and no longer
      refer to Debian's common license template.
  * Bump compat level to 8 and debhelper build-depends to >= 7.9.3~
    accordingly, retaining backportability for squeeze (plain lenny isn't an
    option due to simplified dh7 usage).
  * Refresh patch series and merge with new upstream (0.7.3).
  * Drop patches applied upstream:
    - patches/10_wpa_gui_qt4_network_id_qregexp.patch
    - patches/11_wpa_supplicant_enable_network_tweak.patch
  * update machine readable debian/copyright to be compatible with DEP5 r135.
  * initial update of existing debian/copyright entries.

applied/debian/experimental 2011-03-09 21:27:06 UTC 2011-03-09
Import patches-applied version 0.7.3-1 to applied/debian/experimental

Author: Kel Modderman
Author Date: 2011-03-08 12:02:17 UTC

Import patches-applied version 0.7.3-1 to applied/debian/experimental

Imported using git-ubuntu import.

Changelog parent: 20b1dbeed2d7ddf948941bdfdd99afd0645f0818
Unapplied parent: 93ce02f85bc120f6b2eb36ea86f26df424210180

New changelog entries:
  [ Kel Modderman ]
  * ACK NMU (Closes: #582917) and integrate changelog.
  * New upstream release (Closes: #591371).
    - nl80211 driver interface doesn't use WEXT compat layer
      (Closes: #570688)
  * Adjust debian/watch for 0.7.X series of upstream.
  * Drop patches applied upstream:
    - 11_syslog.patch
    - 18_wpa_gui_wps_ap_avail_annoyance.patch
    - 20_wpa_msg_ctrl_wps.patch
    - 21_kfreebsd.patch
    - 30_cfg80211_association_optimisation.patch
  * Refresh patch series and merge with new upstream.
  * Change build configuration:
    - remove all comments from our config
    - enable new D-Bus interface
    - disable experimental feature CONFIG_EAP_PSK
    - enable CONFIG_AP, which allows hostapd-like functionality
  * Install D-Bus service activation file for new interface.
  * Set default driver type to nl80211,wext in ifupdown glue.
  * Remove duplicate handling of wpa-mode in ifupdown/functions.sh.
  * Add support for scan_freq and freq_list in ifupdown/functions.sh.
  * Install pm-utils action script to notify wpa_supplicant of susepnd
    and resume events.
  * Remove pm-utils stuff from debian/ifupdown/action_wpa.sh.
  * Remove sleep loops which wait for creation of interface specific
    control sockets, these are now created before the process is
    backgrounded (http://w1.fi/bugz/show_bug.cgi?id=283).
  * After a disconnected event, attempt to reassociate to a network
    when using wpa-roam.
  * Add statement to debian/copyright about our choice to distribute
    this software under BSD license and link with openssl.
  * Override lintian in the case of possible-gpl-code-linked-with-
    openssl.
  * Establish control interface when D-Bus activated wpa_supplicant
    daemon starts. (Closes: #606051)
  * Update all patches with DEP-3 compliant header information.
  * Cherry pick upstream commit which fixes up emission of change events
    over D-bus. (Closes: #617199)
  * Add patch to load libpcsclite1 via dlopen(), making pcsc support
    optional. (Closes: #612842, #612715, #583671, #531592)
  * Set build config option CONFIG_PCSC=dyn to use above mentioned feature.
  * Add patch to wpa_gui to use KDE's KNotify when running under KDE.
    (Closes: #582793)
  * Adjust versioned debhelper build-depends to (>> 8).
  * Use architecture wildcards in debian/control.
  * Adjust wpagui versioned dependency on wpasupplicant to >= 0.7.3 to
    make sure all new UI features are supported.
  [ Stefan Lippers-Hollmann ]
  * Add myself to uploaders.
  * Bump policy version to 3.9.1:
    - Include full text of the employed BSD license variant and no longer
      refer to Debian's common license template.
  * Bump compat level to 8 and debhelper build-depends to >= 7.9.3~
    accordingly, retaining backportability for squeeze (plain lenny isn't an
    option due to simplified dh7 usage).
  * Refresh patch series and merge with new upstream (0.7.3).
  * Drop patches applied upstream:
    - patches/10_wpa_gui_qt4_network_id_qregexp.patch
    - patches/11_wpa_supplicant_enable_network_tweak.patch
  * update machine readable debian/copyright to be compatible with DEP5 r135.
  * initial update of existing debian/copyright entries.

applied/debian/squeeze 2010-11-28 21:26:08 UTC 2010-11-28
Import patches-applied version 0.6.10-2.1 to applied/debian/sid

Author: Micha Lenk
Author Date: 2010-11-28 11:22:01 UTC

Import patches-applied version 0.6.10-2.1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: aca376c2627ea8c69e6ec603466beca05becfbf7
Unapplied parent: 7e99d3b1520e044318a5b74cd60b2f66e3411bd7

New changelog entries:
  * Non-maintainer upload approved by Kel Modderman.
  * Added patch 31_fallback_to_full_EAP_authentication.patch (closes: #582917).

debian/squeeze 2010-11-28 21:26:08 UTC 2010-11-28
Import patches-unapplied version 0.6.10-2.1 to debian/sid

Author: Micha Lenk
Author Date: 2010-11-28 11:22:01 UTC

Import patches-unapplied version 0.6.10-2.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 205207ad800565c8ebb2ad95b5a8d84d02b6c097

New changelog entries:
  * Non-maintainer upload approved by Kel Modderman.
  * Added patch 31_fallback_to_full_EAP_authentication.patch (closes: #582917).

ubuntu/natty 2010-11-23 03:04:47 UTC 2010-11-23
Import patches-unapplied version 0.7.3-0ubuntu1 to ubuntu/natty

Author: Mathieu Trudel-Lapierre
Author Date: 2010-11-22 14:43:43 UTC

Import patches-unapplied version 0.7.3-0ubuntu1 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 5c2ac49f97911aae4d2e969aad2d8274dfdc19de

New changelog entries:
  * Get wpasupplicant 0.7.3 from Debian's SVN. Leaving 0.7.3-1 as unreleased
    for now.
  * Build-Depend on debhelper 8, since the packaging from Debian uses compat 8.

applied/ubuntu/natty 2010-11-23 03:04:47 UTC 2010-11-23
Import patches-applied version 0.7.3-0ubuntu1 to applied/ubuntu/natty

Author: Mathieu Trudel-Lapierre
Author Date: 2010-11-22 14:43:43 UTC

Import patches-applied version 0.7.3-0ubuntu1 to applied/ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 904fd49bfcd3b858086171d834cd95a14dada85e
Unapplied parent: 24fa781a8050e6850d1d984af9e949fa849b9bc0

New changelog entries:
  * Get wpasupplicant 0.7.3 from Debian's SVN. Leaving 0.7.3-1 as unreleased
    for now.
  * Build-Depend on debhelper 8, since the packaging from Debian uses compat 8.

applied/ubuntu/natty-devel 2010-11-23 03:04:47 UTC 2010-11-23
Import patches-applied version 0.7.3-0ubuntu1 to applied/ubuntu/natty

Author: Mathieu Trudel-Lapierre
Author Date: 2010-11-22 14:43:43 UTC

Import patches-applied version 0.7.3-0ubuntu1 to applied/ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 904fd49bfcd3b858086171d834cd95a14dada85e
Unapplied parent: 24fa781a8050e6850d1d984af9e949fa849b9bc0

New changelog entries:
  * Get wpasupplicant 0.7.3 from Debian's SVN. Leaving 0.7.3-1 as unreleased
    for now.
  * Build-Depend on debhelper 8, since the packaging from Debian uses compat 8.

ubuntu/natty-devel 2010-11-23 03:04:47 UTC 2010-11-23
Import patches-unapplied version 0.7.3-0ubuntu1 to ubuntu/natty

Author: Mathieu Trudel-Lapierre
Author Date: 2010-11-22 14:43:43 UTC

Import patches-unapplied version 0.7.3-0ubuntu1 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 5c2ac49f97911aae4d2e969aad2d8274dfdc19de

New changelog entries:
  * Get wpasupplicant 0.7.3 from Debian's SVN. Leaving 0.7.3-1 as unreleased
    for now.
  * Build-Depend on debhelper 8, since the packaging from Debian uses compat 8.

applied/ubuntu/lucid 2010-03-07 03:04:49 UTC 2010-03-07
Import patches-applied version 0.6.9-3ubuntu3 to applied/ubuntu/lucid

Author: Alexander Sack
Author Date: 2010-03-07 00:11:22 UTC

Import patches-applied version 0.6.9-3ubuntu3 to applied/ubuntu/lucid

Imported using git-ubuntu import.

Changelog parent: 7b94a61b919dd0c1c85201a08a7020c762214bd9
Unapplied parent: 25aeb493016085db72e8104d8e3530c409c7d765

New changelog entries:
  * rebuild rest of main for armel armv7/thumb2 optimization;
    UbuntuSpec:mobile-lucid-arm-gcc-v7-thumb2

ubuntu/lucid 2010-03-07 03:04:49 UTC 2010-03-07
Import patches-unapplied version 0.6.9-3ubuntu3 to ubuntu/lucid

Author: Alexander Sack
Author Date: 2010-03-07 00:11:22 UTC

Import patches-unapplied version 0.6.9-3ubuntu3 to ubuntu/lucid

Imported using git-ubuntu import.

Changelog parent: 1758816a99727d127f2613926c658e3bdc187f4f

New changelog entries:
  * rebuild rest of main for armel armv7/thumb2 optimization;
    UbuntuSpec:mobile-lucid-arm-gcc-v7-thumb2

ubuntu/maverick-devel 2010-02-28 09:22:14 UTC 2010-02-28
Import patches-unapplied version 0.6.10-2 to debian/sid

Author: Kel Modderman
Author Date: 2010-02-27 01:30:53 UTC

Import patches-unapplied version 0.6.10-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 84ee3732bf8f9befa4ef0f4546a1f7aa03c90533

New changelog entries:
  * Switch to source format 3.0 (quilt), drop quilt build dependency
    and remove '--with quilt' from dh command in debian/rules.
  * Fix "FTBFS on kfreebsd-gnu" with addition of 21_kfreebsd.patch.
    Thanks to work by Stefan Lippers-Hollmann and Petr Salinger.
    (Closes: #480572)
  * Disable experimental feature CONFIG_IEEE80211W (management frame
    protection) due to it not being supported by any driver but ath9k
    and it generating ioctl errors which cause much concern among users
    for little to no benefit.
  * Add traling blank line to debian/NEWS to assist apt-listchanges as
    per lintian advice.
  * Cherry pick 30_cfg80211_association_optimisation.patch from upstream
    git. Add cfg80211-specific optimization to avoid silly behavior.

applied/ubuntu/maverick 2010-02-28 09:22:14 UTC 2010-02-28
Import patches-applied version 0.6.10-2 to applied/debian/sid

Author: Kel Modderman
Author Date: 2010-02-27 01:30:53 UTC

Import patches-applied version 0.6.10-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: a9b7ebe3b8b962d2267b8df0621b88315adf82a0
Unapplied parent: 263521fda95489c75086e9c01304aaaa2f10098f

New changelog entries:
  * Switch to source format 3.0 (quilt), drop quilt build dependency
    and remove '--with quilt' from dh command in debian/rules.
  * Fix "FTBFS on kfreebsd-gnu" with addition of 21_kfreebsd.patch.
    Thanks to work by Stefan Lippers-Hollmann and Petr Salinger.
    (Closes: #480572)
  * Disable experimental feature CONFIG_IEEE80211W (management frame
    protection) due to it not being supported by any driver but ath9k
    and it generating ioctl errors which cause much concern among users
    for little to no benefit.
  * Add traling blank line to debian/NEWS to assist apt-listchanges as
    per lintian advice.
  * Cherry pick 30_cfg80211_association_optimisation.patch from upstream
    git. Add cfg80211-specific optimization to avoid silly behavior.

applied/ubuntu/maverick-devel 2010-02-28 09:22:14 UTC 2010-02-28
Import patches-applied version 0.6.10-2 to applied/debian/sid

Author: Kel Modderman
Author Date: 2010-02-27 01:30:53 UTC

Import patches-applied version 0.6.10-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: a9b7ebe3b8b962d2267b8df0621b88315adf82a0
Unapplied parent: 263521fda95489c75086e9c01304aaaa2f10098f

New changelog entries:
  * Switch to source format 3.0 (quilt), drop quilt build dependency
    and remove '--with quilt' from dh command in debian/rules.
  * Fix "FTBFS on kfreebsd-gnu" with addition of 21_kfreebsd.patch.
    Thanks to work by Stefan Lippers-Hollmann and Petr Salinger.
    (Closes: #480572)
  * Disable experimental feature CONFIG_IEEE80211W (management frame
    protection) due to it not being supported by any driver but ath9k
    and it generating ioctl errors which cause much concern among users
    for little to no benefit.
  * Add traling blank line to debian/NEWS to assist apt-listchanges as
    per lintian advice.
  * Cherry pick 30_cfg80211_association_optimisation.patch from upstream
    git. Add cfg80211-specific optimization to avoid silly behavior.

ubuntu/maverick 2010-02-28 09:22:14 UTC 2010-02-28
Import patches-unapplied version 0.6.10-2 to debian/sid

Author: Kel Modderman
Author Date: 2010-02-27 01:30:53 UTC

Import patches-unapplied version 0.6.10-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 84ee3732bf8f9befa4ef0f4546a1f7aa03c90533

New changelog entries:
  * Switch to source format 3.0 (quilt), drop quilt build dependency
    and remove '--with quilt' from dh command in debian/rules.
  * Fix "FTBFS on kfreebsd-gnu" with addition of 21_kfreebsd.patch.
    Thanks to work by Stefan Lippers-Hollmann and Petr Salinger.
    (Closes: #480572)
  * Disable experimental feature CONFIG_IEEE80211W (management frame
    protection) due to it not being supported by any driver but ath9k
    and it generating ioctl errors which cause much concern among users
    for little to no benefit.
  * Add traling blank line to debian/NEWS to assist apt-listchanges as
    per lintian advice.
  * Cherry pick 30_cfg80211_association_optimisation.patch from upstream
    git. Add cfg80211-specific optimization to avoid silly behavior.

applied/ubuntu/karmic 2009-09-19 21:04:32 UTC 2009-09-19
Import patches-applied version 0.6.9-3ubuntu1 to applied/ubuntu/karmic

Author: Matthias Klose
Author Date: 2009-09-19 20:43:56 UTC

Import patches-applied version 0.6.9-3ubuntu1 to applied/ubuntu/karmic

Imported using git-ubuntu import.

Changelog parent: a4b29751d556f62257af36fd6e41004c589da1f5
Unapplied parent: 1ef575ee5499e011ded701c9abf0e7addd292957

New changelog entries:
  * Build-depend on libreadline-dev instead of libreadline5-dev.

applied/ubuntu/karmic-devel 2009-09-19 21:04:32 UTC 2009-09-19
Import patches-applied version 0.6.9-3ubuntu1 to applied/ubuntu/karmic

Author: Matthias Klose
Author Date: 2009-09-19 20:43:56 UTC

Import patches-applied version 0.6.9-3ubuntu1 to applied/ubuntu/karmic

Imported using git-ubuntu import.

Changelog parent: a4b29751d556f62257af36fd6e41004c589da1f5
Unapplied parent: 1ef575ee5499e011ded701c9abf0e7addd292957

New changelog entries:
  * Build-depend on libreadline-dev instead of libreadline5-dev.

ubuntu/karmic 2009-09-19 21:04:32 UTC 2009-09-19
Import patches-unapplied version 0.6.9-3ubuntu1 to ubuntu/karmic

Author: Matthias Klose
Author Date: 2009-09-19 20:43:56 UTC

Import patches-unapplied version 0.6.9-3ubuntu1 to ubuntu/karmic

Imported using git-ubuntu import.

Changelog parent: e4b19a28db8e6635ff9379cd108b3e68bf7768d6

New changelog entries:
  * Build-depend on libreadline-dev instead of libreadline5-dev.

ubuntu/karmic-devel 2009-09-19 21:04:32 UTC 2009-09-19
Import patches-unapplied version 0.6.9-3ubuntu1 to ubuntu/karmic

Author: Matthias Klose
Author Date: 2009-09-19 20:43:56 UTC

Import patches-unapplied version 0.6.9-3ubuntu1 to ubuntu/karmic

Imported using git-ubuntu import.

Changelog parent: e4b19a28db8e6635ff9379cd108b3e68bf7768d6

New changelog entries:
  * Build-depend on libreadline-dev instead of libreadline5-dev.

ubuntu/jaunty 2009-04-09 02:04:42 UTC 2009-04-09
Import patches-unapplied version 0.6.6-2ubuntu1 to ubuntu/jaunty

Author: Colin Watson
Author Date: 2009-04-09 01:31:17 UTC

Import patches-unapplied version 0.6.6-2ubuntu1 to ubuntu/jaunty

Imported using git-ubuntu import.

Changelog parent: 2381bf63af2a8f69d6d53d05e3dd0bb9bc6e1af4

New changelog entries:
  * Operate reasonably when /var is not yet mounted read-write (LP: #44194):
    - 07_syslog.patch: Backport syslog logging support from upstream.
    - 08_syslog_supplement.patch: Add a few more bits missing from the
      upstream patch, based on
      http://cvs.fedoraproject.org/viewvc/rpms/wpa_supplicant/OLPC-2/wpa_supplicant-0.5.7-use-syslog.patch.
      Compile with -DCONFIG_DEBUG_SYSLOG if CONFIG_DEBUG_SYSLOG is set in
      the configuration file.
    - Enable CONFIG_DEBUG_SYSLOG.
    - debian/ifupdown/functions.sh: Set WPA_SUP_LOGFILE to "syslog" by
      default, and use the -s option in this case.
    - debian/ifupdown/functions.sh: Silence wpa_log_* if /var/log is not yet
      writable; there is little we can do in this case (logger is in /usr,
      so may well also be unusable), and the user can always get more
      information by reconnecting later.

ubuntu/jaunty-devel 2009-04-09 02:04:42 UTC 2009-04-09
Import patches-unapplied version 0.6.6-2ubuntu1 to ubuntu/jaunty

Author: Colin Watson
Author Date: 2009-04-09 01:31:17 UTC

Import patches-unapplied version 0.6.6-2ubuntu1 to ubuntu/jaunty

Imported using git-ubuntu import.

Changelog parent: 2381bf63af2a8f69d6d53d05e3dd0bb9bc6e1af4

New changelog entries:
  * Operate reasonably when /var is not yet mounted read-write (LP: #44194):
    - 07_syslog.patch: Backport syslog logging support from upstream.
    - 08_syslog_supplement.patch: Add a few more bits missing from the
      upstream patch, based on
      http://cvs.fedoraproject.org/viewvc/rpms/wpa_supplicant/OLPC-2/wpa_supplicant-0.5.7-use-syslog.patch.
      Compile with -DCONFIG_DEBUG_SYSLOG if CONFIG_DEBUG_SYSLOG is set in
      the configuration file.
    - Enable CONFIG_DEBUG_SYSLOG.
    - debian/ifupdown/functions.sh: Set WPA_SUP_LOGFILE to "syslog" by
      default, and use the -s option in this case.
    - debian/ifupdown/functions.sh: Silence wpa_log_* if /var/log is not yet
      writable; there is little we can do in this case (logger is in /usr,
      so may well also be unusable), and the user can always get more
      information by reconnecting later.

applied/ubuntu/jaunty-devel 2009-04-09 02:04:42 UTC 2009-04-09
Import patches-applied version 0.6.6-2ubuntu1 to applied/ubuntu/jaunty

Author: Colin Watson
Author Date: 2009-04-09 01:31:17 UTC

Import patches-applied version 0.6.6-2ubuntu1 to applied/ubuntu/jaunty

Imported using git-ubuntu import.

Changelog parent: 2e262b429c0b39b43dc63dd8470526930fa8c6ea
Unapplied parent: 1a9eeba05bbc5799eb1a783d4f115879eb4b7d44

New changelog entries:
  * Operate reasonably when /var is not yet mounted read-write (LP: #44194):
    - 07_syslog.patch: Backport syslog logging support from upstream.
    - 08_syslog_supplement.patch: Add a few more bits missing from the
      upstream patch, based on
      http://cvs.fedoraproject.org/viewvc/rpms/wpa_supplicant/OLPC-2/wpa_supplicant-0.5.7-use-syslog.patch.
      Compile with -DCONFIG_DEBUG_SYSLOG if CONFIG_DEBUG_SYSLOG is set in
      the configuration file.
    - Enable CONFIG_DEBUG_SYSLOG.
    - debian/ifupdown/functions.sh: Set WPA_SUP_LOGFILE to "syslog" by
      default, and use the -s option in this case.
    - debian/ifupdown/functions.sh: Silence wpa_log_* if /var/log is not yet
      writable; there is little we can do in this case (logger is in /usr,
      so may well also be unusable), and the user can always get more
      information by reconnecting later.

applied/ubuntu/jaunty 2009-04-09 02:04:42 UTC 2009-04-09
Import patches-applied version 0.6.6-2ubuntu1 to applied/ubuntu/jaunty

Author: Colin Watson
Author Date: 2009-04-09 01:31:17 UTC

Import patches-applied version 0.6.6-2ubuntu1 to applied/ubuntu/jaunty

Imported using git-ubuntu import.

Changelog parent: 2e262b429c0b39b43dc63dd8470526930fa8c6ea
Unapplied parent: 1a9eeba05bbc5799eb1a783d4f115879eb4b7d44

New changelog entries:
  * Operate reasonably when /var is not yet mounted read-write (LP: #44194):
    - 07_syslog.patch: Backport syslog logging support from upstream.
    - 08_syslog_supplement.patch: Add a few more bits missing from the
      upstream patch, based on
      http://cvs.fedoraproject.org/viewvc/rpms/wpa_supplicant/OLPC-2/wpa_supplicant-0.5.7-use-syslog.patch.
      Compile with -DCONFIG_DEBUG_SYSLOG if CONFIG_DEBUG_SYSLOG is set in
      the configuration file.
    - Enable CONFIG_DEBUG_SYSLOG.
    - debian/ifupdown/functions.sh: Set WPA_SUP_LOGFILE to "syslog" by
      default, and use the -s option in this case.
    - debian/ifupdown/functions.sh: Silence wpa_log_* if /var/log is not yet
      writable; there is little we can do in this case (logger is in /usr,
      so may well also be unusable), and the user can always get more
      information by reconnecting later.

applied/debian/lenny 2008-12-03 14:15:24 UTC 2008-12-03
Import patches-applied version 0.6.4-3 to applied/debian/sid

Author: Reinhard Tartler
Author Date: 2008-12-02 19:52:16 UTC

Import patches-applied version 0.6.4-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: e24a03efc0ff199a74294ce5746c677619e7e2ce
Unapplied parent: 653c67067c01df033d48cfcdde42ae97e4003b4b

New changelog entries:
  * Bugfix: "Missing -d in testing for a directory in init script".
    Thanks to Braun Gábor <braung@renyi.hu> for reporting and the patch.
    (Closes: #506328)

debian/lenny 2008-12-03 14:15:24 UTC 2008-12-03
Import patches-unapplied version 0.6.4-3 to debian/sid

Author: Reinhard Tartler
Author Date: 2008-12-02 19:52:16 UTC

Import patches-unapplied version 0.6.4-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: f41710457e226e2c51ca8cded6f7bbe32b1d8b29

New changelog entries:
  * Bugfix: "Missing -d in testing for a directory in init script".
    Thanks to Braun Gábor <braung@renyi.hu> for reporting and the patch.
    (Closes: #506328)

applied/ubuntu/intrepid-devel 2008-10-29 16:22:56 UTC 2008-10-29
Import patches-applied version 0.6.4-2 to applied/debian/lenny

Author: Reinhard Tartler
Author Date: 2008-08-27 08:10:20 UTC

Import patches-applied version 0.6.4-2 to applied/debian/lenny

Imported using git-ubuntu import.

Unapplied parent: f41710457e226e2c51ca8cded6f7bbe32b1d8b29

ubuntu/intrepid-devel 2008-10-29 16:22:56 UTC 2008-10-29
Import patches-unapplied version 0.6.4-2 to debian/lenny

Author: Reinhard Tartler
Author Date: 2008-08-27 08:10:20 UTC

Import patches-unapplied version 0.6.4-2 to debian/lenny

Imported using git-ubuntu import.

ubuntu/intrepid 2008-10-29 16:22:56 UTC 2008-10-29
Import patches-unapplied version 0.6.4-2 to debian/lenny

Author: Reinhard Tartler
Author Date: 2008-08-27 08:10:20 UTC

Import patches-unapplied version 0.6.4-2 to debian/lenny

Imported using git-ubuntu import.

applied/ubuntu/intrepid 2008-10-29 16:22:56 UTC 2008-10-29
Import patches-applied version 0.6.4-2 to applied/debian/lenny

Author: Reinhard Tartler
Author Date: 2008-08-27 08:10:20 UTC

Import patches-applied version 0.6.4-2 to applied/debian/lenny

Imported using git-ubuntu import.

Unapplied parent: f41710457e226e2c51ca8cded6f7bbe32b1d8b29

applied/ubuntu/hardy-devel 2008-03-12 21:05:46 UTC 2008-03-12
Import patches-applied version 0.6.0+0.5.8-0ubuntu2 to applied/ubuntu/hardy

Author: Reinhard Tartler
Author Date: 2008-03-12 16:40:06 UTC

Import patches-applied version 0.6.0+0.5.8-0ubuntu2 to applied/ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: 268323a4ebd4719355efaeb68a837d85ecd15ca1
Unapplied parent: 33923cdb76a92199821977b14118aa095e8f0eda

New changelog entries:
  * 10_set_channel_in_adhoc_mode: make wpasupplicant set the frequency when.
    LP: #112009. Patch prepared by Kel Modderman for debian.
  * 10_silence_siocsiwauth_icotl_failure: patch taken from upstream.
    when using the wext driver, the error message on the SIOCSIWAUTH ioctl
    is no longer printed via stderr, but properly in the debug log.
    Patch prepared by Kel Modderman for debian.

applied/ubuntu/hardy 2008-03-12 21:05:46 UTC 2008-03-12
Import patches-applied version 0.6.0+0.5.8-0ubuntu2 to applied/ubuntu/hardy

Author: Reinhard Tartler
Author Date: 2008-03-12 16:40:06 UTC

Import patches-applied version 0.6.0+0.5.8-0ubuntu2 to applied/ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: 268323a4ebd4719355efaeb68a837d85ecd15ca1
Unapplied parent: 33923cdb76a92199821977b14118aa095e8f0eda

New changelog entries:
  * 10_set_channel_in_adhoc_mode: make wpasupplicant set the frequency when.
    LP: #112009. Patch prepared by Kel Modderman for debian.
  * 10_silence_siocsiwauth_icotl_failure: patch taken from upstream.
    when using the wext driver, the error message on the SIOCSIWAUTH ioctl
    is no longer printed via stderr, but properly in the debug log.
    Patch prepared by Kel Modderman for debian.

ubuntu/hardy 2008-03-12 21:05:46 UTC 2008-03-12
Import patches-unapplied version 0.6.0+0.5.8-0ubuntu2 to ubuntu/hardy

Author: Reinhard Tartler
Author Date: 2008-03-12 16:40:06 UTC

Import patches-unapplied version 0.6.0+0.5.8-0ubuntu2 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: e4cd09c3f3c81d0dab0cbf59be77b17b5ef93a4f

New changelog entries:
  * 10_set_channel_in_adhoc_mode: make wpasupplicant set the frequency when.
    LP: #112009. Patch prepared by Kel Modderman for debian.
  * 10_silence_siocsiwauth_icotl_failure: patch taken from upstream.
    when using the wext driver, the error message on the SIOCSIWAUTH ioctl
    is no longer printed via stderr, but properly in the debug log.
    Patch prepared by Kel Modderman for debian.

ubuntu/hardy-devel 2008-03-12 21:05:46 UTC 2008-03-12
Import patches-unapplied version 0.6.0+0.5.8-0ubuntu2 to ubuntu/hardy

Author: Reinhard Tartler
Author Date: 2008-03-12 16:40:06 UTC

Import patches-unapplied version 0.6.0+0.5.8-0ubuntu2 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: e4cd09c3f3c81d0dab0cbf59be77b17b5ef93a4f

New changelog entries:
  * 10_set_channel_in_adhoc_mode: make wpasupplicant set the frequency when.
    LP: #112009. Patch prepared by Kel Modderman for debian.
  * 10_silence_siocsiwauth_icotl_failure: patch taken from upstream.
    when using the wext driver, the error message on the SIOCSIWAUTH ioctl
    is no longer printed via stderr, but properly in the debug log.
    Patch prepared by Kel Modderman for debian.

applied/ubuntu/gutsy 2007-09-24 18:03:47 UTC 2007-09-24
Import patches-applied version 0.6.0+0.5.8-0ubuntu1 to applied/ubuntu/gutsy

Author: Reinhard Tartler
Author Date: 2007-08-26 14:06:57 UTC

Import patches-applied version 0.6.0+0.5.8-0ubuntu1 to applied/ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: aed6b7445a34a569c5feaabd62969e20d254f513
Unapplied parent: e4cd09c3f3c81d0dab0cbf59be77b17b5ef93a4f

New changelog entries:
  * New upstream release
  * remove patch 11_erroneous_manpage_ref, applied upstream
  * remove patch 25_wpas_dbus_unregister_iface_fix, applied upstream
  [ Alexander Sack ]
  * bumping upstream version to replace development version 0.6.0 with
    this package from stable release branch.
  * attempt to fix wierd timeout and high latency issues by going
    back to stable upstream version (0.5.9) (LP: #140763,
    LP: #141233).

ubuntu/gutsy 2007-09-24 18:03:47 UTC 2007-09-24
Import patches-unapplied version 0.6.0+0.5.8-0ubuntu1 to ubuntu/gutsy

Author: Reinhard Tartler
Author Date: 2007-08-26 14:06:57 UTC

Import patches-unapplied version 0.6.0+0.5.8-0ubuntu1 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: 241875a6b448895b911ca7f0a7e9294861257b51

New changelog entries:
  * New upstream release
  * remove patch 11_erroneous_manpage_ref, applied upstream
  * remove patch 25_wpas_dbus_unregister_iface_fix, applied upstream
  [ Alexander Sack ]
  * bumping upstream version to replace development version 0.6.0 with
    this package from stable release branch.
  * attempt to fix wierd timeout and high latency issues by going
    back to stable upstream version (0.5.9) (LP: #140763,
    LP: #141233).

ubuntu/gutsy-devel 2007-09-24 18:03:47 UTC 2007-09-24
Import patches-unapplied version 0.6.0+0.5.8-0ubuntu1 to ubuntu/gutsy

Author: Reinhard Tartler
Author Date: 2007-08-26 14:06:57 UTC

Import patches-unapplied version 0.6.0+0.5.8-0ubuntu1 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: 241875a6b448895b911ca7f0a7e9294861257b51

New changelog entries:
  * New upstream release
  * remove patch 11_erroneous_manpage_ref, applied upstream
  * remove patch 25_wpas_dbus_unregister_iface_fix, applied upstream
  [ Alexander Sack ]
  * bumping upstream version to replace development version 0.6.0 with
    this package from stable release branch.
  * attempt to fix wierd timeout and high latency issues by going
    back to stable upstream version (0.5.9) (LP: #140763,
    LP: #141233).

applied/ubuntu/gutsy-devel 2007-09-24 18:03:47 UTC 2007-09-24
Import patches-applied version 0.6.0+0.5.8-0ubuntu1 to applied/ubuntu/gutsy

Author: Reinhard Tartler
Author Date: 2007-08-26 14:06:57 UTC

Import patches-applied version 0.6.0+0.5.8-0ubuntu1 to applied/ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: aed6b7445a34a569c5feaabd62969e20d254f513
Unapplied parent: e4cd09c3f3c81d0dab0cbf59be77b17b5ef93a4f

New changelog entries:
  * New upstream release
  * remove patch 11_erroneous_manpage_ref, applied upstream
  * remove patch 25_wpas_dbus_unregister_iface_fix, applied upstream
  [ Alexander Sack ]
  * bumping upstream version to replace development version 0.6.0 with
    this package from stable release branch.
  * attempt to fix wierd timeout and high latency issues by going
    back to stable upstream version (0.5.9) (LP: #140763,
    LP: #141233).

applied/ubuntu/feisty-devel 2007-04-01 10:03:51 UTC 2007-04-01
Import patches-applied version 0.5.7-0ubuntu2 to applied/ubuntu/feisty

Author: Reinhard Tartler
Author Date: 2007-04-01 08:53:37 UTC

Import patches-applied version 0.5.7-0ubuntu2 to applied/ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: cc00d651e2836505aeaa02c3e5a5a5f5ff7ee8fa
Unapplied parent: 241875a6b448895b911ca7f0a7e9294861257b51

New changelog entries:
  * Apply patch from upstream after private email discussion:
  http://w1.fi/gitweb/gitweb.cgi?p=hostap.git;a=commitdiff;h=33673d3f43da6f5ec0f0aa5a8245a1617b6eb2fd#patch1
    Fixes LP: #98895, #98925

applied/ubuntu/feisty 2007-04-01 10:03:51 UTC 2007-04-01
Import patches-applied version 0.5.7-0ubuntu2 to applied/ubuntu/feisty

Author: Reinhard Tartler
Author Date: 2007-04-01 08:53:37 UTC

Import patches-applied version 0.5.7-0ubuntu2 to applied/ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: cc00d651e2836505aeaa02c3e5a5a5f5ff7ee8fa
Unapplied parent: 241875a6b448895b911ca7f0a7e9294861257b51

New changelog entries:
  * Apply patch from upstream after private email discussion:
  http://w1.fi/gitweb/gitweb.cgi?p=hostap.git;a=commitdiff;h=33673d3f43da6f5ec0f0aa5a8245a1617b6eb2fd#patch1
    Fixes LP: #98895, #98925

ubuntu/feisty-devel 2007-04-01 10:03:51 UTC 2007-04-01
Import patches-unapplied version 0.5.7-0ubuntu2 to ubuntu/feisty

Author: Reinhard Tartler
Author Date: 2007-04-01 08:53:37 UTC

Import patches-unapplied version 0.5.7-0ubuntu2 to ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: 32b3e556d1590c36f254d8a0422dce754bb6ab96

New changelog entries:
  * Apply patch from upstream after private email discussion:
  http://w1.fi/gitweb/gitweb.cgi?p=hostap.git;a=commitdiff;h=33673d3f43da6f5ec0f0aa5a8245a1617b6eb2fd#patch1
    Fixes LP: #98895, #98925

ubuntu/feisty 2007-04-01 10:03:51 UTC 2007-04-01
Import patches-unapplied version 0.5.7-0ubuntu2 to ubuntu/feisty

Author: Reinhard Tartler
Author Date: 2007-04-01 08:53:37 UTC

Import patches-unapplied version 0.5.7-0ubuntu2 to ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: 32b3e556d1590c36f254d8a0422dce754bb6ab96

New changelog entries:
  * Apply patch from upstream after private email discussion:
  http://w1.fi/gitweb/gitweb.cgi?p=hostap.git;a=commitdiff;h=33673d3f43da6f5ec0f0aa5a8245a1617b6eb2fd#patch1
    Fixes LP: #98895, #98925

ubuntu/edgy 2006-08-11 16:03:29 UTC 2006-08-11
Import patches-unapplied version 0.5.4-5 to ubuntu/edgy

Author: kelmo
Author Date: 2006-08-09 15:03:38 UTC

Import patches-unapplied version 0.5.4-5 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: 655737117074e8160e3a929d80f40bf5bb6a8bf5

New changelog entries:
  * STDIN was not given to external mapping script correctly. Use the power of
    eval to fix the issue. [wpa_action.sh]
  * Fix stupid debian/control error: duplicate Suggests fields.
  * Add support to wpa_action.sh and ifupdown.sh for allowing external mapping
    logic to be used as opposed to the id_str logic. Thanks to Felix Homman
    for the great insight while implementing this feature.
  * Add a timeout loop of max 60s when waiting for an action to finish.
    [wpa_action.sh]
  * Minor cleanups wrt code comments and function placement in ifupdown.sh.
  * Suggest guessnet, now that it can directly "plug in" to wpa_action. Also
    demote iproute from Recommends to Suggests, it is not important by any
    means and was only added to honour a wishlist request.
  * Prepare for ctrl_interface socket changes in 0.5.5. It can be provided by
    'DIR=foo GID=bar' or 'ctrl_interface=foo' in wpa_supplicant.conf. Our sed
    check for this path in ifupdown.sh should now support both alternatives.
  * Move LOCKFILE and LOGFILE into WPA_ namespace. [wpa_action.sh]
  * Use semi-colon instead of comma for verbose output as that seems to be a
    standard among many different applications.
  * UNRELEASED
  * Further optimisation of ifupdown.sh, use return values in
    init_wpa_supplicant() to dictate if further commands should follow, rather
    than exiting immediately.
  * Standardize echo'ing in ifupdown.sh. Add a wpa_msg() function to take care
    of "verbose|action|stdout|stderr" messages.
  * Add a 5 second timeout loop to init_wpa_supplicant() that waits for the
    ctrl_interface socket to be established before allowing wpa_cli to launch,
    and avoid a race condition. This means other functions no longer need to
    test for existance of the ctrl_interface socket. [ifupdown.sh]
  * Rename WPA_DRIVER to WPA_SUP_DRIVER to conform with name scheme of other
    similar variables. [ifupdown.sh]
  * Add (untested) wpa-bridge support to ifupdown.sh. This is an experimental
    upstream feature.
  * Major refactoring of wpa_action.sh, with all related commands put into
    independent shell functions.
  * Improve feedback from wpa_action.sh when used interactively. Give usage
    statement instead of simply returning "insufficient parameters".
  * 'wpa_action reload' is logged after the action. It is called interactively,
    and should also give interactive feedback. Same for 'wpa_action stop'.
  * Remove superfluous check for /var/log, and put logging initialisation into
    its own function, log_init(). [wpa_action.sh]
  * Shut `ip addr flush dev "$IFACE" up', it almost always has nothing to flush.
  * wpa-ifupdown init script now takes care of all interfaces while displaying
    only one line.
  * Don't set -e in wpa_action.sh. wpa-ifupdown script no longer takes exit
    status into account, and I'd prefer to account for all possible avenues of
    exit possible and log all encountered problems.
  * Really fix #375599, by containing the CTRL_IFACE_DIR path in WPA_SUP_CONF
    always, customised or not. The WPA_CTRL_IFACE socket was not being created
    when ommitted from the wpa_supplicant.conf file.
  * Add 'wpa-maint-debug' to enable set -x in ifupdown.sh, so that we can easy
    track down vague problems.
  * Slightly modify the way in which madwifi is activated. The default config
    we apply does not activate madwifi by default any longer, it is done via
    seperate patches; 20_include_madwifi modifies the .config file to activate
    the driver_madwifi backend, and adds the required CFLAGS to find the
    includes that are later added via one of the 21_madwifi*_includes patches.
  * Update madwifi includes to that of the current offering in the debian
    archive, r1680.
  * Implement basic locking for wpa_action action's for when the user callable
    "stop" action is executed while wpa_action is busy configuring the device.
    The wpa_cli daemon is killed, then wpa_action waits for the current action
    to finish gracefully before killing wpa_suppliant. This helps avoid
    inconsistencies with ifupdown when volatile conditions are experienced as
    part of the roaming setup (for example, driver problems causing connection
    loops).
  * Rename WPA_CLI_ACTFILE to WPA_CLI_LOCKFILE in ifupdown.sh.
  * Condemn the use of wpa-action scripts:
    - add NEWS item describing the superior alternative: wpa-roam
    - remove example action scripts
    - remove conf_wpa_cli() from ifupdown.sh
  * Condense README.Debian and NEWS, so that they contain only relevant items,
    and do not repeat the same information.
  * Massive enhancement of README.modes, in an attempt to relay the
    information about how this package, and wpa_supplicant work in debian with
    the greatest of clarity.
  * Harden tests for daemon pidfiles. No longer be satisfied that a pidfile
    exists, but use start-stop-daemon to test its validity by sending a signal
    0. Remove pidfiles that do not pass the test.
  * Fix stupid $DAEMON_VEROSITY typo that was used consistently throughout
    script. [ifupdown.sh]
  * Assoctiate "down" with the stop action of wpa_action.
  * Thanks Marc Haber for reading over docs and notifying of some of the
    follwoing issues.
    - Fix typo "automattically" in README.modes.
    - Remove bogus pre-up example from wpa_action(8) and README.modes
    - Explain in more detail how /etc/wpa_supplicant/ifupdown.sh works in
      README.modes.
  * Add "The Logfile" section to README.modes.
  * Add patch from upstream to fix writing of stakey, peerkey, and id_str
    network configuration variables into the configuration file when
    update_config=1 is set. Thanks to Felix for reporting.

applied/ubuntu/edgy 2006-08-11 16:03:29 UTC 2006-08-11
Import patches-applied version 0.5.4-5 to applied/ubuntu/edgy

Author: kelmo
Author Date: 2006-08-09 15:03:38 UTC

Import patches-applied version 0.5.4-5 to applied/ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: 2bf37862621a25c66492601463b0b502ea17797c
Unapplied parent: 2e7a580e3de43658f083409f1dba4c78653a8eef

New changelog entries:
  * STDIN was not given to external mapping script correctly. Use the power of
    eval to fix the issue. [wpa_action.sh]
  * Fix stupid debian/control error: duplicate Suggests fields.
  * Add support to wpa_action.sh and ifupdown.sh for allowing external mapping
    logic to be used as opposed to the id_str logic. Thanks to Felix Homman
    for the great insight while implementing this feature.
  * Add a timeout loop of max 60s when waiting for an action to finish.
    [wpa_action.sh]
  * Minor cleanups wrt code comments and function placement in ifupdown.sh.
  * Suggest guessnet, now that it can directly "plug in" to wpa_action. Also
    demote iproute from Recommends to Suggests, it is not important by any
    means and was only added to honour a wishlist request.
  * Prepare for ctrl_interface socket changes in 0.5.5. It can be provided by
    'DIR=foo GID=bar' or 'ctrl_interface=foo' in wpa_supplicant.conf. Our sed
    check for this path in ifupdown.sh should now support both alternatives.
  * Move LOCKFILE and LOGFILE into WPA_ namespace. [wpa_action.sh]
  * Use semi-colon instead of comma for verbose output as that seems to be a
    standard among many different applications.
  * UNRELEASED
  * Further optimisation of ifupdown.sh, use return values in
    init_wpa_supplicant() to dictate if further commands should follow, rather
    than exiting immediately.
  * Standardize echo'ing in ifupdown.sh. Add a wpa_msg() function to take care
    of "verbose|action|stdout|stderr" messages.
  * Add a 5 second timeout loop to init_wpa_supplicant() that waits for the
    ctrl_interface socket to be established before allowing wpa_cli to launch,
    and avoid a race condition. This means other functions no longer need to
    test for existance of the ctrl_interface socket. [ifupdown.sh]
  * Rename WPA_DRIVER to WPA_SUP_DRIVER to conform with name scheme of other
    similar variables. [ifupdown.sh]
  * Add (untested) wpa-bridge support to ifupdown.sh. This is an experimental
    upstream feature.
  * Major refactoring of wpa_action.sh, with all related commands put into
    independent shell functions.
  * Improve feedback from wpa_action.sh when used interactively. Give usage
    statement instead of simply returning "insufficient parameters".
  * 'wpa_action reload' is logged after the action. It is called interactively,
    and should also give interactive feedback. Same for 'wpa_action stop'.
  * Remove superfluous check for /var/log, and put logging initialisation into
    its own function, log_init(). [wpa_action.sh]
  * Shut `ip addr flush dev "$IFACE" up', it almost always has nothing to flush.
  * wpa-ifupdown init script now takes care of all interfaces while displaying
    only one line.
  * Don't set -e in wpa_action.sh. wpa-ifupdown script no longer takes exit
    status into account, and I'd prefer to account for all possible avenues of
    exit possible and log all encountered problems.
  * Really fix #375599, by containing the CTRL_IFACE_DIR path in WPA_SUP_CONF
    always, customised or not. The WPA_CTRL_IFACE socket was not being created
    when ommitted from the wpa_supplicant.conf file.
  * Add 'wpa-maint-debug' to enable set -x in ifupdown.sh, so that we can easy
    track down vague problems.
  * Slightly modify the way in which madwifi is activated. The default config
    we apply does not activate madwifi by default any longer, it is done via
    seperate patches; 20_include_madwifi modifies the .config file to activate
    the driver_madwifi backend, and adds the required CFLAGS to find the
    includes that are later added via one of the 21_madwifi*_includes patches.
  * Update madwifi includes to that of the current offering in the debian
    archive, r1680.
  * Implement basic locking for wpa_action action's for when the user callable
    "stop" action is executed while wpa_action is busy configuring the device.
    The wpa_cli daemon is killed, then wpa_action waits for the current action
    to finish gracefully before killing wpa_suppliant. This helps avoid
    inconsistencies with ifupdown when volatile conditions are experienced as
    part of the roaming setup (for example, driver problems causing connection
    loops).
  * Rename WPA_CLI_ACTFILE to WPA_CLI_LOCKFILE in ifupdown.sh.
  * Condemn the use of wpa-action scripts:
    - add NEWS item describing the superior alternative: wpa-roam
    - remove example action scripts
    - remove conf_wpa_cli() from ifupdown.sh
  * Condense README.Debian and NEWS, so that they contain only relevant items,
    and do not repeat the same information.
  * Massive enhancement of README.modes, in an attempt to relay the
    information about how this package, and wpa_supplicant work in debian with
    the greatest of clarity.
  * Harden tests for daemon pidfiles. No longer be satisfied that a pidfile
    exists, but use start-stop-daemon to test its validity by sending a signal
    0. Remove pidfiles that do not pass the test.
  * Fix stupid $DAEMON_VEROSITY typo that was used consistently throughout
    script. [ifupdown.sh]
  * Assoctiate "down" with the stop action of wpa_action.
  * Thanks Marc Haber for reading over docs and notifying of some of the
    follwoing issues.
    - Fix typo "automattically" in README.modes.
    - Remove bogus pre-up example from wpa_action(8) and README.modes
    - Explain in more detail how /etc/wpa_supplicant/ifupdown.sh works in
      README.modes.
  * Add "The Logfile" section to README.modes.
  * Add patch from upstream to fix writing of stakey, peerkey, and id_str
    network configuration variables into the configuration file when
    update_config=1 is set. Thanks to Felix for reporting.

applied/ubuntu/edgy-devel 2006-08-11 16:03:29 UTC 2006-08-11
Import patches-applied version 0.5.4-5 to applied/ubuntu/edgy

Author: kelmo
Author Date: 2006-08-09 15:03:38 UTC

Import patches-applied version 0.5.4-5 to applied/ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: 2bf37862621a25c66492601463b0b502ea17797c
Unapplied parent: 2e7a580e3de43658f083409f1dba4c78653a8eef

New changelog entries:
  * STDIN was not given to external mapping script correctly. Use the power of
    eval to fix the issue. [wpa_action.sh]
  * Fix stupid debian/control error: duplicate Suggests fields.
  * Add support to wpa_action.sh and ifupdown.sh for allowing external mapping
    logic to be used as opposed to the id_str logic. Thanks to Felix Homman
    for the great insight while implementing this feature.
  * Add a timeout loop of max 60s when waiting for an action to finish.
    [wpa_action.sh]
  * Minor cleanups wrt code comments and function placement in ifupdown.sh.
  * Suggest guessnet, now that it can directly "plug in" to wpa_action. Also
    demote iproute from Recommends to Suggests, it is not important by any
    means and was only added to honour a wishlist request.
  * Prepare for ctrl_interface socket changes in 0.5.5. It can be provided by
    'DIR=foo GID=bar' or 'ctrl_interface=foo' in wpa_supplicant.conf. Our sed
    check for this path in ifupdown.sh should now support both alternatives.
  * Move LOCKFILE and LOGFILE into WPA_ namespace. [wpa_action.sh]
  * Use semi-colon instead of comma for verbose output as that seems to be a
    standard among many different applications.
  * UNRELEASED
  * Further optimisation of ifupdown.sh, use return values in
    init_wpa_supplicant() to dictate if further commands should follow, rather
    than exiting immediately.
  * Standardize echo'ing in ifupdown.sh. Add a wpa_msg() function to take care
    of "verbose|action|stdout|stderr" messages.
  * Add a 5 second timeout loop to init_wpa_supplicant() that waits for the
    ctrl_interface socket to be established before allowing wpa_cli to launch,
    and avoid a race condition. This means other functions no longer need to
    test for existance of the ctrl_interface socket. [ifupdown.sh]
  * Rename WPA_DRIVER to WPA_SUP_DRIVER to conform with name scheme of other
    similar variables. [ifupdown.sh]
  * Add (untested) wpa-bridge support to ifupdown.sh. This is an experimental
    upstream feature.
  * Major refactoring of wpa_action.sh, with all related commands put into
    independent shell functions.
  * Improve feedback from wpa_action.sh when used interactively. Give usage
    statement instead of simply returning "insufficient parameters".
  * 'wpa_action reload' is logged after the action. It is called interactively,
    and should also give interactive feedback. Same for 'wpa_action stop'.
  * Remove superfluous check for /var/log, and put logging initialisation into
    its own function, log_init(). [wpa_action.sh]
  * Shut `ip addr flush dev "$IFACE" up', it almost always has nothing to flush.
  * wpa-ifupdown init script now takes care of all interfaces while displaying
    only one line.
  * Don't set -e in wpa_action.sh. wpa-ifupdown script no longer takes exit
    status into account, and I'd prefer to account for all possible avenues of
    exit possible and log all encountered problems.
  * Really fix #375599, by containing the CTRL_IFACE_DIR path in WPA_SUP_CONF
    always, customised or not. The WPA_CTRL_IFACE socket was not being created
    when ommitted from the wpa_supplicant.conf file.
  * Add 'wpa-maint-debug' to enable set -x in ifupdown.sh, so that we can easy
    track down vague problems.
  * Slightly modify the way in which madwifi is activated. The default config
    we apply does not activate madwifi by default any longer, it is done via
    seperate patches; 20_include_madwifi modifies the .config file to activate
    the driver_madwifi backend, and adds the required CFLAGS to find the
    includes that are later added via one of the 21_madwifi*_includes patches.
  * Update madwifi includes to that of the current offering in the debian
    archive, r1680.
  * Implement basic locking for wpa_action action's for when the user callable
    "stop" action is executed while wpa_action is busy configuring the device.
    The wpa_cli daemon is killed, then wpa_action waits for the current action
    to finish gracefully before killing wpa_suppliant. This helps avoid
    inconsistencies with ifupdown when volatile conditions are experienced as
    part of the roaming setup (for example, driver problems causing connection
    loops).
  * Rename WPA_CLI_ACTFILE to WPA_CLI_LOCKFILE in ifupdown.sh.
  * Condemn the use of wpa-action scripts:
    - add NEWS item describing the superior alternative: wpa-roam
    - remove example action scripts
    - remove conf_wpa_cli() from ifupdown.sh
  * Condense README.Debian and NEWS, so that they contain only relevant items,
    and do not repeat the same information.
  * Massive enhancement of README.modes, in an attempt to relay the
    information about how this package, and wpa_supplicant work in debian with
    the greatest of clarity.
  * Harden tests for daemon pidfiles. No longer be satisfied that a pidfile
    exists, but use start-stop-daemon to test its validity by sending a signal
    0. Remove pidfiles that do not pass the test.
  * Fix stupid $DAEMON_VEROSITY typo that was used consistently throughout
    script. [ifupdown.sh]
  * Assoctiate "down" with the stop action of wpa_action.
  * Thanks Marc Haber for reading over docs and notifying of some of the
    follwoing issues.
    - Fix typo "automattically" in README.modes.
    - Remove bogus pre-up example from wpa_action(8) and README.modes
    - Explain in more detail how /etc/wpa_supplicant/ifupdown.sh works in
      README.modes.
  * Add "The Logfile" section to README.modes.
  * Add patch from upstream to fix writing of stakey, peerkey, and id_str
    network configuration variables into the configuration file when
    update_config=1 is set. Thanks to Felix for reporting.

ubuntu/edgy-devel 2006-08-11 16:03:29 UTC 2006-08-11
Import patches-unapplied version 0.5.4-5 to ubuntu/edgy

Author: kelmo
Author Date: 2006-08-09 15:03:38 UTC

Import patches-unapplied version 0.5.4-5 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: 655737117074e8160e3a929d80f40bf5bb6a8bf5

New changelog entries:
  * STDIN was not given to external mapping script correctly. Use the power of
    eval to fix the issue. [wpa_action.sh]
  * Fix stupid debian/control error: duplicate Suggests fields.
  * Add support to wpa_action.sh and ifupdown.sh for allowing external mapping
    logic to be used as opposed to the id_str logic. Thanks to Felix Homman
    for the great insight while implementing this feature.
  * Add a timeout loop of max 60s when waiting for an action to finish.
    [wpa_action.sh]
  * Minor cleanups wrt code comments and function placement in ifupdown.sh.
  * Suggest guessnet, now that it can directly "plug in" to wpa_action. Also
    demote iproute from Recommends to Suggests, it is not important by any
    means and was only added to honour a wishlist request.
  * Prepare for ctrl_interface socket changes in 0.5.5. It can be provided by
    'DIR=foo GID=bar' or 'ctrl_interface=foo' in wpa_supplicant.conf. Our sed
    check for this path in ifupdown.sh should now support both alternatives.
  * Move LOCKFILE and LOGFILE into WPA_ namespace. [wpa_action.sh]
  * Use semi-colon instead of comma for verbose output as that seems to be a
    standard among many different applications.
  * UNRELEASED
  * Further optimisation of ifupdown.sh, use return values in
    init_wpa_supplicant() to dictate if further commands should follow, rather
    than exiting immediately.
  * Standardize echo'ing in ifupdown.sh. Add a wpa_msg() function to take care
    of "verbose|action|stdout|stderr" messages.
  * Add a 5 second timeout loop to init_wpa_supplicant() that waits for the
    ctrl_interface socket to be established before allowing wpa_cli to launch,
    and avoid a race condition. This means other functions no longer need to
    test for existance of the ctrl_interface socket. [ifupdown.sh]
  * Rename WPA_DRIVER to WPA_SUP_DRIVER to conform with name scheme of other
    similar variables. [ifupdown.sh]
  * Add (untested) wpa-bridge support to ifupdown.sh. This is an experimental
    upstream feature.
  * Major refactoring of wpa_action.sh, with all related commands put into
    independent shell functions.
  * Improve feedback from wpa_action.sh when used interactively. Give usage
    statement instead of simply returning "insufficient parameters".
  * 'wpa_action reload' is logged after the action. It is called interactively,
    and should also give interactive feedback. Same for 'wpa_action stop'.
  * Remove superfluous check for /var/log, and put logging initialisation into
    its own function, log_init(). [wpa_action.sh]
  * Shut `ip addr flush dev "$IFACE" up', it almost always has nothing to flush.
  * wpa-ifupdown init script now takes care of all interfaces while displaying
    only one line.
  * Don't set -e in wpa_action.sh. wpa-ifupdown script no longer takes exit
    status into account, and I'd prefer to account for all possible avenues of
    exit possible and log all encountered problems.
  * Really fix #375599, by containing the CTRL_IFACE_DIR path in WPA_SUP_CONF
    always, customised or not. The WPA_CTRL_IFACE socket was not being created
    when ommitted from the wpa_supplicant.conf file.
  * Add 'wpa-maint-debug' to enable set -x in ifupdown.sh, so that we can easy
    track down vague problems.
  * Slightly modify the way in which madwifi is activated. The default config
    we apply does not activate madwifi by default any longer, it is done via
    seperate patches; 20_include_madwifi modifies the .config file to activate
    the driver_madwifi backend, and adds the required CFLAGS to find the
    includes that are later added via one of the 21_madwifi*_includes patches.
  * Update madwifi includes to that of the current offering in the debian
    archive, r1680.
  * Implement basic locking for wpa_action action's for when the user callable
    "stop" action is executed while wpa_action is busy configuring the device.
    The wpa_cli daemon is killed, then wpa_action waits for the current action
    to finish gracefully before killing wpa_suppliant. This helps avoid
    inconsistencies with ifupdown when volatile conditions are experienced as
    part of the roaming setup (for example, driver problems causing connection
    loops).
  * Rename WPA_CLI_ACTFILE to WPA_CLI_LOCKFILE in ifupdown.sh.
  * Condemn the use of wpa-action scripts:
    - add NEWS item describing the superior alternative: wpa-roam
    - remove example action scripts
    - remove conf_wpa_cli() from ifupdown.sh
  * Condense README.Debian and NEWS, so that they contain only relevant items,
    and do not repeat the same information.
  * Massive enhancement of README.modes, in an attempt to relay the
    information about how this package, and wpa_supplicant work in debian with
    the greatest of clarity.
  * Harden tests for daemon pidfiles. No longer be satisfied that a pidfile
    exists, but use start-stop-daemon to test its validity by sending a signal
    0. Remove pidfiles that do not pass the test.
  * Fix stupid $DAEMON_VEROSITY typo that was used consistently throughout
    script. [ifupdown.sh]
  * Assoctiate "down" with the stop action of wpa_action.
  * Thanks Marc Haber for reading over docs and notifying of some of the
    follwoing issues.
    - Fix typo "automattically" in README.modes.
    - Remove bogus pre-up example from wpa_action(8) and README.modes
    - Explain in more detail how /etc/wpa_supplicant/ifupdown.sh works in
      README.modes.
  * Add "The Logfile" section to README.modes.
  * Add patch from upstream to fix writing of stakey, peerkey, and id_str
    network configuration variables into the configuration file when
    update_config=1 is set. Thanks to Felix for reporting.

ubuntu/dapper-devel 2006-06-15 15:06:40 UTC 2006-06-15
Import patches-unapplied version 0.4.8-3ubuntu1.1 to ubuntu/dapper-updates

Author: Reinhard Tartler
Author Date: 2006-06-13 16:47:07 UTC

Import patches-unapplied version 0.4.8-3ubuntu1.1 to ubuntu/dapper-updates

Imported using git-ubuntu import.

Changelog parent: bcad8d172f4cc2a026ab7da9b75f996ae278b798

New changelog entries:
  * Apply patch from Kel Modderman for /etc/wpa_supplicant/ifupdown.sh
    + use wpa_cli command add_network instead of some arcane awk magic
    + fix some obvious typos

applied/ubuntu/dapper-devel 2006-06-15 15:06:40 UTC 2006-06-15
Import patches-applied version 0.4.8-3ubuntu1.1 to applied/ubuntu/dapper-updates

Author: Reinhard Tartler
Author Date: 2006-06-13 16:47:07 UTC

Import patches-applied version 0.4.8-3ubuntu1.1 to applied/ubuntu/dapper-updates

Imported using git-ubuntu import.

Changelog parent: 7fce3886650073337cbc4feb57e5d04a6c73706c
Unapplied parent: 225b28f157023f6b8148c50704db682410be45cc

New changelog entries:
  * Apply patch from Kel Modderman for /etc/wpa_supplicant/ifupdown.sh
    + use wpa_cli command add_network instead of some arcane awk magic
    + fix some obvious typos

applied/ubuntu/dapper-updates 2006-06-15 15:06:40 UTC 2006-06-15
Import patches-applied version 0.4.8-3ubuntu1.1 to applied/ubuntu/dapper-updates

Author: Reinhard Tartler
Author Date: 2006-06-13 16:47:07 UTC

Import patches-applied version 0.4.8-3ubuntu1.1 to applied/ubuntu/dapper-updates

Imported using git-ubuntu import.

Changelog parent: 7fce3886650073337cbc4feb57e5d04a6c73706c
Unapplied parent: 225b28f157023f6b8148c50704db682410be45cc

New changelog entries:
  * Apply patch from Kel Modderman for /etc/wpa_supplicant/ifupdown.sh
    + use wpa_cli command add_network instead of some arcane awk magic
    + fix some obvious typos

ubuntu/dapper-updates 2006-06-15 15:06:40 UTC 2006-06-15
Import patches-unapplied version 0.4.8-3ubuntu1.1 to ubuntu/dapper-updates

Author: Reinhard Tartler
Author Date: 2006-06-13 16:47:07 UTC

Import patches-unapplied version 0.4.8-3ubuntu1.1 to ubuntu/dapper-updates

Imported using git-ubuntu import.

Changelog parent: bcad8d172f4cc2a026ab7da9b75f996ae278b798

New changelog entries:
  * Apply patch from Kel Modderman for /etc/wpa_supplicant/ifupdown.sh
    + use wpa_cli command add_network instead of some arcane awk magic
    + fix some obvious typos

ubuntu/dapper 2006-04-27 09:06:26 UTC 2006-04-27
Import patches-unapplied version 0.4.8-3ubuntu1 to ubuntu/dapper

Author: Reinhard Tartler
Author Date: 2006-04-27 08:40:57 UTC

Import patches-unapplied version 0.4.8-3ubuntu1 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 4263c7095e9797607828205da80c843f8e2ba5b7

New changelog entries:
  [ Kel Modderman ]
  * Orphaned daemons that are spawned during an ifup process that is
    manually terminated are now checked for and killed.
  * Don't make noise when we are not using the manual inet method and
    wpa-action is used.
  * Warn about non-executable action script.
  * Ensure wpa_cli actfile is destroyed before launching action script.
  * Make start-stop-daemon verbose when VERBOSITY is set.
  * Fix typo in Readme.Debian, that referred to a non-existant location.
    (Closes: #364829)
  * Add upstream fix for static wep keys with wext interfaces.
    (http://hostap.epitest.fi/bugz/show_bug.cgi?id=140)
  [ Reinhard Tartler ]
  * This is branched of revision 310 of debian/trunk
  * tested snapshot fix https://launchpad.net/bugs/41480
  * made ifupdown.sh quiet on success without --verbose
  [ Kel Modderman ]
  * Remove bad information about wpa-driver-file in docs.
  * Actually fall back to wext as DRIVER type in example init script.
  * Fix typo in debian/control, remove suggests of dhcp*-client alltogether.
    (Closes: #361555)
  * Remove bogus commands to set eapol_version and fast_reauth. They cannot be
    set via wpa_cli. (Closes: #361425)
  * Make preauthenticate a global wpa_cli setting, rather than a per-ssid one.
  * Kill dhclient process after a DISCONNECT signal in dhclient action script
    example.
  * Document that the action script must must be executable.
  * Fix check for wireless extensions for when there is not whitespace after
    $IFACE:.
  * grep for $IFACE in /proc/net/dev to verify it is a valid network interface.
  * Improve documentation about wpa-driver, and further clarify that all
    wpa_cli commands should be supported in e/n/i by prefixing them with
    "wpa-".
  * Add a note about wpa-action-timeout.
  [ Reinhard Tartler ]
  * remove last reference to /etc/default/wpasupplicant. It is gone, don't
    revive zombies!
  * small cleanups in debian/rules
  * backport ap_scan patch. (Closes the other part of: #361425)
  * further clarifications in README.Debian
  [ Kel Modderman ]
  * Make ifupdown script exit silently when binaries are not found or
    executable.
  * When ifupdown exits with an error status, do not hide the echo'd problem
    description behind the VERBOSITY environment variable.
  * Remove check for wpa_cli pidfile when executing an action script. This
    check was racy, and not always successful. Sometimes, the device was
    marked as up without allowing the action script a chance to finish.
  * Improve feedback for wpa_cli action script daemon.
  * Ensure WPA_CLI_ACTFILE is removed when wpa_cli is terminated.
  * Fix typo in ifupdown script that later propogated into some example
    information in README.debian (wpa-apscan should have been wpa-ap-scan).
    Provide backwards compatibility for this change for those who already
    followed the example.
  * Check for existing pidfiles before launching daemons via ifupdown.
  * Provide an example init based roaming daemon and instructions on how to
    restore old behaviour of the package. (Closes: #360387)
  [ Reinhard Tartler ]
  * enable driver test
  * add eap_testing.txt to documentation
  * enhance Readme.txt
  [ Reinhard Tartler ]
  * Finally bringing in the new Upstream version with the ap scan patch for
    wpa-cli, required by network-manager (Closes: #356072)
  * Dropping Mode 3 (start by init script) (Closes: #356842, #357760)
  * add hint for associating to hidden ssids (Closes: #358137)
  * add a note for faciliating debugging connection problems
  * add this note to README.modes as well.
  * remove or backup obsolete conffiles
    /etc/network/if-p{re-up,ost-down}.d/wpasupplicant
  * install the wpasupplicant.conf(5) manpage (Closes: #358138)
  * don't start wpa_supplicant for loopback interface (Closes: #359814)
  * add explanation about action scripts, mentioning that we expect now
    the action script to create a file indicating that the interface is ready
    for use.
  * add warning in NEWS.Debian that upgrading to this package requires
    manual intervention by the local admin.
  * move old 'default configuration' to /usr/share/doc/wpasupplicant/examples
    as example for connecting to open APs.
  * remove version restriction from preinst. This means that obsoleted
    conffiles are always removed!
  * moved the ifupdown script to /etc/wpa_supplicant/ifupdown.sh
  * added note about binaries beeing moved to /sbin
  [ Scott James Remnant ]
  * Undo 0.4.8-0ubuntu2's replacement of the preinst/postinst/postrm triad,
    which replaced the upgrade-failure proof and policy compliant code with
    "something else".
  * Restore change to ifupdown script that makes "wpa-conf" unnecessary.
  * Move /etc/wpa_supplicant.conf to /etc/wpa_supplicant/wpa_supplicant.conf
    if the user has modified it, otherwise remove it and install the new file.
  * Remove 0_ from if-*.d symlink names as we don't force an order or
    even serialisation.
  [ Kel Modderman ]
  * Remove check for /proc/net/packet. (Closes: M#37121)
  * Add timeout loop when launching a wpa_cli action script in conjunction
    with the manual inet METHOD, to allow other ifupdown hooks to
    post-configure the interface just as they would have if using a standard
    method such as dhcp or static. Introduce WPA_CLI_ACTFILE to allow a
    wpa_cli action script to signal connected state to ifupdown.
  * Add skeleton wpa_cli action script to examples.
  * Simplify wpasupplicant.examples.
  * Don't install wpa_supplcant.defconf as the default wpa_supplicant conffile,
    our users don't want that file interrogated by anyone, even dpkg.

applied/ubuntu/dapper 2006-04-27 09:06:26 UTC 2006-04-27
Import patches-applied version 0.4.8-3ubuntu1 to applied/ubuntu/dapper

Author: Reinhard Tartler
Author Date: 2006-04-27 08:40:57 UTC

Import patches-applied version 0.4.8-3ubuntu1 to applied/ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 9d1d19eec478bccfdadf1b6fb56688e9de8ab66f
Unapplied parent: bcad8d172f4cc2a026ab7da9b75f996ae278b798

New changelog entries:
  [ Kel Modderman ]
  * Orphaned daemons that are spawned during an ifup process that is
    manually terminated are now checked for and killed.
  * Don't make noise when we are not using the manual inet method and
    wpa-action is used.
  * Warn about non-executable action script.
  * Ensure wpa_cli actfile is destroyed before launching action script.
  * Make start-stop-daemon verbose when VERBOSITY is set.
  * Fix typo in Readme.Debian, that referred to a non-existant location.
    (Closes: #364829)
  * Add upstream fix for static wep keys with wext interfaces.
    (http://hostap.epitest.fi/bugz/show_bug.cgi?id=140)
  [ Reinhard Tartler ]
  * This is branched of revision 310 of debian/trunk
  * tested snapshot fix https://launchpad.net/bugs/41480
  * made ifupdown.sh quiet on success without --verbose
  [ Kel Modderman ]
  * Remove bad information about wpa-driver-file in docs.
  * Actually fall back to wext as DRIVER type in example init script.
  * Fix typo in debian/control, remove suggests of dhcp*-client alltogether.
    (Closes: #361555)
  * Remove bogus commands to set eapol_version and fast_reauth. They cannot be
    set via wpa_cli. (Closes: #361425)
  * Make preauthenticate a global wpa_cli setting, rather than a per-ssid one.
  * Kill dhclient process after a DISCONNECT signal in dhclient action script
    example.
  * Document that the action script must must be executable.
  * Fix check for wireless extensions for when there is not whitespace after
    $IFACE:.
  * grep for $IFACE in /proc/net/dev to verify it is a valid network interface.
  * Improve documentation about wpa-driver, and further clarify that all
    wpa_cli commands should be supported in e/n/i by prefixing them with
    "wpa-".
  * Add a note about wpa-action-timeout.
  [ Reinhard Tartler ]
  * remove last reference to /etc/default/wpasupplicant. It is gone, don't
    revive zombies!
  * small cleanups in debian/rules
  * backport ap_scan patch. (Closes the other part of: #361425)
  * further clarifications in README.Debian
  [ Kel Modderman ]
  * Make ifupdown script exit silently when binaries are not found or
    executable.
  * When ifupdown exits with an error status, do not hide the echo'd problem
    description behind the VERBOSITY environment variable.
  * Remove check for wpa_cli pidfile when executing an action script. This
    check was racy, and not always successful. Sometimes, the device was
    marked as up without allowing the action script a chance to finish.
  * Improve feedback for wpa_cli action script daemon.
  * Ensure WPA_CLI_ACTFILE is removed when wpa_cli is terminated.
  * Fix typo in ifupdown script that later propogated into some example
    information in README.debian (wpa-apscan should have been wpa-ap-scan).
    Provide backwards compatibility for this change for those who already
    followed the example.
  * Check for existing pidfiles before launching daemons via ifupdown.
  * Provide an example init based roaming daemon and instructions on how to
    restore old behaviour of the package. (Closes: #360387)
  [ Reinhard Tartler ]
  * enable driver test
  * add eap_testing.txt to documentation
  * enhance Readme.txt
  [ Reinhard Tartler ]
  * Finally bringing in the new Upstream version with the ap scan patch for
    wpa-cli, required by network-manager (Closes: #356072)
  * Dropping Mode 3 (start by init script) (Closes: #356842, #357760)
  * add hint for associating to hidden ssids (Closes: #358137)
  * add a note for faciliating debugging connection problems
  * add this note to README.modes as well.
  * remove or backup obsolete conffiles
    /etc/network/if-p{re-up,ost-down}.d/wpasupplicant
  * install the wpasupplicant.conf(5) manpage (Closes: #358138)
  * don't start wpa_supplicant for loopback interface (Closes: #359814)
  * add explanation about action scripts, mentioning that we expect now
    the action script to create a file indicating that the interface is ready
    for use.
  * add warning in NEWS.Debian that upgrading to this package requires
    manual intervention by the local admin.
  * move old 'default configuration' to /usr/share/doc/wpasupplicant/examples
    as example for connecting to open APs.
  * remove version restriction from preinst. This means that obsoleted
    conffiles are always removed!
  * moved the ifupdown script to /etc/wpa_supplicant/ifupdown.sh
  * added note about binaries beeing moved to /sbin
  [ Scott James Remnant ]
  * Undo 0.4.8-0ubuntu2's replacement of the preinst/postinst/postrm triad,
    which replaced the upgrade-failure proof and policy compliant code with
    "something else".
  * Restore change to ifupdown script that makes "wpa-conf" unnecessary.
  * Move /etc/wpa_supplicant.conf to /etc/wpa_supplicant/wpa_supplicant.conf
    if the user has modified it, otherwise remove it and install the new file.
  * Remove 0_ from if-*.d symlink names as we don't force an order or
    even serialisation.
  [ Kel Modderman ]
  * Remove check for /proc/net/packet. (Closes: M#37121)
  * Add timeout loop when launching a wpa_cli action script in conjunction
    with the manual inet METHOD, to allow other ifupdown hooks to
    post-configure the interface just as they would have if using a standard
    method such as dhcp or static. Introduce WPA_CLI_ACTFILE to allow a
    wpa_cli action script to signal connected state to ifupdown.
  * Add skeleton wpa_cli action script to examples.
  * Simplify wpasupplicant.examples.
  * Don't install wpa_supplcant.defconf as the default wpa_supplicant conffile,
    our users don't want that file interrogated by anyone, even dpkg.

ubuntu/breezy-devel 2005-12-21 06:07:19 UTC 2005-12-21
Import patches-unapplied version 0.4.5-0ubuntu1 to ubuntu/breezy

Author: Daniel T Chen
Author Date: 2005-10-03 01:24:42 UTC

Import patches-unapplied version 0.4.5-0ubuntu1 to ubuntu/breezy

Imported using git-ubuntu import.

Changelog parent: 5bae7b39a4b83e96bf86fe91b2d1f63ffac89ad0

New changelog entries:
  * New upstream version.
  * New upstream version.
  * Ship a default /etc/wpa_supplicant.conf which associates with any
    open access point. (closes: #287220, #322171, #315964)
  * /etc/default/wpasupplicant is no longer mode 755 (closes: #315031)
  * Add a postrm script, oops, overlooked this initially... (closes: #327522)
  * Fix hyphen/minus in man pages. (closes: #296310)
  * patches/
    - 01_config
      + update
      + Enable wired driver. (closes: #325296)
      + Add EAP_FAST to config, but comment it out. EAP_FAST requires a patch
        to openssl before it is compileable.
    - 10_madwifi_includes
      + update from madwifi CVS. (closes: #326226)
  * New upstream release.
  * Add debhelper flag to postinst.
  * New upstream release.
  * This release was not uploaded.
  * New upstream release.
  * patches/
    - 12_ipw_open_aps
      + remove patch: It seems to cause problems with associating with
        open access points.
    - 11_madwifi_open_aps
      + remove patch, fixed upstream
          driver_madwifi: fixed association in plaintext mode

ubuntu/breezy 2005-12-21 06:07:19 UTC 2005-12-21
Import patches-unapplied version 0.4.5-0ubuntu1 to ubuntu/breezy

Author: Daniel T Chen
Author Date: 2005-10-03 01:24:42 UTC

Import patches-unapplied version 0.4.5-0ubuntu1 to ubuntu/breezy

Imported using git-ubuntu import.

Changelog parent: 5bae7b39a4b83e96bf86fe91b2d1f63ffac89ad0

New changelog entries:
  * New upstream version.
  * New upstream version.
  * Ship a default /etc/wpa_supplicant.conf which associates with any
    open access point. (closes: #287220, #322171, #315964)
  * /etc/default/wpasupplicant is no longer mode 755 (closes: #315031)
  * Add a postrm script, oops, overlooked this initially... (closes: #327522)
  * Fix hyphen/minus in man pages. (closes: #296310)
  * patches/
    - 01_config
      + update
      + Enable wired driver. (closes: #325296)
      + Add EAP_FAST to config, but comment it out. EAP_FAST requires a patch
        to openssl before it is compileable.
    - 10_madwifi_includes
      + update from madwifi CVS. (closes: #326226)
  * New upstream release.
  * Add debhelper flag to postinst.
  * New upstream release.
  * This release was not uploaded.
  * New upstream release.
  * patches/
    - 12_ipw_open_aps
      + remove patch: It seems to cause problems with associating with
        open access points.
    - 11_madwifi_open_aps
      + remove patch, fixed upstream
          driver_madwifi: fixed association in plaintext mode

applied/ubuntu/breezy 2005-12-21 06:07:19 UTC 2005-12-21
Import patches-applied version 0.4.5-0ubuntu1 to applied/ubuntu/breezy

Author: Daniel T Chen
Author Date: 2005-10-03 01:24:42 UTC

Import patches-applied version 0.4.5-0ubuntu1 to applied/ubuntu/breezy

Imported using git-ubuntu import.

Changelog parent: 3ee9390f7ccb8111a3fc795cf2c0e2a523355a5b
Unapplied parent: c1745bdebd3152f0115f10d9a3d61ff525995884

New changelog entries:
  * New upstream version.
  * New upstream version.
  * Ship a default /etc/wpa_supplicant.conf which associates with any
    open access point. (closes: #287220, #322171, #315964)
  * /etc/default/wpasupplicant is no longer mode 755 (closes: #315031)
  * Add a postrm script, oops, overlooked this initially... (closes: #327522)
  * Fix hyphen/minus in man pages. (closes: #296310)
  * patches/
    - 01_config
      + update
      + Enable wired driver. (closes: #325296)
      + Add EAP_FAST to config, but comment it out. EAP_FAST requires a patch
        to openssl before it is compileable.
    - 10_madwifi_includes
      + update from madwifi CVS. (closes: #326226)
  * New upstream release.
  * Add debhelper flag to postinst.
  * New upstream release.
  * This release was not uploaded.
  * New upstream release.
  * patches/
    - 12_ipw_open_aps
      + remove patch: It seems to cause problems with associating with
        open access points.
    - 11_madwifi_open_aps
      + remove patch, fixed upstream
          driver_madwifi: fixed association in plaintext mode

applied/ubuntu/breezy-devel 2005-12-21 06:07:19 UTC 2005-12-21
Import patches-applied version 0.4.5-0ubuntu1 to applied/ubuntu/breezy

Author: Daniel T Chen
Author Date: 2005-10-03 01:24:42 UTC

Import patches-applied version 0.4.5-0ubuntu1 to applied/ubuntu/breezy

Imported using git-ubuntu import.

Changelog parent: 3ee9390f7ccb8111a3fc795cf2c0e2a523355a5b
Unapplied parent: c1745bdebd3152f0115f10d9a3d61ff525995884

New changelog entries:
  * New upstream version.
  * New upstream version.
  * Ship a default /etc/wpa_supplicant.conf which associates with any
    open access point. (closes: #287220, #322171, #315964)
  * /etc/default/wpasupplicant is no longer mode 755 (closes: #315031)
  * Add a postrm script, oops, overlooked this initially... (closes: #327522)
  * Fix hyphen/minus in man pages. (closes: #296310)
  * patches/
    - 01_config
      + update
      + Enable wired driver. (closes: #325296)
      + Add EAP_FAST to config, but comment it out. EAP_FAST requires a patch
        to openssl before it is compileable.
    - 10_madwifi_includes
      + update from madwifi CVS. (closes: #326226)
  * New upstream release.
  * Add debhelper flag to postinst.
  * New upstream release.
  * This release was not uploaded.
  * New upstream release.
  * patches/
    - 12_ipw_open_aps
      + remove patch: It seems to cause problems with associating with
        open access points.
    - 11_madwifi_open_aps
      + remove patch, fixed upstream
          driver_madwifi: fixed association in plaintext mode

ubuntu/hoary-devel 2005-12-20 21:57:33 UTC 2005-12-20
Import patches-unapplied version 0.3.8-1 to ubuntu/hoary

Author: Kyle McMartin
Author Date: 2005-02-15 05:51:28 UTC

Import patches-unapplied version 0.3.8-1 to ubuntu/hoary

Imported using git-ubuntu import.

applied/ubuntu/hoary-devel 2005-12-20 21:57:33 UTC 2005-12-20
Import patches-applied version 0.3.8-1 to applied/ubuntu/hoary

Author: Kyle McMartin
Author Date: 2005-02-15 05:51:28 UTC

Import patches-applied version 0.3.8-1 to applied/ubuntu/hoary

Imported using git-ubuntu import.

Unapplied parent: 5bae7b39a4b83e96bf86fe91b2d1f63ffac89ad0

applied/ubuntu/hoary 2005-12-20 21:57:33 UTC 2005-12-20
Import patches-applied version 0.3.8-1 to applied/ubuntu/hoary

Author: Kyle McMartin
Author Date: 2005-02-15 05:51:28 UTC

Import patches-applied version 0.3.8-1 to applied/ubuntu/hoary

Imported using git-ubuntu import.

Unapplied parent: 5bae7b39a4b83e96bf86fe91b2d1f63ffac89ad0

ubuntu/hoary 2005-12-20 21:57:33 UTC 2005-12-20
Import patches-unapplied version 0.3.8-1 to ubuntu/hoary

Author: Kyle McMartin
Author Date: 2005-02-15 05:51:28 UTC

Import patches-unapplied version 0.3.8-1 to ubuntu/hoary

Imported using git-ubuntu import.

194 of 94 results

Other repositories

Name Last Modified
lp:ubuntu/+source/wpasupplicant 2018-03-09
11 of 1 result
You can't create new repositories for wpasupplicant in Ubuntu.