lp:ubuntu/precise/facter

Created by James Westby on 2011-10-13 and last modified on 2012-01-30
Get this branch:
bzr branch lp:ubuntu/precise/facter
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

18. By Adam Gandelman on 2012-01-30

* Merge from Debian testing (LP: #922788). Remaining changes:
  - debian/rules: use what we had in natty; we don't want ruby-pkg-tools
    in main. (LP: #408402)
  - debian/control: Continue using ruby + libopenssl-ruby as Build-Depends
    even tho Debian has moved to gem2deb (not in main). Move ruby-json to
    Suggests.
  - debian/rules: Use dh_prep instead of dh_clean, add build-arch +
    build-indep targets
  - debian/control: Make binary package depend on ruby1.8 explicitly.
* Dropped changes:
  - debian/control: Update debhelper Build-Depends to 8 (Updated in Debian)
* Move dmidecode from Depends to Recommends (Closes: #651501)
* New upstream release
* Add dependency on dmidecode
* New upstream release

17. By Adam Gandelman on 2011-11-10

* Merge from Debian testing (LP: #888671). Remaining changes:
  - debian/rules: use what we had in natty; we don't want ruby-pkg-tools
    in main. (LP: #408402)
  - debian/control: Continue using ruby + libopenssl-ruby as Build-Depends
    even tho Debian has moved to gem2deb (not in main). Move ruby-json to
    Suggests.
* debian/rules: Use dh_prep instead of dh_clean, add build-arch + build-indep
  targets
* debian/control: Update debhelper Build-Depends to 8, make binary package
  depend on ruby1.8 explicitly.

16. By Adam Gandelman on 2011-10-18

* Merge from Debian unstable (LP: #877621). Remaining changes:
  - debian/rules: use what we had in natty; we dont want ruby-pkg-tools
    in main. (LP: #408402)
* debian/control: Continue using ruby + libopenssl-ruby as Build-Depends
  even tho Debian has moved to gem2deb (not in main). Move ruby-json to
  Suggests.

15. By Andres Rodriguez on 2011-05-27

* Merge from debian unstable (LP: #788284). Remaining changes:
  - Dropped ruby-pkg-tools and libsetup-ruby1.8; debian/rules: use what we
    had in natty; we dont want ruby-pkg-tools in main. (LP: #408402)
* Dropped changes to lib/facter/ec2.rb. (Use the latest-meta api so it
  always does not retunr false). This was fixed upstream.

14. By Chuck Short on 2011-04-04

lib/facter/ec2.rb: Use the latest-meta api so it always
does not return false. (LP: #732953)

13. By Chuck Short on 2011-02-08

* Merge from debian unstable. Remaining changes:
  - Dropped ruby-pkg-tools and libsetup-ruby1.8, we dont want ruby-pkg-tools
    in main. (LP: #408402)

12. By Chuck Short on 2011-01-10

* Merge from debian unstable, remaining changes are:
  - Dropped ruby-pkg-tools and libsetup-ruby1.8, we dont want ruby-pkg-tools
    in main. (LP: #408402)

11. By Chuck Short on 2010-03-26

* Merge from debian testing. Remaining changes:
  - Dropped ruby-pkg-tools, and libsetup-ruby1.8, and cdbs, use what
    we had in lucid. Since we dont want ruby-pkg-tools in main
    (LP: #408402)

10. By Chuck Short on 2010-03-26

Dropped ruby-pkg-tools, and libsetup-ruby1.8, and cdbs, use what
we had in karmic. Since we dont want ruby-pkg-tools in main.
(LP: #408402)

9. By Chuck Short on 2009-11-06

* Merge from debian testing, remaining changes:
  - Use bind9-host9 only.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/quantal/facter
This branch contains Public information 
Everyone can see this information.

Subscribers