lp:ubuntu/lucid/nvidia-graphics-drivers

Created by James Westby on 2010-01-09 and last modified on 2010-05-21
Get this branch:
bzr branch lp:ubuntu/lucid/nvidia-graphics-drivers
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Development

Recent revisions

19. By Alberto Milone on 2010-04-09

* debian/nvidia-$flavour.{dirs|postinst}.in, rules:
  - Install the blacklist file in /lib/nvidia-$flavour instead
    of /usr/lib/nvidia-$flavour so that the file is available
    early in the boot process when /usr is on a different
    partition (LP: #538071).
  - Ignore errors when trying to update the initramfs
    with -k $CURRENT_KERNEL which is known to fail when
    using chroots (LP: #556653).

18. By Alberto Milone on 2010-03-17

* New upstream release:
  - Fixed a bug that caused the X server to crash when rendering
    occurred while the X server was not on the active VT.
  - Fixed a regression that caused the driver to fail to properly
    adjust the GPU fan speed on some GPUs.
  - Fixed a bug that prevented performance level transitions on
    recent GPUs with SDDR3 and GDDR5 memory.
* debian/nvidia-$flavour.{postinst|prerm}.in:
  - Call gmenucache trigger so that the icon of nvidia-settings
    shows up in the menu (LP: #522969).
* debian/nvidia-current.links{32}.in:
  - Add link to libOpenCL.so in /usr/lib and in /usr/lib32.

17. By Alberto Milone on 2010-03-05

* New upstream release:
  - Added support for the following GPUs:
    o Quadro FX 880M
    o GeForce GTS 350M
    o GeForce GTS 360M
  - Fixed a bug that caused screen corruption after an application
    released a GLX_NV_present_video device.
  - Fixed brightness control hotkeys on some laptops.
  - Fixed a bug that caused G-Sync stereo synchronization to fail
    sometimes when enabling frame lock.
  - Fixed a bug that caused OpenGL applications to occasionally crash
    with "double free or corruption" messages when exiting.
  - On GPUs with VDPAU feature set A, enhanced VDPAU's handling of
    some corrupted or incorrectly formatted MPEG-1/2 streams. This
    solves a reported issue with "0testbad.mpg".
  - Fixed a bug in the VDPAU video mixer that caused chroma
    aberrations, and corruption in the right-hand few columns of
    pixels, when post-processing video surfaces with widths not an
    exact multiple of 4 pixels.
  - Fixed a bug that prevented the GPUFanControlState attribute from
    being set on the nvidia-settings command line.

16. By Alberto Milone on 2010-02-17

* New upstream release:
  - Fixed a regression that made the "TVStandard" X
    configuration option cause system hangs with products
    from the GeForce 6 and 7 series.
  - Worked around a bug in some AUO laptop flat panels
    where the native mode in the EDID is invalid, leading to
    a 640x480 desktop repeated six times across the screen.
  - Increased the maximum number of slices supported by VDPAU
    for MPEG-2 streams, in order to cope with the region 1
    DVD "A Christmas Story".
  - Added unofficial preliminary support for xorg-server
    video driver ABI version 7, including xorg-server-1.7.99.2.
  - Fix the soname of libvdpau_nvidia.so.1 and
    libvdpau_trace.so.1 to match their filenames.

15. By Alberto Milone on 2010-02-04

* debian/rules:
  - Blacklist lbm-nouveau.

14. By Alberto Milone on 2010-02-04

* debian/rules:
  - Use the real name of the kernel module in the modalias
    file instead of the alias.

13. By Alberto Milone on 2010-02-03

* debian/nvidia-current.postinst.in:
  - Pass -u to update-initramfs in addition to -k.

12. By Alberto Milone on 2010-02-03

* debian/postinst.in:
  - Update initramfs for the current kernel instead of
    echoing the action.

11. By Alberto Milone on 2010-02-03

* debian/postinst.in:
  - Update the initramfs for the current kernel and for the
    newest one so that the blacklist file is included in
    the initramfs and nouveau can be blacklisted early.

10. By Alberto Milone on 2010-01-26

* debian/control.in:
  - Add transitional packages for nvidia-185-libvdpau and
    nvidia-185-libvdpau-dev so that old vdpau libraries
    don't break the alternatives system.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/maverick/nvidia-graphics-drivers
This branch contains Public information 
Everyone can see this information.

Subscribers