lp:ubuntu/lucid/gdebi

Created by James Westby on 2009-12-05 and last modified on 2010-04-10
Get this branch:
bzr branch lp:ubuntu/lucid/gdebi
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Development

Recent revisions

23. By Michael Vogt on 2010-04-06

cherry pick r309 from lp:~gdebi-developers/gdebi/trunk to
fix i18n issue (LP: #554731)

22. By Michael Vogt on 2010-03-09

* data/gdebi.desktop.in, data/gdebi-kde.desktop.in:
  - Remove Encoding field, deprecated.
* debian/control:
  - Set XS-Python-Version to all (Closes: #570560).
  - Differentiate short descrriptions for gdebi and gdebi-kde.
* GDebi/DebPackage.py:
  - improve i18n by using %(var)s LP: #403632, thanks to
    David Planella
* data/gdebi.ui, GDebi/DebPackage.py:
  - alignment fixes in the status label
* GDebi/SimpleGtkbuilderApp.py:
  - set translation domain here explicitly instead of in gdebi.ui
    (the later is often cleared by glade for some reason)
* .bzr-builddeb/default.conf:
  - build as native package again
* unified release for Debian&Ubuntu

21. By Luca Falavigna on 2010-01-25

* gdebi, GDebi/GDebiCli.py:
  - Correctly parse translated "y" characters (Closes: #497821).
* GDebi/GDebiCli.py:
  - Allow install of Debian binary packages with uncommon extensions
    or missing one (Closes: #472693).
* po/es.po:
  - Update Spanish translation, by Omar Campagne (Closes: #556927).
* README:
  - No longer mention packages are Ubuntu-specific, they are available
    in Debian too (Closes: #453709).
* debian/control:
  - Do not build-depend on python-dev, python is enough.

20. By Luca Falavigna on 2009-10-20

* GDebi/GDebi.py:
  - Do not pass --status-fd to dpkg to avoid install failures due to bad
    descriptors not correctly passed by vte, this can be reverted when
    https://bugzilla.gnome.org/320128 will be fixed.
* data/gdebi.1, data/gdebi-gtk.1:
  - Refresh man pages, many thanks to Kartik Mistry! (Closes: #531297).
* data/gdebi-kde.1:
  - Add man page for gdebi-kde.

19. By Luca Falavigna on 2009-10-02

* New upstream release from Ubuntu (Closes: #514125).
  + Compatible with recent python-apt versions (Closes: #438714).
  + When checking if a dependency is satified, ensure to test for all
    provided ones (Closes: #490870).
  + Let install packages with spaces in the filename (Closes: #515238).
  + Localization updates:
    - Catalan (Closes: #415987).
    - French (Closes: #410377).
    - German (Closes: #511221).
    - Hebrew (Closes: #461138).
    - Slowak (Closes: #531775).
    - Swedish (Closes: #517508).

* GDebi/GDebi.py:
  + Do not pass --always-ask-pass to gksu, this option is not currently
    supported in Debian gksu package (Closes: #493352).
* debian/control:
  + Add myself to Uploaders, I will help Gustavo and Michael maintaining
    gdebi in Debian via collab-maint (Closes: #547634).
  + Bump Standards-Version to 3.8.3.
* debian/copyright:
  + Add copyright notice.
* debian/rules:
  - Do not hardcode {site,dist}-package directory (Closes: #547873).
  - Remove useless dh_desktop call.

18. By Thomas Viehmann <email address hidden> on 2008-10-04

* Non-maintainer upload.
* GDebi/GDebi.py: Don't use non-existent vte features but
  use a wrapper to proxy dpkg statusfd via a named pipe.
  Closes: #493353.

17. By Gustavo Franco on 2006-08-22

* New Python Policy release. (Closes: #380810)
  - Bump up Standards-Version to 3.7.2
  - Move debhelper and python-all-dev to Build-Depends field
  - Add python-support to Build-Depends-Indep field
    [debian/control]
  - debian/rules: Add dh_pysupport call before dh_python
  - Add debian/pycompat and debian/pyversions
* Merge 0.1.6ubuntu1 changes.

16. By Michael Vogt on 2006-05-19

* data/gdebi.glade:
  - "Included Files" text area is not editable (#44293)
  - make some labels selectable (Maintainer, Section, etc)
   (ubuntu #44295)
* GDebi/GDebi.py:
  - add "KB" for the size (#44286)

15. By Michael Vogt on 2006-05-17

* GDebi/GDebi.py:
  - fix bug in the invokation of the child
  - don't fail on non utf-8 descriptions (ubuntu: #39786)
* po/POTFILES.in:
  - added missing file (ubuntu #44354)

14. By Michael Vogt on 2006-05-08

* use desktop file when runing gksu (thanks to
  Sebastian Heinlein)
* i18n updates from debian

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/maverick/gdebi
This branch contains Public information 
Everyone can see this information.

Subscribers