lp:ubuntu/maverick/gdebi

Created by James Westby on 2010-05-01 and last modified on 2010-09-10
Get this branch:
bzr branch lp:ubuntu/maverick/gdebi
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

27. By Michael Vogt on 2010-09-10

* merged from bzr trunk, this can be later synced with debian
  once debian has a newer version, nothing ubuntu specific
  in this anymore

[ David Prévot ]
* po/fr.po:
  - Update French translation (Closes: #594910).

[ Yaron Shahrabani ]
* po/he.po:
  - Update Hebrew translation (LP: #626360).

[ Luca Falavigna ]
* debian/control:
  - Update maintainer address to the ubuntu-dev-team @Alioth.

[ Michael Vogt ]
* GDebi/GDebi.py:
  - update InstallProgressAdapter to match the new
    apt.progres.base.InstallProgress names
  - fix crash if no synaptic config is there (LP: #624703)
  - do not crash if lock can not be released, but log it
    to the console (LP: #630784)
* GDebi/KDEAptDialogs.py:
  - check if errno is there before using it (LP: #625221)

26. By Michael Vogt on 2010-08-25

* merged from bzr trunk, this can be later synced with debian
  once debian has a newer version, nothing ubuntu specific
  in this anymore

[ Michael Vogt ]
* debian/control:
  - depend on the latest python-apt to get the "dump()"
    method
* GDebi/GDebi.py:
  - synaptics config is always stored under /root

[ Andrew Higginson ]
* GDebi/GDebi.py:
  - Read whether we autoclose from synaptic config
    file and write to it as well (LP: #376966)

[ Michal Simunek ]
* po/cs.po:
  - Update Czech translation (Closes: #590848).

[ Luca Falavigna ]
* GDebi/GDebiKDE.py:
  - Switch back to kdesudo, kdesu isn't available anymore both in
    Debian and Ubuntu (Closes: #591306).
* GDebi/GDebi.py:
  - Adjust FetchProgressAdapter namespace, fix NameError exception
    trying to install packages which requires more dependencies
    (LP: #614690).

25. By Michael Vogt on 2010-07-28

[ Michael Vogt ]
* use DebPackage from python-apt and depend on python-apt >= 0.7.96
* merged lp:~kiwinote/gdebi/use-python-apt (with some minor
  modifcations)

[ Luca Falavigna ]
* GDebi/GDebiKDE.py:
  - Use kdesudo instead of kdesu in Ubuntu (LP: #600644).

24. By Luca Falavigna on 2010-06-24

[ Luca Falavigna ]
* GDebi/DebPackage.py:
  - Correctly parse strictly earlier version of conflicting packages
    to allow installation of packages conflicting with a version lower
    than the one being installed (LP: #484097).
  - Replace imports of deprecated debian_bundle with debian.
* GDebi/DebPackage.py:
  - Fix typo in format string, thanks Simon Ruggier (Closes: #577851).
* GDebi/GDebiKDE.py:
  - Use kdesu instead of kdesudo (Closes: #584860).
* debian/control:
  - Depend on python-debian >= 0.1.15.

[ Michael Vogt ]
* use --auto-deconfigure when runnign dpkg to correctly handle C/R.
* po/es.po:
  - updated, thanks to Omar Campagne (closes: #578612).
* do not use the VteReaper anymore, use the child-exited and
  get_child_exit_status() functions of VteTerminal for this
  (closes: #574168).
* make link in about page clickable and point to launchpad.net
  project page (LP: #562729), thanks to Gabe Gorelick.
* port to python-apt 0.8 API (closes: #571763).

23. By Michael Vogt on 2010-04-06

cherry pick r309 from lp:~gdebi-developers/gdebi/trunk to
fix i18n issue (LP: #554731)

22. By Michael Vogt on 2010-03-09

* data/gdebi.desktop.in, data/gdebi-kde.desktop.in:
  - Remove Encoding field, deprecated.
* debian/control:
  - Set XS-Python-Version to all (Closes: #570560).
  - Differentiate short descrriptions for gdebi and gdebi-kde.
* GDebi/DebPackage.py:
  - improve i18n by using %(var)s LP: #403632, thanks to
    David Planella
* data/gdebi.ui, GDebi/DebPackage.py:
  - alignment fixes in the status label
* GDebi/SimpleGtkbuilderApp.py:
  - set translation domain here explicitly instead of in gdebi.ui
    (the later is often cleared by glade for some reason)
* .bzr-builddeb/default.conf:
  - build as native package again
* unified release for Debian&Ubuntu

21. By Luca Falavigna on 2010-01-25

* gdebi, GDebi/GDebiCli.py:
  - Correctly parse translated "y" characters (Closes: #497821).
* GDebi/GDebiCli.py:
  - Allow install of Debian binary packages with uncommon extensions
    or missing one (Closes: #472693).
* po/es.po:
  - Update Spanish translation, by Omar Campagne (Closes: #556927).
* README:
  - No longer mention packages are Ubuntu-specific, they are available
    in Debian too (Closes: #453709).
* debian/control:
  - Do not build-depend on python-dev, python is enough.

20. By Luca Falavigna on 2009-10-20

* GDebi/GDebi.py:
  - Do not pass --status-fd to dpkg to avoid install failures due to bad
    descriptors not correctly passed by vte, this can be reverted when
    https://bugzilla.gnome.org/320128 will be fixed.
* data/gdebi.1, data/gdebi-gtk.1:
  - Refresh man pages, many thanks to Kartik Mistry! (Closes: #531297).
* data/gdebi-kde.1:
  - Add man page for gdebi-kde.

19. By Luca Falavigna on 2009-10-02

* New upstream release from Ubuntu (Closes: #514125).
  + Compatible with recent python-apt versions (Closes: #438714).
  + When checking if a dependency is satified, ensure to test for all
    provided ones (Closes: #490870).
  + Let install packages with spaces in the filename (Closes: #515238).
  + Localization updates:
    - Catalan (Closes: #415987).
    - French (Closes: #410377).
    - German (Closes: #511221).
    - Hebrew (Closes: #461138).
    - Slowak (Closes: #531775).
    - Swedish (Closes: #517508).

* GDebi/GDebi.py:
  + Do not pass --always-ask-pass to gksu, this option is not currently
    supported in Debian gksu package (Closes: #493352).
* debian/control:
  + Add myself to Uploaders, I will help Gustavo and Michael maintaining
    gdebi in Debian via collab-maint (Closes: #547634).
  + Bump Standards-Version to 3.8.3.
* debian/copyright:
  + Add copyright notice.
* debian/rules:
  - Do not hardcode {site,dist}-package directory (Closes: #547873).
  - Remove useless dh_desktop call.

18. By Thomas Viehmann <email address hidden> on 2008-10-04

* Non-maintainer upload.
* GDebi/GDebi.py: Don't use non-existent vte features but
  use a wrapper to proxy dpkg statusfd via a named pipe.
  Closes: #493353.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/natty/gdebi
This branch contains Public information 
Everyone can see this information.

Subscribers