lp:ubuntu/gutsy-proposed/pidgin

Created by James Westby on 2009-06-27 and last modified on 2009-06-27
Get this branch:
bzr branch lp:ubuntu/gutsy-proposed/pidgin
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Development

Recent revisions

18. By Martin Pitt on 2009-03-10

Add 80_fix_ICQ_new_protocol.patch: Backport upstream patch to fix
connection with new ICQ protocol. (LP: #340151)

17. By Iain Lane on 2008-07-02

Apply patch from upstream to fix issue where ICQ would not connect
(LP: #244591)

16. By Stephan Ruegamer on 2007-11-26

* SECURITY UPDATE: (LP: #158400)
  + CVE-2007-4999: libpurple in Pidgin 2.1.0 through 2.2.1, when using HTML
    logging, allows remote attackers to cause a denial of service (NULL
    dereference and application crash) via a message that contains invalid HTML
    data, a different vector than CVE-2007-4996.
* debian/patches/99_CVE-2007-4999.patch:
  - Applied patch by upstream
  - Link: http://developer.pidgin.im/viewmtn/revision/diff/0810c68ce97a8213a5edbf5ffe7c1418915d3dfe/with/aff089bc73ecc6fe8ebbeac670db8be13511fcf4
* References:
  CVE-2007-4999
  http://developer.pidgin.im/ticket/3436

15. By Sebastien Bacher on 2007-10-10

* debian/patches/80_from_upstream_fix_irc_formatting_issue.patch:
  - patch from upstream, fix an IRC formatting issue
    (LP: #141201)

14. By Sebastien Bacher on 2007-10-03

* debian/control:
  - Build-Depends on libsqlite3-dev (LP: #112720)

13. By Sebastien Bacher on 2007-10-02

* debian/prefs.xml:
  - changes from "Whoopie", don't load docklet.so and use
    "pathlist" rather than "stringlist", fix plugins selections (LP: #144122)

12. By Sebastien Bacher on 2007-10-01

Sync with Debian

11. By Sebastien Bacher on 2007-09-19

* Sync with Debian (LP: #139686)
* debian/control:
  - Build-Depends on liblaunchpad-integration-dev, intltool, libnm-glib-dev
  - don't Build-Depends on libsilc-1.1-2-dev | libsilc-dev (>= 1.1.1),
    the library is in universe
  - changed the transition version to use the ubuntu epoch number
  - list gaim transitionnal package for updates
  - pidgin-data Replaces gaim-data
  - updated the maintainer for Ubuntu
* debian/copyright:
  - build in the source, that's a soyuz requirement to accept the upload
* debian/gaim.links:
  - gaim compatibility symlinks
* debian/patches/01_lpi.patch:
  - launchpad integration patch.
* debian/patches/02_autoconf.patch:
  - configure update
* debian/patches/04_let_crasher_for_apport.patch:
  - don't catch crashes, apport does that.
  - fixes apport having broken backtraces for gaim
* debian/patches/14_xulrunner_nss.patch:
  - removed for Ubuntu, firefox nss is used
* debian/patches/99_default_to_irc_ubuntu_com.patch:
  - set default irc server to irc.ubuntu.com
* debian/pidgin-dbg.preinst, debian/pidgin-dev.preinst, debian/pidgin.preinst:
  - use the correct transition version
* debian/prefs.xml:
  - set the notify by default (Ubuntu: #13389)
* debian/rules:
  - add translation domain and update template
  - build with network-manager and without libsilc
  - don't remove the copyright on clean

10. By Sebastien Bacher on 2007-08-30

* debian/pidgin-dbg.preinst, debian/pidgin-dev.preinst, debian/pidgin.preinst:
  - patch from Laurent Bigonville, use the correct transition version
    (LP: #135722)

9. By Sebastien Bacher on 2007-08-30

* Sync with Debian
* debian/control:
  - Build-Depends on liblaunchpad-integration-dev, intltool, libnm-glib-dev
  - don't Build-Depends on libsilc-1.1-2-dev | libsilc-dev (>= 1.1.1),
    the library is in universe
  - changed the transition version to use the ubuntu epoch number
  - list gaim transitionnal package for updates
  - pidgin-data Replaces gaim-data
  - updated the maintainer for Ubuntu
* debian/copyright:
  - build in the source, that's a soyuz requirement to accept the upload
* debian/gaim.links:
  - transitionnal update package
* debian/patches/01_lpi.patch:
  - launchpad integration patch.
* debian/patches/02_autoconf.patch:
  - configure update
* debian/patches/04_let_crasher_for_apport.patch:
  - don't catch crashes, apport does that.
  - fixes apport having broken backtraces for gaim
* debian/patches/14_xulrunner_nss.patch:
  - removed for Ubuntu, firefox nss is used
* debian/patches/99_default_to_irc_ubuntu_com.patch:
  - set default irc server to irc.ubuntu.com
* debian/prefs.xml:
  - set the notify by default (Ubuntu: #13389)
* debian/rules:
  - add translation domain and update template
  - build with network-manager and without libsilc
  - don't remove the copyright on clean

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/karmic/pidgin
This branch contains Public information 
Everyone can see this information.

Subscribers