Mir

Code review comment for lp:~robertcarr/mir/add-event-action-defines

Revision history for this message
Robert Carr (robertcarr) wrote :

Thanks for review!

>> 1. Missed a spot :)
>> src/client/input/android_input_receiver.cpp: if (ev.key.action == 1)

Good catch. Fixed

>>2. Trying to avoid identifiers getting too long, can we change:
>> mir_key_event_action_*
>> mir_motion_event_action_*
>>to
>> mir_key_action_*
>> mir_motion_action_*
>>?

Yeah!

>> 3. Can we use typedefs instead of anonymous enums? That would allow us to change:
>> int32_t action;
>> to:
>> MirKeyAction action;
>> MirMotionAction action;
>> etc.

I don't have a strong opinion. As it stands though each field is chosen to be the same as the platform-api event struct, there is a bit of a mess there (currently they are out of sync requiring expensive marshalling in the platform-API). Anyway the moral is that I'd like to discuss redesigning and solidifying the event struct next week and delay any changes until then.

« Back to merge proposal