Mir

Code review comment for lp:~robertcarr/mir/add-event-action-defines

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

1. Missed a spot :)
src/client/input/android_input_receiver.cpp: if (ev.key.action == 1)

2. Trying to avoid identifiers getting too long, can we change:
   mir_key_event_action_*
   mir_motion_event_action_*
to
   mir_key_action_*
   mir_motion_action_*
?

3. Can we use typedefs instead of anonymous enums? That would allow us to change:
   int32_t action;
to:
   MirKeyAction action;
   MirMotionAction action;
etc.

review: Needs Fixing

« Back to merge proposal