Code review comment for lp:~rackspace-titan/glance/wsgi-refactor

Revision history for this message
Brian Lamar (blamar) wrote :

164: HTTPBadRequest needs explanation=msg to actually display the passed-in message.

680: Not sure if it will hinder readability, but this blank line seems out of place.

716 + try:
717 + del args['controller']
718 + except KeyError:
719 + pass

I've been playing with this replacement logic/syntax:

args.pop("controller", None)

It's not as explicit, which I don't like, but it gets the job done and isn't too cryptic.

Starting at 1064, should those each be it's own test?

I like your style/spacing! :)

review: Needs Fixing

« Back to merge proposal