aikido:new_planning_api_tests

Last commit made on 2018-05-11
Get this branch:
git clone -b new_planning_api_tests https://git.launchpad.net/aikido

Branch merges

Branch information

Name:
new_planning_api_tests
Repository:
lp:aikido

Recent commits

6bc5f43... by Jeongseok Lee

Add a test for ConfigurationToConfiguration

15adfa6... by Brian Hou <email address hidden>

Remove v0.2.0 from deployed documentation. (#411)

693537d... by Jeongseok Lee <email address hidden>

Refactor planner API (#314)

* Add Planner class and associated APIs

* Fix code format

* Pass function argument as const reference

* Rename planning problems

* Revise snap planner

* Apply snap planner to util

* Add PlannerFor[Single/Multi]Problem

* Remove getPlannableProblems()

* Fix const-correctness of CompositePlanner

* Set state space when a planner is created

Move interpolator from problem to planner

* Rename Problem's getName() to getType()

* Fix grammar errors

* Use unordered_set for goal states

* Remove interpolator from problem

* Code format

* Address comments that are straightforward

* Add missing explicit specifier

* Use more descriptive parameter name

* Add utility functions for goal states

* Minor updates

* Remove PlannerForMultiProblem

rename PlannerForSingleProblem to SingleProblemPlanner

* Remove setters from problem

All the problem classes intentionally don't have setters. This is because we assume creating a new problem for different problem settings makes sense. We can revisit this design decision if we find a compelling reason to have setters.

* Rename TheProblem to SolverblaProblem

* Take problem as const reference

* Remove CompositePlanner::addPlanner()

* Move constraint to Problem

* Add missing [in]

* Fix util according to the API changes

* Address a few TODOs

* Remove constraint from concrete problems

* Code format

* Fix typo: SolverbleProblem --> SolvableProblem

* Be further strict to const-correctness

* Add type checking assertions

* Add docstrings

* Update changelog

* Address Brian's comments (needs code format)

* Format code

* Address Gilwoo's feedback

* Update header guard name

* Throw exception for zero-sized direction vector

* Use \throw instead of \throws

* Pass planner by const reference to check existency

* Fix compilation errors per Clang 9.1.0

a565cd7... by Brian Hou <email address hidden>

Move docs into $TRAVIS_BUILD_DIR rather than $HOME. (#410)

1e1a22a... by Brian Hou <email address hidden>

Add before_deploy step to .travis.yml (#409)

c733c97... by Brian Hou <email address hidden>

Build multiple versions of documentation (#403)

* Introduce a separate DOCS entry in the build matrix.

Build documentation for a list of different versions.

960f1e0... by Brian Hou <email address hidden>

Define variables where they're used. (#407)

f28bb7c... by Jeongseok Lee <email address hidden>

Setup Travis CI to use Docker (#397)

677e9a5... by Brian Hou <email address hidden>

Fix documentation typo. (#406)

263a72a... by Daniel G <email address hidden>

Add get body node or throw (#399)

* added getBodyNodeOrThrow convenience function to robot::util

* code formatting and MetaSkeleton instead of Skeleton

* MetaSkeleton as const reference

* doc update

* integrated PR requests

* Format code