lp:~percona-dev/percona-xtrabackup/mysql-5-5-8-cmake

Created by Ignacio Nin on 2010-12-26 and last modified on 2010-12-26
Get this branch:
bzr branch lp:~percona-dev/percona-xtrabackup/mysql-5-5-8-cmake
Members of Percona developers can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Recent revisions

207. By Ignacio Nin on 2010-12-18

Compile against 5.5.8

MySQL 5.5.8 uses cmake as build system, these changes are to adapt xtrabackup to it

206. By Alexey Kopytov on 2010-12-19

Updated XtraBackup patches and the build script to the latest MySQL 5.1, 5.5 and Percona Server releases.

205. By Alexey Kopytov on 2010-12-10

Added tests for incremental and partial backups (merge from Valentine)

204. By Aleksandr Kuzminsky on 2010-12-10

set dhelper compat level to 5 to let xtrabackup be built on hardy

203. By Aleksandr Kuzminsky on 2010-12-09

Use XtraDB w/o response-time-distribution.patch

202. By Aleksandr Kuzminsky on 2010-12-03

Minimal changes required for fixing the compilation problems created by new version of cpp (present in Maverick and Fedora 14 for example).

201. By Alexey Kopytov on 2010-12-02

Fixed the broken 5.5 build introduced by revision 200.

200. By Alexey Kopytov on 2010-12-01

LP bug#683507: xtrabackup should be updated to use the latest 5.1, 5.5
and XtraDB releases

Updated xtrabackup's code, Makefile and the Percona Server patch so that
they are now based on Percona Server 5.1.53-12.

The patch was also renamed from fix_innodb_for_backup_percona-server-11
to fix_innodb_for_backup_percona-server as it does not make sense to
keep release number in the patch name.

199. By Alexey Kopytov on 2010-12-01

LP bug#683507: xtrabackup should be updated to use the latest 5.1, 5.5
and XtraDB releases

Updated xtrabackup's Makefile and the 5.5 patch so that they are now
based on MySQL 5.5.7.

In addition, to simplify maintenance the parallel transfer functionality
was changed to use os_mutex_* API rather than the mutex_* one because
the last one was changed in 5.5.

198. By Alexey Kopytov on 2010-12-01

LP bug#683507: xtrabackup should be updated to use the latest 5.1, 5.5
               and XtraDB releases

Updated xtrabackup's Makefile and the 5.1/plugin patches so that they
are now based on MySQL 5.1.52.

In addition, fix_innodb_for_backup_5.1_plugin_1.0.7.patch was renamed to
fix_innodb_for_backup_5.1_plugin.patch, since the plugin version is
different now, and it does not make sense to keep the version number in
the patch name.

This patch also fixes LP bug#681789, since I had to update and test the
broken patch anyway.

Branch metadata

Branch format:
Branch format 6
Repository format:
Bazaar pack repository format 1 (needs bzr 0.92)
This branch contains Public information 
Everyone can see this information.