Merge ~paul-martin-1/cirros:paulm/fixes into cirros:master

Proposed by Paul Martin on 2019-04-25
Status: Merged
Merged at revision: 359b5ebda0b84db947b60c2b75e4d14feb900dc6
Proposed branch: ~paul-martin-1/cirros:paulm/fixes
Merge into: cirros:master
Diff against target: 28286 lines (+15285/-2538)
12 files modified
README (+11/-9)
bin/build-release (+3/-3)
bin/system-setup (+1/-0)
conf/buildroot-aarch64.config (+2408/-325)
conf/buildroot-arm.config (+2408/-442)
conf/buildroot-i386.config (+2298/-379)
conf/buildroot-powerpc.config (+2239/-371)
conf/buildroot-ppc64.config (+1805/-293)
conf/buildroot-ppc64le.config (+1796/-288)
conf/buildroot-x86_64.config (+2316/-376)
dev/null (+0/-50)
patches-buildroot/series (+0/-2)
Reviewer Review Type Date Requested Status
Scott Moser 2019-04-25 Approve on 2019-05-16
Review via email: mp+366521@code.launchpad.net

Commit message

Changes to allow building on Ubuntu Bionic (18.04), with an aarch64 image that works.

* Update Buildroot to 2019.02.1.
* Update Kernel to 4.4.0.142.168
* Update Grub2 to 2.02~beta2-36ubuntu3.21

LP: #1813319

To post a comment you must log in.
Scott Moser (smoser) wrote :

> Update source versions in bin/build-release.
...
> NB. The given version of Ubuntu's Linux kernel is the last to contain a
> i386 build.

This comment is just wrong.
There are i386 kernels for 18.04 (4.15).

I put up a merge proposal at
 https://code.launchpad.net/~smoser/cirros/+git/cirros/+merge/367475
which adds downloading support for the 4.15.

I'm testing now with './bin/grab-kernels 4.15.0-50.54'

Paul Martin (paul-martin-1) wrote :

Thanks for those comments. They should now be fixed.

Scott Moser (smoser) wrote :

This was really well done.
Thank you for your work and your patience.

I put a build of at
 http://download.cirros-cloud.net/contrib/nowster/20190515/

with essentially what i just landed here.

I've rebased this branch on top of the 566b84c58 (grab-kernels: support newer kernel packages.)
and then fast-forwarded.

review: Approve

Preview Diff

[H/L] Next/Prev Comment, [J/K] Next/Prev File, [N/P] Next/Prev Hunk
diff --git a/README b/README
index 8422e30..29d3cf0 100644
--- a/README
+++ b/README
@@ -1,7 +1,8 @@
1This is a project to build a small cloud image that has useful tools and1This is a project to build a small cloud image that has useful tools and
2function for debugging or developing cloud infrastructure.2function for debugging or developing cloud infrastructure.
33
4The following works on Ubuntu 14.04 LTS.4The following works on Ubuntu 18.04 LTS, running on x86_64. Native building
5for other architectures is not recommended.
56
6To use it, you would do something like:7To use it, you would do something like:
7 * get the build dependencies:8 * get the build dependencies:
@@ -16,7 +17,7 @@ To use it, you would do something like:
16 * cd cirros17 * cd cirros
1718
18 * download buildroot and setup environment19 * download buildroot and setup environment
19 $ br_ver="2015.05"20 $ br_ver="2019.02.1"
20 $ mkdir -p ../download21 $ mkdir -p ../download
21 $ ln -snf ../download download22 $ ln -snf ../download download
22 $ ( cd download && wget http://buildroot.uclibc.org/downloads/buildroot-${br_ver}.tar.gz )23 $ ( cd download && wget http://buildroot.uclibc.org/downloads/buildroot-${br_ver}.tar.gz )
@@ -32,11 +33,12 @@ To use it, you would do something like:
32 ( cd buildroot && QUILT_PATCHES=$PWD/../patches-buildroot quilt push -a )33 ( cd buildroot && QUILT_PATCHES=$PWD/../patches-buildroot quilt push -a )
3334
34 * download the buildroot sources35 * download the buildroot sources
35 $ make ARCH=i386 br-source36 $ ARCH=i386
37 $ make ARCH=$ARCH br-source
3638
37 * Build buildroot for a given arch39 * Build buildroot for a given arch
38 # ARCH should be set to 'i386', 'x86_64' or 'arm'40 # ARCH should be set to 'i386', 'x86_64', 'arm' or 'aarch64'
39 $ make ARCH=i386 OUT_D=$PWD/output/i38641 $ make ARCH=$ARCH OUT_D=$PWD/output/$ARCH
4042
41 This will do a full buildroot build, which will take a while. The output43 This will do a full buildroot build, which will take a while. The output
42 that CirrOS is interested in is output/i386/rootfs.tar.44 that CirrOS is interested in is output/i386/rootfs.tar.
@@ -48,15 +50,15 @@ To use it, you would do something like:
48 kernel is used as a starting point.50 kernel is used as a starting point.
4951
50 # kver is newest -updates kernel from https://launchpad.net/ubuntu/+source/linux52 # kver is newest -updates kernel from https://launchpad.net/ubuntu/+source/linux
51 $ kver="3.19.0-20.20~14.04.1"53 $ kver="4.4.0-148.174"
52 $ ./bin/grab-kernels "$kver"54 $ ./bin/grab-kernels "$kver" $ARCH
5355
54 * Download EFI grub to use.56 * Download EFI grub to use.
55 The grub-efi input to bundle will be in tar.gz format.57 The grub-efi input to bundle will be in tar.gz format.
5658
57 # gver is newest from https://launchpad.net/ubuntu/+source/grub259 # gver is newest from https://launchpad.net/ubuntu/+source/grub2
58 $ gver="2.02~beta2-36ubuntu8"60 $ gver="2.02~beta2-36ubuntu3.22"
59 $ ./bin/grab-grub-efi "$gver"61 $ ./bin/grab-grub-efi "$gver" $ARCH
6062
61 * build disk images using bin/bundle63 * build disk images using bin/bundle
62 $ sudo ./bin/bundle -v --arch=$ARCH output/$ARCH/rootfs.tar \64 $ sudo ./bin/bundle -v --arch=$ARCH output/$ARCH/rootfs.tar \
diff --git a/bin/build-release b/bin/build-release
index 72e7860..455ad70 100755
--- a/bin/build-release
+++ b/bin/build-release
@@ -28,10 +28,10 @@ if [ "$1" = "daily" ]; then
28fi28fi
29shift29shift
30pre=cirros-$VER30pre=cirros-$VER
31BR_VER="${BR_VER:-2015.05}" # WARNING: this may be non-trivial to change31BR_VER="${BR_VER:-2019.02.1}" # WARNING: this may be non-trivial to change
32ARCHES="${ARCHES:-i386 x86_64 arm powerpc aarch64 ppc64 ppc64le}"32ARCHES="${ARCHES:-i386 x86_64 arm powerpc aarch64 ppc64 ppc64le}"
33KVER="${KVER:-4.4.0-28.47}" # Ubuntu 16.0433KVER="${KVER:-4.4.0-148.174}" # Ubuntu 16.04
34GVER="${GVER:-2.02~beta2-36ubuntu8}" # Ubuntu 16.0434GVER="${GVER:-2.02~beta2-36ubuntu3.22}" # Ubuntu 16.04
35ME=$(readlink -f "$0")35ME=$(readlink -f "$0")
36MY_D=${ME%/*}36MY_D=${ME%/*}
37PATH=${MY_D}:$PATH37PATH=${MY_D}:$PATH
diff --git a/bin/system-setup b/bin/system-setup
index 6b596d3..4fddb5c 100755
--- a/bin/system-setup
+++ b/bin/system-setup
@@ -9,6 +9,7 @@ DEPS=(
9 bc9 bc
10 bison10 bison
11 build-essential11 build-essential
12 grub-common
12 git13 git
13 dosfstools14 dosfstools
14 flex15 flex
diff --git a/conf/buildroot-aarch64.config b/conf/buildroot-aarch64.config
index 5d5b99d..14c1417 100644
--- a/conf/buildroot-aarch64.config
+++ b/conf/buildroot-aarch64.config
@@ -1,20 +1,32 @@
1#1#
2# Automatically generated file; DO NOT EDIT.2# Automatically generated file; DO NOT EDIT.
3# Buildroot 2015.05 Configuration3# Buildroot 2019.02.1-gbb4c1c5 Configuration
4#4#
5BR2_HAVE_DOT_CONFIG=y5BR2_HAVE_DOT_CONFIG=y
6BR2_HOST_GCC_AT_LEAST_4_5=y
7BR2_HOST_GCC_AT_LEAST_4_6=y
8BR2_HOST_GCC_AT_LEAST_4_7=y
9BR2_HOST_GCC_AT_LEAST_4_8=y
10BR2_HOST_GCC_AT_LEAST_4_9=y
11BR2_HOST_GCC_AT_LEAST_5=y
12BR2_HOST_GCC_AT_LEAST_6=y
13BR2_HOST_GCC_AT_LEAST_7=y
614
7#15#
8# Target options16# Target options
9#17#
10BR2_ARCH_IS_64=y18BR2_ARCH_IS_64=y
19BR2_ARCH_HAS_MMU_MANDATORY=y
20BR2_ARCH_HAS_MMU_OPTIONAL=y
11# BR2_arcle is not set21# BR2_arcle is not set
12# BR2_arceb is not set22# BR2_arceb is not set
13# BR2_arm is not set23# BR2_arm is not set
14# BR2_armeb is not set24# BR2_armeb is not set
15BR2_aarch64=y25BR2_aarch64=y
16# BR2_bfin is not set26# BR2_aarch64_be is not set
27# BR2_csky is not set
17# BR2_i386 is not set28# BR2_i386 is not set
29# BR2_m68k is not set
18# BR2_microblazeel is not set30# BR2_microblazeel is not set
19# BR2_microblazebe is not set31# BR2_microblazebe is not set
20# BR2_mips is not set32# BR2_mips is not set
@@ -22,18 +34,77 @@ BR2_aarch64=y
22# BR2_mips64 is not set34# BR2_mips64 is not set
23# BR2_mips64el is not set35# BR2_mips64el is not set
24# BR2_nios2 is not set36# BR2_nios2 is not set
37# BR2_or1k is not set
25# BR2_powerpc is not set38# BR2_powerpc is not set
26# BR2_powerpc64 is not set39# BR2_powerpc64 is not set
27# BR2_powerpc64le is not set40# BR2_powerpc64le is not set
41# BR2_riscv is not set
28# BR2_sh is not set42# BR2_sh is not set
29# BR2_sparc is not set43# BR2_sparc is not set
44# BR2_sparc64 is not set
30# BR2_x86_64 is not set45# BR2_x86_64 is not set
31# BR2_xtensa is not set46# BR2_xtensa is not set
47BR2_ARCH_HAS_TOOLCHAIN_BUILDROOT=y
32BR2_ARCH="aarch64"48BR2_ARCH="aarch64"
33BR2_ENDIAN="LITTLE"49BR2_ENDIAN="LITTLE"
34BR2_ARCH_HAS_ATOMICS=y50BR2_GCC_TARGET_ABI="lp64"
51BR2_GCC_TARGET_CPU="cortex-a53"
35BR2_BINFMT_SUPPORTS_SHARED=y52BR2_BINFMT_SUPPORTS_SHARED=y
53BR2_READELF_ARCH_NAME="AArch64"
36BR2_BINFMT_ELF=y54BR2_BINFMT_ELF=y
55BR2_ARM_CPU_HAS_FPU=y
56BR2_ARM_CPU_HAS_VFPV2=y
57BR2_ARM_CPU_HAS_VFPV3=y
58BR2_ARM_CPU_HAS_VFPV4=y
59BR2_ARM_CPU_HAS_FP_ARMV8=y
60BR2_ARM_CPU_ARMV8A=y
61
62#
63# armv8 cores
64#
65# BR2_cortex_a35 is not set
66BR2_cortex_a53=y
67# BR2_cortex_a57 is not set
68# BR2_cortex_a57_a53 is not set
69# BR2_cortex_a72 is not set
70# BR2_cortex_a72_a53 is not set
71# BR2_cortex_a73 is not set
72# BR2_cortex_a73_a35 is not set
73# BR2_cortex_a73_a53 is not set
74# BR2_exynos_m1 is not set
75# BR2_falkor is not set
76# BR2_qdf24xx is not set
77# BR2_thunderx is not set
78# BR2_thunderxt81 is not set
79# BR2_thunderxt83 is not set
80# BR2_thunderxt88 is not set
81# BR2_thunderxt88p1 is not set
82# BR2_xgene1 is not set
83
84#
85# armv8.1a cores
86#
87# BR2_thunderx2t99 is not set
88# BR2_thunderx2t99p1 is not set
89# BR2_vulcan is not set
90
91#
92# armv8.2a cores
93#
94# BR2_cortex_a55 is not set
95# BR2_cortex_a75 is not set
96# BR2_cortex_a75_a55 is not set
97
98#
99# armv8.3a cores
100#
101# BR2_saphira is not set
102# BR2_ARM_FPU_VFPV2 is not set
103# BR2_ARM_FPU_VFPV3 is not set
104# BR2_ARM_FPU_VFPV3D16 is not set
105# BR2_ARM_FPU_VFPV4 is not set
106# BR2_ARM_FPU_VFPV4D16 is not set
107BR2_ARM_FPU_FP_ARMV8=y
37108
38#109#
39# Build options110# Build options
@@ -49,11 +120,11 @@ BR2_GIT="git"
49BR2_CVS="cvs"120BR2_CVS="cvs"
50BR2_LOCALFILES="cp"121BR2_LOCALFILES="cp"
51BR2_SCP="scp"122BR2_SCP="scp"
52BR2_SSH="ssh"
53BR2_HG="hg"123BR2_HG="hg"
54BR2_ZCAT="gzip -d -c"124BR2_ZCAT="gzip -d -c"
55BR2_BZCAT="bzcat"125BR2_BZCAT="bzcat"
56BR2_XZCAT="xzcat"126BR2_XZCAT="xzcat"
127BR2_LZCAT="lzip -d -c"
57BR2_TAR_OPTIONS=""128BR2_TAR_OPTIONS=""
58BR2_DEFCONFIG="$(CONFIG_DIR)/defconfig"129BR2_DEFCONFIG="$(CONFIG_DIR)/defconfig"
59BR2_DL_DIR="$(TOPDIR)/dl"130BR2_DL_DIR="$(TOPDIR)/dl"
@@ -72,18 +143,18 @@ BR2_JLEVEL=2
72BR2_CCACHE=y143BR2_CCACHE=y
73BR2_CCACHE_DIR="$(HOME)/.buildroot-ccache"144BR2_CCACHE_DIR="$(HOME)/.buildroot-ccache"
74BR2_CCACHE_INITIAL_SETUP=""145BR2_CCACHE_INITIAL_SETUP=""
75# BR2_DEPRECATED is not set146BR2_CCACHE_USE_BASEDIR=y
76# BR2_ENABLE_DEBUG is not set147# BR2_ENABLE_DEBUG is not set
77BR2_STRIP_strip=y148BR2_STRIP_strip=y
78# BR2_STRIP_none is not set
79BR2_STRIP_EXCLUDE_FILES=""149BR2_STRIP_EXCLUDE_FILES=""
80BR2_STRIP_EXCLUDE_DIRS=""150BR2_STRIP_EXCLUDE_DIRS=""
81# BR2_OPTIMIZE_0 is not set151# BR2_OPTIMIZE_0 is not set
82# BR2_OPTIMIZE_1 is not set152# BR2_OPTIMIZE_1 is not set
83# BR2_OPTIMIZE_2 is not set153# BR2_OPTIMIZE_2 is not set
84# BR2_OPTIMIZE_3 is not set154# BR2_OPTIMIZE_3 is not set
155# BR2_OPTIMIZE_G is not set
85BR2_OPTIMIZE_S=y156BR2_OPTIMIZE_S=y
86# BR2_ENABLE_SSP is not set157# BR2_OPTIMIZE_FAST is not set
87# BR2_STATIC_LIBS is not set158# BR2_STATIC_LIBS is not set
88BR2_SHARED_LIBS=y159BR2_SHARED_LIBS=y
89# BR2_SHARED_STATIC_LIBS is not set160# BR2_SHARED_STATIC_LIBS is not set
@@ -94,73 +165,112 @@ BR2_GLOBAL_PATCH_DIR=""
94# Advanced165# Advanced
95#166#
96# BR2_COMPILER_PARANOID_UNSAFE_PATH is not set167# BR2_COMPILER_PARANOID_UNSAFE_PATH is not set
168# BR2_FORCE_HOST_BUILD is not set
169# BR2_REPRODUCIBLE is not set
170
171#
172# Security Hardening Options
173#
174
175#
176# Stack Smashing Protection needs a toolchain w/ SSP
177#
178BR2_RELRO_NONE=y
179# BR2_RELRO_PARTIAL is not set
180# BR2_RELRO_FULL is not set
181
182#
183# Fortify Source needs a glibc toolchain and optimization
184#
97185
98#186#
99# Toolchain187# Toolchain
100#188#
101BR2_TOOLCHAIN=y189BR2_TOOLCHAIN=y
102BR2_TOOLCHAIN_USES_GLIBC=y190BR2_TOOLCHAIN_USES_UCLIBC=y
103BR2_TOOLCHAIN_BUILDROOT=y191BR2_TOOLCHAIN_BUILDROOT=y
104# BR2_TOOLCHAIN_EXTERNAL is not set192# BR2_TOOLCHAIN_EXTERNAL is not set
193
194#
195# Toolchain Buildroot Options
196#
105BR2_TOOLCHAIN_BUILDROOT_VENDOR="buildroot"197BR2_TOOLCHAIN_BUILDROOT_VENDOR="buildroot"
198BR2_TOOLCHAIN_BUILDROOT_UCLIBC=y
199# BR2_TOOLCHAIN_BUILDROOT_GLIBC is not set
200# BR2_TOOLCHAIN_BUILDROOT_MUSL is not set
201BR2_TOOLCHAIN_BUILDROOT_LIBC="uclibc"
106202
107#203#
108# Kernel Header Options204# Kernel Header Options
109#205#
110# BR2_KERNEL_HEADERS_3_2 is not set206# BR2_KERNEL_HEADERS_4_4 is not set
111# BR2_KERNEL_HEADERS_3_4 is not set207# BR2_KERNEL_HEADERS_4_9 is not set
112# BR2_KERNEL_HEADERS_3_10 is not set208# BR2_KERNEL_HEADERS_4_14 is not set
113# BR2_KERNEL_HEADERS_3_12 is not set209BR2_KERNEL_HEADERS_4_19=y
114# BR2_KERNEL_HEADERS_3_14 is not set210# BR2_KERNEL_HEADERS_4_20 is not set
115# BR2_KERNEL_HEADERS_3_18 is not set
116# BR2_KERNEL_HEADERS_3_19 is not set
117BR2_KERNEL_HEADERS_4_0=y
118# BR2_KERNEL_HEADERS_VERSION is not set211# BR2_KERNEL_HEADERS_VERSION is not set
119BR2_DEFAULT_KERNEL_HEADERS="4.0.4"212# BR2_KERNEL_HEADERS_CUSTOM_TARBALL is not set
120# BR2_TOOLCHAIN_BUILDROOT_EGLIBC is not set213# BR2_KERNEL_HEADERS_CUSTOM_GIT is not set
121BR2_TOOLCHAIN_BUILDROOT_GLIBC=y214BR2_DEFAULT_KERNEL_HEADERS="4.19.32"
122# BR2_TOOLCHAIN_BUILDROOT_MUSL is not set215BR2_PACKAGE_LINUX_HEADERS=y
123BR2_TOOLCHAIN_BUILDROOT_LIBC="glibc"216
124BR2_PACKAGE_GLIBC=y217#
125BR2_GLIBC_VERSION_2_20=y218# uClibc Options
126# BR2_GLIBC_VERSION_2_21 is not set219#
127BR2_GLIBC_VERSION_STRING="2.20"220BR2_PACKAGE_UCLIBC=y
221BR2_UCLIBC_CONFIG="package/uclibc/uClibc-ng.config"
222BR2_UCLIBC_CONFIG_FRAGMENT_FILES=""
223# BR2_TOOLCHAIN_BUILDROOT_WCHAR is not set
224# BR2_TOOLCHAIN_BUILDROOT_LOCALE is not set
225BR2_PTHREADS_NATIVE=y
226# BR2_PTHREADS_NONE is not set
227# BR2_PTHREAD_DEBUG is not set
228# BR2_TOOLCHAIN_BUILDROOT_USE_SSP is not set
229BR2_UCLIBC_INSTALL_UTILS=y
128230
129#231#
130# Binutils Options232# Binutils Options
131#233#
132BR2_BINUTILS_VERSION_2_24=y234BR2_PACKAGE_HOST_BINUTILS_SUPPORTS_CFI=y
133# BR2_BINUTILS_VERSION_2_25 is not set235# BR2_BINUTILS_VERSION_2_28_X is not set
134BR2_BINUTILS_VERSION="2.24"236BR2_BINUTILS_VERSION_2_29_X=y
237# BR2_BINUTILS_VERSION_2_30_X is not set
238# BR2_BINUTILS_VERSION_2_31_X is not set
239BR2_BINUTILS_VERSION="2.29.1"
135BR2_BINUTILS_EXTRA_CONFIG_OPTIONS=""240BR2_BINUTILS_EXTRA_CONFIG_OPTIONS=""
136241
137#242#
138# GCC Options243# GCC Options
139#244#
140BR2_GCC_NEEDS_MPC=y
141BR2_GCC_SUPPORTS_GRAPHITE=y
142BR2_GCC_VERSION_4_8_X=y
143# BR2_GCC_VERSION_4_9_X is not set245# BR2_GCC_VERSION_4_9_X is not set
144BR2_GCC_SUPPORTS_FINEGRAINEDMTUNE=y246# BR2_GCC_VERSION_5_X is not set
145BR2_GCC_VERSION="4.8.4"247# BR2_GCC_VERSION_6_X is not set
248BR2_GCC_VERSION_7_X=y
249# BR2_GCC_VERSION_8_X is not set
250BR2_GCC_SUPPORTS_LIBCILKRTS=y
251BR2_GCC_VERSION="7.4.0"
146BR2_EXTRA_GCC_CONFIG_OPTIONS=""252BR2_EXTRA_GCC_CONFIG_OPTIONS=""
147# BR2_TOOLCHAIN_BUILDROOT_CXX is not set253# BR2_TOOLCHAIN_BUILDROOT_CXX is not set
148BR2_GCC_ENABLE_TLS=y254# BR2_TOOLCHAIN_BUILDROOT_FORTRAN is not set
149# BR2_GCC_ENABLE_LTO is not set255# BR2_GCC_ENABLE_LTO is not set
150# BR2_GCC_ENABLE_OPENMP is not set256# BR2_GCC_ENABLE_OPENMP is not set
151# BR2_GCC_ENABLE_LIBMUDFLAP is not set
152# BR2_GCC_ENABLE_GRAPHITE is not set257# BR2_GCC_ENABLE_GRAPHITE is not set
153BR2_TOOLCHAIN_HAS_NATIVE_RPC=y258BR2_PACKAGE_HOST_GDB_ARCH_SUPPORTS=y
154BR2_USE_WCHAR=y259
155BR2_ENABLE_LOCALE=y260#
261# Host GDB Options
262#
263# BR2_PACKAGE_HOST_GDB is not set
264BR2_PACKAGE_GDB_NEEDS_CXX11=y
265
266#
267# Toolchain Generic Options
268#
269BR2_TOOLCHAIN_SUPPORTS_ALWAYS_LOCKFREE_ATOMIC_INTS=y
270BR2_TOOLCHAIN_SUPPORTS_VARIADIC_MI_THUNK=y
156BR2_TOOLCHAIN_HAS_THREADS=y271BR2_TOOLCHAIN_HAS_THREADS=y
157BR2_TOOLCHAIN_HAS_THREADS_DEBUG=y
158BR2_TOOLCHAIN_HAS_THREADS_NPTL=y272BR2_TOOLCHAIN_HAS_THREADS_NPTL=y
159BR2_TOOLCHAIN_HAS_SHADOW_PASSWORDS=y273BR2_TOOLCHAIN_SUPPORTS_PIE=y
160BR2_TOOLCHAIN_HAS_SSP=y
161# BR2_ENABLE_LOCALE_PURGE is not set
162BR2_GENERATE_LOCALE=""
163# BR2_TOOLCHAIN_GLIBC_GCONV_LIBS_COPY is not set
164BR2_USE_MMU=y274BR2_USE_MMU=y
165BR2_TARGET_OPTIMIZATION="-pipe"275BR2_TARGET_OPTIMIZATION="-pipe"
166BR2_TARGET_LDFLAGS=""276BR2_TARGET_LDFLAGS=""
@@ -186,41 +296,81 @@ BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_17=y
186BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_18=y296BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_18=y
187BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_19=y297BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_19=y
188BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_0=y298BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_0=y
189BR2_TOOLCHAIN_HEADERS_AT_LEAST="4.0"299BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_1=y
300BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_2=y
301BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_3=y
302BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_4=y
303BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_5=y
304BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_6=y
305BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_7=y
306BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_8=y
307BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_9=y
308BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_10=y
309BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_11=y
310BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_12=y
311BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_13=y
312BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_14=y
313BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_15=y
314BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_16=y
315BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_17=y
316BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_18=y
317BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_19=y
318BR2_TOOLCHAIN_HEADERS_AT_LEAST="4.19"
319BR2_TOOLCHAIN_GCC_AT_LEAST_4_3=y
320BR2_TOOLCHAIN_GCC_AT_LEAST_4_4=y
321BR2_TOOLCHAIN_GCC_AT_LEAST_4_5=y
322BR2_TOOLCHAIN_GCC_AT_LEAST_4_6=y
323BR2_TOOLCHAIN_GCC_AT_LEAST_4_7=y
324BR2_TOOLCHAIN_GCC_AT_LEAST_4_8=y
325BR2_TOOLCHAIN_GCC_AT_LEAST_4_9=y
326BR2_TOOLCHAIN_GCC_AT_LEAST_5=y
327BR2_TOOLCHAIN_GCC_AT_LEAST_6=y
328BR2_TOOLCHAIN_GCC_AT_LEAST_7=y
329BR2_TOOLCHAIN_GCC_AT_LEAST="7"
330BR2_TOOLCHAIN_HAS_MNAN_OPTION=y
331BR2_TOOLCHAIN_HAS_SYNC_1=y
332BR2_TOOLCHAIN_HAS_SYNC_2=y
333BR2_TOOLCHAIN_HAS_SYNC_4=y
334BR2_TOOLCHAIN_HAS_SYNC_8=y
335BR2_TOOLCHAIN_HAS_LIBATOMIC=y
336BR2_TOOLCHAIN_HAS_ATOMIC=y
190337
191#338#
192# System configuration339# System configuration
193#340#
341BR2_ROOTFS_SKELETON_DEFAULT=y
342# BR2_ROOTFS_SKELETON_CUSTOM is not set
194BR2_TARGET_GENERIC_HOSTNAME="cirros"343BR2_TARGET_GENERIC_HOSTNAME="cirros"
195BR2_TARGET_GENERIC_ISSUE="Welcome to CirrOS"344BR2_TARGET_GENERIC_ISSUE="Welcome to CirrOS"
196BR2_TARGET_GENERIC_PASSWD_MD5=y345BR2_TARGET_GENERIC_PASSWD_SHA256=y
197# BR2_TARGET_GENERIC_PASSWD_SHA256 is not set
198# BR2_TARGET_GENERIC_PASSWD_SHA512 is not set346# BR2_TARGET_GENERIC_PASSWD_SHA512 is not set
199BR2_TARGET_GENERIC_PASSWD_METHOD="md5"347BR2_TARGET_GENERIC_PASSWD_METHOD="sha-256"
200BR2_INIT_BUSYBOX=y348BR2_INIT_BUSYBOX=y
201# BR2_INIT_SYSV is not set349# BR2_INIT_SYSV is not set
202# BR2_INIT_SYSTEMD is not set350
351#
352# systemd needs a glibc toolchain w/ SSP, headers >= 3.10
353#
203# BR2_INIT_NONE is not set354# BR2_INIT_NONE is not set
204# BR2_ROOTFS_DEVICE_CREATION_STATIC is not set355# BR2_ROOTFS_DEVICE_CREATION_STATIC is not set
205BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_DEVTMPFS=y356BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_DEVTMPFS=y
206# BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_MDEV is not set357# BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_MDEV is not set
207# BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_EUDEV is not set358
359#
360# eudev needs a toolchain w/ wchar, dynamic library
361#
208BR2_ROOTFS_DEVICE_TABLE="system/device_table.txt"362BR2_ROOTFS_DEVICE_TABLE="system/device_table.txt"
209BR2_ROOTFS_SKELETON_DEFAULT=y363# BR2_ROOTFS_DEVICE_TABLE_SUPPORTS_EXTENDED_ATTRIBUTES is not set
210# BR2_ROOTFS_SKELETON_CUSTOM is not set364# BR2_ROOTFS_MERGED_USR is not set
365BR2_TARGET_ENABLE_ROOT_LOGIN=y
211BR2_TARGET_GENERIC_ROOT_PASSWD=""366BR2_TARGET_GENERIC_ROOT_PASSWD=""
212BR2_SYSTEM_BIN_SH_BUSYBOX=y367BR2_SYSTEM_BIN_SH_BUSYBOX=y
213368
214#369#
215# bash, dash, zsh need BR2_PACKAGE_BUSYBOX_SHOW_OTHERS370# bash, dash, mksh, zsh need BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
216#371#
217# BR2_SYSTEM_BIN_SH_NONE is not set372# BR2_SYSTEM_BIN_SH_NONE is not set
218BR2_SYSTEM_BIN_SH="/bin/busybox"
219BR2_TARGET_GENERIC_GETTY=y373BR2_TARGET_GENERIC_GETTY=y
220
221#
222# getty options
223#
224BR2_TARGET_GENERIC_GETTY_PORT="ttyS0"374BR2_TARGET_GENERIC_GETTY_PORT="ttyS0"
225# BR2_TARGET_GENERIC_GETTY_BAUDRATE_KEEP is not set375# BR2_TARGET_GENERIC_GETTY_BAUDRATE_KEEP is not set
226# BR2_TARGET_GENERIC_GETTY_BAUDRATE_9600 is not set376# BR2_TARGET_GENERIC_GETTY_BAUDRATE_9600 is not set
@@ -233,10 +383,17 @@ BR2_TARGET_GENERIC_GETTY_TERM="vt100"
233BR2_TARGET_GENERIC_GETTY_OPTIONS=""383BR2_TARGET_GENERIC_GETTY_OPTIONS=""
234BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW=y384BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW=y
235BR2_SYSTEM_DHCP=""385BR2_SYSTEM_DHCP=""
386BR2_SYSTEM_DEFAULT_PATH="/bin:/sbin:/usr/bin:/usr/sbin"
387# BR2_ENABLE_LOCALE_PURGE is not set
388
389#
390# NLS support needs a toolchain w/ wchar, dynamic library
391#
236# BR2_TARGET_TZ_INFO is not set392# BR2_TARGET_TZ_INFO is not set
237BR2_ROOTFS_USERS_TABLES=""393BR2_ROOTFS_USERS_TABLES=""
238BR2_ROOTFS_OVERLAY=""394BR2_ROOTFS_OVERLAY=""
239BR2_ROOTFS_POST_BUILD_SCRIPT=""395BR2_ROOTFS_POST_BUILD_SCRIPT=""
396BR2_ROOTFS_POST_FAKEROOT_SCRIPT=""
240BR2_ROOTFS_POST_IMAGE_SCRIPT=""397BR2_ROOTFS_POST_IMAGE_SCRIPT=""
241398
242#399#
@@ -249,18 +406,31 @@ BR2_ROOTFS_POST_IMAGE_SCRIPT=""
249#406#
250BR2_PACKAGE_BUSYBOX=y407BR2_PACKAGE_BUSYBOX=y
251BR2_PACKAGE_BUSYBOX_CONFIG="package/busybox/busybox-cirros.config"408BR2_PACKAGE_BUSYBOX_CONFIG="package/busybox/busybox-cirros.config"
409BR2_PACKAGE_BUSYBOX_CONFIG_FRAGMENT_FILES=""
252# BR2_PACKAGE_BUSYBOX_SHOW_OTHERS is not set410# BR2_PACKAGE_BUSYBOX_SHOW_OTHERS is not set
411# BR2_PACKAGE_BUSYBOX_INDIVIDUAL_BINARIES is not set
253# BR2_PACKAGE_BUSYBOX_WATCHDOG is not set412# BR2_PACKAGE_BUSYBOX_WATCHDOG is not set
413BR2_PACKAGE_SKELETON=y
414BR2_PACKAGE_HAS_SKELETON=y
415BR2_PACKAGE_PROVIDES_SKELETON="skeleton-init-sysv"
416BR2_PACKAGE_SKELETON_INIT_COMMON=y
417BR2_PACKAGE_SKELETON_INIT_SYSV=y
254418
255#419#
256# Audio and video applications420# Audio and video applications
257#421#
258# BR2_PACKAGE_ALSA_UTILS is not set422# BR2_PACKAGE_ALSA_UTILS is not set
423# BR2_PACKAGE_ATEST is not set
259# BR2_PACKAGE_AUMIX is not set424# BR2_PACKAGE_AUMIX is not set
260425
261#426#
262# bellagio needs a toolchain w/ C++, threads, dynamic library427# bellagio needs a toolchain w/ C++, threads, dynamic library
263#428#
429
430#
431# bluez-alsa needs a toolchain w/ wchar, NPTL, headers >= 3.4, dynamic library
432#
433# BR2_PACKAGE_DVBLAST is not set
264# BR2_PACKAGE_DVDAUTHOR is not set434# BR2_PACKAGE_DVDAUTHOR is not set
265435
266#436#
@@ -271,46 +441,106 @@ BR2_PACKAGE_BUSYBOX_CONFIG="package/busybox/busybox-cirros.config"
271# espeak needs a toolchain w/ C++, wchar, threads, dynamic library441# espeak needs a toolchain w/ C++, wchar, threads, dynamic library
272#442#
273# BR2_PACKAGE_FAAD2 is not set443# BR2_PACKAGE_FAAD2 is not set
444BR2_PACKAGE_FFMPEG_ARCH_SUPPORTS=y
274# BR2_PACKAGE_FFMPEG is not set445# BR2_PACKAGE_FFMPEG is not set
275# BR2_PACKAGE_FLAC is not set446
276# BR2_PACKAGE_FLITE is not set447#
277# BR2_PACKAGE_GSTREAMER is not set448# flac needs a toolchain w/ wchar
278# BR2_PACKAGE_GSTREAMER1 is not set449#
450
451#
452# flite needs a toolchain w/ wchar
453#
454
455#
456# gmrender-resurrect needs a toolchain w/ wchar, threads
457#
458
459#
460# gstreamer 0.10 needs a toolchain w/ wchar, threads, dynamic library
461#
462
463#
464# gstreamer 1.x needs a toolchain w/ wchar, threads
465#
279466
280#467#
281# jack2 needs a toolchain w/ threads, C++, dynamic library468# jack2 needs a toolchain w/ threads, C++, dynamic library
282#469#
470BR2_PACKAGE_KODI_ARCH_SUPPORTS=y
471
472#
473# kodi needs python w/ .py modules, a uClibc or glibc toolchain w/ C++, threads, wchar, dynamic library, gcc >= 4.8, host gcc >= 4.6
474#
475
476#
477# kodi needs an OpenGL EGL backend with OpenGL support
478#
283# BR2_PACKAGE_LAME is not set479# BR2_PACKAGE_LAME is not set
284# BR2_PACKAGE_LIBVPX is not set
285# BR2_PACKAGE_MADPLAY is not set480# BR2_PACKAGE_MADPLAY is not set
286481
287#482#
483# mimic needs a toolchain w/ wchar
484#
485
486#
487# miraclecast needs systemd and a glibc toolchain w/ threads and wchar
488#
489
490#
288# mjpegtools needs a toolchain w/ C++, threads491# mjpegtools needs a toolchain w/ C++, threads
289#492#
290493
291#494#
292# modplugtools needs a toolchain w/ C++495# modplugtools needs a toolchain w/ C++
293#496#
497# BR2_PACKAGE_MOTION is not set
294498
295#499#
296# mpd needs a toolchain w/ C++, threads, wchar500# mpd needs a toolchain w/ C++, threads, wchar, gcc >= 4.9
297#501#
298# BR2_PACKAGE_MPD_MPC is not set502# BR2_PACKAGE_MPD_MPC is not set
299# BR2_PACKAGE_MPG123 is not set503# BR2_PACKAGE_MPG123 is not set
504# BR2_PACKAGE_MPV is not set
505# BR2_PACKAGE_MULTICAT is not set
300# BR2_PACKAGE_MUSEPACK is not set506# BR2_PACKAGE_MUSEPACK is not set
301# BR2_PACKAGE_NCMPC is not set507
508#
509# ncmpc needs a toolchain w/ C++, wchar, threads, gcc >= 4.9
510#
302# BR2_PACKAGE_OPUS_TOOLS is not set511# BR2_PACKAGE_OPUS_TOOLS is not set
303# BR2_PACKAGE_PULSEAUDIO is not set512BR2_PACKAGE_PULSEAUDIO_HAS_ATOMIC=y
513
514#
515# pulseaudio needs a toolchain w/ wchar, threads, dynamic library
516#
304# BR2_PACKAGE_SOX is not set517# BR2_PACKAGE_SOX is not set
518
519#
520# squeezelite needs a toolchain w/ wchar, NPTL, dynamic library
521#
522
523#
524# tovid needs a toolchain w/ threads, C++, wchar, gcc >= 4.5
525#
305# BR2_PACKAGE_TSTOOLS is not set526# BR2_PACKAGE_TSTOOLS is not set
306# BR2_PACKAGE_TWOLAME is not set527# BR2_PACKAGE_TWOLAME is not set
528# BR2_PACKAGE_UDPXY is not set
529
530#
531# upmpdcli needs a toolchain w/ C++, NPTL, gcc >= 4.9
532#
533
534#
535# v4l2grab needs a toolchain w/ threads, dynamic library, C++ and headers >= 3.0
536#
307537
308#538#
309# upmpdcli needs a toolchain w/ C++, threads539# v4l2loopback needs a Linux kernel to be built
310#540#
311541
312#542#
313# vlc needs a uclibc snapshot, uclibc-ng or (e)glibc toolchain w/ C++, wchar, threads, headers >= 3.7543# vlc needs a toolchain w/ C++, dynamic library, wchar, threads, gcc >= 4.9, headers >= 3.7
314#544#
315# BR2_PACKAGE_VORBIS_TOOLS is not set545# BR2_PACKAGE_VORBIS_TOOLS is not set
316# BR2_PACKAGE_WAVPACK is not set546# BR2_PACKAGE_WAVPACK is not set
@@ -320,58 +550,122 @@ BR2_PACKAGE_BUSYBOX_CONFIG="package/busybox/busybox-cirros.config"
320#550#
321# Compressors and decompressors551# Compressors and decompressors
322#552#
553# BR2_PACKAGE_BROTLI is not set
323# BR2_PACKAGE_BZIP2 is not set554# BR2_PACKAGE_BZIP2 is not set
324# BR2_PACKAGE_INFOZIP is not set
325# BR2_PACKAGE_LZ4 is not set555# BR2_PACKAGE_LZ4 is not set
326556
327#557#
328# lzip needs a toolchain w/ C++558# lzip needs a toolchain w/ C++
329#559#
330# BR2_PACKAGE_LZOP is not set560# BR2_PACKAGE_LZOP is not set
561
562#
563# p7zip needs a toolchain w/ threads, wchar, C++
564#
565# BR2_PACKAGE_PIGZ is not set
566
567#
568# pixz needs a toolchain w/ threads, wchar
569#
570
571#
572# unrar needs a toolchain w/ C++, wchar, threads
573#
331# BR2_PACKAGE_XZ is not set574# BR2_PACKAGE_XZ is not set
575# BR2_PACKAGE_ZIP is not set
576# BR2_PACKAGE_ZSTD is not set
332577
333#578#
334# Debugging, profiling and benchmark579# Debugging, profiling and benchmark
335#580#
581# BR2_PACKAGE_BLKTRACE is not set
336582
337#583#
338# bonnie++ needs a toolchain w/ C++584# bonnie++ needs a toolchain w/ C++
339#585#
340# BR2_PACKAGE_CACHE_CALIBRATOR is not set586# BR2_PACKAGE_CACHE_CALIBRATOR is not set
587
588#
589# clinfo needs an OpenCL provider
590#
341# BR2_PACKAGE_DHRYSTONE is not set591# BR2_PACKAGE_DHRYSTONE is not set
592# BR2_PACKAGE_DIEHARDER is not set
342# BR2_PACKAGE_DMALLOC is not set593# BR2_PACKAGE_DMALLOC is not set
343# BR2_PACKAGE_DSTAT is not set594
595#
596# dropwatch needs a toolchain w/ threads, wchar
597#
598
599#
600# dstat needs a toolchain w/ wchar, threads, dynamic library
601#
602# BR2_PACKAGE_DT is not set
344603
345#604#
346# duma needs a toolchain w/ C++, threads, dynamic library605# duma needs a toolchain w/ C++, threads, dynamic library
347#606#
348# BR2_PACKAGE_FIO is not set607# BR2_PACKAGE_FIO is not set
349# BR2_PACKAGE_GDB is not set608
609#
610# fwts needs a glibc toolchain w/ wchar, threads
611#
612BR2_PACKAGE_GDB_ARCH_SUPPORTS=y
613
614#
615# gdb/gdbserver needs a toolchain w/ threads, threads debug
616#
617
618#
619# gdb/gdbserver >= 8.x needs a toolchain w/ C++, gcc >= 4.8
620#
350BR2_PACKAGE_GOOGLE_BREAKPAD_ARCH_SUPPORTS=y621BR2_PACKAGE_GOOGLE_BREAKPAD_ARCH_SUPPORTS=y
351622
352#623#
353# google-breakpad requires an (e)glibc toolchain w/ C++ enabled624# google-breakpad requires a glibc or uClibc toolchain w/ wchar, thread, C++, gcc >= 4.8
354#625#
355# BR2_PACKAGE_IOZONE is not set626# BR2_PACKAGE_IOZONE is not set
627# BR2_PACKAGE_KEXEC is not set
356628
357#629#
358# ktap needs a Linux kernel to be built630# ktap needs a Linux kernel to be built
359#631#
360# BR2_PACKAGE_LATENCYTOP is not set632
633#
634# latencytop needs a toolchain w/ wchar, threads
635#
361# BR2_PACKAGE_LMBENCH is not set636# BR2_PACKAGE_LMBENCH is not set
637BR2_PACKAGE_LTP_TESTSUITE_ARCH_SUPPORTS=y
362# BR2_PACKAGE_LTP_TESTSUITE is not set638# BR2_PACKAGE_LTP_TESTSUITE is not set
363# BR2_PACKAGE_LTTNG_BABELTRACE is not set639BR2_PACKAGE_LTRACE_ARCH_SUPPORTS=y
640
641#
642# ltrace needs a uClibc or glibc toolchain w/ wchar, dynamic library
643#
644
645#
646# lttng-babeltrace needs a toolchain w/ wchar, threads
647#
364648
365#649#
366# lttng-modules needs a Linux kernel to be built650# lttng-modules needs a Linux kernel to be built
367#651#
652# BR2_PACKAGE_LTTNG_TOOLS is not set
368# BR2_PACKAGE_MEMSTAT is not set653# BR2_PACKAGE_MEMSTAT is not set
369# BR2_PACKAGE_NETPERF is not set654# BR2_PACKAGE_NETPERF is not set
370# BR2_PACKAGE_PAX_UTILS is not set
371655
372#656#
373# perf needs a Linux kernel to be built657# netsniff-ng needs a glibc or musl toolchain w/ threads, headers >= 3.0
374#658#
659
660#
661# nmon needs a glibc toolchain
662#
663BR2_PACKAGE_OPROFILE_ARCH_SUPPORTS=y
664
665#
666# oprofile needs a toolchain w/ C++, wchar
667#
668# BR2_PACKAGE_PAX_UTILS is not set
375# BR2_PACKAGE_PV is not set669# BR2_PACKAGE_PV is not set
376# BR2_PACKAGE_RAMSMP is not set670# BR2_PACKAGE_RAMSMP is not set
377# BR2_PACKAGE_RAMSPEED is not set671# BR2_PACKAGE_RAMSPEED is not set
@@ -379,102 +673,179 @@ BR2_PACKAGE_GOOGLE_BREAKPAD_ARCH_SUPPORTS=y
379# BR2_PACKAGE_SPIDEV_TEST is not set673# BR2_PACKAGE_SPIDEV_TEST is not set
380# BR2_PACKAGE_STRACE is not set674# BR2_PACKAGE_STRACE is not set
381# BR2_PACKAGE_STRESS is not set675# BR2_PACKAGE_STRESS is not set
676# BR2_PACKAGE_STRESS_NG is not set
677# BR2_PACKAGE_TCF_AGENT is not set
678BR2_PACKAGE_TCF_AGENT_ARCH="a64"
679BR2_PACKAGE_TCF_AGENT_ARCH_SUPPORTS=y
382# BR2_PACKAGE_TINYMEMBENCH is not set680# BR2_PACKAGE_TINYMEMBENCH is not set
383# BR2_PACKAGE_TRACE_CMD is not set681# BR2_PACKAGE_TRACE_CMD is not set
682BR2_PACKAGE_TRINITY_ARCH_SUPPORTS=y
384# BR2_PACKAGE_TRINITY is not set683# BR2_PACKAGE_TRINITY is not set
684# BR2_PACKAGE_UCLIBC_NG_TEST is not set
685BR2_PACKAGE_VALGRIND_ARCH_SUPPORTS=y
686# BR2_PACKAGE_VALGRIND is not set
687# BR2_PACKAGE_VMTOUCH is not set
385# BR2_PACKAGE_WHETSTONE is not set688# BR2_PACKAGE_WHETSTONE is not set
386689
387#690#
388# Development tools691# Development tools
389#692#
693
694#
695# binutils needs a toolchain w/ wchar
696#
390# BR2_PACKAGE_BSDIFF is not set697# BR2_PACKAGE_BSDIFF is not set
698# BR2_PACKAGE_CHECK is not set
391BR2_PACKAGE_CMAKE_ARCH_SUPPORTS=y699BR2_PACKAGE_CMAKE_ARCH_SUPPORTS=y
392700
393#701#
394# ctest needs a toolchain w/ C++, wchar, dynamic library702# ctest needs a toolchain w/ C++, wchar, dynamic library, gcc >= 4.7, NPTL
395#703#
396704
397#705#
398# cppunit needs a toolchain w/ C++, dynamic library706# cppunit needs a toolchain w/ C++, dynamic library
399#707#
400# BR2_PACKAGE_CVS is not set708# BR2_PACKAGE_CUNIT is not set
709
710#
711# cvs needs a toolchain w/ wchar
712#
713
714#
715# cxxtest needs a toolchain w/ C++ support
716#
401# BR2_PACKAGE_FLEX is not set717# BR2_PACKAGE_FLEX is not set
402# BR2_PACKAGE_GETTEXT is not set718
719#
720# gettext needs a toolchain w/ wchar
721#
403# BR2_PACKAGE_GIT is not set722# BR2_PACKAGE_GIT is not set
404723
405#724#
725# git-crypt needs a toolchain w/ C++, gcc >= 4.9
726#
727
728#
406# gperf needs a toolchain w/ C++729# gperf needs a toolchain w/ C++
407#730#
731# BR2_PACKAGE_JO is not set
408# BR2_PACKAGE_JQ is not set732# BR2_PACKAGE_JQ is not set
409# BR2_PACKAGE_LIBTOOL is not set733# BR2_PACKAGE_LIBTOOL is not set
410# BR2_PACKAGE_MAKE is not set734# BR2_PACKAGE_MAKE is not set
411# BR2_PACKAGE_PKGCONF is not set735# BR2_PACKAGE_PKGCONF is not set
412# BR2_PACKAGE_SSTRIP is not set
413# BR2_PACKAGE_SUBVERSION is not set736# BR2_PACKAGE_SUBVERSION is not set
414# BR2_PACKAGE_TREE is not set737
738#
739# tree needs a toolchain w/ wchar
740#
415741
416#742#
417# Filesystem and flash utilities743# Filesystem and flash utilities
418#744#
745# BR2_PACKAGE_ABOOTIMG is not set
746
747#
748# aufs-util needs a linux kernel and a toolchain w/ threads
749#
750# BR2_PACKAGE_AUTOFS is not set
419# BR2_PACKAGE_BTRFS_PROGS is not set751# BR2_PACKAGE_BTRFS_PROGS is not set
420# BR2_PACKAGE_CIFS_UTILS is not set752# BR2_PACKAGE_CIFS_UTILS is not set
753
754#
755# cpio needs a toolchain w/ wchar
756#
421# BR2_PACKAGE_CRAMFS is not set757# BR2_PACKAGE_CRAMFS is not set
422# BR2_PACKAGE_CURLFTPFS is not set758
423# BR2_PACKAGE_DOSFSTOOLS is not set759#
760# curlftpfs needs a toolchain w/ wchar, threads, dynamic library
761#
762# BR2_PACKAGE_DAVFS2 is not set
763
764#
765# dosfstools needs a toolchain w/ wchar
766#
424BR2_PACKAGE_E2FSPROGS=y767BR2_PACKAGE_E2FSPROGS=y
425# BR2_PACKAGE_E2FSPROGS_BADBLOCKS is not set
426# BR2_PACKAGE_E2FSPROGS_CHATTR is not set
427BR2_PACKAGE_E2FSPROGS_DEBUGFS=y768BR2_PACKAGE_E2FSPROGS_DEBUGFS=y
428# BR2_PACKAGE_E2FSPROGS_DUMPE2FS is not set
429# BR2_PACKAGE_E2FSPROGS_E2FREEFRAG is not set
430# BR2_PACKAGE_E2FSPROGS_E2FSCK is not set
431# BR2_PACKAGE_E2FSPROGS_E2IMAGE is not set769# BR2_PACKAGE_E2FSPROGS_E2IMAGE is not set
432BR2_PACKAGE_E2FSPROGS_E2LABEL=y770
433# BR2_PACKAGE_E2FSPROGS_E2UNDO is not set771#
434# BR2_PACKAGE_E2FSPROGS_E4DEFRAG is not set772# e4defrag needs a glibc or musl toolchain
435# BR2_PACKAGE_E2FSPROGS_FILEFRAG is not set773#
436# BR2_PACKAGE_E2FSPROGS_FINDFS is not set
437# BR2_PACKAGE_E2FSPROGS_FSCK is not set774# BR2_PACKAGE_E2FSPROGS_FSCK is not set
438# BR2_PACKAGE_E2FSPROGS_LOGSAVE is not set775# BR2_PACKAGE_E2FSPROGS_FUSE2FS is not set
439# BR2_PACKAGE_E2FSPROGS_LSATTR is not set
440BR2_PACKAGE_E2FSPROGS_MKE2FS=y
441BR2_PACKAGE_E2FSPROGS_MKLOSTFOUND=y
442BR2_PACKAGE_E2FSPROGS_RESIZE2FS=y776BR2_PACKAGE_E2FSPROGS_RESIZE2FS=y
443# BR2_PACKAGE_E2FSPROGS_TUNE2FS is not set777
444# BR2_PACKAGE_E2FSPROGS_UUIDGEN is not set778#
445# BR2_PACKAGE_E2TOOLS is not set779# e2tools needs a toolchain w/ threads, wchar
446# BR2_PACKAGE_ECRYPTFS_UTILS is not set780#
447# BR2_PACKAGE_EXFAT is not set781
448# BR2_PACKAGE_EXFAT_UTILS is not set782#
449# BR2_PACKAGE_F2FS_TOOLS is not set783# ecryptfs-utils needs a toolchain w/ threads, wchar, dynami library
784#
785
786#
787# exfat needs a toolchain w/ wchar, threads, dynamic library
788#
789
790#
791# exfat-utils needs a toolchain w/ wchar
792#
793
794#
795# f2fs-tools needs a toolchain w/ wchar
796#
450# BR2_PACKAGE_FLASHBENCH is not set797# BR2_PACKAGE_FLASHBENCH is not set
798# BR2_PACKAGE_FSCRYPTCTL is not set
799
800#
801# fwup needs a toolchain w/ wchar
802#
451# BR2_PACKAGE_GENEXT2FS is not set803# BR2_PACKAGE_GENEXT2FS is not set
452# BR2_PACKAGE_GENPART is not set804# BR2_PACKAGE_GENPART is not set
453# BR2_PACKAGE_GENROMFS is not set805# BR2_PACKAGE_GENROMFS is not set
454# BR2_PACKAGE_MAKEDEVS is not set806# BR2_PACKAGE_IMX_USB_LOADER is not set
455# BR2_PACKAGE_MMC_UTILS is not set807# BR2_PACKAGE_MMC_UTILS is not set
456# BR2_PACKAGE_MTD is not set808# BR2_PACKAGE_MTD is not set
457# BR2_PACKAGE_MTOOLS is not set809
810#
811# mtools needs a toolchain w/ wchar
812#
458# BR2_PACKAGE_NFS_UTILS is not set813# BR2_PACKAGE_NFS_UTILS is not set
459# BR2_PACKAGE_NTFS_3G is not set814# BR2_PACKAGE_NILFS_UTILS is not set
460815
461#816#
462# simicsfs needs a Linux kernel to be built817# ntfs-3g needs a toolchain w/ wchar, threads, dynamic library
463#818#
819# BR2_PACKAGE_SP_OOPS_EXTRACT is not set
464# BR2_PACKAGE_SQUASHFS is not set820# BR2_PACKAGE_SQUASHFS is not set
465# BR2_PACKAGE_SSHFS is not set821
822#
823# sshfs needs a toolchain w/ wchar, threads, dynamic library
824#
825
826#
827# udftools needs a toolchain w/ wchar
828#
466# BR2_PACKAGE_UNIONFS is not set829# BR2_PACKAGE_UNIONFS is not set
467# BR2_PACKAGE_XFSPROGS is not set830# BR2_PACKAGE_XFSPROGS is not set
468831
469#832#
470# Fonts, icons, sounds and themes833# Fonts, cursors, icons, sounds and themes
834#
835
836#
837# Cursors
471#838#
839# BR2_PACKAGE_COMIX_CURSORS is not set
840# BR2_PACKAGE_OBSIDIAN_CURSORS is not set
472841
473#842#
474# Fonts843# Fonts
475#844#
476# BR2_PACKAGE_BITSTREAM_VERA is not set845# BR2_PACKAGE_BITSTREAM_VERA is not set
846# BR2_PACKAGE_CANTARELL is not set
477# BR2_PACKAGE_DEJAVU is not set847# BR2_PACKAGE_DEJAVU is not set
848# BR2_PACKAGE_FONT_AWESOME is not set
478# BR2_PACKAGE_GHOSTSCRIPT_FONTS is not set849# BR2_PACKAGE_GHOSTSCRIPT_FONTS is not set
479# BR2_PACKAGE_INCONSOLATA is not set850# BR2_PACKAGE_INCONSOLATA is not set
480# BR2_PACKAGE_LIBERATION is not set851# BR2_PACKAGE_LIBERATION is not set
@@ -482,6 +853,7 @@ BR2_PACKAGE_E2FSPROGS_RESIZE2FS=y
482#853#
483# Icons854# Icons
484#855#
856# BR2_PACKAGE_GOOGLE_MATERIAL_DESIGN_ICONS is not set
485# BR2_PACKAGE_HICOLOR_ICON_THEME is not set857# BR2_PACKAGE_HICOLOR_ICON_THEME is not set
486858
487#859#
@@ -497,6 +869,11 @@ BR2_PACKAGE_E2FSPROGS_RESIZE2FS=y
497#869#
498# Games870# Games
499#871#
872# BR2_PACKAGE_CHOCOLATE_DOOM is not set
873
874#
875# flare-engine needs a toolchain w/ C++, dynamic library
876#
500877
501#878#
502# gnuchess needs a toolchain w/ C++, threads879# gnuchess needs a toolchain w/ C++, threads
@@ -508,6 +885,10 @@ BR2_PACKAGE_E2FSPROGS_RESIZE2FS=y
508# BR2_PACKAGE_SL is not set885# BR2_PACKAGE_SL is not set
509886
510#887#
888# stella needs a toolchain w/ dynamic library, C++, threads, gcc >= 4.9
889#
890
891#
511# Graphic libraries and applications (graphic/text)892# Graphic libraries and applications (graphic/text)
512#893#
513894
@@ -515,17 +896,30 @@ BR2_PACKAGE_E2FSPROGS_RESIZE2FS=y
515# Graphic applications896# Graphic applications
516#897#
517# BR2_PACKAGE_FSWEBCAM is not set898# BR2_PACKAGE_FSWEBCAM is not set
899# BR2_PACKAGE_GHOSTSCRIPT is not set
900
901#
902# glmark2 needs a toolchain w/ C++, gcc >= 4.9
903#
904# BR2_PACKAGE_GNUPLOT is not set
518905
519#906#
520# glmark2 needs an OpenGL or an openGL ES and EGL backend provided by mesa3d907# jhead needs a toolchain w/ wchar
521#908#
522909
523#910#
524# glmark2 needs udev /dev management and a toolchain w/ C++, NPTL911# libva-utils needs a toolchain w/ C++, threads, dynamic library
912#
913# BR2_PACKAGE_NETSURF is not set
914# BR2_PACKAGE_PNGQUANT is not set
915
916#
917# rrdtool needs a toolchain w/ wchar, threads
918#
919
920#
921# tesseract-ocr needs a toolchain w/ threads, C++, gcc >= 4.8, dynamic library, wchar
525#922#
526# BR2_PACKAGE_GNUPLOT is not set
527# BR2_PACKAGE_JHEAD is not set
528# BR2_PACKAGE_RRDTOOL is not set
529923
530#924#
531# Graphic libraries925# Graphic libraries
@@ -536,7 +930,7 @@ BR2_PACKAGE_E2FSPROGS_RESIZE2FS=y
536#930#
537931
538#932#
539# directfb needs a toolchain w/ C++, threads933# directfb needs a glibc or uClibc toolchain w/ C++, NPTL, gcc >= 4.5, dynamic library
540#934#
541# BR2_PACKAGE_FBDUMP is not set935# BR2_PACKAGE_FBDUMP is not set
542# BR2_PACKAGE_FBGRAB is not set936# BR2_PACKAGE_FBGRAB is not set
@@ -546,7 +940,10 @@ BR2_PACKAGE_E2FSPROGS_RESIZE2FS=y
546# fbterm needs a toolchain w/ C++, wchar, locale940# fbterm needs a toolchain w/ C++, wchar, locale
547#941#
548# BR2_PACKAGE_FBV is not set942# BR2_PACKAGE_FBV is not set
549# BR2_PACKAGE_FREERDP is not set943
944#
945# freerdp needs a toolchain w/ wchar, dynamic library, threads, C++
946#
550# BR2_PACKAGE_IMAGEMAGICK is not set947# BR2_PACKAGE_IMAGEMAGICK is not set
551948
552#949#
@@ -554,45 +951,52 @@ BR2_PACKAGE_E2FSPROGS_RESIZE2FS=y
554#951#
555952
556#953#
557# mesa3d needs udev /dev management and a toolchain w/ C++, NPTL954# mesa3d needs a toolchain w/ C++, NPTL, dynamic library
558#955#
559956
560#957#
561# ocrad needs a toolchain w/ C++958# ocrad needs a toolchain w/ C++
562#959#
563# BR2_PACKAGE_PSPLASH is not set960
961#
962# psplash needs a toolchain w/ wchar
963#
564# BR2_PACKAGE_SDL is not set964# BR2_PACKAGE_SDL is not set
965# BR2_PACKAGE_SDL2 is not set
565966
566#967#
567# Other GUIs968# Other GUIs
568#969#
569# BR2_PACKAGE_EFL is not set970BR2_PACKAGE_QT5_JSCORE_AVAILABLE=y
570971
571#972#
572# qt needs a toolchain w/ C++, threads973# Qt5 needs a toolchain w/ wchar, NPTL, C++, dynamic library
573#974#
574975
575#976#
576# Qt5 needs a toolchain w/ wchar, NPTL, C++977# tekui needs a Lua interpreter and a toolchain w/ threads, dynamic library
577#978#
578979
579#980#
580# weston needs udev and a toolchain w/ threads, dynamic library, headers >= 3.0981# weston needs udev and a toolchain w/ locale, threads, dynamic library, headers >= 3.0
581#982#
582# BR2_PACKAGE_XORG7 is not set
583983
584#984#
585# X applications985# X.org needs a toolchain w/ wchar, threads, dynamic library
586#986#
587987
588#988#
589# X libraries and helper libraries989# midori needs libgtk3 and a glibc toolchain w/ C++, gcc >= 6, host gcc >= 4.8
990#
991
992#
993# vte needs a toolchain w/ wchar, threads, C++, gcc >= 4.8
590#994#
591# BR2_PACKAGE_XKEYBOARD_CONFIG is not set
592995
593#996#
594# X window managers997# vte needs an OpenGL or an OpenGL-EGL/wayland backend
595#998#
999# BR2_PACKAGE_XKEYBOARD_CONFIG is not set
5961000
597#1001#
598# Hardware handling1002# Hardware handling
@@ -601,77 +1005,152 @@ BR2_PACKAGE_E2FSPROGS_RESIZE2FS=y
601#1005#
602# Firmware1006# Firmware
603#1007#
1008# BR2_PACKAGE_ARMBIAN_FIRMWARE is not set
604# BR2_PACKAGE_B43_FIRMWARE is not set1009# BR2_PACKAGE_B43_FIRMWARE is not set
605# BR2_PACKAGE_LINUX_FIRMWARE is not set1010# BR2_PACKAGE_LINUX_FIRMWARE is not set
1011# BR2_PACKAGE_RPI_BT_FIRMWARE is not set
1012# BR2_PACKAGE_RPI_FIRMWARE is not set
1013# BR2_PACKAGE_RPI_WIFI_FIRMWARE is not set
606# BR2_PACKAGE_UX500_FIRMWARE is not set1014# BR2_PACKAGE_UX500_FIRMWARE is not set
1015# BR2_PACKAGE_WILC1000_FIRMWARE is not set
1016# BR2_PACKAGE_WILINK_BT_FIRMWARE is not set
607# BR2_PACKAGE_ZD1211_FIRMWARE is not set1017# BR2_PACKAGE_ZD1211_FIRMWARE is not set
608# BR2_PACKAGE_AVRDUDE is not set1018# BR2_PACKAGE_18XX_TI_UTILS is not set
1019# BR2_PACKAGE_ACPICA is not set
1020# BR2_PACKAGE_ACPID is not set
6091021
610#1022#
611# bcache-tools needs udev /dev management and a toolchain w/ wchar1023# acpitool needs a toolchain w/ threads, C++, dynamic library
612#1024#
1025# BR2_PACKAGE_AER_INJECT is not set
6131026
614#1027#
615# cc-tool needs a toolchain w/ C++, threads1028# avrdude needs a uClibc or glibc toolchain w/ threads, wchar, dynamic library
616#1029#
617# BR2_PACKAGE_CDRKIT is not set1030
618# BR2_PACKAGE_CRYPTSETUP is not set1031#
619# BR2_PACKAGE_CWIID is not set1032# bcache-tools needs udev /dev management
620# BR2_PACKAGE_DBUS is not set1033#
1034
1035#
1036# brltty needs a toolchain w/ dynamic lib, threads, wchar
1037#
1038
1039#
1040# cc-tool needs a toolchain w/ C++, threads, wchar
1041#
1042# BR2_PACKAGE_CDRKIT is not set
1043# BR2_PACKAGE_CRYPTSETUP is not set
1044
1045#
1046# dahdi-linux needs a Linux kernel to be built
1047#
1048
1049#
1050# dahdi-tools needs a toolchain w/ threads and a Linux kernel to be built
1051#
1052# BR2_PACKAGE_DBUS is not set
1053# BR2_PACKAGE_DFU_UTIL is not set
1054# BR2_PACKAGE_DMIDECODE is not set
621# BR2_PACKAGE_DMRAID is not set1055# BR2_PACKAGE_DMRAID is not set
1056
1057#
1058# dt-utils needs udev /dev management
1059#
622# BR2_PACKAGE_DTV_SCAN_TABLES is not set1060# BR2_PACKAGE_DTV_SCAN_TABLES is not set
1061# BR2_PACKAGE_DUMP1090 is not set
623# BR2_PACKAGE_DVB_APPS is not set1062# BR2_PACKAGE_DVB_APPS is not set
624# BR2_PACKAGE_DVBSNOOP is not set1063# BR2_PACKAGE_DVBSNOOP is not set
625# BR2_PACKAGE_EEPROG is not set1064# BR2_PACKAGE_EDID_DECODE is not set
6261065
627#1066#
628# eudev needs eudev /dev management1067# eudev needs eudev /dev management
629#1068#
1069
1070#
1071# eudev needs a toolchain w/ wchar, dynamic library
1072#
630# BR2_PACKAGE_EVEMU is not set1073# BR2_PACKAGE_EVEMU is not set
631# BR2_PACKAGE_EVTEST is not set1074# BR2_PACKAGE_EVTEST is not set
632# BR2_PACKAGE_FAN_CTRL is not set1075# BR2_PACKAGE_FAN_CTRL is not set
633# BR2_PACKAGE_FCONFIG is not set1076# BR2_PACKAGE_FCONFIG is not set
634# BR2_PACKAGE_FIS is not set1077# BR2_PACKAGE_FIS is not set
1078BR2_PACKAGE_FLASHROM_ARCH_SUPPORTS=y
1079# BR2_PACKAGE_FLASHROM is not set
635# BR2_PACKAGE_FMTOOLS is not set1080# BR2_PACKAGE_FMTOOLS is not set
1081# BR2_PACKAGE_FREESCALE_IMX is not set
636# BR2_PACKAGE_FXLOAD is not set1082# BR2_PACKAGE_FXLOAD is not set
637# BR2_PACKAGE_GADGETFS_TEST is not set1083# BR2_PACKAGE_GADGETFS_TEST is not set
638# BR2_PACKAGE_GPM is not set1084# BR2_PACKAGE_GPM is not set
639# BR2_PACKAGE_GPSD is not set1085# BR2_PACKAGE_GPSD is not set
6401086
641#1087#
642# gptfdisk needs a toolchain w/ wchar, C++1088# gptfdisk needs a toolchain w/ C++
1089#
1090
1091#
1092# gvfs needs a toolchain w/ wchar, threads
643#1093#
644# BR2_PACKAGE_GVFS is not set
645# BR2_PACKAGE_HWDATA is not set1094# BR2_PACKAGE_HWDATA is not set
646# BR2_PACKAGE_HWLOC is not set1095# BR2_PACKAGE_HWLOC is not set
647# BR2_PACKAGE_I2C_TOOLS is not set
648# BR2_PACKAGE_INPUT_EVENT_DAEMON is not set1096# BR2_PACKAGE_INPUT_EVENT_DAEMON is not set
649# BR2_PACKAGE_INPUT_TOOLS is not set
650# BR2_PACKAGE_IOSTAT is not set1097# BR2_PACKAGE_IOSTAT is not set
651# BR2_PACKAGE_IPMITOOL is not set1098# BR2_PACKAGE_IPMITOOL is not set
652# BR2_PACKAGE_IRDA_UTILS is not set1099# BR2_PACKAGE_IRDA_UTILS is not set
653# BR2_PACKAGE_KBD is not set1100# BR2_PACKAGE_KBD is not set
654# BR2_PACKAGE_LCDPROC is not set1101# BR2_PACKAGE_LCDPROC is not set
655# BR2_PACKAGE_LIRC_TOOLS is not set1102# BR2_PACKAGE_LIBUIO is not set
1103# BR2_PACKAGE_LINUXCONSOLETOOLS is not set
1104
1105#
1106# linux-backports needs a Linux kernel to be built
1107#
1108
1109#
1110# lirc-tools needs a toolchain w/ threads, dynamic library, C++
1111#
656# BR2_PACKAGE_LM_SENSORS is not set1112# BR2_PACKAGE_LM_SENSORS is not set
6571113
658#1114#
659# lshw needs a toolchain w/ C++, wchar1115# lshw needs a toolchain w/ C++, wchar
660#1116#
1117# BR2_PACKAGE_LSSCSI is not set
661# BR2_PACKAGE_LSUIO is not set1118# BR2_PACKAGE_LSUIO is not set
1119# BR2_PACKAGE_LUKSMETA is not set
662# BR2_PACKAGE_LVM2 is not set1120# BR2_PACKAGE_LVM2 is not set
663# BR2_PACKAGE_MDADM is not set1121# BR2_PACKAGE_MDADM is not set
664# BR2_PACKAGE_MEDIA_CTL is not set
665# BR2_PACKAGE_MEMTESTER is not set1122# BR2_PACKAGE_MEMTESTER is not set
666# BR2_PACKAGE_MINICOM is not set1123# BR2_PACKAGE_MEMTOOL is not set
1124
1125#
1126# minicom needs a toolchain w/ wchar
1127#
667# BR2_PACKAGE_NANOCOM is not set1128# BR2_PACKAGE_NANOCOM is not set
668# BR2_PACKAGE_NEARD is not set1129
669# BR2_PACKAGE_OFONO is not set1130#
1131# neard needs a toolchain w/ wchar, threads, dynamic library
1132#
1133# BR2_PACKAGE_NVME is not set
1134
1135#
1136# odroid-mali needs a glibc toolchain
1137#
1138# BR2_PACKAGE_ODROID_SCRIPTS is not set
1139
1140#
1141# ofono needs a toolchain w/ dynamic library, wchar, threads
1142#
670# BR2_PACKAGE_OPEN2300 is not set1143# BR2_PACKAGE_OPEN2300 is not set
1144# BR2_PACKAGE_OPENIPMI is not set
671# BR2_PACKAGE_OPENOCD is not set1145# BR2_PACKAGE_OPENOCD is not set
672# BR2_PACKAGE_PARTED is not set1146
1147#
1148# parted needs a toolchain w/ wchar
1149#
673# BR2_PACKAGE_PCIUTILS is not set1150# BR2_PACKAGE_PCIUTILS is not set
1151# BR2_PACKAGE_PDBG is not set
674# BR2_PACKAGE_PICOCOM is not set1152# BR2_PACKAGE_PICOCOM is not set
1153# BR2_PACKAGE_PIGPIO is not set
6751154
676#1155#
677# powertop needs a toolchain w/ C++, threads, wchar1156# powertop needs a toolchain w/ C++, threads, wchar
@@ -679,33 +1158,96 @@ BR2_PACKAGE_E2FSPROGS_RESIZE2FS=y
679# BR2_PACKAGE_PPS_TOOLS is not set1158# BR2_PACKAGE_PPS_TOOLS is not set
680# BR2_PACKAGE_READ_EDID is not set1159# BR2_PACKAGE_READ_EDID is not set
681# BR2_PACKAGE_RNG_TOOLS is not set1160# BR2_PACKAGE_RNG_TOOLS is not set
1161# BR2_PACKAGE_RS485CONF is not set
1162# BR2_PACKAGE_RTC_TOOLS is not set
1163
1164#
1165# rtl8188eu needs a Linux kernel to be built
1166#
1167
1168#
1169# rtl8189fs needs a Linux kernel to be built
1170#
1171
1172#
1173# rtl8723bs needs a Linux kernel to be built
1174#
1175
1176#
1177# rtl8723bu needs a Linux kernel to be built
1178#
1179
1180#
1181# rtl8821au needs a Linux kernel to be built
1182#
682# BR2_PACKAGE_SANE_BACKENDS is not set1183# BR2_PACKAGE_SANE_BACKENDS is not set
683# BR2_PACKAGE_SDPARM is not set1184# BR2_PACKAGE_SDPARM is not set
1185BR2_PACKAGE_SEDUTIL_ARCH_SUPPORTS=y
1186
1187#
1188# sedutil needs a toolchain w/ C++, gcc >= 4.8, headers >= 3.12
1189#
684# BR2_PACKAGE_SETSERIAL is not set1190# BR2_PACKAGE_SETSERIAL is not set
685# BR2_PACKAGE_SG3_UTILS is not set1191# BR2_PACKAGE_SG3_UTILS is not set
686# BR2_PACKAGE_SIGROK_CLI is not set1192
687# BR2_PACKAGE_SISPMCTL is not set1193#
1194# sigrok-cli needs a toolchain w/ locale, wchar, threads, dynamic library, gcc >= 4.7
1195#
1196
1197#
1198# sispmctl needs a toolchain w/ threads, wchar
1199#
6881200
689#1201#
690# smartmontools needs a toolchain w/ C++1202# smartmontools needs a toolchain w/ C++
691#1203#
692# BR2_PACKAGE_SMSTOOLS3 is not set1204
693# BR2_PACKAGE_SNOWBALL_HDMISERVICE is not set1205#
1206# smstools3 needs a toolchain w/ wchar, threads
1207#
1208# BR2_PACKAGE_SPI_TOOLS is not set
694# BR2_PACKAGE_SREDIRD is not set1209# BR2_PACKAGE_SREDIRD is not set
695# BR2_PACKAGE_STATSERIAL is not set1210# BR2_PACKAGE_STATSERIAL is not set
1211# BR2_PACKAGE_STM32FLASH is not set
696# BR2_PACKAGE_SYSSTAT is not set1212# BR2_PACKAGE_SYSSTAT is not set
6971213
698#1214#
699# targetcli-fb depends on Python1215# targetcli-fb depends on Python
700#1216#
1217
1218#
1219# ti-sgx-um needs the ti-sgx-km driver
1220#
1221
1222#
1223# ti-sgx-um needs a glibc toolchain w/ threads
1224#
701# BR2_PACKAGE_TI_UIM is not set1225# BR2_PACKAGE_TI_UIM is not set
702# BR2_PACKAGE_TI_UTILS is not set1226# BR2_PACKAGE_TI_UTILS is not set
703# BR2_PACKAGE_TRIGGERHAPPY is not set1227# BR2_PACKAGE_TRIGGERHAPPY is not set
704# BR2_PACKAGE_UBOOT_TOOLS is not set1228# BR2_PACKAGE_UBOOT_TOOLS is not set
1229# BR2_PACKAGE_UBUS is not set
1230
1231#
1232# uccp420wlan needs a Linux kernel >= 4.2 to be built
1233#
7051234
706#1235#
707# udisks needs udev /dev management1236# udisks needs udev /dev management
708#1237#
1238
1239#
1240# udisks needs a glibc toolchain w/ wchar, threads, dynamic library
1241#
1242# BR2_PACKAGE_UHUBCTL is not set
1243
1244#
1245# upower needs udev /dev management
1246#
1247
1248#
1249# upower needs a toolchain w/ threads, wchar
1250#
709# BR2_PACKAGE_USB_MODESWITCH is not set1251# BR2_PACKAGE_USB_MODESWITCH is not set
710# BR2_PACKAGE_USB_MODESWITCH_DATA is not set1252# BR2_PACKAGE_USB_MODESWITCH_DATA is not set
7111253
@@ -718,22 +1260,55 @@ BR2_PACKAGE_E2FSPROGS_RESIZE2FS=y
718#1260#
719# BR2_PACKAGE_W_SCAN is not set1261# BR2_PACKAGE_W_SCAN is not set
720# BR2_PACKAGE_WIPE is not set1262# BR2_PACKAGE_WIPE is not set
721# BR2_PACKAGE_XORRISO is not set1263
1264#
1265# xorriso needs a toolchain w/ wchar, threads
1266#
1267
1268#
1269# xr819-xradio driver needs a Linux kernel to be built
1270#
7221271
723#1272#
724# Interpreter languages and scripting1273# Interpreter languages and scripting
725#1274#
1275# BR2_PACKAGE_4TH is not set
726# BR2_PACKAGE_ENSCRIPT is not set1276# BR2_PACKAGE_ENSCRIPT is not set
1277BR2_PACKAGE_HOST_ERLANG_ARCH_SUPPORTS=y
1278BR2_PACKAGE_ERLANG_ARCH_SUPPORTS=y
727# BR2_PACKAGE_ERLANG is not set1279# BR2_PACKAGE_ERLANG is not set
728# BR2_PACKAGE_GUILE is not set1280# BR2_PACKAGE_EXECLINE is not set
1281# BR2_PACKAGE_FICL is not set
1282
1283#
1284# guile needs a uClibc or glibc toolchain w/ threads, wchar, dynamic library
1285#
729# BR2_PACKAGE_HASERL is not set1286# BR2_PACKAGE_HASERL is not set
730# BR2_PACKAGE_JIMTCL is not set1287# BR2_PACKAGE_JIMTCL is not set
731# BR2_PACKAGE_LUA is not set1288# BR2_PACKAGE_LUA is not set
1289BR2_PACKAGE_PROVIDES_HOST_LUAINTERPRETER="host-lua"
1290# BR2_PACKAGE_MICROPYTHON is not set
1291# BR2_PACKAGE_MOARVM is not set
1292BR2_PACKAGE_HOST_MONO_ARCH_SUPPORTS=y
1293BR2_PACKAGE_NODEJS_ARCH_SUPPORTS=y
1294
1295#
1296# nodejs needs a toolchain w/ C++, dynamic library, NPTL, gcc >= 4.8, wchar
1297#
732# BR2_PACKAGE_PERL is not set1298# BR2_PACKAGE_PERL is not set
733# BR2_PACKAGE_PHP is not set1299# BR2_PACKAGE_PHP is not set
734# BR2_PACKAGE_PYTHON is not set1300
735# BR2_PACKAGE_PYTHON3 is not set1301#
736# BR2_PACKAGE_RUBY is not set1302# python needs a toolchain w/ wchar, threads, dynamic library
1303#
1304
1305#
1306# python3 needs a toolchain w/ wchar, threads, dynamic library
1307#
1308
1309#
1310# ruby needs a toolchain w/ wchar, threads, dynamic library
1311#
737# BR2_PACKAGE_TCL is not set1312# BR2_PACKAGE_TCL is not set
7381313
739#1314#
@@ -744,24 +1319,46 @@ BR2_PACKAGE_E2FSPROGS_RESIZE2FS=y
744# Audio/Sound1319# Audio/Sound
745#1320#
746# BR2_PACKAGE_ALSA_LIB is not set1321# BR2_PACKAGE_ALSA_LIB is not set
1322# BR2_PACKAGE_AUBIO is not set
7471323
748#1324#
749# audiofile needs a toolchain w/ C++1325# audiofile needs a toolchain w/ C++
750#1326#
1327# BR2_PACKAGE_BCG729 is not set
751# BR2_PACKAGE_CELT051 is not set1328# BR2_PACKAGE_CELT051 is not set
1329BR2_PACKAGE_FDK_AAC_ARCH_SUPPORTS=y
1330
1331#
1332# fdk-aac needs a toolchain w/ C++
1333#
752# BR2_PACKAGE_LIBAO is not set1334# BR2_PACKAGE_LIBAO is not set
1335
1336#
1337# asplib needs a toolchain w/ C++
1338#
1339# BR2_PACKAGE_LIBBROADVOICE is not set
753# BR2_PACKAGE_LIBCDAUDIO is not set1340# BR2_PACKAGE_LIBCDAUDIO is not set
1341# BR2_PACKAGE_LIBCDDB is not set
754# BR2_PACKAGE_LIBCDIO is not set1342# BR2_PACKAGE_LIBCDIO is not set
1343# BR2_PACKAGE_LIBCDIO_PARANOIA is not set
1344# BR2_PACKAGE_LIBCODEC2 is not set
755# BR2_PACKAGE_LIBCUE is not set1345# BR2_PACKAGE_LIBCUE is not set
756# BR2_PACKAGE_LIBCUEFILE is not set1346# BR2_PACKAGE_LIBCUEFILE is not set
1347# BR2_PACKAGE_LIBEBUR128 is not set
1348# BR2_PACKAGE_LIBG7221 is not set
1349# BR2_PACKAGE_LIBGSM is not set
757# BR2_PACKAGE_LIBID3TAG is not set1350# BR2_PACKAGE_LIBID3TAG is not set
1351# BR2_PACKAGE_LIBILBC is not set
758# BR2_PACKAGE_LIBLO is not set1352# BR2_PACKAGE_LIBLO is not set
759# BR2_PACKAGE_LIBMAD is not set1353# BR2_PACKAGE_LIBMAD is not set
7601354
761#1355#
762# libmodplug needs a toolchain w/ C++1356# libmodplug needs a toolchain w/ C++
763#1357#
764# BR2_PACKAGE_LIBMPD is not set1358
1359#
1360# libmpd needs a toolchain w/ wchar, threads
1361#
765# BR2_PACKAGE_LIBMPDCLIENT is not set1362# BR2_PACKAGE_LIBMPDCLIENT is not set
766# BR2_PACKAGE_LIBREPLAYGAIN is not set1363# BR2_PACKAGE_LIBREPLAYGAIN is not set
767# BR2_PACKAGE_LIBSAMPLERATE is not set1364# BR2_PACKAGE_LIBSAMPLERATE is not set
@@ -769,13 +1366,23 @@ BR2_PACKAGE_E2FSPROGS_RESIZE2FS=y
769#1366#
770# libsidplay2 needs a toolchain w/ C++1367# libsidplay2 needs a toolchain w/ C++
771#1368#
1369# BR2_PACKAGE_LIBSILK is not set
772# BR2_PACKAGE_LIBSNDFILE is not set1370# BR2_PACKAGE_LIBSNDFILE is not set
1371
1372#
1373# libsoundtouch needs a toolchain w/ C++
1374#
773# BR2_PACKAGE_LIBSOXR is not set1375# BR2_PACKAGE_LIBSOXR is not set
774# BR2_PACKAGE_LIBVORBIS is not set1376# BR2_PACKAGE_LIBVORBIS is not set
7751377
776#1378#
777# mp4v2 needs a toolchain w/ C++1379# mp4v2 needs a toolchain w/ C++
778#1380#
1381BR2_PACKAGE_OPENAL_ARCH_SUPPORTS=y
1382
1383#
1384# openal needs a toolchain w/ NPTL, C++
1385#
7791386
780#1387#
781# opencore-amr needs a toolchain w/ C++1388# opencore-amr needs a toolchain w/ C++
@@ -783,7 +1390,10 @@ BR2_PACKAGE_E2FSPROGS_RESIZE2FS=y
783# BR2_PACKAGE_OPUS is not set1390# BR2_PACKAGE_OPUS is not set
784# BR2_PACKAGE_OPUSFILE is not set1391# BR2_PACKAGE_OPUSFILE is not set
785# BR2_PACKAGE_PORTAUDIO is not set1392# BR2_PACKAGE_PORTAUDIO is not set
1393# BR2_PACKAGE_SBC is not set
1394# BR2_PACKAGE_SPANDSP is not set
786# BR2_PACKAGE_SPEEX is not set1395# BR2_PACKAGE_SPEEX is not set
1396# BR2_PACKAGE_SPEEXDSP is not set
7871397
788#1398#
789# taglib needs a toolchain w/ C++, wchar1399# taglib needs a toolchain w/ C++, wchar
@@ -795,15 +1405,32 @@ BR2_PACKAGE_E2FSPROGS_RESIZE2FS=y
795#1405#
796# Compression and decompression1406# Compression and decompression
797#1407#
798# BR2_PACKAGE_LIBARCHIVE is not set1408
1409#
1410# libarchive needs a toolchain w/ wchar
1411#
1412
1413#
1414# libsquish needs a toolchain w/ C++
1415#
799# BR2_PACKAGE_LIBZIP is not set1416# BR2_PACKAGE_LIBZIP is not set
800# BR2_PACKAGE_LZO is not set1417# BR2_PACKAGE_LZO is not set
8011418
802#1419#
1420# minizip needs a toolchain w/ wchar
1421#
1422
1423#
803# snappy needs a toolchain w/ C++1424# snappy needs a toolchain w/ C++
804#1425#
805# BR2_PACKAGE_SZIP is not set1426# BR2_PACKAGE_SZIP is not set
1427BR2_PACKAGE_ZLIB_NG_ARCH_SUPPORTS=y
806BR2_PACKAGE_ZLIB=y1428BR2_PACKAGE_ZLIB=y
1429BR2_PACKAGE_LIBZLIB=y
1430# BR2_PACKAGE_ZLIB_NG is not set
1431BR2_PACKAGE_HAS_ZLIB=y
1432BR2_PACKAGE_PROVIDES_ZLIB="libzlib"
1433BR2_PACKAGE_PROVIDES_HOST_ZLIB="host-libzlib"
8071434
808#1435#
809# Crypto1436# Crypto
@@ -814,38 +1441,81 @@ BR2_PACKAGE_ZLIB=y
814#1441#
815# cryptodev needs a Linux kernel to be built1442# cryptodev needs a Linux kernel to be built
816#1443#
817# BR2_PACKAGE_GNUTLS is not set1444
1445#
1446# gcr needs a toolchain w/ wchar, threads, dynamic library
1447#
1448
1449#
1450# gnutls needs a toolchain w/ wchar, dynamic library
1451#
818# BR2_PACKAGE_LIBASSUAN is not set1452# BR2_PACKAGE_LIBASSUAN is not set
819# BR2_PACKAGE_LIBGCRYPT is not set1453# BR2_PACKAGE_LIBGCRYPT is not set
1454BR2_PACKAGE_LIBGPG_ERROR_ARCH_SUPPORTS=y
820# BR2_PACKAGE_LIBGPG_ERROR is not set1455# BR2_PACKAGE_LIBGPG_ERROR is not set
1456BR2_PACKAGE_LIBGPG_ERROR_SYSCFG="aarch64-unknown-linux-gnu"
821# BR2_PACKAGE_LIBGPGME is not set1457# BR2_PACKAGE_LIBGPGME is not set
1458# BR2_PACKAGE_LIBKCAPI is not set
822# BR2_PACKAGE_LIBKSBA is not set1459# BR2_PACKAGE_LIBKSBA is not set
823# BR2_PACKAGE_LIBMCRYPT is not set1460# BR2_PACKAGE_LIBMCRYPT is not set
824# BR2_PACKAGE_LIBMHASH is not set1461# BR2_PACKAGE_LIBMHASH is not set
825# BR2_PACKAGE_LIBNSS is not set1462# BR2_PACKAGE_LIBNSS is not set
826# BR2_PACKAGE_LIBSECRET is not set1463# BR2_PACKAGE_LIBSCRYPT is not set
1464
1465#
1466# libsecret needs a toolchain w/ wchar, threads
1467#
827# BR2_PACKAGE_LIBSHA1 is not set1468# BR2_PACKAGE_LIBSHA1 is not set
1469# BR2_PACKAGE_LIBSODIUM is not set
1470# BR2_PACKAGE_LIBSSH is not set
828# BR2_PACKAGE_LIBSSH2 is not set1471# BR2_PACKAGE_LIBSSH2 is not set
1472# BR2_PACKAGE_LIBTOMCRYPT is not set
1473# BR2_PACKAGE_LIBUECC is not set
1474# BR2_PACKAGE_MBEDTLS is not set
829# BR2_PACKAGE_NETTLE is not set1475# BR2_PACKAGE_NETTLE is not set
830BR2_PACKAGE_OPENSSL=y1476BR2_PACKAGE_OPENSSL=y
831# BR2_PACKAGE_OPENSSL_BIN is not set1477BR2_PACKAGE_LIBOPENSSL=y
832# BR2_PACKAGE_OPENSSL_ENGINES is not set1478# BR2_PACKAGE_LIBOPENSSL_BIN is not set
833# BR2_PACKAGE_POLARSSL is not set1479# BR2_PACKAGE_LIBOPENSSL_ENGINES is not set
1480# BR2_PACKAGE_LIBRESSL is not set
1481BR2_PACKAGE_HAS_OPENSSL=y
1482BR2_PACKAGE_PROVIDES_OPENSSL="libopenssl"
1483BR2_PACKAGE_PROVIDES_HOST_OPENSSL="host-libopenssl"
1484# BR2_PACKAGE_RHASH is not set
1485# BR2_PACKAGE_TINYDTLS is not set
1486# BR2_PACKAGE_TPM2_TSS is not set
1487# BR2_PACKAGE_TROUSERS is not set
1488# BR2_PACKAGE_USTREAM_SSL is not set
1489# BR2_PACKAGE_WOLFSSL is not set
8341490
835#1491#
836# Database1492# Database
837#1493#
838# BR2_PACKAGE_BERKELEYDB is not set1494# BR2_PACKAGE_BERKELEYDB is not set
839# BR2_PACKAGE_GDBM is not set1495# BR2_PACKAGE_GDBM is not set
1496# BR2_PACKAGE_HIREDIS is not set
1497
1498#
1499# kompexsqlite needs a toolchain w/ C++, wchar, threads, dynamic library
1500#
8401501
841#1502#
842# leveldb needs a toolchain w/ C++, threads1503# leveldb needs a toolchain w/ C++, threads
843#1504#
1505# BR2_PACKAGE_LIBGIT2 is not set
1506BR2_PACKAGE_MONGODB_ARCH_SUPPORTS=y
1507
1508#
1509# mongodb needs a glibc toolchain w/ wchar, threads, C++, gcc >= 6
1510#
1511
1512#
1513# mysql needs a toolchain w/ C++, threads
1514#
8441515
845#1516#
846# MySQL needs a toolchain w/ C++, threads1517# postgresql needs a toolchain w/ dynamic library, wchar
847#1518#
848# BR2_PACKAGE_POSTGRESQL is not set
849# BR2_PACKAGE_REDIS is not set1519# BR2_PACKAGE_REDIS is not set
850# BR2_PACKAGE_SQLCIPHER is not set1520# BR2_PACKAGE_SQLCIPHER is not set
851# BR2_PACKAGE_SQLITE is not set1521# BR2_PACKAGE_SQLITE is not set
@@ -854,7 +1524,10 @@ BR2_PACKAGE_OPENSSL=y
854#1524#
855# Filesystem1525# Filesystem
856#1526#
857# BR2_PACKAGE_GAMIN is not set1527
1528#
1529# gamin needs a toolchain w/ wchar, threads
1530#
858# BR2_PACKAGE_LIBCONFIG is not set1531# BR2_PACKAGE_LIBCONFIG is not set
859# BR2_PACKAGE_LIBCONFUSE is not set1532# BR2_PACKAGE_LIBCONFUSE is not set
860# BR2_PACKAGE_LIBFUSE is not set1533# BR2_PACKAGE_LIBFUSE is not set
@@ -864,9 +1537,40 @@ BR2_PACKAGE_OPENSSL=y
864# BR2_PACKAGE_LOCKDEV is not set1537# BR2_PACKAGE_LOCKDEV is not set
8651538
866#1539#
1540# physfs needs a toolchain w/ C++, threads
1541#
1542
1543#
867# Graphics1544# Graphics
868#1545#
869# BR2_PACKAGE_ATK is not set1546
1547#
1548# assimp needs a toolchain w/ C++
1549#
1550
1551#
1552# at-spi2-atk needs a toolchain w/ wchar, threads
1553#
1554
1555#
1556# at-spi2-atk depends on X.org
1557#
1558
1559#
1560# at-spi2-core needs a toolchain w/ wchar, threads
1561#
1562
1563#
1564# at-spi2-core depends on X.org
1565#
1566
1567#
1568# atk needs a toolchain w/ wchar, threads
1569#
1570
1571#
1572# atkmm needs a toolchain w/ C++, wchar, threads, gcc >= 4.9
1573#
8701574
871#1575#
872# bullet needs a toolchain w/ C++1576# bullet needs a toolchain w/ C++
@@ -874,29 +1578,86 @@ BR2_PACKAGE_OPENSSL=y
874# BR2_PACKAGE_CAIRO is not set1578# BR2_PACKAGE_CAIRO is not set
8751579
876#1580#
877# exiv2 needs a toolchain w/ C++, dynamic library1581# cairomm needs a toolchain w/ C++, wchar, threads, gcc >= 4.8
1582#
1583
1584#
1585# chipmunk needs an OpenGL backend
1586#
1587
1588#
1589# exiv2 needs a uClibc or glibc toolchain w/ C++, wchar, dynamic library, threads
1590#
1591
1592#
1593# exempi needs a toolchain w/ C++, dynamic library, threads
878#1594#
879# BR2_PACKAGE_FONTCONFIG is not set1595# BR2_PACKAGE_FONTCONFIG is not set
880# BR2_PACKAGE_FREETYPE is not set1596# BR2_PACKAGE_FREETYPE is not set
881# BR2_PACKAGE_GD is not set1597# BR2_PACKAGE_GD is not set
882# BR2_PACKAGE_GDK_PIXBUF is not set1598
1599#
1600# gdk-pixbuf needs a toolchain w/ wchar, threads
1601#
883# BR2_PACKAGE_GIFLIB is not set1602# BR2_PACKAGE_GIFLIB is not set
8841603
885#1604#
1605# granite needs libgtk3 and a toolchain w/ wchar, threads
1606#
1607
1608#
1609# graphite2 needs a toolchain w/ C++, dynamic library
1610#
1611
1612#
1613# gtkmm3 needs libgtk3 and a toolchain w/ C++, wchar, threads, gcc >= 4.9
1614#
1615
1616#
886# harfbuzz needs a toolchain w/ C++1617# harfbuzz needs a toolchain w/ C++
887#1618#
888# BR2_PACKAGE_IJS is not set1619# BR2_PACKAGE_IJS is not set
889# BR2_PACKAGE_IMLIB2 is not set1620# BR2_PACKAGE_IMLIB2 is not set
1621
1622#
1623# irrlicht needs a toolchain w/ C++
1624#
890# BR2_PACKAGE_JASPER is not set1625# BR2_PACKAGE_JASPER is not set
891# BR2_PACKAGE_JPEG is not set1626# BR2_PACKAGE_JPEG is not set
1627BR2_PACKAGE_JPEG_SIMD_SUPPORT=y
1628
1629#
1630# kms++ needs a toolchain w/ threads, C++, gcc >= 4.8, headers >= 3.8
1631#
892# BR2_PACKAGE_LCMS2 is not set1632# BR2_PACKAGE_LCMS2 is not set
1633
1634#
1635# lensfun needs a toolchain w/ C++, threads, wchar
1636#
1637# BR2_PACKAGE_LEPTONICA is not set
893# BR2_PACKAGE_LIBART is not set1638# BR2_PACKAGE_LIBART is not set
894# BR2_PACKAGE_LIBDMTX is not set1639# BR2_PACKAGE_LIBDMTX is not set
895# BR2_PACKAGE_LIBDRM is not set1640# BR2_PACKAGE_LIBDRM is not set
1641
1642#
1643# libepoxy needs an OpenGL and/or OpenGL EGL backend
1644#
896# BR2_PACKAGE_LIBEXIF is not set1645# BR2_PACKAGE_LIBEXIF is not set
8971646
898#1647#
899# libfreeimage needs a toolchain w/ C++, dynamic library1648# libfm needs X.org and a toolchain w/ wchar, threads, C++
1649#
1650
1651#
1652# libfm-extra needs a toolchain w/ wchar, threads, C++
1653#
1654
1655#
1656# libfreeglut depends on X.org and needs an OpenGL backend
1657#
1658
1659#
1660# libfreeimage needs a toolchain w/ C++, dynamic library, wchar
900#1661#
901# BR2_PACKAGE_LIBGEOTIFF is not set1662# BR2_PACKAGE_LIBGEOTIFF is not set
9021663
@@ -905,12 +1666,26 @@ BR2_PACKAGE_OPENSSL=y
905#1666#
9061667
907#1668#
1669# libglfw depends on X.org and needs an OpenGL backend
1670#
1671
1672#
908# libglu needs an OpenGL backend1673# libglu needs an OpenGL backend
909#1674#
1675# BR2_PACKAGE_LIBGTA is not set
9101676
911#1677#
912# libgtk3 needs a toolchain w/ wchar, threads, C++1678# libgtk3 needs a toolchain w/ wchar, threads, C++
913#1679#
1680
1681#
1682# libgtk3 needs an OpenGL or an OpenGL-EGL/wayland backend
1683#
1684
1685#
1686# libmediaart needs a toolchain w/ wchar, threads
1687#
1688# BR2_PACKAGE_LIBMNG is not set
914# BR2_PACKAGE_LIBPNG is not set1689# BR2_PACKAGE_LIBPNG is not set
915# BR2_PACKAGE_LIBQRENCODE is not set1690# BR2_PACKAGE_LIBQRENCODE is not set
9161691
@@ -921,6 +1696,10 @@ BR2_PACKAGE_OPENSSL=y
921#1696#
922# librsvg needs a toolchain w/ wchar, threads, C++1697# librsvg needs a toolchain w/ wchar, threads, C++
923#1698#
1699
1700#
1701# libsoil needs an OpenGL backend and a toolchain w/ dynamic library
1702#
924# BR2_PACKAGE_LIBSVG is not set1703# BR2_PACKAGE_LIBSVG is not set
925# BR2_PACKAGE_LIBSVG_CAIRO is not set1704# BR2_PACKAGE_LIBSVG_CAIRO is not set
926# BR2_PACKAGE_LIBSVGTINY is not set1705# BR2_PACKAGE_LIBSVGTINY is not set
@@ -931,13 +1710,25 @@ BR2_PACKAGE_OPENSSL=y
931#1710#
9321711
933#1712#
1713# menu-cache needs a toolchain w/ wchar, threads
1714#
1715
1716#
934# opencv needs a toolchain w/ C++, NPTL, wchar1717# opencv needs a toolchain w/ C++, NPTL, wchar
935#1718#
1719
1720#
1721# opencv3 needs a toolchain w/ C++, NPTL, wchar, dynamic library
1722#
936# BR2_PACKAGE_OPENJPEG is not set1723# BR2_PACKAGE_OPENJPEG is not set
9371724
938#1725#
939# pango needs a toolchain w/ wchar, threads, C++1726# pango needs a toolchain w/ wchar, threads, C++
940#1727#
1728
1729#
1730# pangomm needs a toolchain w/ C++, wchar, threads, gcc >= 4.9
1731#
941# BR2_PACKAGE_PIXMAN is not set1732# BR2_PACKAGE_PIXMAN is not set
9421733
943#1734#
@@ -945,86 +1736,135 @@ BR2_PACKAGE_OPENSSL=y
945#1736#
946# BR2_PACKAGE_TIFF is not set1737# BR2_PACKAGE_TIFF is not set
947# BR2_PACKAGE_WAYLAND is not set1738# BR2_PACKAGE_WAYLAND is not set
1739BR2_PACKAGE_WEBKITGTK_ARCH_SUPPORTS=y
1740BR2_PACKAGE_WEBKITGTK_ARCH_SUPPORTS_JIT=y
1741
1742#
1743# webkitgtk needs libgtk3 and a glibc toolchain w/ C++, gcc >= 6, host gcc >= 4.8
1744#
948# BR2_PACKAGE_WEBP is not set1745# BR2_PACKAGE_WEBP is not set
9491746
950#1747#
951# zxing needs a toolchain w/ C++1748# zbar needs a toolchain w/ threads, C++ and headers >= 3.17
1749#
1750
1751#
1752# zxing-cpp needs a toolchain w/ C++, dynamic library
952#1753#
9531754
954#1755#
955# Hardware handling1756# Hardware handling
956#1757#
1758# BR2_PACKAGE_ACSCCID is not set
957# BR2_PACKAGE_C_PERIPHERY is not set1759# BR2_PACKAGE_C_PERIPHERY is not set
958# BR2_PACKAGE_CCID is not set1760# BR2_PACKAGE_CCID is not set
959# BR2_PACKAGE_DTC is not set1761# BR2_PACKAGE_DTC is not set
1762BR2_PACKAGE_GNU_EFI_ARCH_SUPPORTS=y
1763# BR2_PACKAGE_GNU_EFI is not set
1764# BR2_PACKAGE_HACKRF is not set
1765
1766#
1767# hidapi needs udev /dev management and a toolchain w/ NPTL threads
1768#
9601769
961#1770#
962# lcdapi needs a toolchain w/ C++, threads1771# lcdapi needs a toolchain w/ C++, threads
963#1772#
9641773
965#1774#
1775# let-me-create needs a toolchain w/ C++, threads, dynamic library
1776#
1777# BR2_PACKAGE_LIBAIO is not set
1778
1779#
966# libatasmart requires udev to be enabled1780# libatasmart requires udev to be enabled
967#1781#
9681782
969#1783#
970# libcec needs a toolchain w/ C++, wchar, threads, dynamic library1784# libcec needs a toolchain w/ C++, wchar, threads, dynamic library, gcc >= 4.7
971#1785#
972# BR2_PACKAGE_LIBFREEFARE is not set1786# BR2_PACKAGE_LIBFREEFARE is not set
973# BR2_PACKAGE_LIBFTDI is not set1787# BR2_PACKAGE_LIBFTDI is not set
974# BR2_PACKAGE_LIBFTDI1 is not set1788# BR2_PACKAGE_LIBFTDI1 is not set
1789# BR2_PACKAGE_LIBGPHOTO2 is not set
1790# BR2_PACKAGE_LIBGPIOD is not set
1791
1792#
1793# libgudev needs udev /dev handling and a toolchain w/ wchar, threads
1794#
975# BR2_PACKAGE_LIBHID is not set1795# BR2_PACKAGE_LIBHID is not set
976# BR2_PACKAGE_LIBIIO is not set1796# BR2_PACKAGE_LIBIIO is not set
9771797
978#1798#
979# libinput needs udev /dev management1799# libinput needs udev /dev management and a toolchain w/ locale
980#1800#
981# BR2_PACKAGE_LIBIQRF is not set1801# BR2_PACKAGE_LIBIQRF is not set
982# BR2_PACKAGE_LIBLLCP is not set1802# BR2_PACKAGE_LIBLLCP is not set
9831803
984#1804#
985# libmbim needs udev /dev management and a toolchain w/ wchar, threads1805# libmbim needs a toolchain w/ wchar, threads
986#1806#
987# BR2_PACKAGE_LIBNFC is not set1807# BR2_PACKAGE_LIBNFC is not set
988# BR2_PACKAGE_LIBPCIACCESS is not set1808# BR2_PACKAGE_LIBPCIACCESS is not set
989# BR2_PACKAGE_LIBPHIDGET is not set1809# BR2_PACKAGE_LIBPHIDGET is not set
990# BR2_PACKAGE_LIBQMI is not set1810
1811#
1812# libpri needs a kernel to be built
1813#
1814
1815#
1816# libqmi needs a toolchain w/ wchar, threads
1817#
991# BR2_PACKAGE_LIBRAW1394 is not set1818# BR2_PACKAGE_LIBRAW1394 is not set
992# BR2_PACKAGE_LIBRTLSDR is not set1819# BR2_PACKAGE_LIBRTLSDR is not set
9931820
994#1821#
995# libserial needs a toolchain w/ C++1822# libserial needs a toolchain w/ C++, gcc >= 5, threads, wchar
996#1823#
997# BR2_PACKAGE_LIBSERIALPORT is not set1824# BR2_PACKAGE_LIBSERIALPORT is not set
998# BR2_PACKAGE_LIBSIGROK is not set1825
999# BR2_PACKAGE_LIBSIGROKDECODE is not set1826#
1827# libsigrok needs a toolchain w/ wchar, locale, threads, dynamic library, gcc >= 4.7
1828#
1829
1830#
1831# libsigrokdecode needs a toolchain w/ wchar, threads, dynamic library
1832#
1000# BR2_PACKAGE_LIBSOC is not set1833# BR2_PACKAGE_LIBSOC is not set
1834
1835#
1836# libss7 needs a kernel to be built
1837#
1001# BR2_PACKAGE_LIBUSB is not set1838# BR2_PACKAGE_LIBUSB is not set
1839# BR2_PACKAGE_LIBUSBGX is not set
10021840
1003#1841#
1004# libv4l needs a toolchain w/ threads and C++, headers >= 3.01842# libv4l needs a toolchain w/ threads, C++ and headers >= 3.0
1005#1843#
1006# BR2_PACKAGE_LIBXKBCOMMON is not set1844# BR2_PACKAGE_LIBXKBCOMMON is not set
1007# BR2_PACKAGE_MTDEV is not set1845# BR2_PACKAGE_MTDEV is not set
1008# BR2_PACKAGE_NEARDAL is not set1846
1847#
1848# neardal needs a toolchain w/ wchar, threads
1849#
1850# BR2_PACKAGE_OWFS is not set
1009# BR2_PACKAGE_PCSC_LITE is not set1851# BR2_PACKAGE_PCSC_LITE is not set
1010# BR2_PACKAGE_TSLIB is not set1852# BR2_PACKAGE_TSLIB is not set
10111853
1012#1854#
1013# urg needs a toolchain w/ C++1855# urg needs a toolchain w/ C++
1014#1856#
1857# BR2_PACKAGE_WIRINGPI is not set
10151858
1016#1859#
1017# Javascript1860# Javascript
1018#1861#
1862# BR2_PACKAGE_ANGULARJS is not set
1019# BR2_PACKAGE_BOOTSTRAP is not set1863# BR2_PACKAGE_BOOTSTRAP is not set
1864# BR2_PACKAGE_DUKTAPE is not set
1020# BR2_PACKAGE_EXPLORERCANVAS is not set1865# BR2_PACKAGE_EXPLORERCANVAS is not set
1021# BR2_PACKAGE_FLOT is not set1866# BR2_PACKAGE_FLOT is not set
1022# BR2_PACKAGE_JQUERY is not set1867# BR2_PACKAGE_JQUERY is not set
1023# BR2_PACKAGE_JQUERY_KEYBOARD is not set
1024# BR2_PACKAGE_JQUERY_MOBILE is not set
1025# BR2_PACKAGE_JQUERY_SPARKLINE is not set
1026# BR2_PACKAGE_JQUERY_UI is not set
1027# BR2_PACKAGE_JQUERY_VALIDATION is not set
1028# BR2_PACKAGE_JSMIN is not set1868# BR2_PACKAGE_JSMIN is not set
1029# BR2_PACKAGE_JSON_JAVASCRIPT is not set1869# BR2_PACKAGE_JSON_JAVASCRIPT is not set
10301870
@@ -1039,27 +1879,48 @@ BR2_PACKAGE_OPENSSL=y
1039# BR2_PACKAGE_EXPAT is not set1879# BR2_PACKAGE_EXPAT is not set
1040# BR2_PACKAGE_EZXML is not set1880# BR2_PACKAGE_EZXML is not set
1041# BR2_PACKAGE_JANSSON is not set1881# BR2_PACKAGE_JANSSON is not set
1882# BR2_PACKAGE_JOSE is not set
1883# BR2_PACKAGE_JSMN is not set
1042# BR2_PACKAGE_JSON_C is not set1884# BR2_PACKAGE_JSON_C is not set
1043# BR2_PACKAGE_JSON_GLIB is not set
10441885
1045#1886#
1046# jsoncpp needs a toolchain w/ C++1887# json-for-modern-cpp needs a toolchain w/ C++, gcc >= 4.9
1047#1888#
10481889
1049#1890#
1891# json-glib needs a toolchain w/ wchar, threads
1892#
1893
1894#
1895# jsoncpp needs a toolchain w/ C++, gcc >= 4.7
1896#
1897# BR2_PACKAGE_LIBBSON is not set
1898# BR2_PACKAGE_LIBFASTJSON is not set
1899
1900#
1050# libjson needs a toolchain w/ C++1901# libjson needs a toolchain w/ C++
1051#1902#
1052# BR2_PACKAGE_LIBROXML is not set1903# BR2_PACKAGE_LIBROXML is not set
1904# BR2_PACKAGE_LIBUCL is not set
1053# BR2_PACKAGE_LIBXML2 is not set1905# BR2_PACKAGE_LIBXML2 is not set
10541906
1055#1907#
1056# libxml++ needs a toolchain w/ C++, wchar, threads1908# libxml++ needs a toolchain w/ C++, wchar, threads, gcc >= 4.9
1057#1909#
1058# BR2_PACKAGE_LIBXMLRPC is not set1910# BR2_PACKAGE_LIBXMLRPC is not set
1059# BR2_PACKAGE_LIBXSLT is not set1911# BR2_PACKAGE_LIBXSLT is not set
1060# BR2_PACKAGE_LIBYAML is not set1912# BR2_PACKAGE_LIBYAML is not set
1061# BR2_PACKAGE_MXML is not set1913# BR2_PACKAGE_MXML is not set
1062# BR2_PACKAGE_RAPIDJSON is not set1914
1915#
1916# pugixml needs a toolchain w/ C++
1917#
1918
1919#
1920# rapidjson needs a toolchain w/ C++
1921#
1922# BR2_PACKAGE_RAPIDXML is not set
1923# BR2_PACKAGE_RAPTOR is not set
10631924
1064#1925#
1065# tinyxml needs a toolchain w/ C++1926# tinyxml needs a toolchain w/ C++
@@ -1070,55 +1931,97 @@ BR2_PACKAGE_OPENSSL=y
1070#1931#
10711932
1072#1933#
1934# valijson needs a toolchain w/ C++, threads, wchar support
1935#
1936
1937#
1073# xerces-c++ needs a toolchain w/ C++, wchar1938# xerces-c++ needs a toolchain w/ C++, wchar
1074#1939#
1075# BR2_PACKAGE_YAJL is not set1940# BR2_PACKAGE_YAJL is not set
10761941
1077#1942#
1078# yaml-cpp needs a toolchain w/ C++, threads1943# yaml-cpp needs a toolchain w/ C++, gcc >= 4.7
1079#1944#
10801945
1081#1946#
1082# Logging1947# Logging
1083#1948#
1949# BR2_PACKAGE_EVENTLOG is not set
1950
1951#
1952# glog needs a toolchain w/ C++, threads, dynamic library
1953#
1084# BR2_PACKAGE_LIBLOG4C_LOCALTIME is not set1954# BR2_PACKAGE_LIBLOG4C_LOCALTIME is not set
1085# BR2_PACKAGE_LIBLOGGING is not set1955# BR2_PACKAGE_LIBLOGGING is not set
10861956
1087#1957#
1088# log4cplus needs a toolchain w/ C++, wchar, threads1958# log4cplus needs a toolchain w/ C++, wchar, threads, gcc >= 4.8
1959#
1960
1961#
1962# log4cpp needs a toolchain w/ C++, threads
1089#1963#
10901964
1091#1965#
1092# log4cxx needs a toolchain w/ C++, threads, dynamic library1966# log4cxx needs a toolchain w/ C++, threads, dynamic library
1093#1967#
1968
1969#
1970# opentracing-cpp needs a toolchain w/ C++, threads, dynamic library, gcc >= 4.8
1971#
1094# BR2_PACKAGE_ZLOG is not set1972# BR2_PACKAGE_ZLOG is not set
10951973
1096#1974#
1097# Multimedia1975# Multimedia
1098#1976#
1977# BR2_PACKAGE_BITSTREAM is not set
1978
1979#
1980# kvazaar needs a toolchain w/ C++, threads
1981#
1982# BR2_PACKAGE_LIBAACS is not set
1983# BR2_PACKAGE_LIBAMCODEC is not set
1099# BR2_PACKAGE_LIBASS is not set1984# BR2_PACKAGE_LIBASS is not set
1985# BR2_PACKAGE_LIBBDPLUS is not set
1100# BR2_PACKAGE_LIBBLURAY is not set1986# BR2_PACKAGE_LIBBLURAY is not set
1101# BR2_PACKAGE_LIBDCADEC is not set1987# BR2_PACKAGE_LIBDCADEC is not set
1102# BR2_PACKAGE_LIBDVBCSA is not set1988# BR2_PACKAGE_LIBDVBCSA is not set
1989# BR2_PACKAGE_LIBDVBPSI is not set
11031990
1104#1991#
1105# libdvbsi++ needs a toolchain w/ C++, wchar, threads1992# libdvbsi++ needs a toolchain w/ C++, wchar, threads
1106#1993#
1994# BR2_PACKAGE_LIBDVDCSS is not set
1107# BR2_PACKAGE_LIBDVDNAV is not set1995# BR2_PACKAGE_LIBDVDNAV is not set
1108# BR2_PACKAGE_LIBDVDREAD is not set1996# BR2_PACKAGE_LIBDVDREAD is not set
11091997
1110#1998#
1111# libebml needs a toolchain w/ C++1999# libebml needs a toolchain w/ C++, wchar
2000#
2001# BR2_PACKAGE_LIBHDHOMERUN is not set
2002
2003#
2004# libmatroska needs a toolchain w/ C++, wchar
1112#2005#
11132006
1114#2007#
1115# libmatroska needs a toolchain w/ C++2008# libmms needs a toolchain w/ wchar, threads
1116#2009#
1117# BR2_PACKAGE_LIBMMS is not set
1118# BR2_PACKAGE_LIBMPEG2 is not set2010# BR2_PACKAGE_LIBMPEG2 is not set
1119# BR2_PACKAGE_LIBOGG is not set2011# BR2_PACKAGE_LIBOGG is not set
2012BR2_PACKAGE_LIBOPENH264_ARCH_SUPPORTS=y
2013
2014#
2015# libopenh264 needs a toolchain w/ C++, dynamic library, threads
2016#
2017# BR2_PACKAGE_LIBOPUSENC is not set
1120# BR2_PACKAGE_LIBPLAYER is not set2018# BR2_PACKAGE_LIBPLAYER is not set
1121# BR2_PACKAGE_LIBTHEORA is not set2019# BR2_PACKAGE_LIBTHEORA is not set
2020# BR2_PACKAGE_LIBVPX is not set
2021
2022#
2023# libyuv needs a toolchain w/ C++, dynamic library
2024#
11222025
1123#2026#
1124# live555 needs a toolchain w/ C++2027# live555 needs a toolchain w/ C++
@@ -1130,53 +2033,134 @@ BR2_PACKAGE_OPENSSL=y
1130# BR2_PACKAGE_X264 is not set2033# BR2_PACKAGE_X264 is not set
11312034
1132#2035#
2036# x265 needs a toolchain w/ C++, threads, dynamic library
2037#
2038
2039#
1133# Networking2040# Networking
1134#2041#
11352042
1136#2043#
1137# agent++ needs a toolchain w/ threads, C++, dynamic library2044# agent++ needs a toolchain w/ threads, C++, dynamic library
1138#2045#
2046
2047#
2048# alljoyn needs a toolchain w/ C++, threads, wchar and dynamic library
2049#
2050
2051#
2052# alljoyn-base needs a toolchain w/ C++, threads, wchar, dynamic library
2053#
2054# BR2_PACKAGE_ALLJOYN_TCL is not set
2055# BR2_PACKAGE_ALLJOYN_TCL_BASE is not set
2056
2057#
2058# azmq needs a toolchain w/ C++11, wchar and NTPL
2059#
2060
2061#
2062# azure-iot-sdk-c needs a toolchain w/ C++ and NPTL
2063#
2064
2065#
2066# batman-adv needs a Linux kernel to be built
2067#
1139# BR2_PACKAGE_C_ARES is not set2068# BR2_PACKAGE_C_ARES is not set
1140# BR2_PACKAGE_CGIC is not set2069# BR2_PACKAGE_CGIC is not set
11412070
1142#2071#
1143# cppzmq needs a toolchain w/ C++, wchar, threads2072# cppzmq needs a toolchain w/ C++, threads
2073#
2074
2075#
2076# curlpp needs a toolchain w/ C++, dynamic library
1144#2077#
11452078
1146#2079#
1147# czmq needs a toolchain w/ C++, wchar, threads2080# czmq needs a toolchain w/ C++, threads
1148#2081#
2082# BR2_PACKAGE_DAQ is not set
2083# BR2_PACKAGE_DAVICI is not set
11492084
1150#2085#
1151# filemq needs a toolchain w/ C++, wchar, threads2086# filemq needs a toolchain w/ C++, threads
1152#2087#
1153# BR2_PACKAGE_FLICKCURL is not set2088# BR2_PACKAGE_FLICKCURL is not set
1154# BR2_PACKAGE_FREERADIUS_CLIENT is not set2089# BR2_PACKAGE_FREERADIUS_CLIENT is not set
1155# BR2_PACKAGE_GEOIP is not set2090# BR2_PACKAGE_GEOIP is not set
1156# BR2_PACKAGE_GLIB_NETWORKING is not set2091
2092#
2093# glib-networking needs a toolchain w/ wchar, threads, dynamic library
2094#
2095
2096#
2097# grpc needs a toolchain w/ C++, threads, dynamic library, host and target gcc >= 4.8
2098#
2099
2100#
2101# gssdp needs a toolchain w/ wchar, threads
2102#
2103
2104#
2105# gupnp needs a toolchain w/ wchar, threads
2106#
2107
2108#
2109# gupnp-av needs a toolchain w/ wchar, threads
2110#
2111
2112#
2113# gupnp-dlna needs a toolchain w/ wchar, threads
2114#
2115
2116#
2117# ibrcommon needs a toolchain w/ C++, threads
2118#
2119
2120#
2121# ibrdtn needs a toolchain w/ C++, threads
2122#
1157# BR2_PACKAGE_LIBCGI is not set2123# BR2_PACKAGE_LIBCGI is not set
11582124
1159#2125#
1160# libcgicc needs a toolchain w/ C++2126# libcgicc needs a toolchain w/ C++
1161#2127#
2128# BR2_PACKAGE_LIBCOAP is not set
2129
2130#
2131# libcpprestsdk needs a toolchain w/ NPTL, C++, wchar
2132#
1162BR2_PACKAGE_LIBCURL=y2133BR2_PACKAGE_LIBCURL=y
1163BR2_PACKAGE_CURL=y2134BR2_PACKAGE_CURL=y
2135# BR2_PACKAGE_LIBCURL_VERBOSE is not set
2136BR2_PACKAGE_LIBCURL_TLS_SUPPORT=y
2137BR2_PACKAGE_LIBCURL_OPENSSL=y
1164# BR2_PACKAGE_LIBDNET is not set2138# BR2_PACKAGE_LIBDNET is not set
1165# BR2_PACKAGE_LIBEXOSIP2 is not set2139# BR2_PACKAGE_LIBEXOSIP2 is not set
1166# BR2_PACKAGE_LIBFCGI is not set2140# BR2_PACKAGE_LIBFCGI is not set
1167# BR2_PACKAGE_LIBGSASL is not set2141
2142#
2143# libgsasl needs a toolchain w/ wchar
2144#
2145# BR2_PACKAGE_LIBHTTPPARSER is not set
1168# BR2_PACKAGE_LIBIDN is not set2146# BR2_PACKAGE_LIBIDN is not set
2147# BR2_PACKAGE_LIBIDN2 is not set
1169# BR2_PACKAGE_LIBISCSI is not set2148# BR2_PACKAGE_LIBISCSI is not set
2149# BR2_PACKAGE_LIBKRB5 is not set
2150# BR2_PACKAGE_LIBLDNS is not set
2151# BR2_PACKAGE_LIBMAXMINDDB is not set
1170# BR2_PACKAGE_LIBMBUS is not set2152# BR2_PACKAGE_LIBMBUS is not set
11712153
1172#2154#
1173# libmemcached needs a toolchain w/ C++, threads2155# libmemcached needs a toolchain w/ C++, threads
1174#2156#
1175# BR2_PACKAGE_LIBMICROHTTPD is not set2157# BR2_PACKAGE_LIBMICROHTTPD is not set
2158# BR2_PACKAGE_LIBMINIUPNPC is not set
1176# BR2_PACKAGE_LIBMNL is not set2159# BR2_PACKAGE_LIBMNL is not set
1177# BR2_PACKAGE_LIBMODBUS is not set2160# BR2_PACKAGE_LIBMODBUS is not set
2161# BR2_PACKAGE_LIBNATPMP is not set
1178# BR2_PACKAGE_LIBNDP is not set2162# BR2_PACKAGE_LIBNDP is not set
1179# BR2_PACKAGE_LIBNICE is not set2163# BR2_PACKAGE_LIBNET is not set
1180# BR2_PACKAGE_LIBNETFILTER_ACCT is not set2164# BR2_PACKAGE_LIBNETFILTER_ACCT is not set
1181# BR2_PACKAGE_LIBNETFILTER_CONNTRACK is not set2165# BR2_PACKAGE_LIBNETFILTER_CONNTRACK is not set
1182# BR2_PACKAGE_LIBNETFILTER_CTHELPER is not set2166# BR2_PACKAGE_LIBNETFILTER_CTHELPER is not set
@@ -1185,41 +2169,94 @@ BR2_PACKAGE_CURL=y
1185# BR2_PACKAGE_LIBNETFILTER_QUEUE is not set2169# BR2_PACKAGE_LIBNETFILTER_QUEUE is not set
1186# BR2_PACKAGE_LIBNFNETLINK is not set2170# BR2_PACKAGE_LIBNFNETLINK is not set
1187# BR2_PACKAGE_LIBNFTNL is not set2171# BR2_PACKAGE_LIBNFTNL is not set
2172
2173#
2174# libnice needs a toolchain w/ wchar, threads, dynamic library
2175#
1188# BR2_PACKAGE_LIBNL is not set2176# BR2_PACKAGE_LIBNL is not set
1189# BR2_PACKAGE_LIBOAUTH is not set2177# BR2_PACKAGE_LIBOAUTH is not set
1190# BR2_PACKAGE_LIBOPING is not set2178# BR2_PACKAGE_LIBOPING is not set
1191# BR2_PACKAGE_LIBOSIP2 is not set2179# BR2_PACKAGE_LIBOSIP2 is not set
2180# BR2_PACKAGE_LIBPAGEKITE is not set
1192# BR2_PACKAGE_LIBPCAP is not set2181# BR2_PACKAGE_LIBPCAP is not set
2182
2183#
2184# libpjsip needs a toolchain w/ C++, threads
2185#
1193# BR2_PACKAGE_LIBRSYNC is not set2186# BR2_PACKAGE_LIBRSYNC is not set
1194# BR2_PACKAGE_LIBSHAIRPLAY is not set2187# BR2_PACKAGE_LIBSHAIRPLAY is not set
1195# BR2_PACKAGE_LIBSHOUT is not set2188# BR2_PACKAGE_LIBSHOUT is not set
1196# BR2_PACKAGE_LIBSOCKETCAN is not set2189# BR2_PACKAGE_LIBSOCKETCAN is not set
1197# BR2_PACKAGE_LIBSOUP is not set2190
2191#
2192# libsoup needs a toolchain w/ wchar, threads
2193#
1198# BR2_PACKAGE_LIBSRTP is not set2194# BR2_PACKAGE_LIBSRTP is not set
1199# BR2_PACKAGE_LIBSTROPHE is not set2195# BR2_PACKAGE_LIBSTROPHE is not set
1200# BR2_PACKAGE_LIBTIRPC is not set2196BR2_PACKAGE_LIBTIRPC=y
12012197
1202#2198#
1203# libtorrent needs a toolchain w/ C++, threads2199# libtorrent needs a toolchain w/ C++, threads
1204#2200#
2201
2202#
2203# libtorrent-rasterbar needs a toolchain w/ C++, threads, wchar, gcc >= 4.8
2204#
1205# BR2_PACKAGE_LIBUPNP is not set2205# BR2_PACKAGE_LIBUPNP is not set
2206# BR2_PACKAGE_LIBUPNP18 is not set
12062207
1207#2208#
1208# libupnpp needs a toolchain w/ C++, threads2209# libupnpp needs a toolchain w/ C++, threads, gcc >= 4.9
1209#2210#
1210# BR2_PACKAGE_LIBURIPARSER is not set2211# BR2_PACKAGE_LIBURIPARSER is not set
1211# BR2_PACKAGE_LIBVNCSERVER is not set2212# BR2_PACKAGE_LIBVNCSERVER is not set
1212# BR2_PACKAGE_LIBWEBSOCK is not set2213# BR2_PACKAGE_LIBWEBSOCK is not set
1213# BR2_PACKAGE_LIBWEBSOCKETS is not set2214# BR2_PACKAGE_LIBWEBSOCKETS is not set
2215# BR2_PACKAGE_LKSCTP_TOOLS is not set
2216# BR2_PACKAGE_MONGOOSE is not set
2217# BR2_PACKAGE_NANOMSG is not set
1214# BR2_PACKAGE_NEON is not set2218# BR2_PACKAGE_NEON is not set
2219# BR2_PACKAGE_NGHTTP2 is not set
2220
2221#
2222# norm needs a toolchain w/ C++, threads, dynamic library
2223#
2224
2225#
2226# nss-myhostname needs a glibc toolchain
2227#
2228
2229#
2230# nss-pam-ldapd needs a glibc toolchain
2231#
12152232
1216#2233#
1217# omniORB needs a toolchain w/ C++, threads2234# omniORB needs a toolchain w/ C++, threads
1218#2235#
1219# BR2_PACKAGE_OPENLDAP is not set2236
1220# BR2_PACKAGE_OPENPGM is not set2237#
1221# BR2_PACKAGE_ORTP is not set2238# openldap needs a toolchain w/ wchar
2239#
2240
2241#
2242# openmpi needs a toolchain w/ dynamic library, NPTL, wchar, C++
2243#
2244
2245#
2246# openpgm needs a toolchain w/ wchar, threads
2247#
2248
2249#
2250# openzwave needs udev and a toolchain w/ C++, threads, wchar
2251#
2252
2253#
2254# ortp needs a toolchain w/ C++, threads
2255#
2256# BR2_PACKAGE_PAHO_MQTT_C is not set
1222# BR2_PACKAGE_QDECODER is not set2257# BR2_PACKAGE_QDECODER is not set
2258# BR2_PACKAGE_QPID_PROTON is not set
2259# BR2_PACKAGE_RABBITMQ_C is not set
1223# BR2_PACKAGE_RTMPDUMP is not set2260# BR2_PACKAGE_RTMPDUMP is not set
1224# BR2_PACKAGE_SLIRP is not set2261# BR2_PACKAGE_SLIRP is not set
12252262
@@ -1234,19 +2271,23 @@ BR2_PACKAGE_CURL=y
1234# BR2_PACKAGE_USBREDIR is not set2271# BR2_PACKAGE_USBREDIR is not set
12352272
1236#2273#
1237# wvstreams needs a toolchain w/ C++, dynamic library2274# wampcc needs a toolchain w/ C++, NPTL, dynamic library
2275#
2276
2277#
2278# websocketpp needs a toolchain w/ C++ and gcc >= 4.8
1238#2279#
12392280
1240#2281#
1241# zeromq needs a toolchain w/ C++, wchar, threads2282# zeromq needs a toolchain w/ C++, threads
1242#2283#
12432284
1244#2285#
1245# zmqpp needs a toolchain w/ C++, wchar, threads2286# zmqpp needs a toolchain w/ C++, threads, gcc >= 4.7
1246#2287#
12472288
1248#2289#
1249# zyre needs a toolchain w/ C++, wchar, threads2290# zyre needs a toolchain w/ C++, threads
1250#2291#
12512292
1252#2293#
@@ -1254,27 +2295,56 @@ BR2_PACKAGE_CURL=y
1254#2295#
1255# BR2_PACKAGE_APR is not set2296# BR2_PACKAGE_APR is not set
1256# BR2_PACKAGE_APR_UTIL is not set2297# BR2_PACKAGE_APR_UTIL is not set
2298# BR2_PACKAGE_ARGP_STANDALONE is not set
12572299
1258#2300#
1259# armadillo needs a toolchain w/ C++2301# armadillo needs a toolchain w/ C++
1260#2302#
2303
2304#
2305# atf needs a toolchain w/ C++
2306#
2307
2308#
2309# bctoolbox needs a toolchain w/ C++, threads
2310#
1261# BR2_PACKAGE_BDWGC is not set2311# BR2_PACKAGE_BDWGC is not set
12622312
1263#2313#
1264# boost needs a toolchain w/ C++, threads2314# boost needs a toolchain w/ C++, threads, wchar
2315#
2316
2317#
2318# capnproto needs host and target gcc >= 4.8 w/ C++, threads, atomic
2319#
2320
2321#
2322# clang needs a toolchain w/ wchar, threads, C++, gcc >= 4.8, host gcc >= 4.8, dynamic library
1265#2323#
1266BR2_PACKAGE_BOOST_ARCH_SUPPORTS=y
1267# BR2_PACKAGE_CLAPACK is not set2324# BR2_PACKAGE_CLAPACK is not set
2325# BR2_PACKAGE_CMOCKA is not set
12682326
1269#2327#
1270# cppcms needs a toolchain w/ C++, NPTL, wchar, dynamic library2328# cppcms needs a toolchain w/ C++, NPTL, wchar, dynamic library
1271#2329#
2330# BR2_PACKAGE_CRACKLIB is not set
2331
2332#
2333# dawgdic needs a toolchain w/ C++, gcc >= 4.6
2334#
1272# BR2_PACKAGE_DING_LIBS is not set2335# BR2_PACKAGE_DING_LIBS is not set
12732336
1274#2337#
1275# eigen needs a toolchain w/ C++2338# eigen needs a toolchain w/ C++
1276#2339#
1277# BR2_PACKAGE_ELFUTILS is not set2340
2341#
2342# elfutils needs a uClibc or glibc toolchain w/ wchar, dynamic library
2343#
2344
2345#
2346# ell needs a toolchain w/ dynamic library, wchar
2347#
1278# BR2_PACKAGE_FFTW is not set2348# BR2_PACKAGE_FFTW is not set
12792349
1280#2350#
@@ -1282,7 +2352,20 @@ BR2_PACKAGE_BOOST_ARCH_SUPPORTS=y
1282#2352#
12832353
1284#2354#
1285# glibmm needs a toolchain w/ C++, wchar, threads2355# flatbuffers needs a toolchain w/ C++, gcc >= 4.7
2356#
2357# BR2_PACKAGE_FLATCC is not set
2358
2359#
2360# gconf needs a toolchain w/ threads, wchar, dynamic library
2361#
2362
2363#
2364# gflags needs a toolchain w/ C++
2365#
2366
2367#
2368# glibmm needs a toolchain w/ C++, wchar, threads, gcc >= 4.9
1286#2369#
12872370
1288#2371#
@@ -1294,101 +2377,225 @@ BR2_PACKAGE_BOOST_ARCH_SUPPORTS=y
1294#2377#
1295# gtest needs a toolchain w/ C++, wchar, threads2378# gtest needs a toolchain w/ C++, wchar, threads
1296#2379#
2380BR2_PACKAGE_JEMALLOC_ARCH_SUPPORTS=y
2381# BR2_PACKAGE_JEMALLOC is not set
2382
2383#
2384# lapack/blas needs a toolchain w/ fortran
2385#
1297# BR2_PACKAGE_LIBARGTABLE2 is not set2386# BR2_PACKAGE_LIBARGTABLE2 is not set
1298BR2_PACKAGE_LIBATOMIC_ARCH_SUPPORTS=y2387BR2_PACKAGE_LIBATOMIC_OPS_ARCH_SUPPORTS=y
1299# BR2_PACKAGE_LIBATOMIC_OPS is not set2388# BR2_PACKAGE_LIBATOMIC_OPS is not set
2389# BR2_PACKAGE_LIBB64 is not set
2390BR2_PACKAGE_LIBBSD_ARCH_SUPPORTS=y
2391
2392#
2393# libbsd needs a toolchain w/ threads, wchar
2394#
1300# BR2_PACKAGE_LIBCAP is not set2395# BR2_PACKAGE_LIBCAP is not set
1301# BR2_PACKAGE_LIBCAP_NG is not set2396# BR2_PACKAGE_LIBCAP_NG is not set
13022397
1303#2398#
1304# libcgroup needs an (e)glibc toolchain w/ C++2399# libcgroup needs a glibc toolchain w/ C++
2400#
2401# BR2_PACKAGE_LIBCLC is not set
2402# BR2_PACKAGE_LIBCORRECT is not set
2403
2404#
2405# libcroco needs a toolchain w/ wchar, threads
2406#
2407
2408#
2409# libcrossguid needs a toolchain w/ C++, gcc >= 4.7
1305#2410#
2411# BR2_PACKAGE_LIBCSV is not set
1306# BR2_PACKAGE_LIBDAEMON is not set2412# BR2_PACKAGE_LIBDAEMON is not set
2413BR2_PACKAGE_LIBEASTL_ARCH_SUPPORTS=y
2414
2415#
2416# libeastl needs a toolchain w/ C++, gcc >= 4.9
2417#
1307# BR2_PACKAGE_LIBEE is not set2418# BR2_PACKAGE_LIBEE is not set
1308# BR2_PACKAGE_LIBEV is not set2419# BR2_PACKAGE_LIBEV is not set
1309# BR2_PACKAGE_LIBEVDEV is not set2420# BR2_PACKAGE_LIBEVDEV is not set
1310# BR2_PACKAGE_LIBEVENT is not set2421# BR2_PACKAGE_LIBEVENT is not set
1311# BR2_PACKAGE_LIBFFI is not set2422# BR2_PACKAGE_LIBFFI is not set
1312# BR2_PACKAGE_LIBGLIB2 is not set2423
1313# BR2_PACKAGE_LIBICAL is not set2424#
2425# libgee needs a toolchain w/ wchar, threads
2426#
2427
2428#
2429# libglib2 needs a toolchain w/ wchar, threads
2430#
2431# BR2_PACKAGE_LIBGLOB is not set
2432
2433#
2434# libical needs a toolchain w/ C++, dynamic library, wchar
2435#
2436# BR2_PACKAGE_LIBITE is not set
13142437
1315#2438#
1316# liblinear needs a toolchain w/ C++2439# liblinear needs a toolchain w/ C++
1317#2440#
2441
2442#
2443# libloki needs a toolchain w/ C++, threads
2444#
2445# BR2_PACKAGE_LIBNPTH is not set
1318BR2_PACKAGE_LIBNSPR_ARCH_SUPPORT=y2446BR2_PACKAGE_LIBNSPR_ARCH_SUPPORT=y
1319# BR2_PACKAGE_LIBNSPR is not set2447# BR2_PACKAGE_LIBNSPR is not set
1320# BR2_PACKAGE_LIBPFM4 is not set2448# BR2_PACKAGE_LIBPFM4 is not set
13212449
1322#2450#
1323# libplist needs a toolchain w/ C++2451# libplist needs a toolchain w/ C++, threads
1324#2452#
1325# BR2_PACKAGE_LIBPTHREAD_STUBS is not set2453# BR2_PACKAGE_LIBPTHREAD_STUBS is not set
1326# BR2_PACKAGE_LIBPTHSEM is not set2454# BR2_PACKAGE_LIBPTHSEM is not set
2455# BR2_PACKAGE_LIBPWQUALITY is not set
2456BR2_PACKAGE_LIBSECCOMP_ARCH_SUPPORTS=y
1327# BR2_PACKAGE_LIBSECCOMP is not set2457# BR2_PACKAGE_LIBSECCOMP is not set
13282458
1329#2459#
1330# libsigc++ needs a toolchain w/ C++2460# libsigc++ needs a toolchain w/ C++, gcc >= 4.8
2461#
2462
2463#
2464# libspatialindex needs a toolchain w/ C++
1331#2465#
1332# BR2_PACKAGE_LIBSIGSEGV is not set
1333# BR2_PACKAGE_LIBTASN1 is not set2466# BR2_PACKAGE_LIBTASN1 is not set
2467# BR2_PACKAGE_LIBTOMMATH is not set
1334# BR2_PACKAGE_LIBTPL is not set2468# BR2_PACKAGE_LIBTPL is not set
1335# BR2_PACKAGE_LIBUBOX is not set2469# BR2_PACKAGE_LIBUBOX is not set
1336# BR2_PACKAGE_LIBUCI is not set2470# BR2_PACKAGE_LIBUCI is not set
2471BR2_PACKAGE_LIBURCU_ARCH_SUPPORTS=y
2472# BR2_PACKAGE_LIBURCU is not set
1337# BR2_PACKAGE_LIBUV is not set2473# BR2_PACKAGE_LIBUV is not set
1338# BR2_PACKAGE_LINUX_PAM is not set2474
2475#
2476# linux-pam needs a uClibc or glibc toolchain w/ wchar, locale, dynamic library
2477#
2478
2479#
2480# liquid-dsp requires a glibc or musl toolchain w/ dynamic library
2481#
2482BR2_PACKAGE_LLVM_ARCH_SUPPORTS=y
2483BR2_PACKAGE_LLVM_TARGET_ARCH="AArch64"
2484
2485#
2486# llvm needs a toolchain w/ wchar, threads, C++, gcc >= 4.8, host gcc >= 4.8, dynamic library
2487#
2488
2489#
2490# lttng-libust needs a toolchain w/ dynamic library, wchar, threads
2491#
1339# BR2_PACKAGE_MPC is not set2492# BR2_PACKAGE_MPC is not set
1340# BR2_PACKAGE_MPDECIMAL is not set2493# BR2_PACKAGE_MPDECIMAL is not set
1341# BR2_PACKAGE_MPFR is not set2494# BR2_PACKAGE_MPFR is not set
2495# BR2_PACKAGE_MPIR is not set
13422496
1343#2497#
1344# msgpack needs a toolchain w/ C++2498# msgpack needs a toolchain w/ C++
1345#2499#
1346# BR2_PACKAGE_MTDEV2TUIO is not set2500# BR2_PACKAGE_MTDEV2TUIO is not set
2501BR2_PACKAGE_OPENBLAS_DEFAULT_TARGET="ARMV8"
2502BR2_PACKAGE_OPENBLAS_ARCH_SUPPORTS=y
2503# BR2_PACKAGE_OPENBLAS is not set
1347# BR2_PACKAGE_ORC is not set2504# BR2_PACKAGE_ORC is not set
1348# BR2_PACKAGE_P11_KIT is not set2505# BR2_PACKAGE_P11_KIT is not set
13492506
1350#2507#
1351# poco needs a toolchain w/ wchar, threads, C++2508# poco needs a toolchain w/ wchar, NPTL, C++, dynamic library
2509#
2510BR2_PACKAGE_PROTOBUF_ARCH_SUPPORTS=y
2511
2512#
2513# protobuf needs a toolchain w/ C++, threads, dynamic library, host and target gcc >= 4.8
2514#
2515
2516#
2517# protobuf-c needs a toolchain w/ C++, threads, host gcc >= 4.8
1352#2518#
13532519
1354#2520#
1355# protobuf-c needs a toolchain w/ C++, threads2521# qhull needs a toolchain w/ C++, dynamic library, gcc >= 4.4
2522#
2523
2524#
2525# qlibc needs a toolchain w/ threads, wchar, dynamic library
2526#
2527
2528#
2529# riemann-c-client needs a toolchain w/ C++, threads, host gcc >= 4.8
2530#
2531
2532#
2533# shapelib needs a toolchain w/ C++, threads
2534#
2535# BR2_PACKAGE_SKALIBS is not set
2536# BR2_PACKAGE_SPHINXBASE is not set
2537# BR2_PACKAGE_TINYCBOR is not set
2538
2539#
2540# xapian needs a toolchain w/ C++
1356#2541#
1357# BR2_PACKAGE_QLIBC is not set
13582542
1359#2543#
1360# Security2544# Security
1361#2545#
1362# BR2_PACKAGE_LIBSELINUX is not set2546
1363# BR2_PACKAGE_LIBSEMANAGE is not set2547#
2548# libselinux needs a glibc toolchain w/ threads, dynamic library
2549#
2550
2551#
2552# libsemanage needs a glibc toolchain w/ threads, dynamic library
2553#
1364# BR2_PACKAGE_LIBSEPOL is not set2554# BR2_PACKAGE_LIBSEPOL is not set
2555# BR2_PACKAGE_SAFECLIB is not set
13652556
1366#2557#
1367# Text and terminal handling2558# Text and terminal handling
1368#2559#
13692560
1370#2561#
2562# augeas needs a toolchain w/ wchar
2563#
2564
2565#
1371# enchant needs a toolchain w/ C++, threads, wchar2566# enchant needs a toolchain w/ C++, threads, wchar
1372#2567#
13732568
1374#2569#
1375# icu needs a toolchain w/ C++, wchar, threads2570# fmt needs a toolchain w/ C++, wchar
2571#
2572
2573#
2574# icu needs a toolchain w/ C++, wchar, threads, gcc >= 4.8, host gcc >= 4.8
1376#2575#
1377# BR2_PACKAGE_LIBCLI is not set2576# BR2_PACKAGE_LIBCLI is not set
1378# BR2_PACKAGE_LIBEDIT is not set2577
2578#
2579# libedit needs a toolchain w/ wchar
2580#
1379# BR2_PACKAGE_LIBENCA is not set2581# BR2_PACKAGE_LIBENCA is not set
1380# BR2_PACKAGE_LIBESTR is not set2582# BR2_PACKAGE_LIBESTR is not set
1381# BR2_PACKAGE_LIBFRIBIDI is not set2583# BR2_PACKAGE_LIBFRIBIDI is not set
1382# BR2_PACKAGE_LIBUNISTRING is not set2584# BR2_PACKAGE_LIBICONV is not set
2585
2586#
2587# libunistring needs a toolchain w/ wchar
2588#
1383# BR2_PACKAGE_LINENOISE is not set2589# BR2_PACKAGE_LINENOISE is not set
1384BR2_PACKAGE_NCURSES=y2590BR2_PACKAGE_NCURSES=y
1385# BR2_PACKAGE_NCURSES_WCHAR is not set
1386# BR2_PACKAGE_NCURSES_TARGET_PANEL is not set
1387# BR2_PACKAGE_NCURSES_TARGET_FORM is not set
1388# BR2_PACKAGE_NCURSES_TARGET_MENU is not set
1389# BR2_PACKAGE_NCURSES_TARGET_PROGS is not set2591# BR2_PACKAGE_NCURSES_TARGET_PROGS is not set
1390# BR2_PACKAGE_NEWT is not set2592BR2_PACKAGE_NCURSES_ADDITIONAL_TERMINFO=""
2593
2594#
2595# newt needs a toolchain w/ wchar, dynamic library
2596#
1391# BR2_PACKAGE_PCRE is not set2597# BR2_PACKAGE_PCRE is not set
2598# BR2_PACKAGE_PCRE2 is not set
1392# BR2_PACKAGE_POPT is not set2599# BR2_PACKAGE_POPT is not set
1393# BR2_PACKAGE_READLINE is not set2600# BR2_PACKAGE_READLINE is not set
1394# BR2_PACKAGE_SLANG is not set2601# BR2_PACKAGE_SLANG is not set
@@ -1407,43 +2614,88 @@ BR2_PACKAGE_NCURSES=y
1407# BR2_PACKAGE_HEIRLOOM_MAILX is not set2614# BR2_PACKAGE_HEIRLOOM_MAILX is not set
1408# BR2_PACKAGE_LIBESMTP is not set2615# BR2_PACKAGE_LIBESMTP is not set
1409# BR2_PACKAGE_MSMTP is not set2616# BR2_PACKAGE_MSMTP is not set
1410# BR2_PACKAGE_MUTT is not set2617
2618#
2619# mutt needs a toolchain w/ wchar
2620#
14112621
1412#2622#
1413# Miscellaneous2623# Miscellaneous
1414#2624#
1415# BR2_PACKAGE_AESPIPE is not set2625# BR2_PACKAGE_AESPIPE is not set
1416# BR2_PACKAGE_BC is not set2626# BR2_PACKAGE_BC is not set
1417# BR2_PACKAGE_CLAMAV is not set2627
2628#
2629# clamav needs a toolchain w/ C++, threads, wchar
2630#
1418# BR2_PACKAGE_COLLECTD is not set2631# BR2_PACKAGE_COLLECTD is not set
2632
2633#
2634# domoticz needs lua 5.3 and a toolchain w/ C++, gcc >= 4.8, NPTL, wchar, dynamic library
2635#
1419# BR2_PACKAGE_EMPTY is not set2636# BR2_PACKAGE_EMPTY is not set
14202637
1421#2638#
1422# gnuradio needs a toolchain w/ C++, NPTL, wchar, dynamic library2639# gnuradio needs a toolchain w/ C++, NPTL, wchar, dynamic library
1423#2640#
1424# BR2_PACKAGE_GOOGLEFONTDIRECTORY is not set2641# BR2_PACKAGE_GOOGLEFONTDIRECTORY is not set
2642
2643#
2644# gqrx needs a toolchain w/ C++, threads, wchar, dynamic library
2645#
2646
2647#
2648# gqrx needs qt5
2649#
2650
2651#
2652# gsettings-desktop-schemas needs a toolchain w/ wchar, threads
2653#
1425# BR2_PACKAGE_HAVEGED is not set2654# BR2_PACKAGE_HAVEGED is not set
2655# BR2_PACKAGE_LINUX_SYSCALL_SUPPORT is not set
1426# BR2_PACKAGE_MCRYPT is not set2656# BR2_PACKAGE_MCRYPT is not set
1427# BR2_PACKAGE_MOBILE_BROADBAND_PROVIDER_INFO is not set2657# BR2_PACKAGE_MOBILE_BROADBAND_PROVIDER_INFO is not set
2658# BR2_PACKAGE_PROJ is not set
2659BR2_PACKAGE_QEMU_ARCH_SUPPORTS_TARGET=y
2660
2661#
2662# QEMU requires a toolchain with wchar, threads
2663#
14282664
1429#2665#
1430# qpdf needs a toolchain w/ C++2666# qpdf needs a toolchain w/ C++
1431#2667#
1432# BR2_PACKAGE_SHARED_MIME_INFO is not set2668
1433# BR2_PACKAGE_SNOWBALL_INIT is not set2669#
2670# shared-mime-info needs a toolchain w/ wchar, threads
2671#
2672
2673#
2674# taskd needs a toolchain w/ C++, wchar, dynamic library
2675#
2676# BR2_PACKAGE_XUTIL_UTIL_MACROS is not set
14342677
1435#2678#
1436# Networking applications2679# Networking applications
1437#2680#
1438# BR2_PACKAGE_AICCU is not set2681
1439# BR2_PACKAGE_AIRCRACK_NG is not set2682#
2683# aircrack-ng needs a toolchain w/ dynamic library, threads, C++
2684#
2685# BR2_PACKAGE_AOETOOLS is not set
1440# BR2_PACKAGE_APACHE is not set2686# BR2_PACKAGE_APACHE is not set
1441# BR2_PACKAGE_ARGUS is not set2687# BR2_PACKAGE_ARGUS is not set
2688# BR2_PACKAGE_ARP_SCAN is not set
1442# BR2_PACKAGE_ARPTABLES is not set2689# BR2_PACKAGE_ARPTABLES is not set
2690
2691#
2692# asterisk needs a glibc or uClibc toolchain w/ C++, dynamic library, threads, wchar
2693#
1443# BR2_PACKAGE_ATFTP is not set2694# BR2_PACKAGE_ATFTP is not set
1444# BR2_PACKAGE_AUTOSSH is not set2695# BR2_PACKAGE_AUTOSSH is not set
1445# BR2_PACKAGE_AVAHI is not set2696# BR2_PACKAGE_AVAHI is not set
1446# BR2_PACKAGE_AXEL is not set2697# BR2_PACKAGE_AXEL is not set
2698# BR2_PACKAGE_BABELD is not set
1447# BR2_PACKAGE_BANDWIDTHD is not set2699# BR2_PACKAGE_BANDWIDTHD is not set
1448# BR2_PACKAGE_BATCTL is not set2700# BR2_PACKAGE_BATCTL is not set
14492701
@@ -1451,22 +2703,58 @@ BR2_PACKAGE_NCURSES=y
1451# bcusdk needs a toolchain w/ C++2703# bcusdk needs a toolchain w/ C++
1452#2704#
1453# BR2_PACKAGE_BIND is not set2705# BR2_PACKAGE_BIND is not set
1454# BR2_PACKAGE_BLUEZ_UTILS is not set2706# BR2_PACKAGE_BIRD is not set
1455# BR2_PACKAGE_BLUEZ5_UTILS is not set2707
2708#
2709# bluez-utils needs a toolchain w/ wchar, threads, dynamic library
2710#
2711
2712#
2713# bluez5-utils needs a toolchain w/ wchar, threads, headers >= 3.4, dynamic library
2714#
1456# BR2_PACKAGE_BMON is not set2715# BR2_PACKAGE_BMON is not set
1457# BR2_PACKAGE_BOA is not set2716# BR2_PACKAGE_BOA is not set
2717
2718#
2719# boinc needs a toolchain w/ dynamic library, C++, threads
2720#
2721# BR2_PACKAGE_BRCM_PATCHRAM_PLUS is not set
1458# BR2_PACKAGE_BRIDGE_UTILS is not set2722# BR2_PACKAGE_BRIDGE_UTILS is not set
1459# BR2_PACKAGE_BWM_NG is not set2723# BR2_PACKAGE_BWM_NG is not set
2724# BR2_PACKAGE_C_ICAP is not set
1460# BR2_PACKAGE_CAN_UTILS is not set2725# BR2_PACKAGE_CAN_UTILS is not set
2726
2727#
2728# cannelloni needs a toolchain w/ C++, threads, dynamic library, gcc >= 4.8
2729#
1461# BR2_PACKAGE_CHRONY is not set2730# BR2_PACKAGE_CHRONY is not set
1462# BR2_PACKAGE_CIVETWEB is not set2731# BR2_PACKAGE_CIVETWEB is not set
1463# BR2_PACKAGE_CONNMAN is not set2732
2733#
2734# connman needs a glibc or uClibc toolchain w/ wchar, threads, resolver, dynamic library
2735#
2736
2737#
2738# connman-gtk needs libgtk3 and a glibc or uClibc toolchain w/ wchar, threads, resolver, dynamic library
2739#
1464# BR2_PACKAGE_CONNTRACK_TOOLS is not set2740# BR2_PACKAGE_CONNTRACK_TOOLS is not set
2741# BR2_PACKAGE_CORKSCREW is not set
1465# BR2_PACKAGE_CRDA is not set2742# BR2_PACKAGE_CRDA is not set
14662743
1467#2744#
1468# ctorrent needs a toolchain w/ C++2745# ctorrent needs a toolchain w/ C++
1469#2746#
2747
2748#
2749# cups needs a toolchain w/ C++, threads
2750#
2751
2752#
2753# cups-filters needs a toolchain w/ wchar, C++, threads and dynamic library, gcc >= 4.8
2754#
2755# BR2_PACKAGE_DANTE is not set
2756# BR2_PACKAGE_DARKHTTPD is not set
2757# BR2_PACKAGE_DEHYDRATED is not set
1470# BR2_PACKAGE_DHCPCD is not set2758# BR2_PACKAGE_DHCPCD is not set
1471# BR2_PACKAGE_DHCPDUMP is not set2759# BR2_PACKAGE_DHCPDUMP is not set
1472# BR2_PACKAGE_DNSMASQ is not set2760# BR2_PACKAGE_DNSMASQ is not set
@@ -1477,28 +2765,72 @@ BR2_PACKAGE_DROPBEAR_DISABLE_REVERSEDNS=y
1477BR2_PACKAGE_DROPBEAR_SMALL=y2765BR2_PACKAGE_DROPBEAR_SMALL=y
1478# BR2_PACKAGE_DROPBEAR_WTMP is not set2766# BR2_PACKAGE_DROPBEAR_WTMP is not set
1479# BR2_PACKAGE_DROPBEAR_LASTLOG is not set2767# BR2_PACKAGE_DROPBEAR_LASTLOG is not set
2768# BR2_PACKAGE_DROPBEAR_LEGACY_CRYPTO is not set
1480# BR2_PACKAGE_EBTABLES is not set2769# BR2_PACKAGE_EBTABLES is not set
14812770
1482#2771#
1483# ejabberd needs erlang2772# ejabberd needs erlang, toolchain w/ C++
1484#2773#
1485# BR2_PACKAGE_ETHTOOL is not set2774# BR2_PACKAGE_ETHTOOL is not set
1486# BR2_PACKAGE_FAIFA is not set2775# BR2_PACKAGE_FAIFA is not set
2776# BR2_PACKAGE_FASTD is not set
2777# BR2_PACKAGE_FCGIWRAP is not set
2778# BR2_PACKAGE_FLANNEL is not set
1487# BR2_PACKAGE_FPING is not set2779# BR2_PACKAGE_FPING is not set
1488# BR2_PACKAGE_GESFTPSERVER is not set2780
2781#
2782# freeswitch needs a toolchain w/ C++, dynamic library, threads, wchar
2783#
2784
2785#
2786# gerbera needs a toolchain w/ C++, threads, gcc >= 7
2787#
2788
2789#
2790# gesftpserver needs a toolchain w/ wchar, threads
2791#
2792# BR2_PACKAGE_GLORYTUN is not set
2793
2794#
2795# gupnp-tools needs libgtk3
2796#
14892797
1490#2798#
1491# hans needs a toolchain w/ C++2799# hans needs a toolchain w/ C++
1492#2800#
2801# BR2_PACKAGE_HAPROXY is not set
1493# BR2_PACKAGE_HIAWATHA is not set2802# BR2_PACKAGE_HIAWATHA is not set
1494# BR2_PACKAGE_HOSTAPD is not set2803# BR2_PACKAGE_HOSTAPD is not set
1495# BR2_PACKAGE_HTTPING is not set2804
2805#
2806# httping needs a toolchain w/ wchar
2807#
2808
2809#
2810# i2pd needs a toolchain w/ C++, NPTL, wchar
2811#
2812
2813#
2814# ibrdtn-tools needs a toolchain w/ C++, threads
2815#
2816
2817#
2818# ibrdtnd needs a toolchain w/ C++, threads
2819#
1496# BR2_PACKAGE_IFTOP is not set2820# BR2_PACKAGE_IFTOP is not set
2821BR2_PACKAGE_IFUPDOWN_SCRIPTS=y
2822
2823#
2824# igd2-for-linux needs a toolchain w/ threads, wchar
2825#
14972826
1498#2827#
1499# igh-ethercat needs a Linux kernel to be built2828# igh-ethercat needs a Linux kernel to be built
1500#2829#
1501# BR2_PACKAGE_IGMPPROXY is not set2830
2831#
2832# igmpproxy needs a toolchain w/ wchar
2833#
1502# BR2_PACKAGE_INADYN is not set2834# BR2_PACKAGE_INADYN is not set
1503# BR2_PACKAGE_IODINE is not set2835# BR2_PACKAGE_IODINE is not set
15042836
@@ -1512,14 +2844,27 @@ BR2_PACKAGE_DROPBEAR_SMALL=y
1512# BR2_PACKAGE_IPTABLES is not set2844# BR2_PACKAGE_IPTABLES is not set
1513# BR2_PACKAGE_IPTRAF_NG is not set2845# BR2_PACKAGE_IPTRAF_NG is not set
1514# BR2_PACKAGE_IPUTILS is not set2846# BR2_PACKAGE_IPUTILS is not set
2847
2848#
2849# irssi needs a toolchain w/ wchar, threads
2850#
1515# BR2_PACKAGE_IW is not set2851# BR2_PACKAGE_IW is not set
1516# BR2_PACKAGE_JANUS_GATEWAY is not set
15172852
1518#2853#
1519# kismet needs a toolchain w/ threads, C++2854# iwd needs a toolchain w/ dynamic library, wchar
2855#
2856
2857#
2858# janus-gateway needs a toolchain w/ dynamic library, threads, wchar
2859#
2860# BR2_PACKAGE_KEEPALIVED is not set
2861
2862#
2863# kismet needs a toolchain w/ threads, C++, dynamic library
1520#2864#
1521# BR2_PACKAGE_KNOCK is not set2865# BR2_PACKAGE_KNOCK is not set
1522# BR2_PACKAGE_LEAFNODE2 is not set2866# BR2_PACKAGE_LEAFNODE2 is not set
2867# BR2_PACKAGE_LFT is not set
15232868
1524#2869#
1525# lftp requires a toolchain w/ C++, wchar2870# lftp requires a toolchain w/ C++, wchar
@@ -1535,25 +2880,40 @@ BR2_PACKAGE_DROPBEAR_SMALL=y
1535# linphone needs a toolchain w/ threads, C++2880# linphone needs a toolchain w/ threads, C++
1536#2881#
1537# BR2_PACKAGE_LINUX_ZIGBEE is not set2882# BR2_PACKAGE_LINUX_ZIGBEE is not set
2883# BR2_PACKAGE_LINUXPTP is not set
2884# BR2_PACKAGE_LLDPD is not set
1538# BR2_PACKAGE_LRZSZ is not set2885# BR2_PACKAGE_LRZSZ is not set
2886# BR2_PACKAGE_LYNX is not set
1539# BR2_PACKAGE_MACCHANGER is not set2887# BR2_PACKAGE_MACCHANGER is not set
1540# BR2_PACKAGE_MEMCACHED is not set2888# BR2_PACKAGE_MEMCACHED is not set
1541# BR2_PACKAGE_MII_DIAG is not set2889# BR2_PACKAGE_MII_DIAG is not set
1542# BR2_PACKAGE_MINIDLNA is not set2890# BR2_PACKAGE_MINI_SNMPD is not set
2891
2892#
2893# minidlna needs a toolchain w/ dynamic library, threads, wchar
2894#
2895# BR2_PACKAGE_MINISSDPD is not set
1543# BR2_PACKAGE_MJPG_STREAMER is not set2896# BR2_PACKAGE_MJPG_STREAMER is not set
15442897
1545#2898#
1546# modemmanager needs udev /dev management and a toolchain w/ wchar, threads2899# modemmanager needs a toolchain w/ wchar, threads
1547#2900#
1548# BR2_PACKAGE_MONGOOSE is not set
15492901
1550#2902#
1551# mongrel2 needs a toolchain w/ C++, threads, wchar2903# mongrel2 needs a uClibc or glibc toolchain w/ C++, threads, dynamic library
2904#
2905# BR2_PACKAGE_MONKEY is not set
2906
2907#
2908# mosh needs a toolchain w/ C++, threads, dynamic library, wchar, host and target gcc >= 4.8
1552#2909#
1553# BR2_PACKAGE_MOSQUITTO is not set2910# BR2_PACKAGE_MOSQUITTO is not set
1554# BR2_PACKAGE_MROUTED is not set2911# BR2_PACKAGE_MROUTED is not set
1555# BR2_PACKAGE_MTR is not set2912# BR2_PACKAGE_MTR is not set
1556# BR2_PACKAGE_NBD is not set2913
2914#
2915# nbd needs a toolchain w/ wchar, threads
2916#
1557# BR2_PACKAGE_NCFTP is not set2917# BR2_PACKAGE_NCFTP is not set
1558BR2_PACKAGE_NDISC6=y2918BR2_PACKAGE_NDISC6=y
1559# BR2_PACKAGE_NDISC6_NAME2ADDR is not set2919# BR2_PACKAGE_NDISC6_NAME2ADDR is not set
@@ -1569,16 +2929,23 @@ BR2_PACKAGE_NDISC6_RDISC6=y
1569# BR2_PACKAGE_NETSTAT_NAT is not set2929# BR2_PACKAGE_NETSTAT_NAT is not set
15702930
1571#2931#
1572# NetworkManager needs udev /dev management and a (e)glibc toolchain w/ headers >= 3.72932# NetworkManager needs udev /dev management and a glibc toolchain w/ headers >= 3.2, dynamic library
1573#2933#
1574# BR2_PACKAGE_NFACCT is not set2934# BR2_PACKAGE_NFACCT is not set
1575# BR2_PACKAGE_NFTABLES is not set2935
2936#
2937# nftables needs a toolchain w/ wchar, headers >= 3.12
2938#
1576# BR2_PACKAGE_NGINX is not set2939# BR2_PACKAGE_NGINX is not set
1577# BR2_PACKAGE_NGIRCD is not set2940# BR2_PACKAGE_NGIRCD is not set
1578# BR2_PACKAGE_NGREP is not set2941# BR2_PACKAGE_NGREP is not set
15792942
1580#2943#
1581# nmap needs a toolchain w/ C++, threads2944# nload needs a toolchain w/ C++
2945#
2946
2947#
2948# nmap-nmap needs a toolchain w/ C++, threads
1582#2949#
1583# BR2_PACKAGE_NOIP is not set2950# BR2_PACKAGE_NOIP is not set
1584# BR2_PACKAGE_NTP is not set2951# BR2_PACKAGE_NTP is not set
@@ -1586,50 +2953,92 @@ BR2_PACKAGE_NDISC6_RDISC6=y
1586BR2_PACKAGE_ODHCP6C=y2953BR2_PACKAGE_ODHCP6C=y
1587# BR2_PACKAGE_ODHCPLOC is not set2954# BR2_PACKAGE_ODHCPLOC is not set
1588# BR2_PACKAGE_OLSR is not set2955# BR2_PACKAGE_OLSR is not set
2956# BR2_PACKAGE_OPEN_LLDP is not set
1589# BR2_PACKAGE_OPEN_PLC_UTILS is not set2957# BR2_PACKAGE_OPEN_PLC_UTILS is not set
1590# BR2_PACKAGE_OPENNTPD is not set2958# BR2_PACKAGE_OPENNTPD is not set
1591# BR2_PACKAGE_OPENOBEX is not set2959# BR2_PACKAGE_OPENOBEX is not set
2960# BR2_PACKAGE_OPENRESOLV is not set
1592# BR2_PACKAGE_OPENSSH is not set2961# BR2_PACKAGE_OPENSSH is not set
1593# BR2_PACKAGE_OPENSWAN is not set2962# BR2_PACKAGE_OPENSWAN is not set
1594# BR2_PACKAGE_OPENVPN is not set2963# BR2_PACKAGE_OPENVPN is not set
1595# BR2_PACKAGE_P910ND is not set2964# BR2_PACKAGE_P910ND is not set
1596# BR2_PACKAGE_PHIDGETWEBSERVICE is not set2965# BR2_PACKAGE_PHIDGETWEBSERVICE is not set
1597# BR2_PACKAGE_PORTMAP is not set2966# BR2_PACKAGE_PHYTOOL is not set
2967# BR2_PACKAGE_PIMD is not set
2968# BR2_PACKAGE_PIXIEWPS is not set
2969# BR2_PACKAGE_POUND is not set
1598# BR2_PACKAGE_PPPD is not set2970# BR2_PACKAGE_PPPD is not set
1599# BR2_PACKAGE_PPTP_LINUX is not set2971# BR2_PACKAGE_PPTP_LINUX is not set
2972# BR2_PACKAGE_PRIVOXY is not set
1600# BR2_PACKAGE_PROFTPD is not set2973# BR2_PACKAGE_PROFTPD is not set
2974
2975#
2976# prosody needs the lua interpreter, dynamic library
2977#
1601# BR2_PACKAGE_PROXYCHAINS_NG is not set2978# BR2_PACKAGE_PROXYCHAINS_NG is not set
1602# BR2_PACKAGE_PTPD is not set2979# BR2_PACKAGE_PTPD is not set
1603# BR2_PACKAGE_PTPD2 is not set2980# BR2_PACKAGE_PTPD2 is not set
1604# BR2_PACKAGE_PURE_FTPD is not set2981# BR2_PACKAGE_PURE_FTPD is not set
2982
2983#
2984# putty needs a toolchain w/ wchar
2985#
1605# BR2_PACKAGE_QUAGGA is not set2986# BR2_PACKAGE_QUAGGA is not set
2987
2988#
2989# rabbitmq-server needs erlang
2990#
1606# BR2_PACKAGE_RADVD is not set2991# BR2_PACKAGE_RADVD is not set
2992# BR2_PACKAGE_REAVER is not set
2993# BR2_PACKAGE_RP_PPPOE is not set
1607# BR2_PACKAGE_RPCBIND is not set2994# BR2_PACKAGE_RPCBIND is not set
1608# BR2_PACKAGE_RSH_REDONE is not set2995# BR2_PACKAGE_RSH_REDONE is not set
1609# BR2_PACKAGE_RSYNC is not set2996# BR2_PACKAGE_RSYNC is not set
16102997
1611#2998#
1612# rtorrent needs a toolchain w/ C++, threads, wchar2999# rtorrent needs a toolchain w/ C++, threads, wchar, gcc >= 4.9
1613#3000#
1614# BR2_PACKAGE_RTPTOOLS is not set3001# BR2_PACKAGE_RTPTOOLS is not set
1615# BR2_PACKAGE_SAMBA4 is not set3002# BR2_PACKAGE_S6_DNS is not set
3003# BR2_PACKAGE_S6_NETWORKING is not set
3004
3005#
3006# samba4 needs a uClibc or glibc toolchain w/ wchar, dynamic library, NPTL
3007#
16163008
1617#3009#
1618# sconeserver needs a toolchain w/ C++, NPTL3010# sconeserver needs a toolchain with dynamic library, C++, NPTL
1619#3011#
1620# BR2_PACKAGE_SER2NET is not set3012# BR2_PACKAGE_SER2NET is not set
1621# BR2_PACKAGE_SHAIRPORT_SYNC is not set3013# BR2_PACKAGE_SHADOWSOCKS_LIBEV is not set
3014
3015#
3016# shairport-sync needs a toolchain w/ C++, NPTL
3017#
3018# BR2_PACKAGE_SHELLINABOX is not set
1622# BR2_PACKAGE_SMCROUTE is not set3019# BR2_PACKAGE_SMCROUTE is not set
3020# BR2_PACKAGE_SNGREP is not set
3021
3022#
3023# snort needs a toolchain w/ wchar, threads, dynamic library
3024#
1623# BR2_PACKAGE_SOCAT is not set3025# BR2_PACKAGE_SOCAT is not set
1624# BR2_PACKAGE_SOCKETCAND is not set3026# BR2_PACKAGE_SOCKETCAND is not set
1625# BR2_PACKAGE_SOFTETHER is not set3027
3028#
3029# softether needs a toolchain w/ wchar, threads
3030#
1626# BR2_PACKAGE_SPAWN_FCGI is not set3031# BR2_PACKAGE_SPAWN_FCGI is not set
1627# BR2_PACKAGE_SPICE_PROTOCOL is not set3032# BR2_PACKAGE_SPICE_PROTOCOL is not set
16283033
1629#3034#
1630# squid needs a toolchain w/ C++, headers >= 3.03035# squid needs a toolchain w/ C++, gcc >= 4.8 not affected by bug 64735
1631#3036#
1632# BR2_PACKAGE_SSHPASS is not set3037# BR2_PACKAGE_SSHPASS is not set
3038
3039#
3040# sslh needs a toolchain w/ C++
3041#
1633# BR2_PACKAGE_STRONGSWAN is not set3042# BR2_PACKAGE_STRONGSWAN is not set
1634# BR2_PACKAGE_STUNNEL is not set3043# BR2_PACKAGE_STUNNEL is not set
1635# BR2_PACKAGE_TCPDUMP is not set3044# BR2_PACKAGE_TCPDUMP is not set
@@ -1638,26 +3047,44 @@ BR2_PACKAGE_ODHCP6C=y
1638# BR2_PACKAGE_THTTPD is not set3047# BR2_PACKAGE_THTTPD is not set
1639# BR2_PACKAGE_TINC is not set3048# BR2_PACKAGE_TINC is not set
1640# BR2_PACKAGE_TINYHTTPD is not set3049# BR2_PACKAGE_TINYHTTPD is not set
1641# BR2_PACKAGE_TN5250 is not set
1642# BR2_PACKAGE_TOR is not set3050# BR2_PACKAGE_TOR is not set
3051# BR2_PACKAGE_TRACEROUTE is not set
1643# BR2_PACKAGE_TRANSMISSION is not set3052# BR2_PACKAGE_TRANSMISSION is not set
3053# BR2_PACKAGE_TUNCTL is not set
1644# BR2_PACKAGE_TVHEADEND is not set3054# BR2_PACKAGE_TVHEADEND is not set
1645# BR2_PACKAGE_UDPCAST is not set3055# BR2_PACKAGE_UDPCAST is not set
3056# BR2_PACKAGE_UHTTPD is not set
3057# BR2_PACKAGE_ULOGD is not set
1646# BR2_PACKAGE_USHARE is not set3058# BR2_PACKAGE_USHARE is not set
1647# BR2_PACKAGE_USSP_PUSH is not set3059
3060#
3061# ussp-push needs a toolchain w/ wchar, threads, dynamic library
3062#
1648# BR2_PACKAGE_VDE2 is not set3063# BR2_PACKAGE_VDE2 is not set
1649# BR2_PACKAGE_VNSTAT is not set3064
1650# BR2_PACKAGE_VPNC is not set3065#
3066# vdr needs a glibc or uClibc toolchain w/ C++, dynamic library, NPTL, wchar, headers >= 3.9
3067#
3068
3069#
3070# vnstat needs a toolchain w/ wchar
3071#
3072
3073#
3074# vpnc needs a toolchain w/ wchar, dynamic library
3075#
1651# BR2_PACKAGE_VSFTPD is not set3076# BR2_PACKAGE_VSFTPD is not set
1652# BR2_PACKAGE_VTUN is not set3077# BR2_PACKAGE_VTUN is not set
3078# BR2_PACKAGE_WAVEMON is not set
3079# BR2_PACKAGE_WIREGUARD is not set
1653# BR2_PACKAGE_WIRELESS_REGDB is not set3080# BR2_PACKAGE_WIRELESS_REGDB is not set
1654# BR2_PACKAGE_WIRELESS_TOOLS is not set3081# BR2_PACKAGE_WIRELESS_TOOLS is not set
1655# BR2_PACKAGE_WIRESHARK is not set
1656# BR2_PACKAGE_WPA_SUPPLICANT is not set
16573082
1658#3083#
1659# wvdial needs a toolchain w/ C++, dynamic library3084# wireshark needs a toolchain w/ wchar, threads
1660#3085#
3086# BR2_PACKAGE_WPA_SUPPLICANT is not set
3087# BR2_PACKAGE_WPAN_TOOLS is not set
1661# BR2_PACKAGE_XINETD is not set3088# BR2_PACKAGE_XINETD is not set
1662# BR2_PACKAGE_XL2TP is not set3089# BR2_PACKAGE_XL2TP is not set
16633090
@@ -1666,18 +3093,98 @@ BR2_PACKAGE_ODHCP6C=y
1666#3093#
16673094
1668#3095#
1669# znc needs a toolchain w/ C++3096# znc needs a toolchain w/ C++, dynamic library, gcc >= 4.8, threads
1670#3097#
16713098
1672#3099#
1673# Package managers3100# Package managers
1674#3101#
1675# BR2_PACKAGE_IPKG is not set3102
1676# BR2_PACKAGE_OPKG is not set3103#
3104# -------------------------------------------------------
3105#
3106
3107#
3108# Please note:
3109#
3110
3111#
3112# - Buildroot does *not* generate binary packages,
3113#
3114
3115#
3116# - Buildroot does *not* install any package database.
3117#
3118
3119#
3120# *
3121#
3122
3123#
3124# It is up to you to provide those by yourself if you
3125#
3126
3127#
3128# want to use any of those package managers.
3129#
3130
3131#
3132# *
3133#
3134
3135#
3136# See the manual:
3137#
3138
3139#
3140# http://buildroot.org/manual.html#faq-no-binary-packages
3141#
3142
3143#
3144# -------------------------------------------------------
3145#
3146
3147#
3148# opkg needs a toolchain w/ wchar
3149#
16773150
1678#3151#
1679# Real-Time3152# Real-Time
1680#3153#
3154# BR2_PACKAGE_XENOMAI is not set
3155
3156#
3157# Security
3158#
3159
3160#
3161# checkpolicy needs a glibc toolchain w/ threads, dynamic library
3162#
3163
3164#
3165# paxtest needs a glibc toolchain
3166#
3167
3168#
3169# policycoreutils needs a glibc toolchain w/ threads, dynamic library
3170#
3171
3172#
3173# refpolicy needs a glibc toolchain w/ threads, dynamic library
3174#
3175
3176#
3177# restorecond needs a toolchain w/ wchar, threads, dynamic library
3178#
3179
3180#
3181# selinux-python packages needs a toolchain w/ wchar, threads, dynamic library
3182#
3183# BR2_PACKAGE_SEMODULE_UTILS is not set
3184
3185#
3186# setools needs a glibc toolchain w/ threads, C++, wchar, dynamic library
3187#
16813188
1682#3189#
1683# Shell and utilities3190# Shell and utilities
@@ -1686,6 +3193,8 @@ BR2_PACKAGE_ODHCP6C=y
1686#3193#
1687# Shells3194# Shells
1688#3195#
3196# BR2_PACKAGE_MKSH is not set
3197# BR2_PACKAGE_ZSH is not set
16893198
1690#3199#
1691# Utilities3200# Utilities
@@ -1694,90 +3203,215 @@ BR2_PACKAGE_ODHCP6C=y
1694# BR2_PACKAGE_CCRYPT is not set3203# BR2_PACKAGE_CCRYPT is not set
1695# BR2_PACKAGE_DIALOG is not set3204# BR2_PACKAGE_DIALOG is not set
1696# BR2_PACKAGE_DTACH is not set3205# BR2_PACKAGE_DTACH is not set
3206# BR2_PACKAGE_EASY_RSA is not set
1697# BR2_PACKAGE_FILE is not set3207# BR2_PACKAGE_FILE is not set
1698# BR2_PACKAGE_GNUPG is not set3208# BR2_PACKAGE_GNUPG is not set
1699# BR2_PACKAGE_GNUPG2 is not set3209# BR2_PACKAGE_GNUPG2 is not set
1700# BR2_PACKAGE_INOTIFY_TOOLS is not set3210# BR2_PACKAGE_INOTIFY_TOOLS is not set
1701# BR2_PACKAGE_LOCKFILE_PROGS is not set3211# BR2_PACKAGE_LOCKFILE_PROGS is not set
1702# BR2_PACKAGE_LOGROTATE is not set3212
3213#
3214# logrotate needs a toolchain w/ wchar
3215#
1703# BR2_PACKAGE_LOGSURFER is not set3216# BR2_PACKAGE_LOGSURFER is not set
3217# BR2_PACKAGE_PDMENU is not set
1704# BR2_PACKAGE_PINENTRY is not set3218# BR2_PACKAGE_PINENTRY is not set
3219
3220#
3221# ranger needs a toolchain w/ wchar, threads, dynamic library
3222#
1705BR2_PACKAGE_SCREEN=y3223BR2_PACKAGE_SCREEN=y
1706BR2_PACKAGE_SUDO=y3224BR2_PACKAGE_SUDO=y
1707# BR2_PACKAGE_TMUX is not set3225# BR2_PACKAGE_TINI is not set
3226
3227#
3228# tmux needs a toolchain w/ wchar, locale
3229#
1708# BR2_PACKAGE_XMLSTARLET is not set3230# BR2_PACKAGE_XMLSTARLET is not set
3231# BR2_PACKAGE_XXHASH is not set
17093232
1710#3233#
1711# System tools3234# System tools
1712#3235#
1713# BR2_PACKAGE_ACL is not set3236# BR2_PACKAGE_ACL is not set
3237# BR2_PACKAGE_ANDROID_TOOLS is not set
3238# BR2_PACKAGE_ATOP is not set
1714# BR2_PACKAGE_ATTR is not set3239# BR2_PACKAGE_ATTR is not set
3240BR2_PACKAGE_AUDIT_ARCH_SUPPORTS=y
3241# BR2_PACKAGE_AUDIT is not set
3242# BR2_PACKAGE_CGROUPFS_MOUNT is not set
3243
3244#
3245# circus needs Python and a toolchain w/ C++, threads
3246#
1715# BR2_PACKAGE_CPULOAD is not set3247# BR2_PACKAGE_CPULOAD is not set
3248# BR2_PACKAGE_DAEMON is not set
3249# BR2_PACKAGE_DC3DD is not set
3250
3251#
3252# ddrescue needs a toolchain w/ C++
3253#
3254# BR2_PACKAGE_DOCKER_CLI is not set
3255
3256#
3257# docker-compose needs a toolchain w/ wchar, threads, dynamic library
3258#
3259
3260#
3261# docker-containerd needs a glibc or musl toolchain w/ threads
3262#
3263
3264#
3265# docker-engine needs a glibc or musl toolchain w/ threads, headers >= 3.11
3266#
3267# BR2_PACKAGE_DOCKER_PROXY is not set
3268# BR2_PACKAGE_EFIBOOTMGR is not set
3269BR2_PACKAGE_EFIVAR_ARCH_SUPPORTS=y
3270# BR2_PACKAGE_EFIVAR is not set
3271
3272#
3273# emlog needs a Linux kernel to be built
3274#
1716# BR2_PACKAGE_FTOP is not set3275# BR2_PACKAGE_FTOP is not set
1717# BR2_PACKAGE_GETENT is not set3276# BR2_PACKAGE_GETENT is not set
1718# BR2_PACKAGE_HTOP is not set3277# BR2_PACKAGE_HTOP is not set
3278BR2_PACKAGE_INITSCRIPTS=y
17193279
1720#3280#
1721# iotop depends on python or python33281# iotop depends on python or python3
1722#3282#
1723# BR2_PACKAGE_IPRUTILS is not set3283# BR2_PACKAGE_IPRUTILS is not set
1724# BR2_PACKAGE_IRQBALANCE is not set3284
3285#
3286# irqbalance needs a toolchain w/ wchar, threads
3287#
1725# BR2_PACKAGE_KEYUTILS is not set3288# BR2_PACKAGE_KEYUTILS is not set
1726# BR2_PACKAGE_KMOD is not set3289# BR2_PACKAGE_KMOD is not set
3290
3291#
3292# kvmtool needs a glibc or musl toolchain w/ dynamic library
3293#
3294
3295#
3296# libostree needs a uClibc or glibc toolchain w/ threads, dynamic library, wchar
3297#
1727# BR2_PACKAGE_LXC is not set3298# BR2_PACKAGE_LXC is not set
3299# BR2_PACKAGE_MENDER is not set
1728# BR2_PACKAGE_MONIT is not set3300# BR2_PACKAGE_MONIT is not set
1729# BR2_PACKAGE_NCDU is not set3301# BR2_PACKAGE_NCDU is not set
3302# BR2_PACKAGE_NUMACTL is not set
17303303
1731#3304#
1732# nut needs a toolchain w/ C++3305# nut needs a toolchain w/ C++
1733#3306#
1734# BR2_PACKAGE_POLKIT is not set3307
3308#
3309# pamtester depends on linux-pam
3310#
3311
3312#
3313# polkit needs a toolchain w/ wchar, threads
3314#
3315# BR2_PACKAGE_PROCRANK_LINUX is not set
1735# BR2_PACKAGE_PWGEN is not set3316# BR2_PACKAGE_PWGEN is not set
1736# BR2_PACKAGE_QUOTA is not set3317
3318#
3319# quota needs a toolchain w/ wchar, threads
3320#
3321# BR2_PACKAGE_QUOTATOOL is not set
3322
3323#
3324# rauc needs a toolchain w/ wchar, threads
3325#
3326# BR2_PACKAGE_S6 is not set
3327# BR2_PACKAGE_S6_LINUX_INIT is not set
3328# BR2_PACKAGE_S6_LINUX_UTILS is not set
3329# BR2_PACKAGE_S6_PORTABLE_UTILS is not set
3330# BR2_PACKAGE_S6_RC is not set
3331# BR2_PACKAGE_SCRUB is not set
3332# BR2_PACKAGE_SCRYPT is not set
1737# BR2_PACKAGE_SMACK is not set3333# BR2_PACKAGE_SMACK is not set
17383334
1739#3335#
1740# supervisor needs the python interpreter3336# supervisor needs the python interpreter
1741#3337#
3338# BR2_PACKAGE_SWUPDATE is not set
1742BR2_PACKAGE_SYSTEMD_ARCH_SUPPORTS=y3339BR2_PACKAGE_SYSTEMD_ARCH_SUPPORTS=y
3340# BR2_PACKAGE_TPM_TOOLS is not set
3341
3342#
3343# tpm2-abrmd needs a toolchain w/ dynamic library, wchar, threads
3344#
3345
3346#
3347# tpm2-tools needs a toolchain w/ dynamic library, wchar, threads
3348#
3349
3350#
3351# unscd needs a glibc toolchain
3352#
1743BR2_PACKAGE_UTIL_LINUX=y3353BR2_PACKAGE_UTIL_LINUX=y
1744BR2_PACKAGE_UTIL_LINUX_LIBBLKID=y3354BR2_PACKAGE_UTIL_LINUX_LIBBLKID=y
3355BR2_PACKAGE_UTIL_LINUX_LIBFDISK=y
1745BR2_PACKAGE_UTIL_LINUX_LIBMOUNT=y3356BR2_PACKAGE_UTIL_LINUX_LIBMOUNT=y
1746BR2_PACKAGE_UTIL_LINUX_LIBSMARTCOLS=y3357BR2_PACKAGE_UTIL_LINUX_LIBSMARTCOLS=y
1747BR2_PACKAGE_UTIL_LINUX_LIBUUID=y3358BR2_PACKAGE_UTIL_LINUX_LIBUUID=y
1748BR2_PACKAGE_UTIL_LINUX_BINARIES=y3359BR2_PACKAGE_UTIL_LINUX_BINARIES=y
1749# BR2_PACKAGE_UTIL_LINUX_AGETTY is not set3360# BR2_PACKAGE_UTIL_LINUX_AGETTY is not set
1750# BR2_PACKAGE_UTIL_LINUX_ARCH is not set
1751# BR2_PACKAGE_UTIL_LINUX_BFS is not set3361# BR2_PACKAGE_UTIL_LINUX_BFS is not set
1752# BR2_PACKAGE_UTIL_LINUX_CHFN_CHSH is not set3362# BR2_PACKAGE_UTIL_LINUX_CAL is not set
3363
3364#
3365# chfn/chsh needs a uClibc or glibc toolchain w/ wchar, locale, dynamic library
3366#
3367# BR2_PACKAGE_UTIL_LINUX_CHMEM is not set
1753# BR2_PACKAGE_UTIL_LINUX_CRAMFS is not set3368# BR2_PACKAGE_UTIL_LINUX_CRAMFS is not set
1754# BR2_PACKAGE_UTIL_LINUX_DDATE is not set
1755# BR2_PACKAGE_UTIL_LINUX_EJECT is not set3369# BR2_PACKAGE_UTIL_LINUX_EJECT is not set
1756# BR2_PACKAGE_UTIL_LINUX_FALLOCATE is not set3370# BR2_PACKAGE_UTIL_LINUX_FALLOCATE is not set
1757# BR2_PACKAGE_UTIL_LINUX_FDFORMAT is not set3371# BR2_PACKAGE_UTIL_LINUX_FDFORMAT is not set
1758# BR2_PACKAGE_UTIL_LINUX_FSCK is not set3372# BR2_PACKAGE_UTIL_LINUX_FSCK is not set
1759BR2_PACKAGE_UTIL_LINUX_HWCLOCK=y3373BR2_PACKAGE_UTIL_LINUX_HWCLOCK=y
3374# BR2_PACKAGE_UTIL_LINUX_IPCRM is not set
3375# BR2_PACKAGE_UTIL_LINUX_IPCS is not set
1760# BR2_PACKAGE_UTIL_LINUX_KILL is not set3376# BR2_PACKAGE_UTIL_LINUX_KILL is not set
1761# BR2_PACKAGE_UTIL_LINUX_LAST is not set3377# BR2_PACKAGE_UTIL_LINUX_LAST is not set
1762# BR2_PACKAGE_UTIL_LINUX_LOGIN_UTILS is not set3378# BR2_PACKAGE_UTIL_LINUX_LINE is not set
3379# BR2_PACKAGE_UTIL_LINUX_LOGGER is not set
3380
3381#
3382# login needs a uClibc or glibc toolchain w/ wchar, locale, dynamic library
3383#
1763# BR2_PACKAGE_UTIL_LINUX_LOSETUP is not set3384# BR2_PACKAGE_UTIL_LINUX_LOSETUP is not set
3385# BR2_PACKAGE_UTIL_LINUX_LSLOGINS is not set
3386# BR2_PACKAGE_UTIL_LINUX_LSMEM is not set
1764# BR2_PACKAGE_UTIL_LINUX_MESG is not set3387# BR2_PACKAGE_UTIL_LINUX_MESG is not set
1765# BR2_PACKAGE_UTIL_LINUX_MINIX is not set3388# BR2_PACKAGE_UTIL_LINUX_MINIX is not set
1766# BR2_PACKAGE_UTIL_LINUX_NSENTER is not set
1767# BR2_PACKAGE_UTIL_LINUX_MORE is not set3389# BR2_PACKAGE_UTIL_LINUX_MORE is not set
1768# BR2_PACKAGE_UTIL_LINUX_MOUNT is not set3390# BR2_PACKAGE_UTIL_LINUX_MOUNT is not set
1769# BR2_PACKAGE_UTIL_LINUX_MOUNTPOINT is not set3391# BR2_PACKAGE_UTIL_LINUX_MOUNTPOINT is not set
1770# BR2_PACKAGE_UTIL_LINUX_NEWGRP is not set3392# BR2_PACKAGE_UTIL_LINUX_NEWGRP is not set
1771# BR2_PACKAGE_UTIL_LINUX_NOLOGIN is not set3393# BR2_PACKAGE_UTIL_LINUX_NOLOGIN is not set
1772# BR2_PACKAGE_UTIL_LINUX_PIVOT_ROOT is not set3394# BR2_PACKAGE_UTIL_LINUX_NSENTER is not set
3395# BR2_PACKAGE_UTIL_LINUX_PG is not set
1773BR2_PACKAGE_UTIL_LINUX_PARTX=y3396BR2_PACKAGE_UTIL_LINUX_PARTX=y
3397# BR2_PACKAGE_UTIL_LINUX_PIVOT_ROOT is not set
1774# BR2_PACKAGE_UTIL_LINUX_RAW is not set3398# BR2_PACKAGE_UTIL_LINUX_RAW is not set
1775# BR2_PACKAGE_UTIL_LINUX_RENAME is not set3399# BR2_PACKAGE_UTIL_LINUX_RENAME is not set
1776# BR2_PACKAGE_UTIL_LINUX_RESET is not set3400# BR2_PACKAGE_UTIL_LINUX_RFKILL is not set
3401
3402#
3403# runuser needs a uClibc or glibc toolchain w/ wchar, locale, dynamic library
3404#
1777# BR2_PACKAGE_UTIL_LINUX_SCHEDUTILS is not set3405# BR2_PACKAGE_UTIL_LINUX_SCHEDUTILS is not set
1778# BR2_PACKAGE_UTIL_LINUX_SETPRIV is not set3406# BR2_PACKAGE_UTIL_LINUX_SETPRIV is not set
1779# BR2_PACKAGE_UTIL_LINUX_SETTERM is not set3407# BR2_PACKAGE_UTIL_LINUX_SETTERM is not set
3408
3409#
3410# su needs a uClibc or glibc toolchain w/ wchar, locale, dynamic library
3411#
3412# BR2_PACKAGE_UTIL_LINUX_SULOGIN is not set
1780# BR2_PACKAGE_UTIL_LINUX_SWITCH_ROOT is not set3413# BR2_PACKAGE_UTIL_LINUX_SWITCH_ROOT is not set
3414# BR2_PACKAGE_UTIL_LINUX_TUNELP is not set
1781# BR2_PACKAGE_UTIL_LINUX_UL is not set3415# BR2_PACKAGE_UTIL_LINUX_UL is not set
1782# BR2_PACKAGE_UTIL_LINUX_UNSHARE is not set3416# BR2_PACKAGE_UTIL_LINUX_UNSHARE is not set
1783# BR2_PACKAGE_UTIL_LINUX_UTMPDUMP is not set3417# BR2_PACKAGE_UTIL_LINUX_UTMPDUMP is not set
@@ -1787,23 +3421,35 @@ BR2_PACKAGE_UTIL_LINUX_PARTX=y
1787# BR2_PACKAGE_UTIL_LINUX_WDCTL is not set3421# BR2_PACKAGE_UTIL_LINUX_WDCTL is not set
1788# BR2_PACKAGE_UTIL_LINUX_WRITE is not set3422# BR2_PACKAGE_UTIL_LINUX_WRITE is not set
1789# BR2_PACKAGE_UTIL_LINUX_ZRAMCTL is not set3423# BR2_PACKAGE_UTIL_LINUX_ZRAMCTL is not set
3424# BR2_PACKAGE_XEN is not set
3425BR2_PACKAGE_XVISOR_ARCH_SUPPORTS=y
3426# BR2_PACKAGE_XVISOR is not set
17903427
1791#3428#
1792# Text editors and viewers3429# Text editors and viewers
1793#3430#
1794# BR2_PACKAGE_ED is not set3431# BR2_PACKAGE_ED is not set
1795# BR2_PACKAGE_JOE is not set3432# BR2_PACKAGE_JOE is not set
1796# BR2_PACKAGE_MC is not set3433
1797# BR2_PACKAGE_NANO is not set3434#
3435# mc needs a toolchain w/ threads, wchar
3436#
3437
3438#
3439# nano needs a toolchain w/ wchar
3440#
1798# BR2_PACKAGE_UEMACS is not set3441# BR2_PACKAGE_UEMACS is not set
17993442
1800#3443#
1801# Filesystem images3444# Filesystem images
1802#3445#
3446# BR2_TARGET_ROOTFS_AXFS is not set
3447# BR2_TARGET_ROOTFS_BTRFS is not set
1803# BR2_TARGET_ROOTFS_CLOOP is not set3448# BR2_TARGET_ROOTFS_CLOOP is not set
1804# BR2_TARGET_ROOTFS_CPIO is not set3449# BR2_TARGET_ROOTFS_CPIO is not set
1805# BR2_TARGET_ROOTFS_CRAMFS is not set3450# BR2_TARGET_ROOTFS_CRAMFS is not set
1806# BR2_TARGET_ROOTFS_EXT2 is not set3451# BR2_TARGET_ROOTFS_EXT2 is not set
3452# BR2_TARGET_ROOTFS_F2FS is not set
18073453
1808#3454#
1809# initramfs needs a Linux kernel to be built3455# initramfs needs a Linux kernel to be built
@@ -1815,10 +3461,12 @@ BR2_TARGET_ROOTFS_TAR=y
1815BR2_TARGET_ROOTFS_TAR_NONE=y3461BR2_TARGET_ROOTFS_TAR_NONE=y
1816# BR2_TARGET_ROOTFS_TAR_GZIP is not set3462# BR2_TARGET_ROOTFS_TAR_GZIP is not set
1817# BR2_TARGET_ROOTFS_TAR_BZIP2 is not set3463# BR2_TARGET_ROOTFS_TAR_BZIP2 is not set
3464# BR2_TARGET_ROOTFS_TAR_LZ4 is not set
1818# BR2_TARGET_ROOTFS_TAR_LZMA is not set3465# BR2_TARGET_ROOTFS_TAR_LZMA is not set
1819# BR2_TARGET_ROOTFS_TAR_LZO is not set3466# BR2_TARGET_ROOTFS_TAR_LZO is not set
1820# BR2_TARGET_ROOTFS_TAR_XZ is not set3467# BR2_TARGET_ROOTFS_TAR_XZ is not set
1821BR2_TARGET_ROOTFS_TAR_OPTIONS=""3468BR2_TARGET_ROOTFS_TAR_OPTIONS=""
3469# BR2_TARGET_ROOTFS_UBI is not set
1822# BR2_TARGET_ROOTFS_UBIFS is not set3470# BR2_TARGET_ROOTFS_UBIFS is not set
1823# BR2_TARGET_ROOTFS_YAFFS2 is not set3471# BR2_TARGET_ROOTFS_YAFFS2 is not set
18243472
@@ -1826,44 +3474,512 @@ BR2_TARGET_ROOTFS_TAR_OPTIONS=""
1826# Bootloaders3474# Bootloaders
1827#3475#
1828# BR2_TARGET_BAREBOX is not set3476# BR2_TARGET_BAREBOX is not set
3477# BR2_TARGET_BINARIES_MARVELL is not set
18293478
1830#3479#
1831# boot-wrapper-aarch64 needs a Linux kernel to be built3480# boot-wrapper-aarch64 needs a Linux kernel to be built
1832#3481#
3482BR2_TARGET_GRUB2_ARCH_SUPPORTS=y
3483
3484#
3485# grub2 needs a toolchain w/ wchar
3486#
3487# BR2_TARGET_MV_DDR_MARVELL is not set
3488# BR2_TARGET_SHIM is not set
1833# BR2_TARGET_UBOOT is not set3489# BR2_TARGET_UBOOT is not set
3490# BR2_TARGET_VEXPRESS_FIRMWARE is not set
18343491
1835#3492#
1836# Host utilities3493# Host utilities
1837#3494#
3495# BR2_PACKAGE_HOST_AESPIPE is not set
3496# BR2_PACKAGE_HOST_ANDROID_TOOLS is not set
3497# BR2_PACKAGE_HOST_BTRFS_PROGS is not set
3498# BR2_PACKAGE_HOST_CARGO is not set
1838# BR2_PACKAGE_HOST_CHECKPOLICY is not set3499# BR2_PACKAGE_HOST_CHECKPOLICY is not set
3500# BR2_PACKAGE_HOST_CHECKSEC is not set
3501# BR2_PACKAGE_HOST_CMAKE is not set
1839# BR2_PACKAGE_HOST_CRAMFS is not set3502# BR2_PACKAGE_HOST_CRAMFS is not set
3503# BR2_PACKAGE_HOST_CRYPTSETUP is not set
1840# BR2_PACKAGE_HOST_DFU_UTIL is not set3504# BR2_PACKAGE_HOST_DFU_UTIL is not set
1841# BR2_PACKAGE_HOST_DOS2UNIX is not set3505# BR2_PACKAGE_HOST_DOS2UNIX is not set
1842# BR2_PACKAGE_HOST_DOSFSTOOLS is not set3506# BR2_PACKAGE_HOST_DOSFSTOOLS is not set
3507# BR2_PACKAGE_HOST_DTC is not set
1843# BR2_PACKAGE_HOST_E2FSPROGS is not set3508# BR2_PACKAGE_HOST_E2FSPROGS is not set
1844# BR2_PACKAGE_HOST_E2TOOLS is not set3509# BR2_PACKAGE_HOST_E2TOOLS is not set
3510# BR2_PACKAGE_HOST_F2FS_TOOLS is not set
3511# BR2_PACKAGE_HOST_FAKETIME is not set
3512# BR2_PACKAGE_HOST_FWUP is not set
1845# BR2_PACKAGE_HOST_GENEXT2FS is not set3513# BR2_PACKAGE_HOST_GENEXT2FS is not set
1846# BR2_PACKAGE_HOST_GENIMAGE is not set3514# BR2_PACKAGE_HOST_GENIMAGE is not set
1847# BR2_PACKAGE_HOST_GENPART is not set3515# BR2_PACKAGE_HOST_GENPART is not set
3516# BR2_PACKAGE_HOST_GNUPG is not set
3517BR2_PACKAGE_HOST_GO_ARCH_SUPPORTS=y
3518BR2_PACKAGE_HOST_GO_CGO_LINKING_SUPPORTS=y
3519BR2_PACKAGE_HOST_GO_BOOTSTRAP_ARCH_SUPPORTS=y
3520BR2_PACKAGE_HOST_GOOGLE_BREAKPAD_ARCH_SUPPORTS=y
3521# BR2_PACKAGE_HOST_GPTFDISK is not set
3522# BR2_PACKAGE_HOST_IMX_MKIMAGE is not set
3523# BR2_PACKAGE_HOST_IMX_USB_LOADER is not set
3524# BR2_PACKAGE_HOST_JQ is not set
3525# BR2_PACKAGE_HOST_JSMIN is not set
1848# BR2_PACKAGE_HOST_LPC3250LOADER is not set3526# BR2_PACKAGE_HOST_LPC3250LOADER is not set
1849# BR2_PACKAGE_HOST_MKE2IMG is not set3527# BR2_PACKAGE_HOST_LTTNG_BABELTRACE is not set
3528# BR2_PACKAGE_HOST_MKPASSWD is not set
1850# BR2_PACKAGE_HOST_MTD is not set3529# BR2_PACKAGE_HOST_MTD is not set
1851# BR2_PACKAGE_HOST_MTOOLS is not set3530# BR2_PACKAGE_HOST_MTOOLS is not set
1852# BR2_PACKAGE_HOST_OPENOCD is not set3531# BR2_PACKAGE_HOST_OPENOCD is not set
3532# BR2_PACKAGE_HOST_OPKG_UTILS is not set
1853# BR2_PACKAGE_HOST_PARTED is not set3533# BR2_PACKAGE_HOST_PARTED is not set
1854# BR2_PACKAGE_HOST_PATCHELF is not set3534BR2_PACKAGE_HOST_PATCHELF=y
3535# BR2_PACKAGE_HOST_PKGCONF is not set
1855# BR2_PACKAGE_HOST_PWGEN is not set3536# BR2_PACKAGE_HOST_PWGEN is not set
3537# BR2_PACKAGE_HOST_PYTHON_CYTHON is not set
3538# BR2_PACKAGE_HOST_PYTHON_LXML is not set
3539# BR2_PACKAGE_HOST_PYTHON_SIX is not set
3540# BR2_PACKAGE_HOST_PYTHON_XLRD is not set
3541BR2_PACKAGE_HOST_QEMU_ARCH_SUPPORTS=y
3542BR2_PACKAGE_HOST_QEMU_SYSTEM_ARCH_SUPPORTS=y
3543BR2_PACKAGE_HOST_QEMU_USER_ARCH_SUPPORTS=y
1856# BR2_PACKAGE_HOST_QEMU is not set3544# BR2_PACKAGE_HOST_QEMU is not set
3545# BR2_PACKAGE_HOST_RAUC is not set
3546# BR2_PACKAGE_HOST_RCW is not set
3547BR2_PACKAGE_HOST_RUSTC_ARCH_SUPPORTS=y
3548BR2_PACKAGE_HOST_RUSTC_ARCH="aarch64"
3549# BR2_PACKAGE_HOST_RUSTC is not set
3550BR2_PACKAGE_PROVIDES_HOST_RUSTC="host-rust-bin"
1857# BR2_PACKAGE_HOST_SAM_BA is not set3551# BR2_PACKAGE_HOST_SAM_BA is not set
1858# BR2_PACKAGE_HOST_SQUASHFS is not set3552# BR2_PACKAGE_HOST_SQUASHFS is not set
3553# BR2_PACKAGE_HOST_SWIG is not set
1859# BR2_PACKAGE_HOST_UBOOT_TOOLS is not set3554# BR2_PACKAGE_HOST_UBOOT_TOOLS is not set
1860# BR2_PACKAGE_HOST_UTIL_LINUX is not set3555# BR2_PACKAGE_HOST_UTIL_LINUX is not set
3556# BR2_PACKAGE_HOST_UTP_COM is not set
3557# BR2_PACKAGE_HOST_VBOOT_UTILS is not set
3558# BR2_PACKAGE_HOST_XORRISO is not set
3559# BR2_PACKAGE_HOST_ZIP is not set
3560# BR2_PACKAGE_HOST_ZSTD is not set
18613561
1862#3562#
1863# Legacy config options3563# Legacy config options
1864#3564#
18653565
1866#3566#
3567# Legacy options removed in 2019.02
3568#
3569# BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_APEXSINK is not set
3570# BR2_PACKAGE_QT is not set
3571# BR2_PACKAGE_QTUIO is not set
3572# BR2_PACKAGE_PINENTRY_QT4 is not set
3573# BR2_PACKAGE_POPPLER_QT is not set
3574# BR2_PACKAGE_OPENCV3_WITH_QT is not set
3575# BR2_PACKAGE_OPENCV_WITH_QT is not set
3576# BR2_PACKAGE_AMD_CATALYST_CCCLE is not set
3577# BR2_PACKAGE_SDL_QTOPIA is not set
3578# BR2_PACKAGE_PYTHON_PYQT is not set
3579# BR2_PACKAGE_GNURADIO_QTGUI is not set
3580# BR2_PACKAGE_LUACRYPTO is not set
3581# BR2_PACKAGE_TN5250 is not set
3582# BR2_PACKAGE_BOOST_SIGNALS is not set
3583# BR2_PACKAGE_FFTW_PRECISION_SINGLE is not set
3584# BR2_PACKAGE_FFTW_PRECISION_DOUBLE is not set
3585# BR2_PACKAGE_FFTW_PRECISION_LONG_DOUBLE is not set
3586# BR2_PACKAGE_LUA_5_2 is not set
3587# BR2_TARGET_GENERIC_PASSWD_MD5 is not set
3588
3589#
3590# Legacy options removed in 2018.11
3591#
3592# BR2_TARGET_XLOADER is not set
3593# BR2_PACKAGE_TIDSP_BINARIES is not set
3594# BR2_PACKAGE_DSP_TOOLS is not set
3595# BR2_PACKAGE_GST_DSP is not set
3596# BR2_PACKAGE_BOOTUTILS is not set
3597# BR2_PACKAGE_EXPEDITE is not set
3598# BR2_PACKAGE_MESA3D_OPENGL_TEXTURE_FLOAT is not set
3599# BR2_KERNEL_HEADERS_4_10 is not set
3600# BR2_KERNEL_HEADERS_4_11 is not set
3601# BR2_KERNEL_HEADERS_4_12 is not set
3602# BR2_KERNEL_HEADERS_4_13 is not set
3603# BR2_KERNEL_HEADERS_4_15 is not set
3604# BR2_KERNEL_HEADERS_4_17 is not set
3605# BR2_PACKAGE_LIBNFTNL_XML is not set
3606# BR2_KERNEL_HEADERS_3_2 is not set
3607# BR2_KERNEL_HEADERS_4_1 is not set
3608# BR2_KERNEL_HEADERS_4_16 is not set
3609# BR2_KERNEL_HEADERS_4_18 is not set
3610
3611#
3612# Legacy options removed in 2018.08
3613#
3614# BR2_PACKAGE_DOCKER_ENGINE_STATIC_CLIENT is not set
3615# BR2_PACKAGE_XSERVER_XORG_SERVER_V_1_19 is not set
3616# BR2_PACKAGE_XPROTO_APPLEWMPROTO is not set
3617# BR2_PACKAGE_XPROTO_BIGREQSPROTO is not set
3618# BR2_PACKAGE_XPROTO_COMPOSITEPROTO is not set
3619# BR2_PACKAGE_XPROTO_DAMAGEPROTO is not set
3620# BR2_PACKAGE_XPROTO_DMXPROTO is not set
3621# BR2_PACKAGE_XPROTO_DRI2PROTO is not set
3622# BR2_PACKAGE_XPROTO_DRI3PROTO is not set
3623# BR2_PACKAGE_XPROTO_FIXESPROTO is not set
3624# BR2_PACKAGE_XPROTO_FONTCACHEPROTO is not set
3625# BR2_PACKAGE_XPROTO_FONTSPROTO is not set
3626# BR2_PACKAGE_XPROTO_GLPROTO is not set
3627# BR2_PACKAGE_XPROTO_INPUTPROTO is not set
3628# BR2_PACKAGE_XPROTO_KBPROTO is not set
3629# BR2_PACKAGE_XPROTO_PRESENTPROTO is not set
3630# BR2_PACKAGE_XPROTO_RANDRPROTO is not set
3631# BR2_PACKAGE_XPROTO_RECORDPROTO is not set
3632# BR2_PACKAGE_XPROTO_RENDERPROTO is not set
3633# BR2_PACKAGE_XPROTO_RESOURCEPROTO is not set
3634# BR2_PACKAGE_XPROTO_SCRNSAVERPROTO is not set
3635# BR2_PACKAGE_XPROTO_VIDEOPROTO is not set
3636# BR2_PACKAGE_XPROTO_WINDOWSWMPROTO is not set
3637# BR2_PACKAGE_XPROTO_XCMISCPROTO is not set
3638# BR2_PACKAGE_XPROTO_XEXTPROTO is not set
3639# BR2_PACKAGE_XPROTO_XF86BIGFONTPROTO is not set
3640# BR2_PACKAGE_XPROTO_XF86DGAPROTO is not set
3641# BR2_PACKAGE_XPROTO_XF86DRIPROTO is not set
3642# BR2_PACKAGE_XPROTO_XF86VIDMODEPROTO is not set
3643# BR2_PACKAGE_XPROTO_XINERAMAPROTO is not set
3644# BR2_PACKAGE_XPROTO_XPROTO is not set
3645# BR2_PACKAGE_XPROTO_XPROXYMANAGEMENTPROTOCOL is not set
3646# BR2_PACKAGE_GST1_PLUGINS_BAD_LIB_OPENGL_OPENGL is not set
3647# BR2_PACKAGE_GST1_PLUGINS_BAD_LIB_OPENGL_GLES2 is not set
3648# BR2_PACKAGE_GST1_PLUGINS_BAD_LIB_OPENGL_GLX is not set
3649# BR2_PACKAGE_GST1_PLUGINS_BAD_LIB_OPENGL_EGL is not set
3650# BR2_PACKAGE_GST1_PLUGINS_BAD_LIB_OPENGL_X11 is not set
3651# BR2_PACKAGE_GST1_PLUGINS_BAD_LIB_OPENGL_WAYLAND is not set
3652# BR2_PACKAGE_GST1_PLUGINS_BAD_LIB_OPENGL_DISPMANX is not set
3653# BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_AUDIOMIXER is not set
3654# BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_LAME is not set
3655# BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_MPG123 is not set
3656# BR2_GDB_VERSION_7_11 is not set
3657# BR2_GDB_VERSION_7_10 is not set
3658
3659#
3660# Legacy options removed in 2018.05
3661#
3662# BR2_PACKAGE_MEDIAART_BACKEND_NONE is not set
3663# BR2_PACKAGE_MEDIAART_BACKEND_GDK_PIXBUF is not set
3664# BR2_PACKAGE_TI_SGX_AM335X is not set
3665# BR2_PACKAGE_TI_SGX_AM437X is not set
3666# BR2_PACKAGE_TI_SGX_AM4430 is not set
3667# BR2_PACKAGE_TI_SGX_AM5430 is not set
3668# BR2_PACKAGE_JANUS_AUDIO_BRIDGE is not set
3669# BR2_PACKAGE_JANUS_ECHO_TEST is not set
3670# BR2_PACKAGE_JANUS_RECORDPLAY is not set
3671# BR2_PACKAGE_JANUS_SIP_GATEWAY is not set
3672# BR2_PACKAGE_JANUS_STREAMING is not set
3673# BR2_PACKAGE_JANUS_TEXT_ROOM is not set
3674# BR2_PACKAGE_JANUS_VIDEO_CALL is not set
3675# BR2_PACKAGE_JANUS_VIDEO_ROOM is not set
3676# BR2_PACKAGE_JANUS_MQTT is not set
3677# BR2_PACKAGE_JANUS_RABBITMQ is not set
3678# BR2_PACKAGE_JANUS_REST is not set
3679# BR2_PACKAGE_JANUS_UNIX_SOCKETS is not set
3680# BR2_PACKAGE_JANUS_WEBSOCKETS is not set
3681# BR2_PACKAGE_IPSEC_SECCTX_DISABLE is not set
3682# BR2_PACKAGE_IPSEC_SECCTX_ENABLE is not set
3683# BR2_PACKAGE_IPSEC_SECCTX_KERNEL is not set
3684# BR2_PACKAGE_LIBTFDI_CPP is not set
3685# BR2_PACKAGE_JQUERY_UI_THEME_BLACK_TIE is not set
3686# BR2_PACKAGE_JQUERY_UI_THEME_BLITZER is not set
3687# BR2_PACKAGE_JQUERY_UI_THEME_CUPERTINO is not set
3688# BR2_PACKAGE_JQUERY_UI_THEME_DARK_HIVE is not set
3689# BR2_PACKAGE_JQUERY_UI_THEME_DOT_LUV is not set
3690# BR2_PACKAGE_JQUERY_UI_THEME_EGGPLANT is not set
3691# BR2_PACKAGE_JQUERY_UI_THEME_EXCITE_BIKE is not set
3692# BR2_PACKAGE_JQUERY_UI_THEME_FLICK is not set
3693# BR2_PACKAGE_JQUERY_UI_THEME_HOT_SNEAKS is not set
3694# BR2_PACKAGE_JQUERY_UI_THEME_HUMANITY is not set
3695# BR2_PACKAGE_JQUERY_UI_THEME_LE_FROG is not set
3696# BR2_PACKAGE_JQUERY_UI_THEME_MINT_CHOC is not set
3697# BR2_PACKAGE_JQUERY_UI_THEME_OVERCAST is not set
3698# BR2_PACKAGE_JQUERY_UI_THEME_PEPPER_GRINDER is not set
3699# BR2_PACKAGE_JQUERY_UI_THEME_REDMOND is not set
3700# BR2_PACKAGE_JQUERY_UI_THEME_SMOOTHNESS is not set
3701# BR2_PACKAGE_JQUERY_UI_THEME_SOUTH_STREET is not set
3702# BR2_PACKAGE_JQUERY_UI_THEME_START is not set
3703# BR2_PACKAGE_JQUERY_UI_THEME_SUNNY is not set
3704# BR2_PACKAGE_JQUERY_UI_THEME_SWANKY_PURSE is not set
3705# BR2_PACKAGE_JQUERY_UI_THEME_TRONTASTIC is not set
3706# BR2_PACKAGE_JQUERY_UI_THEME_UI_DARKNESS is not set
3707# BR2_PACKAGE_JQUERY_UI_THEME_UI_LIGHTNESS is not set
3708# BR2_PACKAGE_JQUERY_UI_THEME_VADER is not set
3709# BR2_PACKAGE_BLUEZ5_PLUGINS_HEALTH is not set
3710# BR2_PACKAGE_BLUEZ5_PLUGINS_MIDI is not set
3711# BR2_PACKAGE_BLUEZ5_PLUGINS_NFC is not set
3712# BR2_PACKAGE_BLUEZ5_PLUGINS_SAP is not set
3713# BR2_PACKAGE_BLUEZ5_PLUGINS_SIXAXIS is not set
3714# BR2_PACKAGE_TRANSMISSION_REMOTE is not set
3715# BR2_PACKAGE_LIBKCAPI_APPS is not set
3716# BR2_PACKAGE_MPLAYER is not set
3717# BR2_PACKAGE_MPLAYER_MPLAYER is not set
3718# BR2_PACKAGE_MPLAYER_MENCODER is not set
3719# BR2_PACKAGE_LIBPLAYER_MPLAYER is not set
3720# BR2_PACKAGE_IQVLINUX is not set
3721# BR2_BINFMT_FLAT_SEP_DATA is not set
3722# BR2_bfin is not set
3723# BR2_PACKAGE_KODI_ADSP_BASIC is not set
3724# BR2_PACKAGE_KODI_ADSP_FREESURROUND is not set
3725
3726#
3727# Legacy options removed in 2018.02
3728#
3729# BR2_KERNEL_HEADERS_3_4 is not set
3730# BR2_KERNEL_HEADERS_3_10 is not set
3731# BR2_KERNEL_HEADERS_3_12 is not set
3732# BR2_BINUTILS_VERSION_2_27_X is not set
3733# BR2_PACKAGE_EEPROG is not set
3734# BR2_PACKAGE_GNUPG2_GPGV2 is not set
3735# BR2_PACKAGE_IMX_GPU_VIV_APITRACE is not set
3736# BR2_PACKAGE_IMX_GPU_VIV_G2D is not set
3737
3738#
3739# Legacy options removed in 2017.11
3740#
3741# BR2_PACKAGE_RFKILL is not set
3742# BR2_PACKAGE_UTIL_LINUX_RESET is not set
3743# BR2_PACKAGE_POLICYCOREUTILS_AUDIT2ALLOW is not set
3744# BR2_PACKAGE_POLICYCOREUTILS_RESTORECOND is not set
3745# BR2_PACKAGE_SEPOLGEN is not set
3746# BR2_PACKAGE_OPENOBEX_BLUEZ is not set
3747# BR2_PACKAGE_OPENOBEX_LIBUSB is not set
3748# BR2_PACKAGE_OPENOBEX_APPS is not set
3749# BR2_PACKAGE_OPENOBEX_SYSLOG is not set
3750# BR2_PACKAGE_OPENOBEX_DUMP is not set
3751# BR2_PACKAGE_AICCU is not set
3752# BR2_PACKAGE_UTIL_LINUX_LOGIN_UTILS is not set
3753
3754#
3755# Legacy options removed in 2017.08
3756#
3757# BR2_TARGET_GRUB is not set
3758# BR2_PACKAGE_SIMICSFS is not set
3759# BR2_BINUTILS_VERSION_2_26_X is not set
3760BR2_XTENSA_OVERLAY_DIR=""
3761BR2_XTENSA_CUSTOM_NAME=""
3762# BR2_PACKAGE_HOST_MKE2IMG is not set
3763BR2_TARGET_ROOTFS_EXT2_BLOCKS=0
3764BR2_TARGET_ROOTFS_EXT2_EXTRA_INODES=0
3765# BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_CDXAPARSE is not set
3766# BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_DATAURISRC is not set
3767# BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_DCCP is not set
3768# BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_HDVPARSE is not set
3769# BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_MVE is not set
3770# BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_NUVDEMUX is not set
3771# BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_PATCHDETECT is not set
3772# BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SDI is not set
3773# BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_TTA is not set
3774# BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_VIDEOMEASURE is not set
3775# BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_APEXSINK is not set
3776# BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SDL is not set
3777# BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_MAD is not set
3778# BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBRTC is not set
3779# BR2_STRIP_none is not set
3780# BR2_PACKAGE_BEECRYPT_CPP is not set
3781# BR2_PACKAGE_SPICE_CLIENT is not set
3782# BR2_PACKAGE_SPICE_GUI is not set
3783# BR2_PACKAGE_SPICE_TUNNEL is not set
3784# BR2_PACKAGE_INPUT_TOOLS is not set
3785# BR2_PACKAGE_INPUT_TOOLS_INPUTATTACH is not set
3786# BR2_PACKAGE_INPUT_TOOLS_JSCAL is not set
3787# BR2_PACKAGE_INPUT_TOOLS_JSTEST is not set
3788# BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_SH is not set
3789# BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_X86 is not set
3790# BR2_GCC_VERSION_4_8_X is not set
3791
3792#
3793# Legacy options removed in 2017.05
3794#
3795# BR2_PACKAGE_SUNXI_MALI_R2P4 is not set
3796# BR2_PACKAGE_NODEJS_MODULES_COFFEESCRIPT is not set
3797# BR2_PACKAGE_NODEJS_MODULES_EXPRESS is not set
3798# BR2_PACKAGE_BLUEZ5_UTILS_GATTTOOL is not set
3799# BR2_PACKAGE_OPENOCD_FT2XXX is not set
3800# BR2_PACKAGE_KODI_RTMPDUMP is not set
3801# BR2_PACKAGE_KODI_VISUALISATION_FOUNTAIN is not set
3802# BR2_PACKAGE_PORTMAP is not set
3803# BR2_BINUTILS_VERSION_2_25_X is not set
3804# BR2_TOOLCHAIN_BUILDROOT_INET_RPC is not set
3805BR2_TARGET_ROOTFS_EXT2_EXTRA_BLOCKS=0
3806# BR2_PACKAGE_SYSTEMD_KDBUS is not set
3807# BR2_PACKAGE_POLARSSL is not set
3808# BR2_NBD_CLIENT is not set
3809# BR2_NBD_SERVER is not set
3810# BR2_PACKAGE_GMOCK is not set
3811# BR2_KERNEL_HEADERS_4_8 is not set
3812# BR2_KERNEL_HEADERS_3_18 is not set
3813# BR2_GLIBC_VERSION_2_22 is not set
3814
3815#
3816# Legacy options removed in 2017.02
3817#
3818# BR2_PACKAGE_PERL_DB_FILE is not set
3819# BR2_KERNEL_HEADERS_4_7 is not set
3820# BR2_KERNEL_HEADERS_4_6 is not set
3821# BR2_KERNEL_HEADERS_4_5 is not set
3822# BR2_KERNEL_HEADERS_3_14 is not set
3823# BR2_TOOLCHAIN_EXTERNAL_MUSL_CROSS is not set
3824# BR2_UCLIBC_INSTALL_TEST_SUITE is not set
3825# BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX is not set
3826# BR2_PACKAGE_MAKEDEVS is not set
3827# BR2_TOOLCHAIN_EXTERNAL_ARAGO_ARMV7A is not set
3828# BR2_TOOLCHAIN_EXTERNAL_ARAGO_ARMV5TE is not set
3829# BR2_PACKAGE_SNOWBALL_HDMISERVICE is not set
3830# BR2_PACKAGE_SNOWBALL_INIT is not set
3831# BR2_GDB_VERSION_7_9 is not set
3832
3833#
3834# Legacy options removed in 2016.11
3835#
3836# BR2_PACKAGE_PHP_SAPI_CLI_CGI is not set
3837# BR2_PACKAGE_PHP_SAPI_CLI_FPM is not set
3838# BR2_PACKAGE_WVSTREAMS is not set
3839# BR2_PACKAGE_WVDIAL is not set
3840# BR2_PACKAGE_WEBKITGTK24 is not set
3841# BR2_PACKAGE_TORSMO is not set
3842# BR2_PACKAGE_SSTRIP is not set
3843# BR2_KERNEL_HEADERS_4_3 is not set
3844# BR2_KERNEL_HEADERS_4_2 is not set
3845# BR2_PACKAGE_KODI_ADDON_XVDR is not set
3846# BR2_PACKAGE_IPKG is not set
3847# BR2_GCC_VERSION_4_7_X is not set
3848# BR2_B