lp:~paelzer/ubuntu-seeds/+git/ubuntu

Get this repository:
git clone https://git.launchpad.net/~paelzer/ubuntu-seeds/+git/ubuntu
Only Christian Ehrhardt  can upload to this repository. If you are Christian Ehrhardt  please log in for upload directions.

Branches

Name Last Modified Last Commit
remove-unused-drac 2020-09-29 12:36:31 UTC 2020-09-29
development: drop unused drac-dev

Author: Christian Ehrhardt 
Author Date: 2020-09-29 12:36:31 UTC

development: drop unused drac-dev

The package drac was once used for pop-before-smtp functionality
but is no more used that way.
  $ reverse-depends --release=groovy --build-depends src:drac
  No reverse dependencies found
  $ reverse-depends --release=groovy src:drac
  No reverse dependencies found

It also is essentially untouched and unmaintained for years (dh compat 5)
$ rma drac
drac | 1.12-8 | oldoldstable | source
drac | 1.12-8 | oldstable | source
drac | 1.12-8 | stable | source
drac | 1.12-8 | testing | source
drac | 1.12-8 | unstable | source
drac | 1.12-8 | unstable-debug | source
drac | 1.12-8+b1 | oldoldstable | amd64, armel, armhf, i386
drac | 1.12-8+b2 | oldstable | amd64, arm64, armel, armhf, i386, mips, mips64el, mipsel, ppc64el, s390x
drac | 1.12-8+b2 | stable | amd64, arm64, armel, armhf, i386, mips, mips64el, mipsel, ppc64el, s390x
drac | 1.12-8+b2 | testing | amd64, arm64, armel, armhf, i386, mips64el, mipsel, ppc64el, s390x
drac | 1.12-8+b2 | unstable | amd64, arm64, armel, armhf, i386, mips64el, mipsel, ppc64el, s390x
drac | 1.12-7.2 | precise | source
drac | 1.12-7.2 | precise/universe | amd64, armel, armhf, i386, powerpc
drac | 1.12-8build1 | trusty | source
drac | 1.12-8build1 | trusty/universe | amd64, arm64, armhf, i386, powerpc, ppc64el
drac | 1.12-8build1 | xenial | source
drac | 1.12-8build1 | xenial/universe | amd64, arm64, armhf, i386, powerpc, ppc64el, s390x
drac | 1.12-8build2 | bionic | source
drac | 1.12-8build2 | bionic/universe | amd64, arm64, armhf, i386, ppc64el, s390x
drac | 1.12-8build2 | focal | source
drac | 1.12-8build2 | focal/universe | amd64, arm64, armhf, ppc64el, riscv64, s390x
drac | 1.12-8build2 | groovy | source
drac | 1.12-8build2 | groovy/universe | amd64, arm64, armhf, ppc64el, riscv64, s390x

As there is no need for it in main anymore, let us remove its direct
seeding.

Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>

debug-esmtp-listing 2020-09-09 14:45:26 UTC 2020-09-09
simplify down to just the problem

Author: Christian Ehrhardt 
Author Date: 2020-09-09 09:52:53 UTC

simplify down to just the problem

Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>

prepare-to-drop-server-ship 2020-08-28 07:25:40 UTC 2020-08-28
drop server-ship

Author: Christian Ehrhardt 
Author Date: 2020-08-28 07:25:40 UTC

drop server-ship

This seed is no more used and the packages still held in main due to
that have now been taken over in the platform/supported-* seeds.

Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>

exclude-python-ssl-doc 2020-08-26 11:10:08 UTC 2020-08-26
exclude python-ssl-doc to avoid its dependency chain

Author: Christian Ehrhardt 
Author Date: 2020-08-26 11:09:07 UTC

exclude python-ssl-doc to avoid its dependency chain

Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>

focal-dont-auto-include-dpdk-doc 2020-03-27 07:27:24 UTC 2020-03-27
supported: do not auto-promote dpdk-doc (LP: #1869147)

Author: Christian Ehrhardt 
Author Date: 2020-03-27 07:27:24 UTC

supported: do not auto-promote dpdk-doc (LP: #1869147)

This packages has recently gained universe deps (it formerly shipped
fonts on his own and by fixing that it now depends on a universe fonts
package).

But furthermore the package also includes examples which are ncie but
not meant to be "fully supported" so main is the wrong place for them
anyway.

More details at:
https://bugs.launchpad.net/ubuntu/+source/dpdk/+bug/1869147/comments/12

Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>

update-libvirt-seeding 2020-02-05 09:15:31 UTC 2020-02-05
extra-exclude libvirt-dev to be able to demote src:xen

Author: Christian Ehrhardt 
Author Date: 2020-02-05 09:12:30 UTC

extra-exclude libvirt-dev to be able to demote src:xen

As part of the demotion of xen let libvirt-dev be demoted.
It currently has no dependencies holding it in, but comes via the
auto-inclusion of -dev libraries.

Note: The active xen bits in libvirt are nowadays in binaries that are already
demoted to universe. This shall only move also libvirt-dev which (after
the one from qemu, currently in proposed, is gone) should be the last remaining
dependency holding srx:xen in main.

Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>

pmdk-extra-exclude-2 2020-02-05 08:27:42 UTC 2020-02-05
add -debug packages to pmdk related excludes

Author: Christian Ehrhardt 
Author Date: 2020-02-05 08:27:42 UTC

add -debug packages to pmdk related excludes

Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>

pmdk-extra-exclude 2020-02-02 18:39:47 UTC 2020-02-02
avoid semi-experimental dev/libs from pmdk

Author: Christian Ehrhardt 
Author Date: 2020-02-02 18:39:47 UTC

avoid semi-experimental dev/libs from pmdk

pmdk builds a lot of things, and some of them are considered too new and
changing too much. For now we only want the libpmem1 dependency through
qemu in main. The reast might ofllow later, but for now avoid adding too
much due to the auto-inclusion of -dev packages.

Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>

focal-promote-gpsd 2020-01-10 07:12:46 UTC 2020-01-10
Extra-Exclude: libqgpsmm-dev avoiding the qt portion of gpsd to be promoted

Author: Christian Ehrhardt 
Author Date: 2020-01-10 07:12:46 UTC

Extra-Exclude: libqgpsmm-dev avoiding the qt portion of gpsd to be promoted

Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>

demote-vlan-focal 2019-12-13 07:14:54 UTC 2019-12-13
server-ship: demote vlan (LP: #1856279)

Author: Christian Ehrhardt 
Author Date: 2019-12-13 07:04:22 UTC

server-ship: demote vlan (LP: #1856279)

The vlan toolset was only used in the context of ifupdown.
Since network migrated to netplan.io this isn't needed in main anymore.

https://lists.ubuntu.com/archives/ubuntu-server/2019-December/008039.html

Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>

demote-nmap-focal 2019-12-13 06:58:06 UTC 2019-12-13
server-ship: demote nmap

Author: Christian Ehrhardt 
Author Date: 2019-12-13 06:58:06 UTC

server-ship: demote nmap

nmap isn't strictly required in main for it's use cases in Ubuntu.
Furthermore it has an internal libssh2 which isn't supposed to be used
and the external one won't get into main for libssh being the preferred
alternative.

Therefore instead of disabling the ssh features let us demote it to
universe where people can use it just the same as before.

See also the discussion on (LP: #681423)

Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>

cleanup-dec2019 2019-12-12 06:36:30 UTC 2019-12-12
cleanup: remove transitional iptraf

Author: Christian Ehrhardt 
Author Date: 2019-12-12 06:36:30 UTC

cleanup: remove transitional iptraf

This was added when iptraf-ng took over iptraf.
But going forward the transitional package isn't needed to be listed.

Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>

eoan-server-meta-updates 2019-05-10 07:09:51 UTC 2019-05-10
server: do not explicitly state fwupd-signed as some arches wont need/have EFI

Author: Christian Ehrhardt 
Author Date: 2019-05-10 07:09:51 UTC

server: do not explicitly state fwupd-signed as some arches wont need/have EFI

Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>

disco-remove-libdpdk-dev-from-auto-promotion 2019-02-04 07:16:53 UTC 2019-02-04
Do not auto-promote libdpdk-dev from src:dpdk

Author: Christian Ehrhardt 
Author Date: 2019-02-04 07:16:53 UTC

Do not auto-promote libdpdk-dev from src:dpdk

Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>

make-open-iscsi-removable 2018-05-28 08:30:14 UTC 2018-05-28
server: make open-iscsi removable (LP: #1630946)

Author: Christian Ehrhardt 
Author Date: 2018-05-28 08:30:14 UTC

server: make open-iscsi removable (LP: #1630946)

We will keep open-iscsid on our images for older MAAS but also further
use cases in cloud environments. But we will work on having the daemon
not auto-starting if not needed (bug 1755858) and ensure that people
can get rid of it without removing ubuntu-server meta.

Therefore lower open-iscsi to a recommends.

Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>

115 of 15 results
This repository contains Public information 
Everyone can see this information.