Code review comment for lp:~nick-dedekind/unity8/side-stage-redesign

Revision history for this message
Nick Dedekind (nick-dedekind) wrote :

> In qml/Stages/TabletSideStageTouchGesture.qml:
>
> """
> signal drag
> """
>
> It's named like a function. Suggestions: "signal dragStarted" or "property
> bool dragging" (like in DirectionalDragArea/SwipeArea)
>
> Also couldn't find any code using it. Maybe we could just remove it?
>
> """
> signal drop
> """
>
> It's named like a function. Suggestion: "dropped" (would a "property bool
> dragging" cover both signals?). Also the only code I found using it was
> TabletSideStageTouchGesture. Should it be privatized somehow?
>
>
> """
> signal cancel
> """
>
> It's named like a function. Also the only code I found using it was
> TabletSideStageTouchGesture, like with the "drop" signal.

Changed the names.
I'm using clicked, dropped & cancelled signals in the tutorial branch. Drag signal is for API completeness (drop without a drag isn't great API).

« Back to merge proposal