Code review comment for lp:~nick-dedekind/unity8/side-stage-redesign

Revision history for this message
Nick Dedekind (nick-dedekind) wrote :

> In qml/Stages/TabletSideStageTouchGesture.qml:
>
> """
> property bool enableDrag: true
> """
>
> Doesn't seem to ever change to false (at least couldn't find code doing it).
> So maybe this is redundant now (and thus could be removed)?

It's being used by the tutorial branch associated with this one.
https://code.launchpad.net/~nick-dedekind/unity8/side-stage-redesign-tutorial/+merge/281506

>
> """
> property bool wasRecognisedPress: false
> property bool wasRecognisedDrag: false
> readonly property bool recognisedPress: status ==
> TouchGestureArea.Recognized &&
> touchPoints.length >=
> minimumTouchPoints &&
> touchPoints.length <=
> maximumTouchPoints
> readonly property bool recognisedDrag: wasRecognisedPress && dragging
> """
>
> They all seem to be private properties. If so, please move them to the priv
> object.

Privatized the wasRecognised[Drag/Press]

« Back to merge proposal