Code review comment for lp:~mc.../inkscape/SelContainer

Revision history for this message
Krzysztof Kosinski (tweenk) wrote :

Converting Selection to a vector is not the best thing to do. Selection
should be a data structure equivalent to Java's LinkedHashSet, because the
most common operation is lookup (whether something is in the selection) and
we also need to remember the selection's order for purposes such as Boolean
operations.

Regards, Krzysztof

2015-02-24 12:08 GMT+01:00 Mc <email address hidden>:

> > I added some fancy new diff comments that should help show where things
> need
> > fixing.
>
> Thanks a lot for your comments !
>
> I actually meant to change the semantics of SPObject::childList : It used
> to return a GSList, whose *last* element was the first child, and to be
> reversed in many places.
>
> Now it returns a vector whose *first* element is the first child, so that
> allows us to actually simplify a lot of things (use push_back instead of
> insert in all the places that deals with childList)
>
> I'll try to apply your comments as soon as i can.
> --
> https://code.launchpad.net/~mc.../inkscape/SelContainer/+merge/250681
> You are subscribed to branch lp:inkscape.
>

« Back to merge proposal