Code review comment for lp:~laetitia-gangloff/hr-timesheet/hr_attendance_analysis_externalise_contract_calendar_

Revision history for this message
Laetitia Gangloff (Acsone) (laetitia-gangloff) wrote :

Sorry for the late resolution.

There is no more conflict (for the moment...).

Changes are :

- rename get_active_contracts to get_reference_calendar and return the possible calendar attached to retrieve contract
- update code to take account of this change (_get_attendance_duration and print_calendar method) -> there is many 'if' on same thing to avoid indentation problem, it can be correct in next version
- externalise store part of column in _store_rules to easily extends it
- add some context

« Back to merge proposal