Mir

Code review comment for lp:~kdub/mir/require-streams-when-creating-surface

Revision history for this message
Cemil Azizoglu (cemil-azizoglu) wrote :

The name added_streams is a bit confusing since streams may later be removed as well. How about just calling it 'streams'.
180 + std::unordered_map<SurfaceId, frontend::BufferStreamId> added_streams;
-------------------

We should just call them add_buffer_stream_for() and remove_buffer_stream_for() instead of
170 + void add_content_for(frontend::SurfaceId id, frontend::BufferStreamId);
171 + void remove_content_for(frontend::SurfaceId, frontend::Session&);

review: Needs Fixing

« Back to merge proposal