Mir

Code review comment for lp:~kdub/mir/hwc-integration

Revision history for this message
Alexandros Frantzis (afrantzis) wrote :

317 +mga::AndroidFBFactory::AndroidFBFactory(std::shared_ptr<DisplayFactory> const& fb_factory,
318 + std::shared_ptr<HWCFactory> const& hwc_factory)
319 + : fb_factory(fb_factory),

s/fb_factory/display_factory/ ?

36 + virtual std::shared_ptr<Display> create_fb() const = 0;

This seems a bit strange, since we have an Android*FB*Factory::create_*fb*() returning a std::shared_ptr<*Display*>. I would expect this to be called an AndroidDisplayFactory::create_display(). We have used "Display" in different contexts (mg::Display and HWCDisplay/AndroidDisplay) and it causes some confusion/conflict.
Perhaps we should rename FBFactory->DisplayFactory, and the existing DisplayFactory->SomethingElse (FramebufferFactory, HWCDisplay->HWCFramebuffer, AndroidDisplay->GPUFramebuffer)? Thoughts?

review: Needs Fixing

« Back to merge proposal