Merge lp:~gandelman-a/ubuntu/quantal/keystone/2012.2.1 into lp:~openstack-ubuntu-testing/keystone/folsom

Proposed by Adam Gandelman on 2012-11-30
Status: Merged
Approved by: Chuck Short on 2012-12-03
Approved revision: no longer in the source branch.
Merge reported by: Adam Gandelman
Merged at revision: not available
Proposed branch: lp:~gandelman-a/ubuntu/quantal/keystone/2012.2.1
Merge into: lp:~openstack-ubuntu-testing/keystone/folsom
Diff against target: 60 lines (+37/-2)
1 file modified
debian/changelog (+37/-2)
To merge this branch: bzr merge lp:~gandelman-a/ubuntu/quantal/keystone/2012.2.1
Reviewer Review Type Date Requested Status
Openstack Ubuntu Testers 2012-11-30 Pending
Review via email: mp+137352@code.launchpad.net
To post a comment you must log in.
155. By Adam Gandelman on 2012-12-03

Merge 2012.2.1 changes.

Preview Diff

[H/L] Next/Prev Comment, [J/K] Next/Prev File, [N/P] Next/Prev Hunk
=== modified file 'debian/changelog'
--- debian/changelog 2012-10-31 16:34:40 +0000
+++ debian/changelog 2012-12-01 04:25:22 +0000
@@ -1,11 +1,47 @@
1keystone (2012.2-0ubuntu1.1) UNRELEASED; urgency=low1keystone (2012.2.1-0ubuntu1) UNRELEASED; urgency=low
22
3 * Ubuntu updates:3 * Ubuntu updates:
4 - debian/control: Ensure keystoneclient is upgraded with keystone,4 - debian/control: Ensure keystoneclient is upgraded with keystone,
5 require python-keystoneclient >= 1:0.1.3. (LP: #1073273)5 require python-keystoneclient >= 1:0.1.3. (LP: #1073273)
6 - Dropped patches, applied upsteram:
7 - debian/patches/CVE-2012-5563.patch
8 - debian/patches/CVE-2012-5571.patch
9 - debian/patches/fix-ssl-tests-lp1068851.patch
10 * Resynchronize with stable/folsom (7869c3ec) (LP: #1085255):
11 - [f9d4766] token expires time incorrect for auth by one token
12 (LP: #1079216)
13 - [80d63c8] keystone throws error when removing user from tenant.
14 (LP: #1078497)
15 - [37308dd] Removing user from a tenant isn't invalidating user access to
16 tenant (LP: #1064914)
17 - [bec9b68] Redo part of bp/sql-identiy-pam undone by bug 968519
18 (LP: #1068674)
19 - [ee645e6] Jenkins jobs fail because of incompatibility between sqlalchemy-
20 migrate and the newest sqlalchemy-0.8.0b1 (LP: #1073569)
21 - [094c494] Non PKI Tokens longer than 32 characters can never be valid
22 (LP: #1060389)
23 - [3cd343b] Openssl tests rely on expired certificate (LP: #1068851)
24 - [2f9807e] Set defaultbranch in .gitreview to stable/folsom
625
7 -- Adam Gandelman <adamg@canonical.com> Wed, 31 Oct 2012 13:43:11 +010026 -- Adam Gandelman <adamg@canonical.com> Wed, 31 Oct 2012 13:43:11 +0100
827
28keystone (2012.2-0ubuntu1.2) quantal-security; urgency=low
29
30 * SECURITY UPDATE: fix for EC2-style credentials invalidation
31 - debian/patches/CVE-2012-5571.patch: adjust contrib/ec2/core.py to verify
32 that the user is in at least one valid role for the tenant
33 - CVE-2012-5571
34 - LP: #1064914
35 * debian/patches/fix-ssl-tests-lp1068851.patch: update certificates for
36 SSL tests
37 * SECURITY UPDATE: fix for token expiration
38 - debian/patches/CVE-2012-5563.patch: ensure token expiration is
39 maintained
40 - CVE-2012-5563
41 - LP: #1079216
42
43 -- Jamie Strandboge <jamie@ubuntu.com> Wed, 28 Nov 2012 11:29:47 -0600
44
9keystone (2012.2-0ubuntu1) quantal; urgency=low45keystone (2012.2-0ubuntu1) quantal; urgency=low
1046
11 * New upstream release.47 * New upstream release.
@@ -281,7 +317,6 @@
281317
282 -- Chuck Short <zulcss@ubuntu.com> Fri, 16 Dec 2011 15:38:05 -0500318 -- Chuck Short <zulcss@ubuntu.com> Fri, 16 Dec 2011 15:38:05 -0500
283319
284
285keystone (2012.1~e2~20111209.1405-0ubuntu1) precise; urgency=low320keystone (2012.1~e2~20111209.1405-0ubuntu1) precise; urgency=low
286321
287 * New upstream release.322 * New upstream release.

Subscribers

People subscribed via source and target branches