lp:~bzr/ubuntu/jaunty/debhelper/builddeps-ppa

Created by Max Bowsher on 2011-05-15 and last modified on 2011-05-15
Get this branch:
bzr branch lp:~bzr/ubuntu/jaunty/debhelper/builddeps-ppa
Members of Bazaar Developers can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Bazaar Developers
Status:
Development

Recent revisions

49. By Max Bowsher on 2011-05-15

* Backport fix to python_distutils buildsystem code from debhelper 7.4.3:
* python_distutils: Run default python last, not first, and pass --force
  to setup.py install to ensure that timestamps do not prevent installation
  of the scripts built for the default python, with unversioned shebang
  lines. Closes: #547510 (Thanks, Andrew Straw)

48. By Max Bowsher on 2011-03-31

Rebuild karmic-vintage debhelper for jaunty, no changes made.

47. By Colin Watson on 2009-08-25

* Resynchronise with Debian. Remaining changes:
  - dh_installudev: Default priority is now 40 by default.
  - dh_installudev: Handle conffile migration from old Ubuntu defaults
    (needed until after the next LTS release).

46. By أحمد المحمودي (Ahmed El-Mahmoudy) on 2009-07-25

* Merge with Debian unstable (LP: #404561). Remaining Ubuntu changes:
  - dh_installudev: Default priority is now 40 by default, the target
    directory is /lib/udev/rules.d, and rules use '-' as separator instead of
    '_'. Remove files from /etc/udev/rules.d unless they are user modified;
    if modified and of default priority, take care to rename.
    This should eventually go to Debian as well, see Debian #491117.

45. By Michael Bienia on 2009-05-24

* Merge with Debian unstable (lp: #379950). Remaining Ubuntu changes:
  - dh_installudev: Default priority is now 40 by default, the target
    directory is /lib/udev/rules.d, and rules use '-' as separator instead of
    '_'. Remove files from /etc/udev/rules.d unless they are user modified;
    if modified and of default priority, take care to rename.
    This should eventually go to Debian as well, see Debian #491117.
  - dh_auto_install: add "--install-layout=deb" to setup.py install calls
    (new Python 2.6 policy).

44. By Martin Pitt on 2009-04-24

* Merge with Debian unstable. Remaining Ubuntu changes:
  - dh_installudev: Default priority is now 40 by default, the target
    directory is /lib/udev/rules.d, and rules use '-' as separator instead of
    '_'. Remove files from /etc/udev/rules.d unless they are user modified;
    if modified and of default priority, take care to rename.
    This should eventually go to Debian as well, see Debian #491117.
  - dh_auto_install: add "--install-layout=deb" to setup.py install calls
    (new Python 2.6 policy).
* dh_installxfonts: Drop versioned dependency for xfonts-utils. This
  was only necessary for dapper backports, but since dapper desktop goes
  EOL in two months, and we haven't done dapper backports in ages, this is
  just an unnecessary delta.

43. By Michael Bienia on 2009-03-09

dh_auto_install: add "--install-layout=deb" to setup.py install calls.

42. By Scott James Remnant (Canonical) on 2009-03-05

dh_installmodules: Install files to /etc/modprobe.d/*.conf, and move the
file from /etc/modprobe.d/if it exists and is changed (otherwise
remove before upgrade).

41. By Scott James Remnant (Canonical) on 2009-01-06

dh_installudev: Default priority is now 40 by default, and the target
directory is now /lib/udev/rules.d. Remove files from /etc/udev/rules.d
unless they are user modified; if modified and of default priority,
take care to rename.

40. By Colin Watson on 2008-11-02

* Resynchronise with Debian. Remaining changes:
  - dh_installudev: Use priority 50 by default (instead of z60) and '-'
    separator (instead of '_').
  - dh_installxfonts: Use versioned dependency for xfonts-utils. This
    should be kept until dapper goes out of support, to avoid broken
    dapper backports.
* Stop discarding scrollkeeper-update output; this isn't needed now that
  we use rarian-compat.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/oneiric/debhelper
This branch contains Public information 
Everyone can see this information.

Subscribers

No subscribers.