View Bazaar branches
Get this repository:
git clone https://git.launchpad.net/ubuntu/+source/debhelper
Members of Ubuntu Server Dev import team can upload to this repository. Log in for directions.

Branches

Name Last Modified Last Commit
importer/debian/dsc 2019-02-24 10:45:48 UTC 2019-02-24
DSC file for 12.1.1

Author: Ubuntu Git Importer
Author Date: 2019-02-24 10:45:48 UTC

DSC file for 12.1.1

debian/buster 2019-02-24 10:30:47 UTC 2019-02-24
Import patches-unapplied version 12.1.1 to debian/sid

Author: Niels Thykier
Author Date: 2019-02-23 13:24:47 UTC

Import patches-unapplied version 12.1.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d0ac69cc53323b1cd8f2910ed66bae02b2e4329f

New changelog entries:
  * dh_installinitramfs: Install hooks as executable rather than
    plan files. Thanks to Thorsten Glaser for the report.
    (Closes: #922990)
  * dh_compress: Fix bug where examples where compressed when a
    doc package shipped examples for another package. Thanks to
    Christian Kastner for reporting this. (Closes: #922267)

debian/sid 2019-02-24 10:30:47 UTC 2019-02-24
Import patches-unapplied version 12.1.1 to debian/sid

Author: Niels Thykier
Author Date: 2019-02-23 13:24:47 UTC

Import patches-unapplied version 12.1.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d0ac69cc53323b1cd8f2910ed66bae02b2e4329f

New changelog entries:
  * dh_installinitramfs: Install hooks as executable rather than
    plan files. Thanks to Thorsten Glaser for the report.
    (Closes: #922990)
  * dh_compress: Fix bug where examples where compressed when a
    doc package shipped examples for another package. Thanks to
    Christian Kastner for reporting this. (Closes: #922267)

applied/debian/buster 2019-02-24 10:30:47 UTC 2019-02-24
Import patches-applied version 12.1.1 to applied/debian/sid

Author: Niels Thykier
Author Date: 2019-02-23 13:24:47 UTC

Import patches-applied version 12.1.1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: fec93046f7ab1e6ecadd3b5163f27fc17142e0bf
Unapplied parent: 3208537699472a1d0e7cb024df405d339a253c7e

New changelog entries:
  * dh_installinitramfs: Install hooks as executable rather than
    plan files. Thanks to Thorsten Glaser for the report.
    (Closes: #922990)
  * dh_compress: Fix bug where examples where compressed when a
    doc package shipped examples for another package. Thanks to
    Christian Kastner for reporting this. (Closes: #922267)

applied/debian/sid 2019-02-24 10:30:47 UTC 2019-02-24
Import patches-applied version 12.1.1 to applied/debian/sid

Author: Niels Thykier
Author Date: 2019-02-23 13:24:47 UTC

Import patches-applied version 12.1.1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: fec93046f7ab1e6ecadd3b5163f27fc17142e0bf
Unapplied parent: 3208537699472a1d0e7cb024df405d339a253c7e

New changelog entries:
  * dh_installinitramfs: Install hooks as executable rather than
    plan files. Thanks to Thorsten Glaser for the report.
    (Closes: #922990)
  * dh_compress: Fix bug where examples where compressed when a
    doc package shipped examples for another package. Thanks to
    Christian Kastner for reporting this. (Closes: #922267)

importer/ubuntu/dsc 2018-12-24 21:05:42 UTC 2018-12-24
DSC file for 12ubuntu1

Author: Ubuntu Git Importer
Author Date: 2018-12-24 21:05:42 UTC

DSC file for 12ubuntu1

ubuntu/devel 2018-12-24 21:03:11 UTC 2018-12-24
Import patches-unapplied version 12ubuntu1 to ubuntu/disco-proposed

Author: Simon Quigley
Author Date: 2018-12-24 20:29:23 UTC

Import patches-unapplied version 12ubuntu1 to ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 6c0a82a53f376c7cdf459a61cb7ab0da481c926a

New changelog entries:
  * Merge from Debian Sid. Remaining changes:
    - Generate ddebs from debhelper instead of pkg-create-dbgsym:
      + Make debhelper Conflict/Replace pkg-create-dbgsym to force it off.
      + Set DBGSYM_PACKAGE_TYPE to ddeb to get correct debian/files output.
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7 and higher to avoid pointlessly bloating installed packages.
  [ Niels Thykier ]
  * Release debhelper/12 marking compat 12 as stable.
  * dh: Special NOOP PROMISE of cli-options() to always allow skipping
    the helper (as we know no option can make it change behaviour).
  [ Dmitry Shachnev ]
  * dh_compress: Do not compress mkdocs search indices
    (search_index.json).

ubuntu/disco-devel 2018-12-24 21:03:11 UTC 2018-12-24
Import patches-unapplied version 12ubuntu1 to ubuntu/disco-proposed

Author: Simon Quigley
Author Date: 2018-12-24 20:29:23 UTC

Import patches-unapplied version 12ubuntu1 to ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 6c0a82a53f376c7cdf459a61cb7ab0da481c926a

New changelog entries:
  * Merge from Debian Sid. Remaining changes:
    - Generate ddebs from debhelper instead of pkg-create-dbgsym:
      + Make debhelper Conflict/Replace pkg-create-dbgsym to force it off.
      + Set DBGSYM_PACKAGE_TYPE to ddeb to get correct debian/files output.
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7 and higher to avoid pointlessly bloating installed packages.
  [ Niels Thykier ]
  * Release debhelper/12 marking compat 12 as stable.
  * dh: Special NOOP PROMISE of cli-options() to always allow skipping
    the helper (as we know no option can make it change behaviour).
  [ Dmitry Shachnev ]
  * dh_compress: Do not compress mkdocs search indices
    (search_index.json).

ubuntu/disco 2018-12-24 21:03:11 UTC 2018-12-24
Import patches-unapplied version 12ubuntu1 to ubuntu/disco-proposed

Author: Simon Quigley
Author Date: 2018-12-24 20:29:23 UTC

Import patches-unapplied version 12ubuntu1 to ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 6c0a82a53f376c7cdf459a61cb7ab0da481c926a

New changelog entries:
  * Merge from Debian Sid. Remaining changes:
    - Generate ddebs from debhelper instead of pkg-create-dbgsym:
      + Make debhelper Conflict/Replace pkg-create-dbgsym to force it off.
      + Set DBGSYM_PACKAGE_TYPE to ddeb to get correct debian/files output.
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7 and higher to avoid pointlessly bloating installed packages.
  [ Niels Thykier ]
  * Release debhelper/12 marking compat 12 as stable.
  * dh: Special NOOP PROMISE of cli-options() to always allow skipping
    the helper (as we know no option can make it change behaviour).
  [ Dmitry Shachnev ]
  * dh_compress: Do not compress mkdocs search indices
    (search_index.json).

ubuntu/disco-proposed 2018-12-24 21:03:11 UTC 2018-12-24
Import patches-unapplied version 12ubuntu1 to ubuntu/disco-proposed

Author: Simon Quigley
Author Date: 2018-12-24 20:29:23 UTC

Import patches-unapplied version 12ubuntu1 to ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 6c0a82a53f376c7cdf459a61cb7ab0da481c926a

New changelog entries:
  * Merge from Debian Sid. Remaining changes:
    - Generate ddebs from debhelper instead of pkg-create-dbgsym:
      + Make debhelper Conflict/Replace pkg-create-dbgsym to force it off.
      + Set DBGSYM_PACKAGE_TYPE to ddeb to get correct debian/files output.
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7 and higher to avoid pointlessly bloating installed packages.
  [ Niels Thykier ]
  * Release debhelper/12 marking compat 12 as stable.
  * dh: Special NOOP PROMISE of cli-options() to always allow skipping
    the helper (as we know no option can make it change behaviour).
  [ Dmitry Shachnev ]
  * dh_compress: Do not compress mkdocs search indices
    (search_index.json).

ubuntu/cosmic-proposed 2018-06-08 00:38:11 UTC 2018-06-08
Import patches-unapplied version 11.3.2ubuntu1 to ubuntu/cosmic-proposed

Author: Adam Conrad
Author Date: 2018-06-08 00:25:31 UTC

Import patches-unapplied version 11.3.2ubuntu1 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: ca53a6bc7e1ba5db1eca1facf14b2e423c90da68

New changelog entries:
  * Merge from Debian testing. Remaining changes:
    - Generate ddebs from debhelper instead of pkg-create-dbgsym
      + Make debhelper Conflict/Replace pkg-create-dbgsym to force it off.
      + Set DBGSYM_PACKAGE_TYPE to ddeb to get correct debian/files output.
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7 and higher to avoid pointlessly bloating installed packages.

ubuntu/cosmic 2018-06-08 00:38:11 UTC 2018-06-08
Import patches-unapplied version 11.3.2ubuntu1 to ubuntu/cosmic-proposed

Author: Adam Conrad
Author Date: 2018-06-08 00:25:31 UTC

Import patches-unapplied version 11.3.2ubuntu1 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: ca53a6bc7e1ba5db1eca1facf14b2e423c90da68

New changelog entries:
  * Merge from Debian testing. Remaining changes:
    - Generate ddebs from debhelper instead of pkg-create-dbgsym
      + Make debhelper Conflict/Replace pkg-create-dbgsym to force it off.
      + Set DBGSYM_PACKAGE_TYPE to ddeb to get correct debian/files output.
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7 and higher to avoid pointlessly bloating installed packages.

ubuntu/cosmic-devel 2018-06-08 00:38:11 UTC 2018-06-08
Import patches-unapplied version 11.3.2ubuntu1 to ubuntu/cosmic-proposed

Author: Adam Conrad
Author Date: 2018-06-08 00:25:31 UTC

Import patches-unapplied version 11.3.2ubuntu1 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: ca53a6bc7e1ba5db1eca1facf14b2e423c90da68

New changelog entries:
  * Merge from Debian testing. Remaining changes:
    - Generate ddebs from debhelper instead of pkg-create-dbgsym
      + Make debhelper Conflict/Replace pkg-create-dbgsym to force it off.
      + Set DBGSYM_PACKAGE_TYPE to ddeb to get correct debian/files output.
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7 and higher to avoid pointlessly bloating installed packages.

ubuntu/bionic-updates 2018-05-10 10:29:04 UTC 2018-05-10
Import patches-unapplied version 11.1.6ubuntu2 to ubuntu/bionic-proposed

Author: Iain Lane
Author Date: 2018-05-10 09:11:57 UTC

Import patches-unapplied version 11.1.6ubuntu2 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: e7529508e651451354e077618c356cb39a2e1006

New changelog entries:
  [ Iain Lane ]
  * Cherry-pick this change from Debian (98d248f4) (LP: #1767792)
  [ Nicolas Boulenguez ]
  * dh_installxfonts: Fix typo that causes a misc:Depends on
    non-existing xfont-utils. (Closes: #894835)

ubuntu/bionic-proposed 2018-05-10 10:29:04 UTC 2018-05-10
Import patches-unapplied version 11.1.6ubuntu2 to ubuntu/bionic-proposed

Author: Iain Lane
Author Date: 2018-05-10 09:11:57 UTC

Import patches-unapplied version 11.1.6ubuntu2 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: e7529508e651451354e077618c356cb39a2e1006

New changelog entries:
  [ Iain Lane ]
  * Cherry-pick this change from Debian (98d248f4) (LP: #1767792)
  [ Nicolas Boulenguez ]
  * dh_installxfonts: Fix typo that causes a misc:Depends on
    non-existing xfont-utils. (Closes: #894835)

ubuntu/bionic-devel 2018-05-10 10:29:04 UTC 2018-05-10
Import patches-unapplied version 11.1.6ubuntu2 to ubuntu/bionic-proposed

Author: Iain Lane
Author Date: 2018-05-10 09:11:57 UTC

Import patches-unapplied version 11.1.6ubuntu2 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: e7529508e651451354e077618c356cb39a2e1006

New changelog entries:
  [ Iain Lane ]
  * Cherry-pick this change from Debian (98d248f4) (LP: #1767792)
  [ Nicolas Boulenguez ]
  * dh_installxfonts: Fix typo that causes a misc:Depends on
    non-existing xfont-utils. (Closes: #894835)

ubuntu/bionic 2018-03-30 08:43:58 UTC 2018-03-30
Import patches-unapplied version 11.1.6ubuntu1 to ubuntu/bionic-proposed

Author: Adam Conrad
Author Date: 2018-03-30 08:01:04 UTC

Import patches-unapplied version 11.1.6ubuntu1 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: b536cca361f13bfa093e849c6c1cb6f5abba4568

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - Generate ddebs from debhelper instead of pkg-create-dbgsym
      + Make debhelper Conflict/Replace pkg-create-dbgsym to force it off.
      + Set DBGSYM_PACKAGE_TYPE to ddeb to get correct debian/files output.
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7 and higher to avoid pointlessly bloating installed packages.

importer/debian/pristine-tar 2018-03-13 20:35:08 UTC 2018-03-13
Initial Debian pristine-tar branch.

Author: Ubuntu Git Importer
Author Date: 2018-03-13 20:35:08 UTC

Initial Debian pristine-tar branch.

importer/ubuntu/pristine-tar 2018-03-13 20:35:08 UTC 2018-03-13
Initial Ubuntu pristine-tar branch.

Author: Ubuntu Git Importer
Author Date: 2018-03-13 20:35:08 UTC

Initial Ubuntu pristine-tar branch.

applied/debian/experimental 2018-02-24 22:28:21 UTC 2018-02-24
Import patches-applied version 11.1.5~alpha1 to applied/debian/experimental

Author: Niels Thykier
Author Date: 2018-02-24 16:01:31 UTC

Import patches-applied version 11.1.5~alpha1 to applied/debian/experimental

Imported using git-ubuntu import.

Changelog parent: 88c1c2031dc67839e03e0a01a936fd284e3201b5
Unapplied parent: 34dd7bfaad2e068ddb5d77d3f311f4e8b4013320

New changelog entries:
  * dh_installdocs: Add missing documentation about --sourcedir
    in compat 11.
  * dh_installdocs: Document that d/tmp is used by default
    in compat 11.
  * dh_installexamples: Ditto.
  * dh_installinfo: Ditto.
  * dh_installman: Ditto.
  * meson.pm: Apply patch from Jakub Wilk to fix typo in the name
    of the "C.UTF-8" locale.
  * autoscripts/postinst-systemd-restart: Apply patch from
    Christoph Biedl to fix indentation. (Closes: #890373)
  * dh_testroot: With the advent of DEB_RULES_REQUIRES_ROOT, it
    no longer needs to read debian/control to tell whether root
    is needed or not. However, the warning remains for calling
    dh_testroot outside the source root (as we may need to check
    the compat level in a future version of debhelper).
  * makefile.pm: Synchronize output from make (via -O) when
    make runs in parallel except when STDOUT is a TTY. Thanks
    to Goswin von Brederlow for the suggestion. (Closes: #768791)
  * dh_gencontrol: Avoid uninitialized value warning when there
    are no build-ids (e.g. because the builder disabled the
    dbgsym building via DEB_BUILD_OPTIONS). This regression
    was introduced in 11.1. Thanks to Christian Marillat for
    reporting the bug. (Closes: #890736)
  * Dh_Lib: pkgfile() now properly uses for DEB_TARGET_ARCH{,_OS}
    when the package is set to be built for the target
    architecture.
  * d/control: Drop dependency on binutils; it does not reflect
    our actual requirement and the package or builder will ensure
    that the current binutils is installed for other reasons
    any way. Thanks to Helmut Grohne for the report.
    (Closes: #891187)
  * Dh_Lib: Add an experimental feature to determine the requested
    compat level from the Build-Depends field.

debian/experimental 2018-02-24 22:28:21 UTC 2018-02-24
Import patches-unapplied version 11.1.5~alpha1 to debian/experimental

Author: Niels Thykier
Author Date: 2018-02-24 16:01:31 UTC

Import patches-unapplied version 11.1.5~alpha1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: d8ef1d6b8b1c10afb1b3096c8c1bc38800f7cc9e

New changelog entries:
  * dh_installdocs: Add missing documentation about --sourcedir
    in compat 11.
  * dh_installdocs: Document that d/tmp is used by default
    in compat 11.
  * dh_installexamples: Ditto.
  * dh_installinfo: Ditto.
  * dh_installman: Ditto.
  * meson.pm: Apply patch from Jakub Wilk to fix typo in the name
    of the "C.UTF-8" locale.
  * autoscripts/postinst-systemd-restart: Apply patch from
    Christoph Biedl to fix indentation. (Closes: #890373)
  * dh_testroot: With the advent of DEB_RULES_REQUIRES_ROOT, it
    no longer needs to read debian/control to tell whether root
    is needed or not. However, the warning remains for calling
    dh_testroot outside the source root (as we may need to check
    the compat level in a future version of debhelper).
  * makefile.pm: Synchronize output from make (via -O) when
    make runs in parallel except when STDOUT is a TTY. Thanks
    to Goswin von Brederlow for the suggestion. (Closes: #768791)
  * dh_gencontrol: Avoid uninitialized value warning when there
    are no build-ids (e.g. because the builder disabled the
    dbgsym building via DEB_BUILD_OPTIONS). This regression
    was introduced in 11.1. Thanks to Christian Marillat for
    reporting the bug. (Closes: #890736)
  * Dh_Lib: pkgfile() now properly uses for DEB_TARGET_ARCH{,_OS}
    when the package is set to be built for the target
    architecture.
  * d/control: Drop dependency on binutils; it does not reflect
    our actual requirement and the package or builder will ensure
    that the current binutils is installed for other reasons
    any way. Thanks to Helmut Grohne for the report.
    (Closes: #891187)
  * Dh_Lib: Add an experimental feature to determine the requested
    compat level from the Build-Depends field.

ubuntu/artful-devel 2017-08-06 15:43:12 UTC 2017-08-06
Import patches-unapplied version 10.7.2ubuntu2 to ubuntu/artful-proposed

Author: Simon Quigley
Author Date: 2017-08-06 15:13:33 UTC

Import patches-unapplied version 10.7.2ubuntu2 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 0fbd64f2e40ee5f7071eea348d2f9a1cfa87ae99

New changelog entries:
  * Define U_PARAMS correctly in dh_builddeb, and don't try to use it when it
    isn't defined.

ubuntu/artful 2017-08-06 15:43:12 UTC 2017-08-06
Import patches-unapplied version 10.7.2ubuntu2 to ubuntu/artful-proposed

Author: Simon Quigley
Author Date: 2017-08-06 15:13:33 UTC

Import patches-unapplied version 10.7.2ubuntu2 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 0fbd64f2e40ee5f7071eea348d2f9a1cfa87ae99

New changelog entries:
  * Define U_PARAMS correctly in dh_builddeb, and don't try to use it when it
    isn't defined.

ubuntu/artful-proposed 2017-08-06 15:43:12 UTC 2017-08-06
Import patches-unapplied version 10.7.2ubuntu2 to ubuntu/artful-proposed

Author: Simon Quigley
Author Date: 2017-08-06 15:13:33 UTC

Import patches-unapplied version 10.7.2ubuntu2 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 0fbd64f2e40ee5f7071eea348d2f9a1cfa87ae99

New changelog entries:
  * Define U_PARAMS correctly in dh_builddeb, and don't try to use it when it
    isn't defined.

applied/debian/stretch 2017-01-26 04:12:24 UTC 2017-01-26
Import patches-applied version 10.2.5 to applied/debian/sid

Author: Niels Thykier
Author Date: 2017-01-25 20:47:27 UTC

Import patches-applied version 10.2.5 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 93f8beed9f00c8ea5fd2fd19c0f84973251db9bd
Unapplied parent: f33c4d1deb857b4706d62fa5625e93499d7d0168

New changelog entries:
  [ Translations ]
  * Add Japanese translation (Hideki Yamane) (Closes: #852520)

debian/stretch 2017-01-26 04:12:24 UTC 2017-01-26
Import patches-unapplied version 10.2.5 to debian/sid

Author: Niels Thykier
Author Date: 2017-01-25 20:47:27 UTC

Import patches-unapplied version 10.2.5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 89fd1171803438c33a92c75aada6f4096f54cb17

New changelog entries:
  [ Translations ]
  * Add Japanese translation (Hideki Yamane) (Closes: #852520)

ubuntu/yakkety-backports 2016-11-11 11:23:17 UTC 2016-11-11
Import patches-unapplied version 10.2.2ubuntu1~ubuntu16.10.1 to ubuntu/yakket...

Author: Iain Lane
Author Date: 2016-11-11 09:48:55 UTC

Import patches-unapplied version 10.2.2ubuntu1~ubuntu16.10.1 to ubuntu/yakkety-backports

Imported using git-ubuntu import.

Changelog parent: ce9d83c9e9293f4fd1598f5cc08ccd98e6b2cde9

New changelog entries:
  * No-change backport to yakkety

ubuntu/xenial-backports 2016-11-11 11:23:17 UTC 2016-11-11
Import patches-unapplied version 10.2.2ubuntu1~ubuntu16.04.1 to ubuntu/xenial...

Author: Iain Lane
Author Date: 2016-11-11 09:48:33 UTC

Import patches-unapplied version 10.2.2ubuntu1~ubuntu16.04.1 to ubuntu/xenial-backports

Imported using git-ubuntu import.

Changelog parent: ce9d83c9e9293f4fd1598f5cc08ccd98e6b2cde9

New changelog entries:
  * No-change backport to xenial

ubuntu/zesty 2016-10-19 07:08:51 UTC 2016-10-19
Import patches-unapplied version 10.2.2ubuntu1 to ubuntu/zesty-proposed

Author: Martin Pitt
Author Date: 2016-10-17 19:34:23 UTC

Import patches-unapplied version 10.2.2ubuntu1 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: f1d2da15d3799f8248baa4d6e769da913e4462f6

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7. This floods packages with huge upstream changelogs which
      are unnecessary on an installed system.
    - dh_strip: Revert commit f1a803456 to disable ddebs generation by
      default. This first needs adjustments in Launchpad and ddebs.u.c., and
      dropping pkg-create-dbgsym.

ubuntu/zesty-devel 2016-10-19 07:08:51 UTC 2016-10-19
Import patches-unapplied version 10.2.2ubuntu1 to ubuntu/zesty-proposed

Author: Martin Pitt
Author Date: 2016-10-17 19:34:23 UTC

Import patches-unapplied version 10.2.2ubuntu1 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: f1d2da15d3799f8248baa4d6e769da913e4462f6

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7. This floods packages with huge upstream changelogs which
      are unnecessary on an installed system.
    - dh_strip: Revert commit f1a803456 to disable ddebs generation by
      default. This first needs adjustments in Launchpad and ddebs.u.c., and
      dropping pkg-create-dbgsym.

ubuntu/zesty-proposed 2016-10-19 07:08:51 UTC 2016-10-19
Import patches-unapplied version 10.2.2ubuntu1 to ubuntu/zesty-proposed

Author: Martin Pitt
Author Date: 2016-10-17 19:34:23 UTC

Import patches-unapplied version 10.2.2ubuntu1 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: f1d2da15d3799f8248baa4d6e769da913e4462f6

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7. This floods packages with huge upstream changelogs which
      are unnecessary on an installed system.
    - dh_strip: Revert commit f1a803456 to disable ddebs generation by
      default. This first needs adjustments in Launchpad and ddebs.u.c., and
      dropping pkg-create-dbgsym.

applied/debian/jessie 2016-09-17 16:55:34 UTC 2016-09-17
Import patches-applied version 9.20150101+deb8u2 to applied/debian/jessie

Author: Dominic Hargreaves
Author Date: 2016-07-24 19:13:55 UTC

Import patches-applied version 9.20150101+deb8u2 to applied/debian/jessie

Imported using git-ubuntu import.

Changelog parent: 69bca5c13c974a480da07e3e345c5542c018e181
Unapplied parent: 5733398cabc102ace37212f0acf2611a6e5db156

New changelog entries:
  * Non-maintainer upload.
  * Re-upload to security-master
  * Non-maintainer upload.
  * Invoke Makefile.PL and Build.PL with perl -I. as part of the fixes for
    CVE-2016-1238
  * Export PERL_USE_UNSAFE_INC to fix a further set of packages which
    fail to build with . removed from @INC

debian/jessie 2016-09-17 16:55:34 UTC 2016-09-17
Import patches-unapplied version 9.20150101+deb8u2 to debian/jessie

Author: Dominic Hargreaves
Author Date: 2016-07-24 19:13:55 UTC

Import patches-unapplied version 9.20150101+deb8u2 to debian/jessie

Imported using git-ubuntu import.

Changelog parent: c798c45ccb57593754f0d4300de768335e894ad3

New changelog entries:
  * Non-maintainer upload.
  * Re-upload to security-master
  * Non-maintainer upload.
  * Invoke Makefile.PL and Build.PL with perl -I. as part of the fixes for
    CVE-2016-1238
  * Export PERL_USE_UNSAFE_INC to fix a further set of packages which
    fail to build with . removed from @INC

ubuntu/yakkety-proposed 2016-09-12 05:54:14 UTC 2016-09-12
Import patches-unapplied version 10ubuntu1 to ubuntu/yakkety-proposed

Author: Martin Pitt
Author Date: 2016-09-12 05:12:45 UTC

Import patches-unapplied version 10ubuntu1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: f1ef0525f4880d84af836d87a1d5903c15ca6733

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7. This floods packages with huge upstream changelogs which
      are unnecessary on an installed system.
    - dh_strip: Revert commit f1a803456 to disable ddebs generation by
      default. This first needs adjustments in Launchpad and ddebs.u.c., and
      dropping pkg-create-dbgsym.

ubuntu/yakkety 2016-09-12 05:54:14 UTC 2016-09-12
Import patches-unapplied version 10ubuntu1 to ubuntu/yakkety-proposed

Author: Martin Pitt
Author Date: 2016-09-12 05:12:45 UTC

Import patches-unapplied version 10ubuntu1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: f1ef0525f4880d84af836d87a1d5903c15ca6733

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7. This floods packages with huge upstream changelogs which
      are unnecessary on an installed system.
    - dh_strip: Revert commit f1a803456 to disable ddebs generation by
      default. This first needs adjustments in Launchpad and ddebs.u.c., and
      dropping pkg-create-dbgsym.

ubuntu/yakkety-devel 2016-09-12 05:54:14 UTC 2016-09-12
Import patches-unapplied version 10ubuntu1 to ubuntu/yakkety-proposed

Author: Martin Pitt
Author Date: 2016-09-12 05:12:45 UTC

Import patches-unapplied version 10ubuntu1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: f1ef0525f4880d84af836d87a1d5903c15ca6733

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7. This floods packages with huge upstream changelogs which
      are unnecessary on an installed system.
    - dh_strip: Revert commit f1a803456 to disable ddebs generation by
      default. This first needs adjustments in Launchpad and ddebs.u.c., and
      dropping pkg-create-dbgsym.

ubuntu/xenial-devel 2016-03-31 18:18:42 UTC 2016-03-31
Import patches-unapplied version 9.20160115ubuntu3 to ubuntu/xenial-proposed

Author: Nish Aravamudan
Author Date: 2016-03-31 15:33:23 UTC

Import patches-unapplied version 9.20160115ubuntu3 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 5d3e4fb18f79cdb74327ff0fb1235f64f3ee2d9e

New changelog entries:
  * Backport upstream commit 9ca73a0a ("Pass -a to grep to handle
    substvars with unicode content gracefully") to fix build-failure
    with php-mf2 (LP: #1564492, Closes #815620).

ubuntu/xenial-proposed 2016-03-31 18:18:42 UTC 2016-03-31
Import patches-unapplied version 9.20160115ubuntu3 to ubuntu/xenial-proposed

Author: Nish Aravamudan
Author Date: 2016-03-31 15:33:23 UTC

Import patches-unapplied version 9.20160115ubuntu3 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 5d3e4fb18f79cdb74327ff0fb1235f64f3ee2d9e

New changelog entries:
  * Backport upstream commit 9ca73a0a ("Pass -a to grep to handle
    substvars with unicode content gracefully") to fix build-failure
    with php-mf2 (LP: #1564492, Closes #815620).

ubuntu/xenial 2016-03-31 18:18:42 UTC 2016-03-31
Import patches-unapplied version 9.20160115ubuntu3 to ubuntu/xenial-proposed

Author: Nish Aravamudan
Author Date: 2016-03-31 15:33:23 UTC

Import patches-unapplied version 9.20160115ubuntu3 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 5d3e4fb18f79cdb74327ff0fb1235f64f3ee2d9e

New changelog entries:
  * Backport upstream commit 9ca73a0a ("Pass -a to grep to handle
    substvars with unicode content gracefully") to fix build-failure
    with php-mf2 (LP: #1564492, Closes #815620).

ubuntu/wily 2015-10-05 13:34:17 UTC 2015-10-05
Import patches-unapplied version 9.20150811ubuntu2 to ubuntu/wily-proposed

Author: Martin Pitt
Author Date: 2015-10-05 12:33:20 UTC

Import patches-unapplied version 9.20150811ubuntu2 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: d3a3c4d52b72ad0cc65704c3715b7cfb2f2f6c0e

New changelog entries:
  * dh_movefiles: Expand globs in arguments passed in all
    compat levels (and not just compat 1 and 2).
    (Closes: #800332) (cherry-picked from Debian)

ubuntu/wily-devel 2015-10-05 13:34:17 UTC 2015-10-05
Import patches-unapplied version 9.20150811ubuntu2 to ubuntu/wily-proposed

Author: Martin Pitt
Author Date: 2015-10-05 12:33:20 UTC

Import patches-unapplied version 9.20150811ubuntu2 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: d3a3c4d52b72ad0cc65704c3715b7cfb2f2f6c0e

New changelog entries:
  * dh_movefiles: Expand globs in arguments passed in all
    compat levels (and not just compat 1 and 2).
    (Closes: #800332) (cherry-picked from Debian)

ubuntu/wily-proposed 2015-10-05 13:34:17 UTC 2015-10-05
Import patches-unapplied version 9.20150811ubuntu2 to ubuntu/wily-proposed

Author: Martin Pitt
Author Date: 2015-10-05 12:33:20 UTC

Import patches-unapplied version 9.20150811ubuntu2 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: d3a3c4d52b72ad0cc65704c3715b7cfb2f2f6c0e

New changelog entries:
  * dh_movefiles: Expand globs in arguments passed in all
    compat levels (and not just compat 1 and 2).
    (Closes: #800332) (cherry-picked from Debian)

ubuntu/vivid 2015-01-07 10:23:29 UTC 2015-01-07
Import patches-unapplied version 9.20150101ubuntu1 to ubuntu/vivid-proposed

Author: Iain Lane
Author Date: 2015-01-07 09:48:12 UTC

Import patches-unapplied version 9.20150101ubuntu1 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: c798c45ccb57593754f0d4300de768335e894ad3

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - Depend on dh-apparmor.
    - autoscripts/preinst-upstart-compatibility: Handle upgrades from older
      versions that created the /lib/init/upstart-job symlink.
    - autoscripts/*-init*: Test for /etc/init/*.conf where necessary.
    - dh_installinit: Add no-op --upstart-only option for compatibility.
    - dh_installudev: Change default rules.d symlink priority to 40.
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7. This floods packages with huge upstream changelogs which
      take precious CD space.

ubuntu/vivid-proposed 2015-01-07 10:23:29 UTC 2015-01-07
Import patches-unapplied version 9.20150101ubuntu1 to ubuntu/vivid-proposed

Author: Iain Lane
Author Date: 2015-01-07 09:48:12 UTC

Import patches-unapplied version 9.20150101ubuntu1 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: c798c45ccb57593754f0d4300de768335e894ad3

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - Depend on dh-apparmor.
    - autoscripts/preinst-upstart-compatibility: Handle upgrades from older
      versions that created the /lib/init/upstart-job symlink.
    - autoscripts/*-init*: Test for /etc/init/*.conf where necessary.
    - dh_installinit: Add no-op --upstart-only option for compatibility.
    - dh_installudev: Change default rules.d symlink priority to 40.
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7. This floods packages with huge upstream changelogs which
      take precious CD space.

ubuntu/vivid-devel 2015-01-07 10:23:29 UTC 2015-01-07
Import patches-unapplied version 9.20150101ubuntu1 to ubuntu/vivid-proposed

Author: Iain Lane
Author Date: 2015-01-07 09:48:12 UTC

Import patches-unapplied version 9.20150101ubuntu1 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: c798c45ccb57593754f0d4300de768335e894ad3

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - Depend on dh-apparmor.
    - autoscripts/preinst-upstart-compatibility: Handle upgrades from older
      versions that created the /lib/init/upstart-job symlink.
    - autoscripts/*-init*: Test for /etc/init/*.conf where necessary.
    - dh_installinit: Add no-op --upstart-only option for compatibility.
    - dh_installudev: Change default rules.d symlink priority to 40.
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7. This floods packages with huge upstream changelogs which
      take precious CD space.

ubuntu/utopic-devel 2014-07-31 09:28:53 UTC 2014-07-31
Import patches-unapplied version 9.20140613ubuntu2 to ubuntu/utopic-proposed

Author: Dimitri John Ledkov
Author Date: 2014-07-31 09:02:24 UTC

Import patches-unapplied version 9.20140613ubuntu2 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: b0cf32d6ddde35bead817291f4990f263f35dedc

New changelog entries:
  * Remove ubuntu delta and thus call update-rc.d remove in postrm, upon
    removing init.d scripts even if a matching upstart job is
    present. (LP: #1326327)

ubuntu/utopic 2014-07-31 09:28:53 UTC 2014-07-31
Import patches-unapplied version 9.20140613ubuntu2 to ubuntu/utopic-proposed

Author: Dimitri John Ledkov
Author Date: 2014-07-31 09:02:24 UTC

Import patches-unapplied version 9.20140613ubuntu2 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: b0cf32d6ddde35bead817291f4990f263f35dedc

New changelog entries:
  * Remove ubuntu delta and thus call update-rc.d remove in postrm, upon
    removing init.d scripts even if a matching upstart job is
    present. (LP: #1326327)

ubuntu/utopic-proposed 2014-07-31 09:28:53 UTC 2014-07-31
Import patches-unapplied version 9.20140613ubuntu2 to ubuntu/utopic-proposed

Author: Dimitri John Ledkov
Author Date: 2014-07-31 09:02:24 UTC

Import patches-unapplied version 9.20140613ubuntu2 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: b0cf32d6ddde35bead817291f4990f263f35dedc

New changelog entries:
  * Remove ubuntu delta and thus call update-rc.d remove in postrm, upon
    removing init.d scripts even if a matching upstart job is
    present. (LP: #1326327)

ubuntu/trusty-proposed 2014-02-19 14:38:33 UTC 2014-02-19
Import patches-unapplied version 9.20131227ubuntu1 to ubuntu/trusty-proposed

Author: Dimitri John Ledkov
Author Date: 2014-02-19 14:18:57 UTC

Import patches-unapplied version 9.20131227ubuntu1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: fc76ea92221d4197bf5431a7bcdedfac77739546

New changelog entries:
  * Resynchronise with Debian. Remaining changes:
    - Depend on dh-apparmor.
    - dh_installinit, autoscripts/postinst-upstart-replace: Prefer upstart
      jobs where they exist.
    - autoscripts/preinst-upstart-compatibility: Handle upgrades from older
      versions that created the /lib/init/upstart-job symlink.
    - autoscripts/postinst-init*: Only call update-rc.d when there's no
      upstart job.
    - autoscripts/*-init*: Test for /etc/init/*.conf where necessary.
    - dh_installinit: Add no-op --upstart-only option for compatibility.
    - dh_installudev: Change default rules.d symlink priority to 40.
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7. This floods packages with huge upstream changelogs which
      take precious CD space.
    - preserve the change that adds versioned dependency on sysv-rc to
      support precise->trusty upgrades.

ubuntu/trusty-devel 2014-02-19 14:38:33 UTC 2014-02-19
Import patches-unapplied version 9.20131227ubuntu1 to ubuntu/trusty-proposed

Author: Dimitri John Ledkov
Author Date: 2014-02-19 14:18:57 UTC

Import patches-unapplied version 9.20131227ubuntu1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: fc76ea92221d4197bf5431a7bcdedfac77739546

New changelog entries:
  * Resynchronise with Debian. Remaining changes:
    - Depend on dh-apparmor.
    - dh_installinit, autoscripts/postinst-upstart-replace: Prefer upstart
      jobs where they exist.
    - autoscripts/preinst-upstart-compatibility: Handle upgrades from older
      versions that created the /lib/init/upstart-job symlink.
    - autoscripts/postinst-init*: Only call update-rc.d when there's no
      upstart job.
    - autoscripts/*-init*: Test for /etc/init/*.conf where necessary.
    - dh_installinit: Add no-op --upstart-only option for compatibility.
    - dh_installudev: Change default rules.d symlink priority to 40.
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7. This floods packages with huge upstream changelogs which
      take precious CD space.
    - preserve the change that adds versioned dependency on sysv-rc to
      support precise->trusty upgrades.

ubuntu/trusty 2014-02-19 14:38:33 UTC 2014-02-19
Import patches-unapplied version 9.20131227ubuntu1 to ubuntu/trusty-proposed

Author: Dimitri John Ledkov
Author Date: 2014-02-19 14:18:57 UTC

Import patches-unapplied version 9.20131227ubuntu1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: fc76ea92221d4197bf5431a7bcdedfac77739546

New changelog entries:
  * Resynchronise with Debian. Remaining changes:
    - Depend on dh-apparmor.
    - dh_installinit, autoscripts/postinst-upstart-replace: Prefer upstart
      jobs where they exist.
    - autoscripts/preinst-upstart-compatibility: Handle upgrades from older
      versions that created the /lib/init/upstart-job symlink.
    - autoscripts/postinst-init*: Only call update-rc.d when there's no
      upstart job.
    - autoscripts/*-init*: Test for /etc/init/*.conf where necessary.
    - dh_installinit: Add no-op --upstart-only option for compatibility.
    - dh_installudev: Change default rules.d symlink priority to 40.
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7. This floods packages with huge upstream changelogs which
      take precious CD space.
    - preserve the change that adds versioned dependency on sysv-rc to
      support precise->trusty upgrades.

ubuntu/saucy-proposed 2013-07-01 10:33:23 UTC 2013-07-01
Import patches-unapplied version 9.20130630ubuntu1 to ubuntu/saucy-proposed

Author: Colin Watson
Author Date: 2013-07-01 10:20:37 UTC

Import patches-unapplied version 9.20130630ubuntu1 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 8dd38494f5c1aaa104aa074d7e1ad25998838a07

New changelog entries:
  * Resynchronise with Debian. Remaining changes:
    - Depend on dh-apparmor.
    - dh_installinit, autoscripts/postinst-upstart-replace: Prefer upstart
      jobs where they exist.
    - autoscripts/preinst-upstart-compatibility: Handle upgrades from older
      versions that created the /lib/init/upstart-job symlink.
    - autoscripts/postinst-init*: Only call update-rc.d when there's no
      upstart job.
    - autoscripts/*-init*: Test for /etc/init/*.conf where necessary.
    - dh_installinit: Add no-op --upstart-only option for compatibility.
    - dh_installudev: Change default rules.d symlink priority to 40.
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7. This floods packages with huge upstream changelogs which
      take precious CD space.

ubuntu/saucy 2013-07-01 10:33:23 UTC 2013-07-01
Import patches-unapplied version 9.20130630ubuntu1 to ubuntu/saucy-proposed

Author: Colin Watson
Author Date: 2013-07-01 10:20:37 UTC

Import patches-unapplied version 9.20130630ubuntu1 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 8dd38494f5c1aaa104aa074d7e1ad25998838a07

New changelog entries:
  * Resynchronise with Debian. Remaining changes:
    - Depend on dh-apparmor.
    - dh_installinit, autoscripts/postinst-upstart-replace: Prefer upstart
      jobs where they exist.
    - autoscripts/preinst-upstart-compatibility: Handle upgrades from older
      versions that created the /lib/init/upstart-job symlink.
    - autoscripts/postinst-init*: Only call update-rc.d when there's no
      upstart job.
    - autoscripts/*-init*: Test for /etc/init/*.conf where necessary.
    - dh_installinit: Add no-op --upstart-only option for compatibility.
    - dh_installudev: Change default rules.d symlink priority to 40.
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7. This floods packages with huge upstream changelogs which
      take precious CD space.

ubuntu/saucy-devel 2013-07-01 10:33:23 UTC 2013-07-01
Import patches-unapplied version 9.20130630ubuntu1 to ubuntu/saucy-proposed

Author: Colin Watson
Author Date: 2013-07-01 10:20:37 UTC

Import patches-unapplied version 9.20130630ubuntu1 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 8dd38494f5c1aaa104aa074d7e1ad25998838a07

New changelog entries:
  * Resynchronise with Debian. Remaining changes:
    - Depend on dh-apparmor.
    - dh_installinit, autoscripts/postinst-upstart-replace: Prefer upstart
      jobs where they exist.
    - autoscripts/preinst-upstart-compatibility: Handle upgrades from older
      versions that created the /lib/init/upstart-job symlink.
    - autoscripts/postinst-init*: Only call update-rc.d when there's no
      upstart job.
    - autoscripts/*-init*: Test for /etc/init/*.conf where necessary.
    - dh_installinit: Add no-op --upstart-only option for compatibility.
    - dh_installudev: Change default rules.d symlink priority to 40.
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7. This floods packages with huge upstream changelogs which
      take precious CD space.

ubuntu/raring 2012-11-07 20:42:32 UTC 2012-11-07
Import patches-unapplied version 9.20120909ubuntu1 to ubuntu/raring-proposed

Author: Adam Conrad
Author Date: 2012-11-07 20:12:10 UTC

Import patches-unapplied version 9.20120909ubuntu1 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 1a50170337856e5fc2942a20027298837703d57e

New changelog entries:
  * Merge from Debian unstable, remaining changes:
    - Depend on dh-apparmor.
    - dh_installinit: Add --upstart-only and --onlyscripts-upstart modes.
    - continue to use /lib/init/upstart-job symlinks in Ubuntu, since
      insserv is not yet usable with upstart.
    - Add autoscripts for above: postinst-upstart-replace,
      preinst-removeconffile.
    - autoscripts/postinst-init, autoscripts/postinst-init-restart: Only
      call update-rc.d when there's no upstart job.
    - autoscripts/postinst-init-nostart: also handle the upstart case;
      otherwise we call update-rc.d to add, and again to remove!
    - dh_installudev: Change default init.d symlink priority to 40.
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7. This floods packages with huge upstream changelogs which
      take precious CD space.

ubuntu/raring-proposed 2012-11-07 20:42:32 UTC 2012-11-07
Import patches-unapplied version 9.20120909ubuntu1 to ubuntu/raring-proposed

Author: Adam Conrad
Author Date: 2012-11-07 20:12:10 UTC

Import patches-unapplied version 9.20120909ubuntu1 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 1a50170337856e5fc2942a20027298837703d57e

New changelog entries:
  * Merge from Debian unstable, remaining changes:
    - Depend on dh-apparmor.
    - dh_installinit: Add --upstart-only and --onlyscripts-upstart modes.
    - continue to use /lib/init/upstart-job symlinks in Ubuntu, since
      insserv is not yet usable with upstart.
    - Add autoscripts for above: postinst-upstart-replace,
      preinst-removeconffile.
    - autoscripts/postinst-init, autoscripts/postinst-init-restart: Only
      call update-rc.d when there's no upstart job.
    - autoscripts/postinst-init-nostart: also handle the upstart case;
      otherwise we call update-rc.d to add, and again to remove!
    - dh_installudev: Change default init.d symlink priority to 40.
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7. This floods packages with huge upstream changelogs which
      take precious CD space.

ubuntu/raring-devel 2012-11-07 20:42:32 UTC 2012-11-07
Import patches-unapplied version 9.20120909ubuntu1 to ubuntu/raring-proposed

Author: Adam Conrad
Author Date: 2012-11-07 20:12:10 UTC

Import patches-unapplied version 9.20120909ubuntu1 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 1a50170337856e5fc2942a20027298837703d57e

New changelog entries:
  * Merge from Debian unstable, remaining changes:
    - Depend on dh-apparmor.
    - dh_installinit: Add --upstart-only and --onlyscripts-upstart modes.
    - continue to use /lib/init/upstart-job symlinks in Ubuntu, since
      insserv is not yet usable with upstart.
    - Add autoscripts for above: postinst-upstart-replace,
      preinst-removeconffile.
    - autoscripts/postinst-init, autoscripts/postinst-init-restart: Only
      call update-rc.d when there's no upstart job.
    - autoscripts/postinst-init-nostart: also handle the upstart case;
      otherwise we call update-rc.d to add, and again to remove!
    - dh_installudev: Change default init.d symlink priority to 40.
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7. This floods packages with huge upstream changelogs which
      take precious CD space.

ubuntu/oneiric-updates 2012-10-26 13:03:13 UTC 2012-10-26
Import patches-unapplied version 8.9.0ubuntu2.1 to ubuntu/oneiric-security

Author: Marc Deslauriers
Author Date: 2012-10-19 19:51:55 UTC

Import patches-unapplied version 8.9.0ubuntu2.1 to ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: b0458675513280eca93be5bbb260b7b84e2227c1

New changelog entries:
  * Rebuild for -security pocket so security updates get built with
    new dh_apparmor.

ubuntu/oneiric-security 2012-10-26 13:03:13 UTC 2012-10-26
Import patches-unapplied version 8.9.0ubuntu2.1 to ubuntu/oneiric-security

Author: Marc Deslauriers
Author Date: 2012-10-19 19:51:55 UTC

Import patches-unapplied version 8.9.0ubuntu2.1 to ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: b0458675513280eca93be5bbb260b7b84e2227c1

New changelog entries:
  * Rebuild for -security pocket so security updates get built with
    new dh_apparmor.

ubuntu/oneiric-devel 2012-10-26 13:03:13 UTC 2012-10-26
Import patches-unapplied version 8.9.0ubuntu2.1 to ubuntu/oneiric-security

Author: Marc Deslauriers
Author Date: 2012-10-19 19:51:55 UTC

Import patches-unapplied version 8.9.0ubuntu2.1 to ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: b0458675513280eca93be5bbb260b7b84e2227c1

New changelog entries:
  * Rebuild for -security pocket so security updates get built with
    new dh_apparmor.

applied/debian/wheezy 2012-09-10 22:17:42 UTC 2012-09-10
Import patches-applied version 9.20120909 to applied/debian/sid

Author: Joey Hess
Author Date: 2012-09-10 16:54:06 UTC

Import patches-applied version 9.20120909 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 2228b47213c7933e00288556f3558564395c225d
Unapplied parent: 1a50170337856e5fc2942a20027298837703d57e

New changelog entries:
  * autoscript() can now be passed a perl sub to run to s/// lines of
    the script, which avoids problems with using sed, including potentially
    building too long a sed command-line. This will become the recommended
    interface in the future; for now it can be used by specific commands
    such as dh_installxmlcatalogs that encounter the problem.
    Closes: #665296 Thanks, Marcin Owsiany
  * Updated Spanish man page translation. Closes: #686291
  * Updated German man page translation. Closes: #685538
  * Updated French man page translation. Closes: #685560

debian/wheezy 2012-09-10 22:17:42 UTC 2012-09-10
Import patches-unapplied version 9.20120909 to debian/sid

Author: Joey Hess
Author Date: 2012-09-10 16:54:06 UTC

Import patches-unapplied version 9.20120909 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 8c8d37877c2592afd1ece6665ce1f16f658e70ca

New changelog entries:
  * autoscript() can now be passed a perl sub to run to s/// lines of
    the script, which avoids problems with using sed, including potentially
    building too long a sed command-line. This will become the recommended
    interface in the future; for now it can be used by specific commands
    such as dh_installxmlcatalogs that encounter the problem.
    Closes: #665296 Thanks, Marcin Owsiany
  * Updated Spanish man page translation. Closes: #686291
  * Updated German man page translation. Closes: #685538
  * Updated French man page translation. Closes: #685560

ubuntu/oneiric-proposed 2012-07-30 02:33:47 UTC 2012-07-30
Import patches-unapplied version 8.9.0ubuntu2 to ubuntu/oneiric-proposed

Author: Clint Byrum
Author Date: 2012-06-12 06:24:06 UTC

Import patches-unapplied version 8.9.0ubuntu2 to ubuntu/oneiric-proposed

Imported using git-ubuntu import.

Changelog parent: ea828879033f5642f2806b73b036304b6695e712

New changelog entries:
  * autoscripts/postrm-apparmor: do not delete local files if main
    conffile still exists since it probably means it is owned by a
    new/different package. (LP: #986892)

ubuntu/quantal-devel 2012-06-19 22:04:21 UTC 2012-06-19
Import patches-unapplied version 9.20120608ubuntu1 to ubuntu/quantal

Author: Adam Conrad
Author Date: 2012-06-19 20:25:04 UTC

Import patches-unapplied version 9.20120608ubuntu1 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 0247726f6bd1fafb97dc65971a1828c12aaa0aff

New changelog entries:
  * Merge from Debian unstable, remaining changes:
    - Depend on dh-apparmor.
    - dh_installinit: Add --upstart-only and --onlyscripts-upstart modes.
    - continue to use /lib/init/upstart-job symlinks in Ubuntu, since
      insserv is not yet usable with upstart.
    - Add autoscripts for above: postinst-upstart-replace,
      preinst-removeconffile.
    - autoscripts/postinst-init, autoscripts/postinst-init-restart: Only
      call update-rc.d when there's no upstart job.
    - autoscripts/postinst-init-nostart: also handle the upstart case;
      otherwise we call update-rc.d to add, and again to remove!
    - dh_installudev: Change default init.d symlink priority to 40.
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7. This floods packages with huge upstream changelogs which
      take precious CD space.
  * Dropped changes, superseded in Debian:
    - Mark debhelper Multi-Arch: foreign, so it's recognized as satisfying
      cross-dependencies and cross-build-dependencies.

ubuntu/quantal 2012-06-19 22:04:21 UTC 2012-06-19
Import patches-unapplied version 9.20120608ubuntu1 to ubuntu/quantal

Author: Adam Conrad
Author Date: 2012-06-19 20:25:04 UTC

Import patches-unapplied version 9.20120608ubuntu1 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 0247726f6bd1fafb97dc65971a1828c12aaa0aff

New changelog entries:
  * Merge from Debian unstable, remaining changes:
    - Depend on dh-apparmor.
    - dh_installinit: Add --upstart-only and --onlyscripts-upstart modes.
    - continue to use /lib/init/upstart-job symlinks in Ubuntu, since
      insserv is not yet usable with upstart.
    - Add autoscripts for above: postinst-upstart-replace,
      preinst-removeconffile.
    - autoscripts/postinst-init, autoscripts/postinst-init-restart: Only
      call update-rc.d when there's no upstart job.
    - autoscripts/postinst-init-nostart: also handle the upstart case;
      otherwise we call update-rc.d to add, and again to remove!
    - dh_installudev: Change default init.d symlink priority to 40.
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7. This floods packages with huge upstream changelogs which
      take precious CD space.
  * Dropped changes, superseded in Debian:
    - Mark debhelper Multi-Arch: foreign, so it's recognized as satisfying
      cross-dependencies and cross-build-dependencies.

ubuntu/precise-devel 2012-03-02 22:33:58 UTC 2012-03-02
Import patches-unapplied version 9.20120115ubuntu3 to ubuntu/precise

Author: Jamie Strandboge
Author Date: 2012-03-02 14:13:33 UTC

Import patches-unapplied version 9.20120115ubuntu3 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 24e0238819050eeb021231be0dd8e1c231f36bac

New changelog entries:
  * remove dh_apparmor and corresponding autoscripts and adjust debian/control
    to Depends on dh-apparmor. This can be dropped once all packages that use
    dh_apparmor Build-Depends on dh-apparmor.

ubuntu/precise 2012-03-02 22:33:58 UTC 2012-03-02
Import patches-unapplied version 9.20120115ubuntu3 to ubuntu/precise

Author: Jamie Strandboge
Author Date: 2012-03-02 14:13:33 UTC

Import patches-unapplied version 9.20120115ubuntu3 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 24e0238819050eeb021231be0dd8e1c231f36bac

New changelog entries:
  * remove dh_apparmor and corresponding autoscripts and adjust debian/control
    to Depends on dh-apparmor. This can be dropped once all packages that use
    dh_apparmor Build-Depends on dh-apparmor.

ubuntu/oneiric 2011-07-01 23:04:42 UTC 2011-07-01
Import patches-unapplied version 8.9.0ubuntu1 to ubuntu/oneiric

Author: أحمد المحمودي (Ahmed El-Mahmoudy)
Author Date: 2011-07-01 22:04:09 UTC

Import patches-unapplied version 8.9.0ubuntu1 to ubuntu/oneiric

Imported using git-ubuntu import.

Changelog parent: 16b3f27b500b3778268d0798768aef6c173d9ba4

New changelog entries:
  * Merge with Debian (LP: #801884); remaining changes:
    - dh_installinit: Add --upstart-only and --onlyscripts-upstart modes.
    - Add various autoscripts for above: postinst-upstart,
      postinst-upstart-replace, postinst-upstart-restart,
      prerm-upstart, prerm-upstart-norestart, preinst-removeconffile.
    - dh_installudev: Change default init.d symlink priority to 40.
    - dh_installchangelogs: Do not install upstream changelog in compat level
      7. This floods packages with huge upstream changelogs which take
      precious CD space.
    - add dh_apparmor and autoscripts
    - debian/rules: set executable bit for dh_apparmor before actually running
      dh build, that is in order to get the manpage built for dh_apparmor.
    - dh_installinit: drop redundant definition of -O.
    - debian/control: dpkg-dev dependency needs to be on 1.16.0~ubuntu4 for
      multiarch, not just 1.16.0~.

ubuntu/natty-devel 2011-03-22 00:04:53 UTC 2011-03-22
Import patches-unapplied version 8.1.2ubuntu4 to ubuntu/natty

Author: Steve Langasek
Author Date: 2011-03-21 22:59:12 UTC

Import patches-unapplied version 8.1.2ubuntu4 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 9e4fff5b9615f5da5ec1839e3b4fbb7f31dba35d

New changelog entries:
  * debhelper.pod: v9 info was added in the wrong place by mistake; move it
    to where it belongs so the manpage reads sensibly again.

ubuntu/natty 2011-03-22 00:04:53 UTC 2011-03-22
Import patches-unapplied version 8.1.2ubuntu4 to ubuntu/natty

Author: Steve Langasek
Author Date: 2011-03-21 22:59:12 UTC

Import patches-unapplied version 8.1.2ubuntu4 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 9e4fff5b9615f5da5ec1839e3b4fbb7f31dba35d

New changelog entries:
  * debhelper.pod: v9 info was added in the wrong place by mistake; move it
    to where it belongs so the manpage reads sensibly again.

ubuntu/maverick 2010-08-10 13:05:14 UTC 2010-08-10
Import patches-unapplied version 8.0.0ubuntu1 to ubuntu/maverick

Author: أحمد المحمودي (Ahmed El-Mahmoudy)
Author Date: 2010-08-10 09:45:25 UTC

Import patches-unapplied version 8.0.0ubuntu1 to ubuntu/maverick

Imported using git-ubuntu import.

Changelog parent: e2af1bb62358299b8cb34b4f4b6a2ba4b7e974ae

New changelog entries:
  * Merge with Debian (LP: #614787); remaining changes:
    - dh_installinit: Add --upstart-only and --onlyscripts-upstart modes.
    - Add various autoscripts for above: postinst-upstart,
      postinst-upstart-replace, postinst-upstart-restart,
      prerm-upstart, prerm-upstart-norestart, preinst-removeconffile.
    - dh_installudev: Change default init.d symlink priority to 40.
    - dh_installchangelogs: Do not install upstream changelog in compat level
      7. This floods packages with huge upstream changelogs which take
      precious CD space.
    - dh_strip, dh_makeshlibs: use triplet-objdump, triplet-objcopy and
      triplet-strip from cross-binutils when cross-compiling; Debian #412118.
    - add dh_apparmor and autoscripts
  * debian/rules: override build target to set executable bit for dh_apparmor
    before actually running dh build, that is in order to get the manpage
    built for dh_apparmor.

ubuntu/maverick-devel 2010-08-10 13:05:14 UTC 2010-08-10
Import patches-unapplied version 8.0.0ubuntu1 to ubuntu/maverick

Author: أحمد المحمودي (Ahmed El-Mahmoudy)
Author Date: 2010-08-10 09:45:25 UTC

Import patches-unapplied version 8.0.0ubuntu1 to ubuntu/maverick

Imported using git-ubuntu import.

Changelog parent: e2af1bb62358299b8cb34b4f4b6a2ba4b7e974ae

New changelog entries:
  * Merge with Debian (LP: #614787); remaining changes:
    - dh_installinit: Add --upstart-only and --onlyscripts-upstart modes.
    - Add various autoscripts for above: postinst-upstart,
      postinst-upstart-replace, postinst-upstart-restart,
      prerm-upstart, prerm-upstart-norestart, preinst-removeconffile.
    - dh_installudev: Change default init.d symlink priority to 40.
    - dh_installchangelogs: Do not install upstream changelog in compat level
      7. This floods packages with huge upstream changelogs which take
      precious CD space.
    - dh_strip, dh_makeshlibs: use triplet-objdump, triplet-objcopy and
      triplet-strip from cross-binutils when cross-compiling; Debian #412118.
    - add dh_apparmor and autoscripts
  * debian/rules: override build target to set executable bit for dh_apparmor
    before actually running dh build, that is in order to get the manpage
    built for dh_apparmor.

debian/squeeze 2010-08-08 02:16:40 UTC 2010-08-08
Import patches-unapplied version 8.0.0 to debian/sid

Author: Joey Hess
Author Date: 2010-08-07 15:27:24 UTC

Import patches-unapplied version 8.0.0 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c14c2a920b9140403ac2a9eed9a1dc1863d82d37

New changelog entries:
  [ Carsten Hey ]
  * dh_fixperms: Ensure files in /etc/sudoers.d/ are mode 440. Closes: #589574
  [ Joey Hess ]
  * Finalized v8 mode, which is the new recommended default.

applied/debian/squeeze 2010-08-08 02:16:40 UTC 2010-08-08
Import patches-applied version 8.0.0 to applied/debian/sid

Author: Joey Hess
Author Date: 2010-08-07 15:27:24 UTC

Import patches-applied version 8.0.0 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 475d3ae202934d0fd38fa2ffd069fe50bb47c668
Unapplied parent: e2af1bb62358299b8cb34b4f4b6a2ba4b7e974ae

New changelog entries:
  [ Carsten Hey ]
  * dh_fixperms: Ensure files in /etc/sudoers.d/ are mode 440. Closes: #589574
  [ Joey Hess ]
  * Finalized v8 mode, which is the new recommended default.

ubuntu/lucid-devel 2010-02-22 13:05:25 UTC 2010-02-22
Import patches-unapplied version 7.4.15ubuntu1 to ubuntu/lucid

Author: Colin Watson
Author Date: 2010-02-22 12:46:04 UTC

Import patches-unapplied version 7.4.15ubuntu1 to ubuntu/lucid

Imported using git-ubuntu import.

Changelog parent: 2e3280b6e1a35ae533983aee75d9f6073eee6fcb

New changelog entries:
  * Resynchronise with Debian. Remaining changes:
    - dh_installinit: Add --upstart-only and --onlyscripts-upstart modes.
    - Add various autoscripts for above: postinst-upstart,
      postinst-upstart-replace, postinst-upstart-restart,
      prerm-upstart, prerm-upstart-norestart, preinst-removeconffile.
    - dh_installudev: Handle conffile migration from old Ubuntu defaults
      (needed until after the next LTS release).

ubuntu/lucid 2010-02-22 13:05:25 UTC 2010-02-22
Import patches-unapplied version 7.4.15ubuntu1 to ubuntu/lucid

Author: Colin Watson
Author Date: 2010-02-22 12:46:04 UTC

Import patches-unapplied version 7.4.15ubuntu1 to ubuntu/lucid

Imported using git-ubuntu import.

Changelog parent: 2e3280b6e1a35ae533983aee75d9f6073eee6fcb

New changelog entries:
  * Resynchronise with Debian. Remaining changes:
    - dh_installinit: Add --upstart-only and --onlyscripts-upstart modes.
    - Add various autoscripts for above: postinst-upstart,
      postinst-upstart-replace, postinst-upstart-restart,
      prerm-upstart, prerm-upstart-norestart, preinst-removeconffile.
    - dh_installudev: Handle conffile migration from old Ubuntu defaults
      (needed until after the next LTS release).

ubuntu/karmic-devel 2009-10-02 09:04:30 UTC 2009-10-02
Import patches-unapplied version 7.3.15ubuntu3 to ubuntu/karmic

Author: Steve Langasek
Author Date: 2009-09-30 20:57:14 UTC

Import patches-unapplied version 7.3.15ubuntu3 to ubuntu/karmic

Imported using git-ubuntu import.

Changelog parent: 0d5407a0fd84d5699e34d80d30ac56f383d77445

New changelog entries:
  * dh_installinit:
    - Create the upstart-job symlink even when --upstart-only is called,
      since this simplifies implementation of...
    - --restart-after-upgrade: we can't use the upstart 'restart' command here
      because this will give wrong behavior if we're adding a new job to an
      existing package; instead just use the standard invoke-rc.d snippet,
      which (combined with the above) will at least give us compatibility
      with policy-rc.d for preventing stopped jobs from starting on upgrade.
      (N.B.: prerm scripts could also safely reuse the invoke-rc.d handling
      instead of calling 'stop' directly, but leaving this alone for now
      because the current behavior is only minorly buggy.)
    - Drop unnecessary UPSTART_ONLY check; --upstart-only should never be set
      without having an upstart job so this is redundant.
    - postinst-reboot-required is never the right snippet to include here.
    - Merge in the final changes to the upstartification as accepted into
      debhelper upstream, dropping the --onlyscripts-upstart option from
      the documentation but mapping it to --onlyscripts for compatibility in
      karmic.
  * autoscript/postinst-upstart: typo fix.

ubuntu/karmic 2009-10-02 09:04:30 UTC 2009-10-02
Import patches-unapplied version 7.3.15ubuntu3 to ubuntu/karmic

Author: Steve Langasek
Author Date: 2009-09-30 20:57:14 UTC

Import patches-unapplied version 7.3.15ubuntu3 to ubuntu/karmic

Imported using git-ubuntu import.

Changelog parent: 0d5407a0fd84d5699e34d80d30ac56f383d77445

New changelog entries:
  * dh_installinit:
    - Create the upstart-job symlink even when --upstart-only is called,
      since this simplifies implementation of...
    - --restart-after-upgrade: we can't use the upstart 'restart' command here
      because this will give wrong behavior if we're adding a new job to an
      existing package; instead just use the standard invoke-rc.d snippet,
      which (combined with the above) will at least give us compatibility
      with policy-rc.d for preventing stopped jobs from starting on upgrade.
      (N.B.: prerm scripts could also safely reuse the invoke-rc.d handling
      instead of calling 'stop' directly, but leaving this alone for now
      because the current behavior is only minorly buggy.)
    - Drop unnecessary UPSTART_ONLY check; --upstart-only should never be set
      without having an upstart job so this is redundant.
    - postinst-reboot-required is never the right snippet to include here.
    - Merge in the final changes to the upstartification as accepted into
      debhelper upstream, dropping the --onlyscripts-upstart option from
      the documentation but mapping it to --onlyscripts for compatibility in
      karmic.
  * autoscript/postinst-upstart: typo fix.

ubuntu/jaunty-devel 2009-03-09 16:05:00 UTC 2009-03-09
Import patches-unapplied version 7.0.17ubuntu4 to ubuntu/jaunty

Author: Michael Bienia
Author Date: 2009-03-09 15:17:31 UTC

Import patches-unapplied version 7.0.17ubuntu4 to ubuntu/jaunty

Imported using git-ubuntu import.

Changelog parent: 2d53e452d96abf30a03f1e28a7683c4eb9615a4c

New changelog entries:
  * dh_auto_install: add "--install-layout=deb" to setup.py install calls.

ubuntu/jaunty 2009-03-09 16:05:00 UTC 2009-03-09
Import patches-unapplied version 7.0.17ubuntu4 to ubuntu/jaunty

Author: Michael Bienia
Author Date: 2009-03-09 15:17:31 UTC

Import patches-unapplied version 7.0.17ubuntu4 to ubuntu/jaunty

Imported using git-ubuntu import.

Changelog parent: 2d53e452d96abf30a03f1e28a7683c4eb9615a4c

New changelog entries:
  * dh_auto_install: add "--install-layout=deb" to setup.py install calls.

ubuntu/hardy-backports 2008-11-10 15:04:16 UTC 2008-11-10
Import patches-unapplied version 7.0.13ubuntu1~hardy1 to ubuntu/hardy-backports

Author: Michael Casadevall
Author Date: 2008-11-10 13:04:27 UTC

Import patches-unapplied version 7.0.13ubuntu1~hardy1 to ubuntu/hardy-backports

Imported using git-ubuntu import.

Changelog parent: 5087ec3771106c0af3d83888b7ffda6fcbc4b143

New changelog entries:
  * Automated backport upload; no source changes.

debian/lenny 2008-10-29 13:00:25 UTC 2008-10-29
Import patches-unapplied version 7.0.15 to debian/lenny

Author: Joey Hess
Author Date: 2008-07-09 20:16:11 UTC

Import patches-unapplied version 7.0.15 to debian/lenny

Imported using git-ubuntu import.

applied/debian/lenny 2008-10-29 13:00:25 UTC 2008-10-29
Import patches-applied version 7.0.15 to applied/debian/lenny

Author: Joey Hess
Author Date: 2008-07-09 20:16:11 UTC

Import patches-applied version 7.0.15 to applied/debian/lenny

Imported using git-ubuntu import.

Unapplied parent: 01da7bdfbf228fc52f7142873aae85dca9cf58c1

ubuntu/intrepid-devel 2008-06-28 01:04:16 UTC 2008-06-28
Import patches-unapplied version 7.0.13ubuntu1 to ubuntu/intrepid

Author: Steve Langasek
Author Date: 2008-06-28 00:41:46 UTC

Import patches-unapplied version 7.0.13ubuntu1 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: e8494cb1421f8cd5e1f458d8b43fc6bba0db758d

New changelog entries:
  * Merge from Debian unstable, remaining changes:
    - autoscripts/postinst-scrollkeeper: Do not show scrollkeeper-update
      output.
    - dh_installudev: Use priority 50 by default (instead of z60) and '-'
      separator (instead of '_').
    - dh_installxfonts: Use versioned dependency for xfonts-utils. This should
      be kept until dapper goes out of support, to avoid broken dapper
      backports.
  * dh_auto_install: Rather than looking at the number of binary packages
    being acted on, look at the total number of binary packages in the
    source package when deciding whether to install to debian/package or
    debian/tmp. This avoids inconsistencies when building mixed arch all+any
    packages using the binary-indep and binary-arch targets.
    Closes: #487938
  * Correct docs about dh_install and debian/tmp in v7 mode. It first looks in
    the current directory, or whatever is configured with --srcdir. Then it
    always falls back to looking in debian/tmp.
  * Medium urgency to get this doc fix into testing.

ubuntu/intrepid 2008-06-28 01:04:16 UTC 2008-06-28
Import patches-unapplied version 7.0.13ubuntu1 to ubuntu/intrepid

Author: Steve Langasek
Author Date: 2008-06-28 00:41:46 UTC

Import patches-unapplied version 7.0.13ubuntu1 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: e8494cb1421f8cd5e1f458d8b43fc6bba0db758d

New changelog entries:
  * Merge from Debian unstable, remaining changes:
    - autoscripts/postinst-scrollkeeper: Do not show scrollkeeper-update
      output.
    - dh_installudev: Use priority 50 by default (instead of z60) and '-'
      separator (instead of '_').
    - dh_installxfonts: Use versioned dependency for xfonts-utils. This should
      be kept until dapper goes out of support, to avoid broken dapper
      backports.
  * dh_auto_install: Rather than looking at the number of binary packages
    being acted on, look at the total number of binary packages in the
    source package when deciding whether to install to debian/package or
    debian/tmp. This avoids inconsistencies when building mixed arch all+any
    packages using the binary-indep and binary-arch targets.
    Closes: #487938
  * Correct docs about dh_install and debian/tmp in v7 mode. It first looks in
    the current directory, or whatever is configured with --srcdir. Then it
    always falls back to looking in debian/tmp.
  * Medium urgency to get this doc fix into testing.

ubuntu/hardy 2008-01-28 08:03:54 UTC 2008-01-28
Import patches-unapplied version 6.0.4ubuntu1 to ubuntu/hardy

Author: Michael Bienia
Author Date: 2008-01-26 13:14:22 UTC

Import patches-unapplied version 6.0.4ubuntu1 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: bc843404d337104fc76d88cb88bff7dc77e26aa4

New changelog entries:
  * Merge with Debian unstable (LP: #184545). Remaining changes:
    - autoscripts/postinst-scrollkeeper: Do not show scrollkeeper-update
      output.
    - dh_installudev: Use priority 50 by default (instead of z60) and '-'
      separator (instead of '_').
    - dh_installxfonts: Use versioned dependency for xfonts-utils. This should
      be kept until dapper goes out of support, to avoid broken dapper
      backports.
    - dh_python: Add 2.5 as supported Python version. dh_python is generally
      deprecated in favor of dh_py{central,support}, but universe might still
      have some unconverted packages. This should be dropped at some point,
      though.
  * dh_strip: Improve the idempotency fix put in for #380314.
  * dh_strip: The -k flag didn't work (--keep did). Fix.
  * dh_shlibdeps: Add emul to exclude list.
  * dh_link: -X can be used to avoid it modifying symlinks to be compliant
    with policy. Closes: #461392
  * dh_shlibdeps: Rather than skipping everything in /usr/lib/debug,
    which can include debug libraries that dpkg-shlibdeps should look at,
    only skip the subdirectories of it that contain separate debugging
    symbols. (Hardcoding the names of those directories is not the best
    implementation, but it will do for now.) Closes: #461339
  * Revert slightly broken refactoring of some exclude code.
    Closes: #460340, #460351
  * dh_installdocs/examples: Don't unnecessarily use the exclude code path.
  * dh_install{,docs,examples}: Avoid infinite recursion when told to
    install a directory ending with "/." (slashdot effect?) when exclusion is
    enabled. Emulate the behavior of cp in this case. Closes: #253234
  * dh_install: Fix #459426 here too.
  * dh_gencontrol: Stop passing -isp, it's the default now. Closes: #458114
  * dh_shlibdeps: Update documentation for -L and -l. dpkg-shlibdeps is now
    much smarter, and these options are almost never needed. Closes: #459226
  * dh_shlibdeps: If a relative path is specified in -l, don't prepend the pwd
    to it, instead just prepend a slash to make it absolute. dpkg-shlibdeps
    has changed how it used LD_LIBRARY_PATH, so making it point into the
    package build directory won't work.
  * dh_shlibdeps: Change "-L pkg" to cause "-Sdebian/pkg" to be passed to
    dpkg-shlibdeps. The old behavior of passing -L to dpkg-shlibdeps didn't
    affect where it looked for symbols files. Closes: #459224
  * Depend on dpkg-dev 1.14.15, the first to support dpkg-shlibdeps -S.
  * dh_installdocs, dh_installexamples: Support files with spaces in exclude
    mode. Closes: #459426
  * debhelper v6 mode is finalised and is the new recommended compatibility
    level.
  * dh_installdocs: Tighten doc-base document id parsing to only accept
    the characters that the doc-base manual allows in the id. Closes: #445541

ubuntu/hardy-devel 2008-01-28 08:03:54 UTC 2008-01-28
Import patches-unapplied version 6.0.4ubuntu1 to ubuntu/hardy

Author: Michael Bienia
Author Date: 2008-01-26 13:14:22 UTC

Import patches-unapplied version 6.0.4ubuntu1 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: bc843404d337104fc76d88cb88bff7dc77e26aa4

New changelog entries:
  * Merge with Debian unstable (LP: #184545). Remaining changes:
    - autoscripts/postinst-scrollkeeper: Do not show scrollkeeper-update
      output.
    - dh_installudev: Use priority 50 by default (instead of z60) and '-'
      separator (instead of '_').
    - dh_installxfonts: Use versioned dependency for xfonts-utils. This should
      be kept until dapper goes out of support, to avoid broken dapper
      backports.
    - dh_python: Add 2.5 as supported Python version. dh_python is generally
      deprecated in favor of dh_py{central,support}, but universe might still
      have some unconverted packages. This should be dropped at some point,
      though.
  * dh_strip: Improve the idempotency fix put in for #380314.
  * dh_strip: The -k flag didn't work (--keep did). Fix.
  * dh_shlibdeps: Add emul to exclude list.
  * dh_link: -X can be used to avoid it modifying symlinks to be compliant
    with policy. Closes: #461392
  * dh_shlibdeps: Rather than skipping everything in /usr/lib/debug,
    which can include debug libraries that dpkg-shlibdeps should look at,
    only skip the subdirectories of it that contain separate debugging
    symbols. (Hardcoding the names of those directories is not the best
    implementation, but it will do for now.) Closes: #461339
  * Revert slightly broken refactoring of some exclude code.
    Closes: #460340, #460351
  * dh_installdocs/examples: Don't unnecessarily use the exclude code path.
  * dh_install{,docs,examples}: Avoid infinite recursion when told to
    install a directory ending with "/." (slashdot effect?) when exclusion is
    enabled. Emulate the behavior of cp in this case. Closes: #253234
  * dh_install: Fix #459426 here too.
  * dh_gencontrol: Stop passing -isp, it's the default now. Closes: #458114
  * dh_shlibdeps: Update documentation for -L and -l. dpkg-shlibdeps is now
    much smarter, and these options are almost never needed. Closes: #459226
  * dh_shlibdeps: If a relative path is specified in -l, don't prepend the pwd
    to it, instead just prepend a slash to make it absolute. dpkg-shlibdeps
    has changed how it used LD_LIBRARY_PATH, so making it point into the
    package build directory won't work.
  * dh_shlibdeps: Change "-L pkg" to cause "-Sdebian/pkg" to be passed to
    dpkg-shlibdeps. The old behavior of passing -L to dpkg-shlibdeps didn't
    affect where it looked for symbols files. Closes: #459224
  * Depend on dpkg-dev 1.14.15, the first to support dpkg-shlibdeps -S.
  * dh_installdocs, dh_installexamples: Support files with spaces in exclude
    mode. Closes: #459426
  * debhelper v6 mode is finalised and is the new recommended compatibility
    level.
  * dh_installdocs: Tighten doc-base document id parsing to only accept
    the characters that the doc-base manual allows in the id. Closes: #445541

ubuntu/gutsy 2007-07-12 09:03:27 UTC 2007-07-12
Import patches-unapplied version 5.0.51ubuntu3 to ubuntu/gutsy

Author: Daniel Holbach
Author Date: 2007-07-12 08:26:39 UTC

Import patches-unapplied version 5.0.51ubuntu3 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: 5333d04c33d8a678e392c75688e9b31d0f774952

New changelog entries:
  * autoscripts/postinst-iconcache, autoscripts/postrm-iconcache:
    run gtk-update-icon-cache <args> || true to not bomb out in postinsts.

applied/ubuntu/hardy 2007-07-12 09:03:27 UTC 2007-07-12
Import patches-applied version 5.0.51ubuntu3 to applied/ubuntu/gutsy

Author: Daniel Holbach
Author Date: 2007-07-12 08:26:39 UTC

Import patches-applied version 5.0.51ubuntu3 to applied/ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: a0fabe980aa832c3f8a1d95e1a1ac4b513f7da87
Unapplied parent: 7bfdb394a6f446b42e1f085cecc6342049092423

New changelog entries:
  * autoscripts/postinst-iconcache, autoscripts/postrm-iconcache:
    run gtk-update-icon-cache <args> || true to not bomb out in postinsts.

applied/ubuntu/gutsy-devel 2007-07-12 09:03:27 UTC 2007-07-12
Import patches-applied version 5.0.51ubuntu3 to applied/ubuntu/gutsy

Author: Daniel Holbach
Author Date: 2007-07-12 08:26:39 UTC

Import patches-applied version 5.0.51ubuntu3 to applied/ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: a0fabe980aa832c3f8a1d95e1a1ac4b513f7da87
Unapplied parent: 7bfdb394a6f446b42e1f085cecc6342049092423

New changelog entries:
  * autoscripts/postinst-iconcache, autoscripts/postrm-iconcache:
    run gtk-update-icon-cache <args> || true to not bomb out in postinsts.

applied/ubuntu/gutsy 2007-07-12 09:03:27 UTC 2007-07-12
Import patches-applied version 5.0.51ubuntu3 to applied/ubuntu/gutsy

Author: Daniel Holbach
Author Date: 2007-07-12 08:26:39 UTC

Import patches-applied version 5.0.51ubuntu3 to applied/ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: a0fabe980aa832c3f8a1d95e1a1ac4b513f7da87
Unapplied parent: 7bfdb394a6f446b42e1f085cecc6342049092423

New changelog entries:
  * autoscripts/postinst-iconcache, autoscripts/postrm-iconcache:
    run gtk-update-icon-cache <args> || true to not bomb out in postinsts.

ubuntu/gutsy-devel 2007-07-12 09:03:27 UTC 2007-07-12
Import patches-unapplied version 5.0.51ubuntu3 to ubuntu/gutsy

Author: Daniel Holbach
Author Date: 2007-07-12 08:26:39 UTC

Import patches-unapplied version 5.0.51ubuntu3 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: 5333d04c33d8a678e392c75688e9b31d0f774952

New changelog entries:
  * autoscripts/postinst-iconcache, autoscripts/postrm-iconcache:
    run gtk-update-icon-cache <args> || true to not bomb out in postinsts.

applied/ubuntu/devel 2007-07-12 09:03:27 UTC 2007-07-12
Import patches-applied version 5.0.51ubuntu3 to applied/ubuntu/gutsy

Author: Daniel Holbach
Author Date: 2007-07-12 08:26:39 UTC

Import patches-applied version 5.0.51ubuntu3 to applied/ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: a0fabe980aa832c3f8a1d95e1a1ac4b513f7da87
Unapplied parent: 7bfdb394a6f446b42e1f085cecc6342049092423

New changelog entries:
  * autoscripts/postinst-iconcache, autoscripts/postrm-iconcache:
    run gtk-update-icon-cache <args> || true to not bomb out in postinsts.

applied/ubuntu/hardy-devel 2007-07-12 09:03:27 UTC 2007-07-12
Import patches-applied version 5.0.51ubuntu3 to applied/ubuntu/gutsy

Author: Daniel Holbach
Author Date: 2007-07-12 08:26:39 UTC

Import patches-applied version 5.0.51ubuntu3 to applied/ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: a0fabe980aa832c3f8a1d95e1a1ac4b513f7da87
Unapplied parent: 7bfdb394a6f446b42e1f085cecc6342049092423

New changelog entries:
  * autoscripts/postinst-iconcache, autoscripts/postrm-iconcache:
    run gtk-update-icon-cache <args> || true to not bomb out in postinsts.

applied/ubuntu/feisty-devel 2006-12-20 13:03:38 UTC 2006-12-20
Import patches-applied version 5.0.42ubuntu1 to applied/ubuntu/feisty

Author: Colin Watson
Author Date: 2006-12-20 12:11:03 UTC

Import patches-applied version 5.0.42ubuntu1 to applied/ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: 687c9e7ab4ba5ffb4ead6894965737fd1e2a9a13
Unapplied parent: 03f4923d9471e352a709ec3f82322ca837ecb90f

New changelog entries:
  * Resynchronise with Debian. Remaining changes:
    - autoscripts/postinst-scrollkeeper: Do not display scrollkeeper output.
    - Add dh_iconcache.
    - dh_gconf: Update package versions for Ubuntu.
    - dh_installwm: In backward-compatibility code, assume /usr/bin/X11
      rather than /usr/X11R6/bin.
    - Make dh_installudev conform to Ubuntu udev policy by installing files
      directly under /etc/udev/rules.d/ rather than installing them in
      /etc/udev/ and creating symlinks.
    - dh_installxfonts: Set a versioned Depends on xfonts-utils to ensure
      availability of --x11r7-layout.
  [ Valery Perrin ]
  * Update french translation with recents changes in dh_link and
    dh_installinfo
  [ Joey Hess ]
  * Patch from Simon Paillard to convert French manpages from utf-8 to
    ISO-8859-15. Closes: #397953
  [ Joey Hess ]
  * dh_installchangelogs man page typo. Closes: #393155
  [ Valery Perrin ]
  * Encoding french translation from charset ISO-8859-1 to UTF-8
  * Update french translation with recent change in dh_installchangelogs
  [ Joey Hess ]
  * Tighten python-support and python-central dependencies of debhelper,
    in an IMHO rather futile attempt to deal with derived distributions.
    Closes: #395495
  * Correct some incorrect instances of "v4 only" in docs. Closes: #381536
  * dh_installinfo: Put the section madness to bed by not passing any section
    information to install-info. Current install-info parses INFO-DIR-SECTION
    on its own if that's not specified. Closes: #337215

ubuntu/feisty 2006-12-20 13:03:38 UTC 2006-12-20
Import patches-unapplied version 5.0.42ubuntu1 to ubuntu/feisty

Author: Colin Watson
Author Date: 2006-12-20 12:11:03 UTC

Import patches-unapplied version 5.0.42ubuntu1 to ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: df135ee26d2d360bd65d6c0481c9f3eb9a0de30f

New changelog entries:
  * Resynchronise with Debian. Remaining changes:
    - autoscripts/postinst-scrollkeeper: Do not display scrollkeeper output.
    - Add dh_iconcache.
    - dh_gconf: Update package versions for Ubuntu.
    - dh_installwm: In backward-compatibility code, assume /usr/bin/X11
      rather than /usr/X11R6/bin.
    - Make dh_installudev conform to Ubuntu udev policy by installing files
      directly under /etc/udev/rules.d/ rather than installing them in
      /etc/udev/ and creating symlinks.
    - dh_installxfonts: Set a versioned Depends on xfonts-utils to ensure
      availability of --x11r7-layout.
  [ Valery Perrin ]
  * Update french translation with recents changes in dh_link and
    dh_installinfo
  [ Joey Hess ]
  * Patch from Simon Paillard to convert French manpages from utf-8 to
    ISO-8859-15. Closes: #397953
  [ Joey Hess ]
  * dh_installchangelogs man page typo. Closes: #393155
  [ Valery Perrin ]
  * Encoding french translation from charset ISO-8859-1 to UTF-8
  * Update french translation with recent change in dh_installchangelogs
  [ Joey Hess ]
  * Tighten python-support and python-central dependencies of debhelper,
    in an IMHO rather futile attempt to deal with derived distributions.
    Closes: #395495
  * Correct some incorrect instances of "v4 only" in docs. Closes: #381536
  * dh_installinfo: Put the section madness to bed by not passing any section
    information to install-info. Current install-info parses INFO-DIR-SECTION
    on its own if that's not specified. Closes: #337215

applied/ubuntu/feisty 2006-12-20 13:03:38 UTC 2006-12-20
Import patches-applied version 5.0.42ubuntu1 to applied/ubuntu/feisty

Author: Colin Watson
Author Date: 2006-12-20 12:11:03 UTC

Import patches-applied version 5.0.42ubuntu1 to applied/ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: 687c9e7ab4ba5ffb4ead6894965737fd1e2a9a13
Unapplied parent: 03f4923d9471e352a709ec3f82322ca837ecb90f

New changelog entries:
  * Resynchronise with Debian. Remaining changes:
    - autoscripts/postinst-scrollkeeper: Do not display scrollkeeper output.
    - Add dh_iconcache.
    - dh_gconf: Update package versions for Ubuntu.
    - dh_installwm: In backward-compatibility code, assume /usr/bin/X11
      rather than /usr/X11R6/bin.
    - Make dh_installudev conform to Ubuntu udev policy by installing files
      directly under /etc/udev/rules.d/ rather than installing them in
      /etc/udev/ and creating symlinks.
    - dh_installxfonts: Set a versioned Depends on xfonts-utils to ensure
      availability of --x11r7-layout.
  [ Valery Perrin ]
  * Update french translation with recents changes in dh_link and
    dh_installinfo
  [ Joey Hess ]
  * Patch from Simon Paillard to convert French manpages from utf-8 to
    ISO-8859-15. Closes: #397953
  [ Joey Hess ]
  * dh_installchangelogs man page typo. Closes: #393155
  [ Valery Perrin ]
  * Encoding french translation from charset ISO-8859-1 to UTF-8
  * Update french translation with recent change in dh_installchangelogs
  [ Joey Hess ]
  * Tighten python-support and python-central dependencies of debhelper,
    in an IMHO rather futile attempt to deal with derived distributions.
    Closes: #395495
  * Correct some incorrect instances of "v4 only" in docs. Closes: #381536
  * dh_installinfo: Put the section madness to bed by not passing any section
    information to install-info. Current install-info parses INFO-DIR-SECTION
    on its own if that's not specified. Closes: #337215

ubuntu/feisty-devel 2006-12-20 13:03:38 UTC 2006-12-20
Import patches-unapplied version 5.0.42ubuntu1 to ubuntu/feisty

Author: Colin Watson
Author Date: 2006-12-20 12:11:03 UTC

Import patches-unapplied version 5.0.42ubuntu1 to ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: df135ee26d2d360bd65d6c0481c9f3eb9a0de30f

New changelog entries:
  * Resynchronise with Debian. Remaining changes:
    - autoscripts/postinst-scrollkeeper: Do not display scrollkeeper output.
    - Add dh_iconcache.
    - dh_gconf: Update package versions for Ubuntu.
    - dh_installwm: In backward-compatibility code, assume /usr/bin/X11
      rather than /usr/X11R6/bin.
    - Make dh_installudev conform to Ubuntu udev policy by installing files
      directly under /etc/udev/rules.d/ rather than installing them in
      /etc/udev/ and creating symlinks.
    - dh_installxfonts: Set a versioned Depends on xfonts-utils to ensure
      availability of --x11r7-layout.
  [ Valery Perrin ]
  * Update french translation with recents changes in dh_link and
    dh_installinfo
  [ Joey Hess ]
  * Patch from Simon Paillard to convert French manpages from utf-8 to
    ISO-8859-15. Closes: #397953
  [ Joey Hess ]
  * dh_installchangelogs man page typo. Closes: #393155
  [ Valery Perrin ]
  * Encoding french translation from charset ISO-8859-1 to UTF-8
  * Update french translation with recent change in dh_installchangelogs
  [ Joey Hess ]
  * Tighten python-support and python-central dependencies of debhelper,
    in an IMHO rather futile attempt to deal with derived distributions.
    Closes: #395495
  * Correct some incorrect instances of "v4 only" in docs. Closes: #381536
  * dh_installinfo: Put the section madness to bed by not passing any section
    information to install-info. Current install-info parses INFO-DIR-SECTION
    on its own if that's not specified. Closes: #337215

ubuntu/edgy-devel 2006-10-09 06:03:14 UTC 2006-10-09
Import patches-unapplied version 5.0.37.3ubuntu4 to ubuntu/edgy

Author: Fabio Massimo Di Nitto
Author Date: 2006-10-09 05:10:42 UTC

Import patches-unapplied version 5.0.37.3ubuntu4 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: c7a698ceafe08ee048a0b533c0f9cbdc18911f6f

New changelog entries:
  * dh_installxfonts: Set a versioned Depends on xfonts-utils. This change is
    ubuntu specific. Debian doesn't suffer of this issue because they never
    released a version of xfonts-utils that does not support --x11r7-layout
    option.
    (Closes Ubuntu: #52803)

applied/ubuntu/edgy 2006-10-09 06:03:14 UTC 2006-10-09
Import patches-applied version 5.0.37.3ubuntu4 to applied/ubuntu/edgy

Author: Fabio Massimo Di Nitto
Author Date: 2006-10-09 05:10:42 UTC

Import patches-applied version 5.0.37.3ubuntu4 to applied/ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: 1fcdd90a911d5f3be9d298c180cc21ba351b2d85
Unapplied parent: 12960b4a162a73b1321193a1efb5643e22067a5e

New changelog entries:
  * dh_installxfonts: Set a versioned Depends on xfonts-utils. This change is
    ubuntu specific. Debian doesn't suffer of this issue because they never
    released a version of xfonts-utils that does not support --x11r7-layout
    option.
    (Closes Ubuntu: #52803)

1100 of 118 results

Other repositories

Name Last Modified
lp:ubuntu/+source/debhelper 2019-03-06
11 of 1 result
You can't create new repositories for debhelper in Ubuntu.