Code review comment for lp:~bryce/launchpad/lp-617695-linkui

Revision history for this message
Bryce Harrington (bryce) wrote :

>> + @property
>> + def page_title(self):
>> + return smartquote(
>> + u'Link a distribution source package to the %s component'
>> + % self.context.name)
>
> This is an odd breadcrumb/page_title. Labels are meant to be verbose,
> while this attribute is meant to be tearse so that it fits in the breadcrumbs:
>
> Bug trackers > AbiSource bug tracker > Link component

I don't understand this review comment. I modeled the page_title for this off of the BugTrackerEditView classes' page_title() which looks like this:

    @property
    def page_title(self):
        return smartquote(
            u'Change details for the "%s" bug tracker' % self.context.title)

Can you elaborate on how you think it should be worded?

« Back to merge proposal