Code review comment for lp:~artmello/webbrowser-app/webbrowser-app-bookmarks_top_sites

Revision history for this message
Olivier Tilloy (osomon) wrote :

A tiny remark on semantics:

943 + def ensure_new_tab_view_visible(self):
947 + def ensure_new_tab_view_eventually_hidden(self):

Those two methods should be renamed:

    assert_new_tab_view_eventually_visible()
    assert_new_tab_view_eventually_hidden()

Methods that start with "ensure_" actually perform some actions to ensure that the result is achieved, as opposed to methods that start with "assert_" that merely wait until the condition is verified.

« Back to merge proposal