Mir

Code review comment for lp:~andreas-pokorny/mir/use-input-channel-to-send-input

Revision history for this message
Alan Griffiths (alan-griffiths) wrote :

24 + virtual void send_event(uint32_t seq, MirEvent const& event) const = 0;

Like Kevin says: What is the significance of seq? Why do I need it to send an event?

~~~~

77 +void react_to_result(droidinput::status_t result)

This seems a bad name. Vis:

142 + react_to_result(publisher.publishMotionEvent(seq, ...));

"check_result" is slightly better, "check" possibly better still.

~~~~

90 + channel = new droidinput::InputChannel(droidinput::String8("TODO: Name"), s_fd);

"TODO: Name" is a distracting choice. What is going on here?

review: Needs Fixing

« Back to merge proposal