Code review comment for lp:~alan-griffiths/mir/add-mir_surface_spec_attach

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

I considered 'MirPlacement' but decided not to suggest it because 'MirPlacement' is too general. Once we have a "MirPlacement" that's just for surfaces then if something else needs a placement enum the naming will look inconsistent: MirPlacement, MirSomethingElsePlacement

Please mention it's for placing surfaces in the least, and ideally edges too. So something like 'MirSurfacePlacementEdge'.

I know the team often belittles the importance of naming, but this is a permanent decision about the clarity of our communication to developers.

review: Needs Fixing

« Back to merge proposal