Code review comment for lp:~akretion-team/anybox.recipe.openerp/git-shallow-clone

Revision history for this message
Laurent Mignon (Acsone) (lmi) wrote :

It would be nice to specify generically any argument in the options for the fetch command. We could imagine a naming convention for the options. ex 'fetch.depth', 'fetch.prune'.
The code could be:
for option, value in self.options.items():
   if not option.statswith('fetch'):
       continue
    arg = '--%s' %option.split('.')[1]
    if value:
       arg += "=%s"%value
    fetch_cmd.extend([arg]])

Just an idea

« Back to merge proposal