lp:~zulcss/heat/heat-refresh-ubuntu-style

Created by Chuck Short on 2013-05-29 and last modified on 2013-05-29
Get this branch:
bzr branch lp:~zulcss/heat/heat-refresh-ubuntu-style
Only Chuck Short can upload to this branch. If you are Chuck Short please log in for upload directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Chuck Short
Project:
OpenStack Heat
Status:
Development

Recent revisions

8. By Chuck Short on 2013-05-29

debian/watch: Dropped.

7. By Chuck Short on 2013-05-29

debian/po/*: Dropped.

6. By Chuck Short on 2013-05-29

debian/gbp.conf: Dropped.

5. By Chuck Short on 2013-05-29

Add missing files

4. By Chuck Short on 2013-05-29

Add more missing files

3. By Chuck Short on 2013-05-29

Add missing patch

2. By Chuck Short on 2013-05-29

* New upstream release.
* debian/control, debian/rules: Dropped openstack-pkg-tools.
* debian/control:
  - Dropped python-argparse
  - Dropped python-qpid
  - Added python-pbr
  - Added python-d2to1
  - Added python-six
  - Dropped python-pycryptoppo
  - Droped python-nose
  - Added python-testtools
  - Added testrepository
* debian/control: Dropped dbconfig-common.
* debian/pydist-overrides: Added python-argparse its apart of
  python-2.7.
* debian/*.config.in: Dropped config.in files, we are not using them.
* debian/*.templates.in: Dropped templates.in files, we are not using them.
* Added upstart jobs.
* debian/patches/ubuntu-configuration.patch: Fix configuration files
  to use the kombu rpc_backend.
* debian/patches/removes-lxml-version-limitation-from-pip-requires.patch:
  Refreshed.
* debian/patches/fix-package-version-detection-when-building-doc.patch:
  Dropped no longer needed.
* debian/heat-common.install: Install api-paste.ini and policy.json.

1. By Chuck Short on 2013-05-29

* Fixed the dbsync to the new thing upstream is using (it was crashing the
  postinst).
* Fixed the prerm script of heat-engine that was calling dbc_go heat instead
  of dbc_go heat-engine.
* Added missing dependency: python-mysqldb.
* Added missing dbconfig-common depends (Closes: #709126). Thanks to Andrea
  Beckmann for the bug report.
* Uploading to unstable.
* Removes the <=2.3.5 from python-lxml requirements.
* Fix package version detection when building docs.
* Cleans doc/build on the clean target.
* Initial release (Closes: #695302).

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.

Subscribers