lp:zeitgeist

Created by Siegfried Gevatter on 2011-10-29 and last modified on 2020-04-06
Get this branch:
bzr branch lp:zeitgeist

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Zeitgeist Framework Team
Project:
Zeitgeist Framework
Status:
Mature

Import details

Import Status: Reviewed

This branch is an import of the HEAD branch of the Git repository at git://anongit.freedesktop.org/zeitgeist/zeitgeist.

The next import is scheduled to run in 3 minutes.

Last successful import was 5 hours ago.

Import started 5 hours ago on alnitak and finished 5 hours ago taking 20 seconds — see the log
Import started 11 hours ago on izar and finished 11 hours ago taking 20 seconds — see the log
Import started 17 hours ago on alnitak and finished 17 hours ago taking 20 seconds — see the log
Import started 23 hours ago on alnitak and finished 23 hours ago taking 20 seconds — see the log
Import started on 2020-04-08 on izar and finished on 2020-04-08 taking 20 seconds — see the log
Import started on 2020-04-08 on izar and finished on 2020-04-08 taking 20 seconds — see the log
Import started on 2020-04-07 on izar and finished on 2020-04-07 taking 20 seconds — see the log
Import started on 2020-04-07 on izar and finished on 2020-04-07 taking 20 seconds — see the log
Import started on 2020-04-07 on alnitak and finished on 2020-04-07 taking 20 seconds — see the log
Import started on 2020-04-07 on alnitak and finished on 2020-04-07 taking 20 seconds — see the log

Recent revisions

781. By Rico Tzschichholz on 2020-04-06

Allow the sender parameter of DBusSignalCallback to be null

https://gitlab.gnome.org/GNOME/glib/commit/5a74c2f445458c037aa71ac51de3ed6af325a1ab

780. By Rico Tzschichholz on 2019-09-01

build: Allow building with gettext ≥ 0.20

The use of AM_GNU_GETTEXT_VERSION in configure.ac instructs autopoint to
copy po/Makefile.in.in from the exact gettext version. It is fine if the
version of gettext installed on the system has the same minor version
number with the requested version, but it fails if you have a newer
version of gettext because of the mismatch between autoconf macros and
Makefile.in.in.

  *** error: gettext infrastructure mismatch: using a Makefile.in.in
  from gettext version 0.19 but the autoconf macros are from gettext
  version 0.20

Instead of specifying the exact version with AM_GNU_GETTEXT_VERSION, we
can use AM_GNU_GETTEXT_REQUIRE_VERSION to ask autopoint to simply use
the gettext version installed on the system to prevent the mismatch.

This also bumps the version requirement on gettext to 0.19.6 because
AM_GNU_GETTEXT_REQUIRE_VERSION was added in this version.

Fixes https://gitlab.freedesktop.org/zeitgeist/zeitgeist/issues/18

779. By Rico Tzschichholz on 2019-01-31

Release 1.0.2

778. By David King on 2019-01-31

fts: Correctly implement the org.gnome.zeitgeist.Index DBus interface

Adapt fully for commit 131a84f1

777. By Rico Tzschichholz on 2019-01-31

test-log: Use correct free function for ZeitgeistResultSet

Additionally free leaking GArrays

776. By Corentin Noël on 2018-11-23

Do not require rapper as it is not used anymore

775. By Corentin Noël on 2018-11-23

Make ontology2code work with python3

774. By Corentin Noël on 2018-11-23

Properly fallback with the Zeitgeist version

773. By Corentin Noël on 2018-11-23

Use rdflib directly to parse the trig files

772. By Corentin Noël on 2018-11-23

Update Ontology2code to ba able to specify the output path

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.