lp:~xaba/ubuntu/natty/pytrainer/bug-760885

Created by Xavier Bassery and last modified
Get this branch:
bzr branch lp:~xaba/ubuntu/natty/pytrainer/bug-760885
Only Xavier Bassery can upload to this branch. If you are Xavier Bassery please log in for upload directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Xavier Bassery
Status:
Development

Recent revisions

12. By Xavier Bassery

log the defaut profile creation when none exists.

11. By Xavier Bassery

Let the application start even if the user configuration file is not found or empty

10. By Lorenzo De Liso

* Merge from debian unstable (LP: #599457), remaining changes:
  - Replace Depends on iceweasel with firefox | abrowser.
  - Drop dependency on python-glade2 (libglade -> gtkbuilder transition).

9. By Daniel Holbach

* Merge from debian testing, remaining changes
  - debian/control:
    + Replace Depends on iceweasel with firefox | abrowser.
    - Drop dependency on python-glade2 (libglade -> gtkbuilder transition).
* Non-maintainer upload, to prepare for Python 2.6 transition
* debian/rules
  - added '--install-layout=deb' parameter to setup.py install call; thanks to
    Jakub Wilk for the report; Closes: #530526
* debian/control
  - set b-d on python (instead of p-dev) and bump version to '>= 2.5.3-1~', to
    support install-layout
* debian/{control, rules}
  - added python-support, to byte-compiling and properly handle Python
    module; thanks to Luca Falavigna for the report; Closes: #566046
* plugins/{garmintools/garmintools.py, garmintools_full/garmintools_full.py},
  import/file_garmintools.py
  - patched to explicitly import the "with" statement; thanks to Jonathan
    Wiltshire for the report; Closes: #568781

8. By Alessio Treglia

* Merge from debian testing, remaining changes:
  - debian/control:
    + Replace Depends on iceweasel with firefox | abrowser.
    + Bump python-dev,debhelper build-dependencies.
    - Drop dependency on python-glade2 (libglade -> gtkbuilder transition).
  - debian/rules:
    + Append --install-laoyut=deb to setup.py install to prevent a build
      failure with Python 2.6.

7. By Alessio Treglia

* Merge from debian unstable (LP: #477875), Ubuntu remaining changes:
  - Replace Depends on iceweasel with firefox | abrowser.
  - Add --install-layout=deb to setup.py install arguments to prevent FTBFS
    with Python 2.6 on Ubuntu.
  - Bump-up debhelper, python-dev build-dependencies.
* Remove python-glade2 (libglade -> gtkbuilder transition).

6. By Alessio Treglia

Replace Depends on iceweasel with firefox | abrowser.

5. By Alessio Treglia

* Add --install-layout=deb to setup.py install arguments to build with
  Python 2.6, fix FTBFS.
* Bump-up debhelper, python-dev build-dependencies.

4. By Noël Köthe

new upstream release from 2009-04-19

3. By Noël Köthe

* added missing dependency. closes: #528427
* corrected Homepage: (e-oss.net is outdated)
* updated Standards-Version: without changes
* raised compat version to 5
* corrected menu section

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/natty/pytrainer
This branch contains Public information 
Everyone can see this information.

Subscribers