lp:~vibhavp/ubuntu/raring/dahdi-tools/merge-from-debian

Created by Vibhav Pant on 2012-12-26 and last modified on 2012-12-27
Get this branch:
bzr branch lp:~vibhavp/ubuntu/raring/dahdi-tools/merge-from-debian
Only Vibhav Pant can upload to this branch. If you are Vibhav Pant please log in for upload directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Vibhav Pant
Status:
Development

Recent revisions

10. By Vibhav Pant on 2012-12-27

Fix debian/rules error message

9. By Vibhav Pant on 2012-12-26

* Merge from Debian unstable. Remaining changes:
  - Bug Fix: If linux-headers are not installed, don't block, and print
    information for the user.
  - added debian/dahdi.postinst
  - added --error-handler=init_failed to debian/rules
  - debian/control: Added gawk as dependency for dkms build (LP: #493304)
  - Changes from Debian:
    - debian/control: Change Maintainer
    - debian/control: Removed Uploaders field.
    - debian/control: Removed Debian Vcs-Svn entry and replaced with
      ubuntu-voip Vcs-Bzr, to reflect divergence in packages.
    - debian/control: Package dahdi Depends on dahdi-dkms | dahdi-source

8. By Martin Pitt on 2012-02-29

No-change rebuild against current pkgbinarymangler to fix broken
md5sums. (see LP #875466)

7. By Stefan Lesicnik on 2011-05-08

* Merge from Debian. Remaining changes:
  - Bug Fix: If linux-headers are not installed, don't block, and print
    information for the user.
  - added debian/dahdi.postinst
  - added --error-handler=init_failed to debian/rules
  - Changes from Debian:
    - debian/control: Change Maintainer
    - debian/control: Removed Uploaders field.
    - debian/control: Removed Debian Vcs-Svn entry and replaced with
      ubuntu-voip Vcs-Bzr, to reflect divergence in packages.
    - debian/control: Package dahdi Depends on dahdi-dkms | dahdi-source
* debian/control: Added gawk as dependency for dkms build (LP: #493304)
* New upstream release (Closes: #581076, #582094).
* Patches hardware_rescan, perl_fix_noserial, perl_fix_transportdir,
  astribank_allow_ignoreend, init_unload_modules and wcb4xxp_extra_trunk
  dropped: merged upstream.
* dahdi-linux 2.3.0 is required (extra config options for dahdi_cfg).
* Convert to dpkg v.3 format.
* Standards version: 3.9.1.0 (No change needed.

6. By Stefan Lesicnik on 2010-11-11

* Merge from Debian testing. Remaining changes:
  - Bug Fix: If linux-headers are not installed, don't block, and print
    information for the user.
    - added debian/dahdi.postinst
    - added --error-handler=init_failed to debian/rules
  - Changes from Debian:
    - debian/control: Change Maintainer
    - debian/control: Removed Uploaders field.
    - debian/control: Removed Debian Vcs-Svn entry and replaced with
      ubuntu-voip Vcs-Bzr, to reflect divergence in packages.
    - debian/control: Package dahdi Depends on dahdi-dkms | dahdi-source
* New minor upstream release.
* Patch wcb4xxp_extra_trunk: recognize some extra HFC-[248]S PCI IDs.
* DEP3 heaaders for all patches in use.
* Refreshed some patches.
* Standards version 3.8.4 (no change needed).
* Use a @debian.org adderss.
* New upstream release (Closes: #536257, #564381).
* Patch 'bashism' dropped: merged upstream.
* Patch xpp_no_extra_at dropped: merged upstream.
* Add an example genconf_parameters.
* Compat level 7.
* Bump standars version to 3.8.3.0 (no change needed)
* Udev rules are now in dahdi-linux.
* Patches perl_fix_noserial, perl_fix_transportdir: Fixes for some
  minor perl issues.
* Add the missing ${misc:Depends}, as per lintian.
* Patch astribank_allow_ignoreend: an extra missing patch from upstream.
* Patches init_unload_modules and init_unload_oslec: also unload OSLEC
  when unloading all modules.
* Added bristuff 0.3.0-PRE1 for Asterisk 1.2.0 support.
* fix Makefile_deps_kern.dpatch
* remove .rej from Makefile.uname.dpatch
* do install genzaptelconf man page
* update genzaptelconf and its man page
* echocan_env.dpatch: allow changing the echo canceller at zaptel-modules
  build time
* Makefile_kbuild.dpatch: use kbuild for 2.6 modules build. used for:
* Makefile_xpp.dpatch: (not applied by default)
  a small patch to enable the build of:
* xpp.dpatch: drivers for Xorcom Asteribank
* Build and package libtonezone.so
* New upstream release
* Remove Makefile_deps_kern.dpatch as it doesnt apply upstream
* New Upstream Release

5. By Jean-Michel Dault on 2010-04-13

* Bug Fix: If linux-headers are not installed, don't block, and print
   information for the user. (LP: #429510, LP: #474350)
   - added debian/dahdi.postinst
   - added --error-handler=init_failed to debian/rules

4. By Jean-Michel Dault on 2010-02-16

* Merge from Debian pkg-voip.
  * Changes from Debian:
  - debian/control: Change Maintainer
  - debian/control: Removed Uploaders field.
  - debian/control: Removed Debian Vcs-Svn entry and replaced with
      ubuntu-voip Vcs-Bzr, to reflect divergence in packages.
  - debian/control: Package dahdi Depends on dahdi-dkms | dahdi-source

* From Debian pkg-voip:
[ Tzafrir Cohen ]
* New upstream release (Closes: #536257, #564381).
* Patch 'bashism' dropped: merged upstream.
* Patch xpp_no_extra_at dropped: merged upstream.
* Add an example genconf_parameters.
* Compat level 7.
* Bump standars version to 3.8.3.0 (no change needed)
* Udev rules are now in dahdi-linux.
* Patches perl_fix_noserial, perl_fix_transportdir: Fixes for some
  minor perl issues.
* Add the missing ${misc:Depends}, as per lintian.
* Patch astribank_allow_ignoreend: an extra missing patch from upstream.
* Patches init_unload_modules and init_unload_oslec: also unload OSLEC
  when unloading all modules.

3. By Jean-Michel Dault on 2009-08-25

* Merge from debian pkg-voip (2.2.0 final)
* Change maintainer and standards version
* Since the init script needs /dev/dahdi, require either dahdi-dkms or
  dahdi-source.

* Debian changes

 [ Tzafrir Cohen ]
 * New upstream release.
 * Patch bashism: fixes bashism in waitfor_xpds (Closes: #535865).
 * Patch hardware_rescan: backport Dahdi::Hardware->rescan()
 * Patch no_extra_at: backport of a per/xpp fix.

2. By Mark Purcell on 2009-06-01

[ Tzafrir Cohen ]
* New upstream release candidate.

[ Mark Purcell ]
* Cleanup debian/watch to point to upstream dahdi-tools ;-)
* Update Standards version -> 3.8.1
* Fix binary-control-field-duplicates-source

1. By Mark Purcell on 2009-06-01

Import upstream version 2.2.0~rc3

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/raring/dahdi-tools
This branch contains Public information 
Everyone can see this information.

Subscribers