lp:gtk

Created by Jelmer Vernooij on 2009-12-16 and last modified on 2016-06-26
Get this branch:
bzr branch lp:gtk

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
VCS imports
Project:
GTK+
Status:
Development

Import details

Import Status: Reviewed

This branch is an import of the HEAD branch of the Git repository at git://git.gnome.org/gtk+.

The next import is scheduled to run in 4 hours.

Last successful import was 1 hour ago.

Import started 1 hour ago on pear and finished 1 hour ago taking 2 minutes — see the log
Import started 7 hours ago on pear and finished 7 hours ago taking 1 minute — see the log
Import started 13 hours ago on pear and finished 13 hours ago taking 2 minutes — see the log
Import started 19 hours ago on pear and finished 19 hours ago taking 1 minute — see the log
Import started on 2016-06-25 on pear and finished on 2016-06-25 taking 1 minute — see the log
Import started on 2016-06-25 on pear and finished on 2016-06-25 taking 1 minute — see the log
Import started on 2016-06-25 on pear and finished on 2016-06-25 taking 2 minutes — see the log
Import started on 2016-06-24 on pear and finished on 2016-06-24 taking 2 minutes — see the log
Import started on 2016-06-24 on pear and finished on 2016-06-24 taking 2 minutes — see the log
Import started on 2016-06-24 on pear and finished on 2016-06-24 taking 1 minute — see the log

Recent revisions

43625. By Yosef Or Boczko <email address hidden> 2 hours ago

Updated Hebrew translation

43624. By Lapo Calamandrei 22 hours ago

Adwaita: color the selection of entries with error...

...or warning style class applied.
This particular style bit wasn't converted to the saner 3.20 way
so `entry:selected` used in place of `entry selection`.

Fixes https://bugzilla.gnome.org/show_bug.cgi?id=768025

43623. By Lapo Calamandrei 23 hours ago

Adwaita: restrict infobar styling to, well, infobars

we used to style infobars by using the .info, .question, .warning
and .error selectors directly, which used to be ok when we had just
styleclasses all over the place, now it needs to be more specific
or it interferes with everything with those styleclasses applied
like entries.

43622. By Andika Triwidada <email address hidden> on 2016-06-25

Updated Indonesian translation

43621. By Andika Triwidada <email address hidden> on 2016-06-25

Updated Indonesian translation
(cherry picked from commit 3abb9ffa917611e81cc4cb50b7ddd38879a49b8f)

43620. By Ray Strode <email address hidden> on 2016-06-25

headerbar: support expand property for children

The header bar currently ignores the expand property on its
children. This commit changes the code to honor that property.

It divvies up any free space and distributes it equally to packed
children (with any left over space given out a pixel at a time
on a first come, first serve basis).

This commit also adds support for the title widget to be made
expandable.

It accomplishes this by using up the padding the title widget
is centered with.

https://bugzilla.gnome.org/show_bug.cgi?id=724332

43619. By Ray Strode <email address hidden> on 2016-06-25

headerbar: compute nominal size of sides up front

In order to support the expand property on children, we're
going to need to look at the size of the packed children
on each side of the title widget, up front, before allocating
them (to compute how much extra allocation each expanded child
gets).

This commit lays the groundwork for that analysis by splitting
the size calculation of each side of the header bar outside
of the loop that allocates each child of the header bar.

https://bugzilla.gnome.org/show_bug.cgi?id=724332

43618. By Ray Strode <email address hidden> on 2016-06-25

headerbar: simplify some size allocation code

With a headerbar, the widget in the center may be a label, constructed
internally, or a custom widget, constructed externally. The size
allocation code needs to handle either case the same way for the most
part. There's more than one place in the code that checks which of
the two widgets to use and does some operation on the selected one.

This commit simplifies the code by checking up front which one is the
center (title) widget and storing that in a temporary variable,
This allows reducing duplicated logic later on in the function.

https://bugzilla.gnome.org/show_bug.cgi?id=724332

43617. By Ray Strode <email address hidden> on 2016-06-25

headerbar: simplify calculation in size allocation code

There's some extraneous MIN() calls that have predetermined answers.

This commit drops them and then simplifies a few redudant checks into
one MIN call.

https://bugzilla.gnome.org/show_bug.cgi?id=724332

43616. By Matthias Clasen <email address hidden> on 2016-06-23

Fix an array overrun

When I introduced the new input source enum value for
track points, I forgot that there is a fixed-size array
with names for those in the inspector.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.

Subscribers