ubuntu/+source/zlib:ubuntu/dapper-devel

Last commit made on 2006-01-30
Get this branch:
git clone -b ubuntu/dapper-devel https://git.launchpad.net/ubuntu/+source/zlib
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/dapper-devel
Repository:
lp:ubuntu/+source/zlib

Recent commits

4379aa8... by Matthias Klose on 2006-01-13

Import patches-unapplied version 1:1.2.3-6ubuntu4 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 9a78f5cfcd65c803d1f0c7216d6a646a1d467d22

New changelog entries:
  * Replace (build-)dependency ia32-libs-dev [amd64] -> libc6-dev-i386 [amd64]

9a78f5c... by Matthias Klose on 2005-11-16

Import patches-unapplied version 1:1.2.3-6ubuntu3 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 33e5e11a780a9f5c02bb4be6441700b25ca582db

New changelog entries:
  * Add dependencies to the biarch packages.
  * Fix typo in lib64z1-dev dependency.
  * Synchronize with unstable.
  * Most of the changes in this version are based heavily on work done for
    Ubuntu by Matthias Klose <email address hidden>. Thanks!
  * Build biarch packages on PowerPC (closes: #325560).
  * Build biarch packages on i386, replacing amd64-libs prior to 1.4 which
    included its own copy and adding a theoretically spurious build dep
    on amd64-libs to work around binutils troubles (closes: #334013).
  * Drop build dep on GCC 3.4 on amd64 - we already stopped using it.
  * Update all the lib64 development dependencies to use lib64c-dev rather
    than the specific libc-${ARCH}-dev package.
  * Don't test lib64 builds - there's a good chance they'll fail due to the
    system not being able to execute 64 bit code. Similarly, don't worry if
    dh_shlibdeps fails and hard code an unversioned dependency on the
    appropriate libc.
  * Since GCC no longer ICEs at -O3 on m68k revert to using -O3 there like
    we do elsewhere.
  * Add ppc64 biarch support using patch included in the report by Andreas
    Jochens <email address hidden> (closes: #323591).

33e5e11... by Matthias Klose on 2005-09-03

Import patches-unapplied version 1:1.2.3-3ubuntu4 to ubuntu/breezy

Imported using git-ubuntu import.

Changelog parent: 46bb82af7beb87acb87ec967642815f15e86f687

New changelog entries:
  * Fix lib32z1-dev dependency.
  * Explicitely set -march/-mtune options for 64bit i386 build.
  * Fix typo in build dependencies.
  * Synchronize with Debian.
  * Build lib64z1 for i386 and powerpc, conflicts/replaces amd64-libs.
  * Ignore dh_shlibdeps failures, trying to run 32bit ldd on 64bit
    binaries.
  * lib64z1-dev: Depend on the needed libc6-dev package.
  * debian/*dirs: Replace /emul/* with /usr/lib32.
  * Fix minizip build (closes: #321355).
  * Fix noopt (closes: #320999).
  * Apply CFLAGS to minizip too.
  * Policy 3.6.2 (no changes).
  * Put the libraries into /usr/lib32 on amd64.
  * Stop calling dh_shlibdeps when building lib32z1 on amd64.
  * Resynchronise with Debian, resolving conflicts (Ubuntu #12391).
    - Drop patches incorporated upstream.
    - Drop most of our changes in favour of Debian's to minimize our diff.
  * New upstream release.
  * This release includes a fix for CAN-2005-1849.
  * Work around an ICE on m68k by building at -O2 there.
  * Implement noopt support while we're at it.
  * Remove GCC 3.4 hack for amd64 since the default compiler is now supposed
    to be able to do biarch.
  * Add patch fixing CAN-2005-2096 in inflate.
  * Fix some build failures on amd64 (closes: #316779). The package still
    fails to build but this appears to be due to toolchain issues.
  * Build a 32 bit copy on amd64 (closes: #311618).
  * Hack build with GCC 3.4 on amd64 since the default 3.3 is broken for
    biarch builds. This should be removed once the default compiler does
    this properly.
  * Remove libc5 support and therefore revert to using plain gcc when not
    cross-compiling.
  * Upgrade to Debhelper interface 4.
  * SECURITY UPDATE: Fix another buffer overflow on invalid data streams.
  * Add debian/patches/020_CAN-2005-1849:
    - inftrees.h: Raise ENOUGH and MAXD to be big enough.
    - Patch from zlib upstream author.
    - CAN-2005-1849
  * SECURITY UPDATE: Fix buffer overflow on invalid data streams.
  * Add debian/patches/019_CAN-2005-2096.patch:
    - Permit incomplete codes only if they consist of a single code of length
      1, as described in the spec. Longer codes overflowed various buffers.
    - Patch from zlib upstream author.
    - CAN-2005-2096
  * Add a (temporary) build dependency on lib32gcc1.
  * Fix build failure with dpkg 1.13.
  * Build 32bit packages for amd64.

46bb82a... by Scott James Remnant (Canonical) on 2004-12-10

Import patches-unapplied version 1:1.2.2-4ubuntu1 to ubuntu/hoary

Imported using git-ubuntu import.

Changelog parent: 92e7fe5df1e5ef3f5d0adc04150da07ae74ba347

New changelog entries:
  * Resynchronise with Debian.
  * Run dh_installdeb before dh_shlibdeps (closes: #282882).
  * Specify the shlibs for the library directly to dpkg-shlibs.
  * Resynchronise with Debian.
  * Generate shared libraries sensibly for zlib-bin (closes: #278977).
  * Remove shlibs from udeb.
  * Resynchronise with Debian.
  * New upstream release.
  * New upstream release.
  * Upstream now includes patch improving error reporting when gzio is used on
    empty files (closes: #258087).
  * Upstream have fixed a valgrind warning. Other valgrind warnings remain
    but have been analysed and found safe - uninitialised memory is read from
    a buffer allocated by zlib during deflate but bounds checking is
    subsequently performed and the output unaffected (closes: #270070).
  * Once more, with feeling.
  * Fix the error handling in the new inflate implementation to avoid
    incorrectly continuing to process in the error state. Thanks to Johan
    Thelmén <email address hidden> for his help in finding and fixing this
    bug. This is CAN-2004-0797 (closes: #252253).
  * Build a 64 bit libz on s390 and sparc. Original patch provided by Bastian
    Blank <email address hidden> but since modified (closes: #257940).
  * Mark the udeb as such for Debhelper but note that the udeb support appears
    not to cope with epochs so leave the code to build it.
  * Apply patch from David Weinehall <email address hidden> avoiding some XSIisms in
    the package scripts (closes: #256363).
  * Policy 3.6.1 (no changes).
  * Incorporate current upstream patch to minizip. This supercedes most of
    the current Debian patches (8,14,15 and 17) and has some additional
    bugfixes.

92e7fe5... by Matt Zimmerman on 2004-09-10

Import patches-unapplied version 1:1.2.1.1-3ubuntu1 to ubuntu/warty

Imported using git-ubuntu import.