ubuntu/+source/zlib:applied/debian/stretch

Last commit made on 2017-01-29
Get this branch:
git clone -b applied/debian/stretch https://git.launchpad.net/ubuntu/+source/zlib
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/debian/stretch
Repository:
lp:ubuntu/+source/zlib

Recent commits

84b3fa4... by Mark Brown on 2017-01-29

Import patches-applied version 1:1.2.8.dfsg-5 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 76da459db624c1b37410077738d98723f148787f
Unapplied parent: f43e1ab1c43d8ec0cbbb4ed5f2d457798b8d3f0b

New changelog entries:
  * Add loud warnings to the descriptions of all the multilib packages
    to try to discurage anyone from using them in error, the *only* user
    is the D compiler which does this because apparently D users will
    want to do cross builds but will be unable to install multilib
    packages. No new packages should add usage, it is difficult to see
    any sensible use case (closes: #787956, #845793, #709623, #853087).
  * Non-maintainer upload.
  * Revert "Install zconf.h in multiarch path"; this broke lib{32,64}z1-dev
    and is not necessary with upstream version 1.2.8 (Closes: #787956)
  * Revert "Fix cross 32 builds."; this broke lib64z1-dev (Closes: #845793)
  * Add stage1 profile that excludes multilib packages (Closes: #709623)

f43e1ab... by Mark Brown on 2017-01-29

CVE-2016-9843

No DEP3 Subject or Description header found

Gbp-Pq: CVE-2016-9843.

bd6e5d8... by Mark Brown on 2017-01-29

CVE-2016-9842

No DEP3 Subject or Description header found

Gbp-Pq: CVE-2016-9842.

cb93f2f... by Mark Brown on 2017-01-29

CVE-2016-9841

No DEP3 Subject or Description header found

Gbp-Pq: CVE-2016-9841.

29f8ede... by Mark Brown on 2017-01-29

CVE-2016-9840

No DEP3 Subject or Description header found

Gbp-Pq: CVE-2016-9840.

66f70d9... by Mark Brown on 2017-01-29

use-dso-really

No DEP3 Subject or Description header found

Gbp-Pq: use-dso-really.

42eb391... by Mark Brown on 2017-01-29

use-dso

No DEP3 Subject or Description header found

Gbp-Pq: use-dso.

21476ef... by Mark Brown on 2017-01-29

cflags-for-minizip

No DEP3 Subject or Description header found

Gbp-Pq: cflags-for-minizip.

547291b... by Mark Brown on 2017-01-29

[PATCH] Restore gzflags symbol for ABI compatibility

Gbp-Pq: 0001-Restore-gzflags-symbol-for-ABI-compatibility.patch.

fe908eb... by Mark Brown on 2017-01-29

Import patches-unapplied version 1:1.2.8.dfsg-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 1123d1f5c1c9adf848c84a42056d3dde34eda478

New changelog entries:
  * Add loud warnings to the descriptions of all the multilib packages
    to try to discurage anyone from using them in error, the *only* user
    is the D compiler which does this because apparently D users will
    want to do cross builds but will be unable to install multilib
    packages. No new packages should add usage, it is difficult to see
    any sensible use case (closes: #787956, #845793, #709623, #853087).
  * Non-maintainer upload.
  * Revert "Install zconf.h in multiarch path"; this broke lib{32,64}z1-dev
    and is not necessary with upstream version 1.2.8 (Closes: #787956)
  * Revert "Fix cross 32 builds."; this broke lib64z1-dev (Closes: #845793)
  * Add stage1 profile that excludes multilib packages (Closes: #709623)